yatex-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.74
  5. Release: 5%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.yatex.org/yatex10203151806.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## pre-formatted info files here
  15. Source10: yatexe
  16. Source11: yatexj
  17. Source12: yahtmle
  18. Source13: yahtmlj
  19. ## Vine Patch(es)
  20. Patch0: yatex-info.diff
  21. Patch1: yatexhlp-emacs.diff
  22. Patch2: yatex-make.diff
  23. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  24. # and modified to suit 1.70 release
  25. Patch3: yahtml-1.70-timestamp.patch
  26. URL: http://www.yatex.org/
  27. Group: Applications/Editors/Emacs
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Summary: YaTeX - Yet Another TeX mode for Emacs
  30. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  31. BuildArch: noarch
  32. PreReq: emacsen
  33. %prereq_ge emacsen-common
  34. BuildRequires: emacsen-common
  35. Obsoletes: yatex-xemacs
  36. Distribution: Vine Linux
  37. Vendor: Project Vine
  38. %description
  39. YaTeX is an intelligent, acquisitive and integrated package which reduces
  40. your efforts of composing LaTeX source on GNU Emacs.
  41. If you are YaTeX user and you install both yatex and auctex on your system,
  42. you may add the following configure in your emacs init file
  43. %if %{?_dist_release} == "vl5"
  44. ~/.emacs.el:
  45. %else
  46. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  47. %endif
  48. ;; I am YaTeX user!!!
  49. (setq vine-default-auctex nil
  50. vine-default-preview-latex nil)
  51. %description -l ja
  52. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  53. してくれる、LaTeX 入力支援環境です。
  54. yatex と auctex パッケージの両方をインストールする場合、
  55. %if %{?_dist_release} == "vl5"
  56. ~/.emacs.el:
  57. %else
  58. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  59. %endif
  60. に以下の設定を追加するとよいでしょう。
  61. ;; YaTeX ユーザです!!!
  62. (setq vine-default-auctex nil
  63. vine-default-preview-latex nil)
  64. %prep
  65. %setup -n yatex%{version}
  66. %patch0 -p1
  67. %patch1 -p1
  68. %patch2 -p1
  69. %patch3 -p1
  70. %build
  71. (cd docs
  72. chmod 644 *
  73. %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
  74. )
  75. %install
  76. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  77. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  80. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  81. #
  82. # install el files
  83. #
  84. %__cp -a *.el makefile help \
  85. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  86. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  87. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  88. #
  89. # install info files
  90. #
  91. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  92. ${RPM_BUILD_ROOT}%{_infodir}
  93. #
  94. # install script (bytecompile el and install elc, remove)
  95. #
  96. %_installemacsenscript %{name} %{SOURCE1}
  97. %_removeemacsenscript %{name} %{SOURCE2}
  98. %clean
  99. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  100. %post
  101. #
  102. # bytecompile and install
  103. #
  104. if [ "$1" = 2 ] ; then
  105. %_emacsenPackageRemove %{name}
  106. fi
  107. %_addemacsenlist %{name}
  108. %_emacsenPackageInstall %{name}
  109. /sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
  110. --section="Emacs"
  111. /sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
  112. --section="Emacs"
  113. /sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
  114. --section="Emacs"
  115. /sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  116. --section="Emacs"
  117. %preun
  118. if [ "$1" = 0 ]; then
  119. %_emacsenPackageRemove %{name}
  120. %_removeemacsenlist %{name}
  121. /sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
  122. --section="Emacs"
  123. /sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
  124. --section="Emacs"
  125. /sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
  126. --section="Emacs"
  127. /sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  128. --section="Emacs"
  129. fi
  130. %files
  131. %defattr(-,root,root)
  132. %doc 00readme install manifest yatex.new
  133. %doc docs
  134. %{_datadir}/emacs/site-lisp/yatex/
  135. %{_infodir}/*
  136. %{emacsen_pkgdir}/install/%{name}
  137. %{emacsen_pkgdir}/remove/%{name}
  138. %changelog
  139. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  140. - updated yatex-init.el
  141. - dropped all pathes of auctex and preview-latex from load-path
  142. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  143. - updated vine-default-yatex.el
  144. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  145. - supported TeX Live
  146. - used "eplatex", "pxdvi", "pdvips" as default commands
  147. - updated yatex-init.el
  148. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  149. - defined vine-default-yahtml
  150. - added vine-default-yahtml.el
  151. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  152. - updated vine-default-yatex.el
  153. - added bbl extension in auto-mode-alist to run yatex-mode
  154. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  155. - updated vine-default-yatex.el
  156. - supported new vine-default
  157. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  158. - new upstream release
  159. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  160. - updated vine-default-yatex.el
  161. - dropped (setq YaTeX-no-begend-shortcut t)
  162. - use %{emacsen_pkgdir}
  163. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  164. - updated vine-default-yatex.el
  165. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  166. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  167. - updated yatex-install.sh
  168. - *-init.el: changed from hard copy to symbolic link
  169. on /etc/emacs-XX.YY/site-start.d
  170. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  171. - fixed yatex-init.el
  172. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  173. - added yatex-init.el, vine-default-yatex.el
  174. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  175. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  176. - spec in utf8
  177. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  178. - applied new versioning policy
  179. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  180. - new upstream release
  181. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  182. - s/Copyright/License/
  183. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  184. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  185. - update yatex-1.72
  186. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  187. - update yatex-1.71
  188. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  189. - added Patch3 to add hhmts timestamp feature
  190. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  191. - update yatex-1.70
  192. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  193. - update yatex10203151806
  194. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  195. - fixed: bytecompile yatex19
  196. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  197. - now emacsen-common aware
  198. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  199. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  200. - 1.68-0vl2
  201. - no kanji code conversion of documents
  202. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  203. - 1.68-0vl1
  204. - update to 1.68
  205. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  206. - 1.67-6vl5
  207. - YATEXHLP.{jp,eng} moved to appropriate dir
  208. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  209. - 1.67-6vl3
  210. - rebuilt for emacs-20.7
  211. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  212. - 1.67-6vl2
  213. - oops ... fixed target dir for help files
  214. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  215. - 1.67-6vl1
  216. - rebuilt for emacs-20.6
  217. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  218. - 1.67-6
  219. - included forgotten info file for YaHTML
  220. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  221. - 1.67-5
  222. - updated for emacs-20.5a release
  223. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  224. - 1.67-4
  225. - change Group to Applications/Editors/EmacsLisp
  226. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  227. - 1.67-3
  228. - %post and %preun section modified
  229. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  230. - 1.67-2
  231. - fixed minor problem in the %files section
  232. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  233. - 1.67-1
  234. - updated to 1.67 release
  235. - rebuilt for emacs-20.4 on Vine Linux 1.9
  236. - updated URL for the new web site of YaTeX
  237. - some typo fix
  238. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  239. - Initial Release