xorg-x11-drv-radeonhd-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393
  1. %define tarname xf86-video-radeonhd
  2. %define moduledir %(pkg-config xorg-server --variable=moduledir)
  3. %define driverdir %{moduledir}/drivers
  4. %define tarball %{tarname}-%{version}
  5. Summary: Xorg X11 radeonhd driver for AMD GPG r5xx/r6xx Chipsets
  6. Summary(ja): Xorg X11 radeonhd ドライバ - AMD GPG r5xx/r6xx チップセット用
  7. Name: xorg-x11-drv-radeonhd
  8. Version: 1.3.0
  9. Release: 3%{?_dist_release}
  10. License: MIT
  11. Group: User Interface/X Hardware Support
  12. URL: http://www.x.org/
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Source0: ftp://ftp.x.org/pub/individual/driver/%{tarball}.tar.bz2
  15. Source10: radeonhd.xinf
  16. ExcludeArch: s390 s390x
  17. # EL5 does not have pkgconfig in default buildroot. Does not hurt others.
  18. BuildRequires: pkgconfig
  19. BuildRequires: pciutils-devel
  20. BuildRequires: zlib-devel
  21. BuildRequires: xorg-x11-server-sdk >= 1.4.99
  22. Requires: xorg-x11-server-Xorg
  23. Requires: xorg-x11-server-utils
  24. %description
  25. X.org X11 radeonhd driver for AMD GPG r5xx/r6xx Chipsets.
  26. %prep
  27. %setup -q -n %{tarball}
  28. %build
  29. %{configure} --with-xorg-module-dir=%{moduledir} --disable-static
  30. %{__make} %{?_smp_mflags}
  31. %install
  32. %{__rm} -rf "%{buildroot}"
  33. %{__make} install DESTDIR="%{buildroot}"
  34. %{__rm} -f "%{buildroot}%{driverdir}/radeonhd_drv.la"
  35. %{__install} -m 0755 -d "%{buildroot}/%{_bindir}"
  36. %{__install} -p -m 0755 utils/conntest/rhd_conntest "%{buildroot}/%{_bindir}/rhd_conntest"
  37. %{__install} -d $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  38. %{__install} -m644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  39. %check
  40. %{__make} check || %{__make} check VERBOSE=yes
  41. %clean
  42. %{__rm} -rf "%{buildroot}"
  43. %files
  44. %defattr(-,root,root,-)
  45. %doc README COPYING
  46. %doc ChangeLog
  47. %{_bindir}/rhd_conntest
  48. %{driverdir}/radeonhd_drv.so
  49. %{_datadir}/hwdata/videoaliases/radeonhd.xinf
  50. %{_mandir}/man4/radeonhd.4.gz
  51. %changelog
  52. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-3
  53. - rebuild with xserver-1.9.2
  54. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-2
  55. - rebuild with xserver-1.8rc
  56. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.0-1
  57. - new upstream release
  58. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  59. - new upstream release
  60. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-2
  61. - rebuild with X server 1.6.0
  62. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  63. - new upstream release
  64. * Mon Oct 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  65. - new upstream release
  66. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
  67. - fix %%files
  68. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  69. - new upstream release
  70. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  71. - initial build for Vine Linux
  72. * Fri Apr 04 2008 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.7.20080404git
  73. - Do not create fedora snapshot git branch unless necessary
  74. - New snapshot (upstream commit db2c3948d5a398047b3a881f6f88541dc963d22e):
  75. - db2c3948: Fix LVTMA code to also handle single link DVI correctly.
  76. - 55e3b21e: HDMI Type A is single link DVI while B is dual link.
  77. - d53f2201: Add source select to DDIA block.
  78. - be9055f0: Fixed argument order to rhdAtomGetTableRevisionAndSize().
  79. - 1623f86f: Added missing rhd_ddia.c/rhd_ddia.o to Imakefile.
  80. - 186c345c: Print output name for sensed type.
  81. - d7d63b25: Print sensed type also for RandR.
  82. - 6d628f56: Make debugging output of HPD verbose about the result.
  83. - 811b0cd6: Added quirk table entry for a different Sapphire X1300
  84. - 89cfb738: Add support for RS690 DDIA digital block.
  85. - b6418a97: Add debugging aids.
  86. - c8ad2599: Reset CRTC horizontal counter replication.
  87. - bd11d76a: Handle AtomBIOS TMDS PLL parameters correctly.
  88. - 806d9536: HDMI Type B connector is dual link capable.
  89. - ae3171b9: Add TMDS PLL macro control values for M54 (0x7145).
  90. - 19a6eb46: Chipset name review.
  91. - 96f36339: Fixed imake build.
  92. - 3d62e9a1: Cosmetics: Move RV620/635 to a more sensible position in our devices list.
  93. - 9de85904: RHDPLLsInit: PLL2: Add missing " else " in "if () {}{}"... Duh.
  94. - 00f182d6: Use correct option name for (yet unused) TVMode option.
  95. - 98d328b0: Fix endless loop.
  96. - 427d9553: If available read panel dithering parameters from AtomBIOS.
  97. - c336508e: Remove DVI_DUAL as a type which can be detected by load detection.
  98. - bf8bda88: Make variable and enum names more consistent.
  99. - db0d6058: Fix a memory leak.
  100. - 098cf71d: Make test for DIG2 more consistent.
  101. - 46a40c82: Add #ifdef wrappers around AtomBIOS related code.
  102. - 54f491f9: Add AtomBIOS based UNIPHY support for RV620/635.
  103. - 2d81ffc7: Fix a wrong type in ATOM_ANALOG_TV_INFO in upstream version of atombios.h.
  104. - cab03118: DxCRTC: Fix disabling check.
  105. - 52f04a7f: TMDSA: Fix sensing with respect to duallink.
  106. - 42d3201b: PLL: further fall-out of removal of validation callback for our hw.
  107. - 8f499c38: DVI is on TMDSB not LVDS.
  108. - 56a264f8: Set Connector element already in rhdRROutputDetect().
  109. - 478bda79: Fix issues with DDC on RV620/635.
  110. - e5dddbc2: Fix issues with DAC load detection on RV620/635.
  111. - 5596d06d: Fix issues with DAC load detection and erronous DDC detection on RV620/635.
  112. - c9ccc4c4: Resolve unknown registers.
  113. - aa7037a7: Remove stale structure elements.
  114. - dfe36048: Changed heuristics for encoder link enabling.
  115. - 153331e8: Properly restore Encoder and Transmitter.
  116. - 6742f79e: RV620: Add Pixelclock support.
  117. - 807e525a: Implement the hardware level scaling code.
  118. - fd6a7abf: Restructure FMT block handling.
  119. - 2e1f55b0: Consolidate handling of dual link TMDS displays.
  120. - f0256f38: List explicite arguments for FMT block programming.
  121. - 59de4071: Fix identification of end-of-code table data tables and GoldenSettings search.
  122. - b3df388f: Add RV620/RV635 devices.
  123. - c13650e6: Add KLDSKP_LVTMA and UNIPHYs to connector handling.
  124. - 0dee42c5: Add support for new DIG blocks on RV620/635.
  125. - 8dabb69a: Fix structure names in rhd_output.c.
  126. - 80fb6b3f: Fix copy-over artefacts from rhd_conntest.
  127. - 252491e4: Adding KLDSKP_LVTMA and UNIPYA/B as output types.
  128. - 6dab67a8: Add RHD_CONNECTOR_DVI_SINGLE to be able to mark a single link connector.
  129. - abb188fe: Separate query for temporal and spatial dithering.
  130. - 4ec30282: Add more verbose output on GoldenSettings matching.
  131. - a0c11368: Add support enumerated object IDs to the connector table parser.
  132. - b280b417: Support for TMDSA dual link load detection (untested!).
  133. - dec87ba6: Add support for dual link DVI panels (untested!).
  134. - cf8eea25: Add support for two new ObjectIDs required for RV620/635.
  135. - 55ce4f82: Added own version of AtomBIOS getConditionalGoldenValues().
  136. - 283c2d2e: Fix GPIO routing for DDC in RV620/635.
  137. - d499a616: Fix GPIO routing for DDC for RV620/635 in rhd_conntest.c.
  138. - 8de4cd9a: Locate data tables embedded in AtomBIOS command tables.
  139. - e29024d9: Consolidate load detection for R5xx/r6xx in rhd_conntest.
  140. - f021c0cf: Add support for DAC load detection and I2C for RV620/RV635 to rhd_conntest.
  141. - 481df402: Add stubs for the PLL subsystem.
  142. - 3ba1c093: Add support for the DAC output subsystem for RV620/RV635.
  143. - b08e64ec: Add I2C subsystem support for RV620/RV635.
  144. - 089801d4: Add RV620/RV635 PCI IDs.
  145. - 47298a34: Add support for sensing and programming different analog outputs.
  146. - 2d42e5b7: Add monitor support for TVs.
  147. - 8f06626d: Add an option to pass the TV standard to override boot default.
  148. - 3fe49f2a: Fix spelling of 'Supp(p)orted' to match the fixed spelling in atombios.h.
  149. - 2bcabe12: Add parsing of TV releated data tables to the AtomBIOS support.
  150. - 726f6da1: Add TV detection do DAC load detection.
  151. - e1605dfb: Be more verbose about fb parameters.
  152. - 5163b9fb: Get and store verbosity level.
  153. - 00e1b025: Restore original order of CRTCRestore and VGARestore.
  154. * Sat Mar 01 2008 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.7.20080301git
  155. - Add dependency on xorg server on F9 to prevent ABI compatibility issues (#431176)
  156. - Reflect R5xx partial 2D acceleration support in README.fedora
  157. - New snapshot (upstream commit 8c6d1b46b70ae19fafb5484c238a74cca18d5990):
  158. - 8c6d1b46: conntest: add new ids.
  159. - 294cf1f6: Fix test for RS6XX in RHDMCSetup().
  160. - 1b3f3c9c: Add connector table flag for X1400 (0x7145, 0x1297, 0x3058).
  161. - a23b1123: Loop over all CRTCs when shutting down memory access.
  162. - 8432cb08: Add quirk table entry for Diamond Viper Radeon X1650 Pro
  163. - 5ba5f4b5: Include description for acceleration options.
  164. - eee9b718: Fix typo in patch adding DradonFlyBSD support.
  165. - f89bac58: Add support for DragonFlyBSD.
  166. - 1223e40a: Add debugging to rhd_conntest.c
  167. - 1e8637b1: Changing R6XX_MC_VM_MISC_OFFSET to R6XX_HDP_NONSURFACE_BASE.
  168. - 854ce3b2: Make DDC for panels work on MacBook Pro's.
  169. - 247d4263: Set up GPIO pin HW access for DDC testing in rhd_conntest.
  170. - 23a47ec0: Restore VGA after restoring the CRTCs.
  171. - 74eacf3e: Make sure GRAPH and CRTC engine are disabled before changing surface.
  172. - 2b16734b: Set GPIO pins to be HW driven on R5xx for HW controlled I2C.
  173. - 2feff5cb: Add wait for memory idle state.
  174. - e0d58784: Handle LVTMA_TRANSMITTER_ENABLE identically on R5/6xx.
  175. - 1849092e: Add connector information for a Sapphire Radeon HD 2600 PRO AGP (PnPID: 0x9587:0x1002:0x0028).
  176. - 7527df07: Revert "PATCH: Report PANEL as disconnected when no modes are available"
  177. - 3d29d4ce: PATCH: Report PANEL as disconnected when no modes are available
  178. - cd6a4b89: typo fix in DPI guessing code
  179. - 1a503c59: Update ObjectID.h
  180. - 8640be8e: Update atombios.h
  181. * Sat Feb 16 2008 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.6.20080216git
  182. - New snapshot (upstream commit a9af866ae712a0048d374dc640e482d1f4ce8859):
  183. - a9af866a: Prevent endless loop in connector table parser.
  184. - 80c7c9e5: Fix device ID for 0x7187, 0x174B, 0x3000 in cards table.
  185. - bef7f09c: Ask people to not only send in their log file but also to describe their problem.
  186. - bde5fbbf: Added 'HPD swap' flag for 0x7187, 0x174B, 0x300.
  187. - 7606be1a: Fully implement the SaveScreen() function.
  188. - 748de840: VGA: bitten by pScrn->videoRam in kB instead of B again.
  189. - cbbd54a2: Fix blaning problem in bug #13853.
  190. - f37d4cb9: Don't make assumptions about DDC clk line on RS690 when AtomBIOS is not available.
  191. - dc519eb2: Need to include string.h in r5xx_exa.c
  192. * Sun Feb 03 2008 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.5.20080203git
  193. - New snapshot (upstream commit caa10014d115a49a59b4a2aef6ce36a4e615556a):
  194. - Basic EXA/XAA for R5xx
  195. - Add PowerColor X1550, PCP X1600 400M/500E, R680 (HD3870 X2)
  196. - 7cab021c: Improve FB handling
  197. - e0cfbcd5: Add AccelMethod Option and related handling
  198. - 5829bff7: TMDSA: Add control value for 71C4
  199. - 7cb27bca: Add RHD_CARD_FLAG_HPDOFF flag, improve quirk entries for T60p
  200. - 32d1b4d9: If no EDID is available, assume 96dpi on the first (preferred) mode
  201. - ad50eaa0: Correct order of mask and value in ROM access code
  202. - 0f066c20: Implemented PLL functions for CAIL, fixed MC
  203. - 361ba486: Change heuristics to check for an unPOSTed card
  204. - 72e7b062: Fix some issues when reading PCI ROM on POSTed systems
  205. - a412d582: Read PCI BIOS on secondary R5xx cards
  206. * Thu Jan 03 2008 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.3.20080103git
  207. - New snapshot (upstream commit 4e488a349c862da2e27f6025d376fb2b63db3bf9):
  208. - Enable FB location fix for r5xx.
  209. - Fix PLLControlTableRetrieve() loop.
  210. * Fri Dec 28 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.0-0.2.20071228git
  211. - New snapshot (upstream commit fcf15c8facb7c2c1a4a2513f3f84537f3f35c6a1):
  212. - (Some?) RV670 support
  213. - c036b819: Only report unknown cards IF they have issues.
  214. - b9277bfc: Check for loaded fglrx kernel module.
  215. - 765f5972: Man page describes all RandR properties
  216. - 2b3928c6: Fix "messed up colours" issues after suspend/resume
  217. - ...
  218. * Wed Dec 19 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.0.0-0.4.20071219git
  219. - New snapshot (upstream commit 861debbf8d649ce09d53d5880f819757ac9c7814)
  220. - 861debbf: Make the driver build with the latest ustream git server sources again.
  221. - 9120f95f: Delete a spurious git_version.h.new when doing make clean.
  222. - e98195bd: Don't fail immediately when git-rev-parse fails.
  223. - 6d9a6709: IDs: Asus M2A-VM should now no longer need a connector table.
  224. - 521bcace: DxGRPH: Fix graphics engine colour issues (hopefully).
  225. - 47f8a6f7: Add support for HDMI connectors.
  226. - 21e1c6c4: Get EDID block for panels from AtomBIOS even if there is a special Mode.
  227. - 492e94c3: LVDS: Fix 18/24 bit dithering and disable spatial dither.
  228. - 55f89f69: LVDS: Fix FPDI handling.
  229. - ef51931a: HPD pin swapping logic.
  230. - 9741c5be: TMDSA: properly add macro control for 0x7149 (M56)
  231. - dcfd91c2: TMDSA/B: add macro control values for 0x71C6 (RV530)
  232. - c784c92a: TMDSA: add macro control for 0x7147 (M56)
  233. - 5acefe5c: ID: 0x724B: Sapphire Radeon X1900 GT
  234. - 1a1d110f: Restore: Fix VGA textmode restore when VSYNC length is 0.
  235. * Wed Dec 12 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.0.0-0.3.20071212git
  236. - New snapshot (upstream commit b991fe3d884a51e236f895c41b0ba1b06127f7dd):
  237. - b991fe3d: DACs: Properly set up and save/restore SYNC_SELECT.
  238. - bb12148c: Added Asus M2A-VM (RS690 based) to quirks table.
  239. - 87f8f8e9: Add Gigabyte HD 2600 XT to quirks table.
  240. - b0cb8aec: Don't check for connector type for DMS-59 detection (RandR case).
  241. - affbdf54: Additional checks for cursor size in UseHWCursor().
  242. - 09b4dea7: Only reload cursor image if there is one.
  243. - dc7fe476: Broken connector table: GeCube Radeon HD 2400 AGP: proper fix.
  244. - ae46a18d: TMDSA/B: 9587 electrical values.
  245. - 030f715c: Fix 13509: Xserver crash when RandR finds no modes.
  246. - c01edd52: Improve scanning of panning area specification. Pan to area on setting it.
  247. - 42a07a0d: Re-create Atoms for properties in CreateResources.
  248. - 6d0c7c32: Add panning in RandR mode.
  249. - Ship new ChangeLog file.
  250. * Sun Dec 09 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.0.0-0.2.20071209git
  251. - New snapshot (upstream commit e399d16597e30a6c53c8f70aa122285615fe7d08)
  252. - Fix blank screen occuring in some cases.
  253. - Initial RS600 support.
  254. - Sync and LUT fixes.
  255. - Add useful DPI calculation.
  256. - Relax xorg-x11-server-utils requirement: Only for F-8 and later, no %%{dist}.
  257. * Fri Nov 30 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.0.0-0.1.20071130git
  258. - New snapshot (upstream commit 9fe776edf44c40d06e0059878df4f37391409c66 aka 1.0.0)
  259. - Significantly improve README and radeonhd(4) man page.
  260. - Add a number of connector table workarounds.
  261. - Several messages fixed or toned down.
  262. * Thu Nov 29 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.4-0.2.20071129git
  263. - New snapshot (upstream commit 8b1b8bfb21d2d86780cb4e02abc813578daa24bd):
  264. - RandR 1.2 support with hotplugging of monitors.
  265. - R600 LVDS: RS690M, M72, M74 and M76 devices.
  266. - Fixed "white screen" bug.
  267. - Numerous fixes and new support for features.
  268. - Preserve source file timestamps where possible.
  269. * Fri Nov 16 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.18.20071116git
  270. - New snapshot (upstream commit dbb073b8b314264e311c3a1ebecd13d93e9627a6):
  271. - Macbook Pro PCI ID based workaround for awkward AtomBIOS connector table.
  272. - TMDSA: create a table for electrical adjustments.
  273. - Fix bug submission URL in README.fedora.
  274. * Tue Nov 13 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.17.20071113git
  275. - New snapshot (upstream commit 6f1800ca52531f5baf3df2e65a7bbd93e4b1e637):
  276. - LVTMA TMDS: Add initial TMDS support for r5xx.
  277. - TMDS B: Add table with macro control values.
  278. - Loosen requirements on xorg-x11-server-{Xorg,sdk} from 1.3 to 1.1 (FC6, EL5).
  279. - Require pkgconfig for building (not in EL5 default buildroot).
  280. - Adapt references to rhd_conntest in filesystem.
  281. - Fix git:// URL in README.fedora.
  282. * Sun Nov 11 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.16.20071105git
  283. - Updated README.fedora.
  284. - Improved git commit log message.
  285. - First F-7 and F-8 builds.
  286. * Mon Nov 05 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.15.20071105git
  287. - New snapshot (upstream commit e9c24f662860229440dc61ecbae22e7d7c74d442):
  288. - Improve online help in rhd_conntest.
  289. - Use correct variable for DDC speed setting on R6xx, fix some warnings.
  290. - Add git version to program output (we emulate that).
  291. - Ship rhd_conntest source, and build it (we also install it).
  292. * Tue Oct 31 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.14.20071031git
  293. - New snapshot (upstream commit ad599c4436c64b11d18c89da6a684f5241979a96):
  294. - Fix 1650Pro PLL gain control.
  295. - Improve connector handling.
  296. - Stow away radeonhd.xinf generator for possible later use.
  297. * Tue Oct 30 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.13.20071030git
  298. - Do not #include <sys/io.h> in rhd_conntest.c (fix PPC build).
  299. * Tue Oct 30 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.12.20071030git
  300. - New snapshot (upstream commit f3a2530cea981c6b4c88ec85093032ea152ed47f):
  301. - #include standard headers in corner cases (supposed to fix FC6 build)
  302. * Sun Oct 28 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.11.20071028git
  303. - New snapshot (upstream commit 604bfb02cefa5f56b40aea2dc3256f09836121a4):
  304. - Added ID for Radeon HD 2600 LE (RV630).
  305. - Be smarter about the xorg.conf monitor section by selectively ignoring it.
  306. - Fix mode instability when returning to VT on some mobilities.
  307. * Thu Oct 25 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.10.20071025git
  308. - New snapshot (upstream commit d8cb8a2a8315f86fae0266f58ee30b609c81d510).
  309. - Remove man page patches (man page is upstream now).
  310. * Tue Oct 23 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.9.20071023git
  311. - New snapshot (upstream commit 8699deaba2c920a3df35acfea49360888868becb).
  312. - Add bug report section to README.fedora.
  313. * Sat Oct 20 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.8.20071020git
  314. - New snapshot (upstream commit 3579bdddd95dc6f129e57bcf05cbd8b9b375940f).
  315. - Cleaned up snapshot script.
  316. - Package rhd_conntest utility when building snapshot package.
  317. - Add simple man page.
  318. - Add README.fedora file.
  319. * Wed Oct 17 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.2-0.7.20071017git
  320. - New snapshot (upstream commit d03841b4950b3b827b3c42507e01767d0569391f).
  321. - Use upstream's version 0.0.2.
  322. - Trade in ThinkPad backlight key fix for non-broken mode on lid event.
  323. * Mon Oct 15 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.1-0.6.20071015git
  324. - Hard-code version at 0.0.1 until upstream have figured out what they want.
  325. - Names of snapshot tarballs now contain timestamp.
  326. - Static definition of %%{date}, optionally updated by snapshot script.
  327. - Non-executable snapshot script.
  328. * Mon Oct 15 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.1-0.5.20071015git
  329. - Use %%{driverdir} where possible.
  330. - Include xorg-x11-drv-radeonhd-snapshot.sh script in SRPM.
  331. - Trimmed Description.
  332. - Removed unnecessary -n from %%files.
  333. - Removed ".fc8" from changelog entries.
  334. - Improved comment on %%define snapshot.
  335. * Mon Oct 15 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.1-0.4.20071015git
  336. - New snapshot (needs less patches).
  337. * Sun Oct 14 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 1.1.1-0.3.20071014git
  338. - Initial Fedora RPM package.