totem-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.26.0
  5. %define _gtk_ver 2.22.0
  6. %define _gnomeicon_ver 2.31.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.10.30
  10. %define _gstpb_ver 0.10.30
  11. %define _gstpg_ver 0.10.24
  12. %define _xulrunner_ver 1.9
  13. %define _nautilus_ver 2.32.0
  14. %define _shared_mime_info_ver 0.17
  15. %define _unique_ver 1.0
  16. %define _vala_ver 0.10.0
  17. %define _totem_pl_parser_ver 2.32.0
  18. %define _libgdata_ver 0.6.5
  19. %define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
  20. %define mozplug_dir %{_libdir}/mozilla/plugins
  21. Summary: Movie player for GNOME 2
  22. Summary(ja): GNOME2 用動画プレイヤー
  23. Name: totem
  24. Version: 2.32.0
  25. Release: 1%{?_dist_release}
  26. License: GPL
  27. Group: Applications/Multimedia
  28. URL: http://www.gnome.org/projects/totem/
  29. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/2.32/totem-%{version}.tar.bz2
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. BuildRequires: gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  36. BuildRequires: dbus-devel >= %{_dbus_ver}
  37. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  38. BuildRequires: gettext, scrollkeeper
  39. BuildRequires: perl-XML-Parser
  40. BuildRequires: iso-codes
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: bluez-libs-devel >= 4.15
  43. BuildRequires: lirc
  44. BuildRequires: unique-devel >= %{_unique_ver}
  45. BuildRequires: vala-devel >= %{_vala_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pygtk2-devel
  48. BuildRequires: libgdata-devel >= %{_libgdata_ver}
  49. BuildRequires: gstreamer-devel >= %{_gst_ver}
  50. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  51. BuildRequires: gstreamer-plugins-good >= %{_gstpg_ver}
  52. %if %{build_plugin}
  53. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  54. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  55. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  56. %endif
  57. Requires: gstreamer >= %{_gst_ver}
  58. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  59. Requires: gstreamer-plugins-good >= %{_gstpg_ver}
  60. Requires: iso-codes
  61. # for opensubtitles plugin
  62. Requires: pyxdg
  63. # for python plugins
  64. Requires: pygtk2
  65. # for coherence plugins
  66. Requires: python-Coherence >= 0.6.6.2
  67. Obsoletes: nautilus-media
  68. Obsoletes: %{name}-gstreamer < 2.30.1-2
  69. Obsoletes: %{name}-xine < 2.30.1-2
  70. Obsoletes: %{name}-common < 2.30.1-3
  71. Provides: nautilus-media
  72. Provides: %{name}-common = %{version}-%{release}
  73. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  74. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  75. Requires(preun): GConf2
  76. %description
  77. Totem is simple movie player for the Gnome desktop. It features a
  78. simple playlist, a full-screen mode, seek and volume controls, as well as
  79. a pretty complete keyboard navigation.
  80. %if %{build_plugin}
  81. %package mozilla
  82. Summary: Totem movie plugin for Mozilla
  83. Summary(ja): Mozilla 用 Totem 動画プラグイン
  84. Group: Applications/Internet
  85. Requires: %{name} = %{version}-%{release}
  86. Obsoletes: %{name}-mozilla-common
  87. Obsoletes: %{name}-mozilla-gstreamer
  88. Obsoletes: %{name}-mozilla-xine
  89. %description mozilla
  90. Totem is simple movie player for the Gnome desktop. It features a
  91. simple playlist, a full-screen mode, seek and volume controls, as well as
  92. a pretty complete keyboard navigation.
  93. This package contains a Totem video plugin for Mozilla. It allows Totem
  94. movie player to be embedded into a web browser.
  95. %endif
  96. %prep
  97. %setup -q
  98. %build
  99. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  100. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  101. %configure \
  102. --disable-schemas-install \
  103. --disable-scrollkeeper \
  104. --enable-python \
  105. --enable-nautilus \
  106. --enable-gmp-plugin \
  107. --enable-narrowspace-plugin \
  108. --enable-mully-plugin \
  109. %if %{build_plugin}
  110. --enable-browser-plugins
  111. %else
  112. --disable-browser-plugins
  113. %endif
  114. make %{?_smp_mflags}
  115. %install
  116. rm -rf $RPM_BUILD_ROOT
  117. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  118. make install DESTDIR=$RPM_BUILD_ROOT
  119. # remove unneeded files
  120. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  121. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  122. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  123. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  124. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  125. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  126. %find_lang %{name} --with-gnome
  127. # save space by linking identical images in translated docs
  128. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  129. for f in $helpdir/C/figures/*.png; do
  130. b="$(basename $f)"
  131. for d in $helpdir/*; do
  132. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  133. g="$d/figures/$b"
  134. if [ -f "$g" ]; then
  135. if cmp -s $f $g; then
  136. rm "$g"; ln -s "../../C/figures/$b" "$g"
  137. fi
  138. fi
  139. fi
  140. done
  141. done
  142. %clean
  143. %__rm -rf %{buildroot}
  144. %post
  145. %{_bindir}/scrollkeeper-update -q
  146. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  147. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  148. gconftool-2 --makefile-install-rule \
  149. %{_sysconfdir}/gconf/schemas/totem.schemas \
  150. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  151. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  152. >& /dev/null || :
  153. touch %{_datadir}/icons/hicolor
  154. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  155. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  156. fi
  157. %pre
  158. if [ "$1" -gt 1 ]; then
  159. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  160. gconftool-2 --makefile-uninstall-rule \
  161. %{_sysconfdir}/gconf/schemas/totem.schemas \
  162. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  163. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  164. >& /dev/null || :
  165. fi
  166. %preun
  167. if [ "$1" -eq 0 ]; then
  168. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  169. gconftool-2 --makefile-uninstall-rule \
  170. %{_sysconfdir}/gconf/schemas/totem.schemas \
  171. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  172. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  173. >& /dev/null || :
  174. fi
  175. %postun
  176. %{_bindir}/scrollkeeper-update -q
  177. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  178. touch %{_datadir}/icons/hicolor
  179. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  180. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  181. fi
  182. %files -f %{name}.lang
  183. %defattr(-,root,root,-)
  184. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  185. %config %{_sysconfdir}/gconf/schemas/*.schemas
  186. %{_bindir}/totem
  187. %{_bindir}/totem-audio-preview
  188. %{_bindir}/totem-video-indexer
  189. %{_bindir}/totem-video-thumbnailer
  190. %{_datadir}/applications/%{name}.desktop
  191. %{_datadir}/icons/*/*/apps/*
  192. %{_datadir}/icons/*/*/devices/*
  193. %{_datadir}/%{name}
  194. %{_datadir}/gtk-doc/html/totem
  195. %dir %{_libdir}/totem
  196. %dir %{_libdir}/totem/plugins
  197. %{_libdir}/totem/plugins/brasero-disc-recorder
  198. %{_libdir}/totem/plugins/chapters
  199. %{_libdir}/totem/plugins/coherence_upnp
  200. %{_libdir}/totem/plugins/dbus
  201. %{_libdir}/totem/plugins/gromit
  202. %{_libdir}/totem/plugins/iplayer
  203. %{_libdir}/totem/plugins/jamendo
  204. %{_libdir}/totem/plugins/lirc
  205. %{_libdir}/totem/plugins/media-player-keys
  206. %{_libdir}/totem/plugins/ontop
  207. %{_libdir}/totem/plugins/opensubtitles
  208. %{_libdir}/totem/plugins/properties
  209. %{_libdir}/totem/plugins/pythonconsole
  210. %{_libdir}/totem/plugins/sample-vala
  211. %{_libdir}/totem/plugins/screensaver
  212. %{_libdir}/totem/plugins/screenshot
  213. %{_libdir}/totem/plugins/skipto
  214. %{_libdir}/totem/plugins/thumbnail
  215. %{_libdir}/totem/plugins/youtube
  216. %{_libdir}/totem/plugins/totem
  217. %if %{build_plugin}
  218. %{_libdir}/nautilus/extensions-2.0/*.so*
  219. %endif
  220. %{_libexecdir}/%{name}/totem-bugreport.py
  221. %{_mandir}/man1/*
  222. %if %{build_plugin}
  223. %files mozilla
  224. %defattr(-,root,root,-)
  225. %{mozplug_dir}/*
  226. %{_libexecdir}/totem-plugin-viewer
  227. %endif
  228. %changelog
  229. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  230. - new upstream release
  231. - fix %files
  232. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  233. - new upstream release
  234. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  235. - clean up spec file
  236. - remove totem-common and merged to totem main package.
  237. - add Obsoletes: totem-common
  238. - remove unneeded BR: and R:
  239. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  240. - libmusicbrainz, alternatives
  241. - remove explicit dependency
  242. - gtk2, glib2, dbus
  243. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  244. - add R: gstreamer-plugins-good
  245. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  246. - rebuild with libgdata (add youtube plugin)
  247. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  248. - add Obsolete: totem-gstreamer, totem-xine)
  249. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  250. - new upstream release
  251. - chagnge _gst_ver from 0.10.19 to 0.10.29
  252. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  253. - new upstream release
  254. - drop totem-tracker package
  255. - add BuildRequires: unique-devel
  256. - remove BuildRequires: hal-devel
  257. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  258. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  259. - remove unneeded autoreconf
  260. - add BR: lirc
  261. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  262. - new upstream release
  263. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  264. - remove bemused plugin
  265. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  266. - new upstream release
  267. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  268. - added tracker video search sub-package
  269. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  270. - new upstream release
  271. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  272. - new upstream release
  273. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  274. - remove libxine dependency from totem-common
  275. - build xine backend with minimum dependency
  276. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  277. - add BR: bluez-libs-devel >= 4.15
  278. - fix typo in %%postun xine
  279. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  280. - rebuild with bluez-libs-devel-4.15
  281. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  282. - new upstream release
  283. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  284. - new upstream release
  285. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  286. - new upstream release
  287. - add patch1 to build with xulrunner-1.9
  288. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  289. - new upstream release
  290. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  291. - new upstream release
  292. - disabled devel package (replaced by totem-pl-parser-devel)
  293. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  294. - new upstream release
  295. - update version macros
  296. - enable browser plugins on x86_64
  297. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  298. - new upstream release
  299. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  300. - upstream release
  301. - drop obsolete ja.po.patch (patch0)
  302. - revert change of 1.4.4-0vl2
  303. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  304. - upstream release
  305. - enable browser plugins (exclude x86_64 arch)
  306. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  307. - upstream release
  308. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  309. - update configure options
  310. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  311. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  312. - fix mistranslation (patch0)
  313. - add icon symlink
  314. - add BuildRequires: gstreamer-plugins-good
  315. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  316. - upstream release
  317. - update %%_glib_ver, %%_xine_ver
  318. - add BuildRequires: hal
  319. - update %%configure options
  320. - update %%files
  321. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  322. - upstream release
  323. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  324. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  325. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  326. - upstream release
  327. - drop obsolete patch0
  328. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  329. - upstream release
  330. - add patch0 to build with intltool-0.35
  331. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  332. - upstream release
  333. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  334. - upstream release
  335. - update alternatives entry
  336. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  337. - upstream release
  338. - drop fix-sort-function.patch (was merged to upstream, #331426)
  339. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  340. - rebuild with gnome-2.14rc
  341. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  342. - upstream release
  343. - add macros
  344. - _gtk_ver, _glib_ver
  345. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  346. - _dbus_ver
  347. - _gst_ver, gstpb_ver, _xine_ver
  348. - add fix-sort-function.patch to build with glib < 2.9.1
  349. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  350. - upstream release
  351. - add BuildRequires:
  352. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  353. - gnome-vfs2-devel >= 2.9.92
  354. - dbus-devel >= 0.35
  355. - use gstreamer-0.10 as backend for totem-gstreamer
  356. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  357. - use gstreamer08 instead of gstreamer
  358. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  359. - upstream release
  360. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  361. - fix missing links
  362. - update file list
  363. - update update-alternatives scripts
  364. - fix totem-gstreamer's %%postun script
  365. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  366. - upstream release
  367. - add BuildRequires: iso-codes, libmusicbrainz-devel
  368. - add Requires: iso-codes, libmusicbrains to -common package
  369. - remove BuildRequires: nautilus-cd-burner
  370. - remove Requires: nautilus-cd-burner from -common package
  371. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  372. - totem-gstreamer obsoletes nautilus-media
  373. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  374. - upstream release
  375. - add Requires(post,postun): alternatives for gstreamer,xine
  376. - add Requires(postun,triggers): alternatives for common
  377. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  378. - upstream release
  379. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  380. - build xine backend
  381. - move common files to common package
  382. - move GStreamer related files to gstreamer package
  383. - install xine related files to xine package
  384. - fix scripts
  385. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  386. - upstream release
  387. - update URL
  388. - move *.{a,la} to devel package
  389. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  390. - fix %%{post,preun} script (video-thumbnail.schemas)
  391. - sync with Fedora Core's 1.0.1-1
  392. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  393. - Update to upstream version 1.0.1
  394. - Break out devel package
  395. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  396. - add %%{post,pre}un script
  397. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  398. - initial build for Vine Linux
  399. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  400. - fix %%post
  401. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  402. - Obsolete nautilus-media
  403. - Install property page and thumbnailer
  404. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  405. - Update to 0.101
  406. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  407. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  408. missing menu entry (144088)
  409. - Remove workaround for desktop file being misinstalled, fixed
  410. by above patch
  411. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  412. - New upstream version 0.100
  413. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  414. - update to 0.99.22
  415. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  416. - Add patch to remove removed items from package from help
  417. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  418. - New upstream 0.99.19
  419. - Fixes crasher with CD playback (see NEWS)
  420. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  421. - Call update-desktop-database in post
  422. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  423. - update to 0.99.18
  424. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  425. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>