thread-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389
  1. %define tclmajor 8.4
  2. %define majorver 2.6
  3. Summary: A Tcl/Tk development environment: thread
  4. Summary(ja): Tcl/Tk 開発環境: thread
  5. Name: thread
  6. Version: %{majorver}.5
  7. Release: 2%{?_dist_release}
  8. License: BSD
  9. Group: Development/Languages
  10. BuildRequires: libtool, util-linux, perl, gdbm
  11. BuildRequires: tcl >= %{tclmajor}
  12. BuildRequires: tk >= %{tclmajor}
  13. Requires: tcl >= %{tclmajor}
  14. Requires: tk >= %{tclmajor}
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. URL: http://tcl.sourceforge.net/
  17. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
  18. %description
  19. You can use this extension to gain script-level access to Tcl threading capabilities.
  20. %prep
  21. %setup -q -n %{name}%{version}
  22. %build
  23. chmod 755 ./configure
  24. %configure \
  25. --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
  26. --enable-threads --enable-64bit
  27. make %{?_smp_mflags}
  28. %install
  29. rm -rf ${RPM_BUILD_ROOT}
  30. %makeinstall
  31. echo "%%defattr(-,root,root)" > thread.files
  32. (find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  33. find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  34. | sort | uniq -u >> thread.files
  35. set +x +H
  36. for n in `cat thread.files`; do
  37. test -f $n || continue
  38. head -1 $n | grep -q ^#! || continue
  39. chmod u+w $n
  40. perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  41. done
  42. set -x -H
  43. #
  44. # post process the *.files list, removing build sys references and mark
  45. # which are directories
  46. set +x
  47. for n in *.files; do
  48. mv $n $n.in
  49. sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  50. if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  51. echo -n '%dir '
  52. fi
  53. echo $file
  54. done > $n
  55. rm -f $n.in
  56. done
  57. set -x
  58. #
  59. # Man pages can be compressed
  60. perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  61. %post -p /sbin/ldconfig -n thread
  62. %postun -p /sbin/ldconfig -n thread
  63. %clean
  64. rm -rf ${RPM_BUILD_ROOT}
  65. rm -f *.files
  66. %files -f thread.files -n thread
  67. %changelog
  68. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
  69. - rebuilt with new environment
  70. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
  71. - applied new versioning policy and spec in utf-8
  72. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
  73. - rebuild with tcl/tk-8.4.18
  74. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
  75. - rebuild with tcl/tk-8.4.16
  76. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
  77. - update thread to 2.6.5
  78. - rebuilt with new toolchain
  79. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
  80. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  81. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
  82. - update thread to 2.6.2
  83. - rebuilt for tcl/tk-8.4.11
  84. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
  85. - rebuild for tcl/tk-8.4.6
  86. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
  87. - source update
  88. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
  89. - modified for Vine Linux
  90. - splite source package
  91. * Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
  92. - update Tcl/Tk 8.4.2
  93. * Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
  94. - update thread 2.5
  95. - update expect-20030203 (nightly-cvs)
  96. - remove xotcl
  97. * Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
  98. - add config patch for Trf
  99. - add static libraries of Tcl and Tk
  100. - add tbcload and tclcompiler again
  101. * Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
  102. - build on RH 8.0
  103. - update expect 5.38.0
  104. - remove tcllib module, which will be separate RPM from this.
  105. - remove tbcload module, which will be separate RPM from this.
  106. - remove tclcompiler module, which will be separate RPM from this.
  107. - add XOTcl 1.0
  108. - add Tcl-Trf 2.1p2
  109. - add Memchan 2.2a4
  110. * Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
  111. - fix to make XIC free, and eliminate XCloseIM when exiting Tk.
  112. * Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
  113. - update Tcl/Tk 8.4.1.
  114. * Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
  115. - correct install sequence in Tk.
  116. * Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
  117. - add TclPro tools:
  118. - tbcload CVS
  119. - tclcompiler CVS
  120. * Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
  121. - add iwidgets4.0.1.
  122. - correct symbolic link
  123. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
  124. - fix stub problem in itcl.
  125. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
  126. - adjust libary names to meet compatibility.
  127. * Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
  128. - update Tcl/Tk 8.4.0.
  129. - update TclX 8.4.
  130. - update tcllib 1.3.
  131. - add thread2.4.
  132. * Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
  133. - update tcllib 1.2.
  134. * Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
  135. - correct to install all of message catalogs for Img.
  136. * Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
  137. - add tcl-8.3.4-encoding.patch for JIS encoding
  138. * Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
  139. - update itcl 3.2.1
  140. * Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
  141. - add link for tclth8.3 and wish8.3
  142. - add img 1.2.4
  143. * Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
  144. - update Tcl/Tk 8.3.4
  145. - update tcllib 1.1
  146. - update patch tcl-8.3.4-cruft.patch
  147. - update patch tcl-8.3.4-makecfg.patch
  148. - update patch tk-8.3.4-makecfg.patch
  149. * Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
  150. - hard-coded the compat symlink for tix libdir. (bug 52812)
  151. * Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
  152. - fixed itkwish/itclsh lib problem (bug 52608)
  153. - make itcl install not need tclsh/wish during config/make (bug 52606)
  154. - expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
  155. * Mon Aug 8 2001 Adrian Havill <havill@redhat.com>
  156. - changed rev for tcllib to 1.0
  157. - added execute bit mode for itclsh and itksh compat shells
  158. - re-enable glibc string and math inlines; recent gcc is a-ok.
  159. - optimize at -O2 instead of -O
  160. - rename "soname" patches related to makefile/autoconf changes
  161. - added elf "needed" for tk, tclx, tix, itk
  162. - removed warnings from tclX
  163. * Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
  164. - added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
  165. - fixed 64 bit RPM provides for dependencies
  166. * Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
  167. - updated tclX to the latest version
  168. - fixed tclX 8.3's busted help install
  169. - eliminated make TK_LIB kludge for multiple math libs for tclX
  170. - used %%makeinstall to brute force fix any remaining unflexible makefile dirs
  171. - fixed bad ref count release in tcl (bug 49406)
  172. - improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
  173. - revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
  174. - fixed DirTree in Tix (bug 45570)
  175. * Sun Jul 8 2001 Adrian Havill <havill@redhat.com>
  176. - refresh all sources to latest stable (TODO: separate expect/expectk)
  177. - massage out some build stuff to patches (TODO: libtoolize hacked constants)
  178. - remove patches already rolled into the upstream
  179. - remove unneeded autopasswd
  180. - removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
  181. - changed shared object filenames to something less gross
  182. - fixed tclX shell's argv parsing (bug 47710)
  183. - reenable threads which seem to work now
  184. - added all necessary header files for itcl (bug 41374)
  185. - fixed spawn/eof read problem with expect (bug 43310)
  186. - made compile-friendly for IA64
  187. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  188. - Bump release + rebuild for 7.2.
  189. * Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
  190. - bzip2 sources
  191. * Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
  192. - build with -D_GNU_SOURCE - fixes expect on ia64
  193. * Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
  194. - build fix from ahavill.
  195. * Wed Feb 21 2001 Tim Powers <timp@redhat.com>
  196. - fixed weather expect script using wrong server (#28505)
  197. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  198. - added "ja_JP.eucJP" to locale list for tcl
  199. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  200. - rebuild so make check passes
  201. * Fri Oct 20 2000 Than Ngo <than@redhat.com>
  202. - rebuild with -O0 on alpha (bug #19461)
  203. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  204. - summaries from specspo.
  205. * Tue Aug 8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  206. - remove symlink to libtixsam.so
  207. * Thu Aug 3 2000 Jeff Johnson <jbj@redhat.com>
  208. - merge "best known" patches from searching, stubs were broken.
  209. - tix needs -fwritable-strings (#14352).
  210. - create tixwish symlink.
  211. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  212. - rebuild against "working" util-linux col.
  213. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  214. - automatic rebuild
  215. * Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
  216. - make sure that tix shared libraries are installed.
  217. - don't mess with %%{_libdir}, it's gonna be a FHS pita.
  218. * Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
  219. - move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
  220. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  221. - tclX had wrong version.
  222. * Fri Jun 2 2000 Jeff Johnson <jbj@redhat.com>
  223. - FHS packaging changes.
  224. - revert --enable-threads, linux is not ready (yet) (#11789).
  225. - tcl/tk: update to 8.3.1 (#10779).
  226. - expect: update to 5.31.7+ (#11595).
  227. - add tcllib-0.4.
  228. - abstract major tcltk version for soname expansion etc.
  229. * Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
  230. - update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
  231. - use perl to drill out pre-pended RPM_BUILD_ROOT.
  232. - configure with --enable-threads (experimental).
  233. - improved version of autopasswd (#4788).
  234. - autopasswd needs to handle password starting with hyphen (#9917).
  235. - handle 553 ftp status in rftp expect script (#7869).
  236. - remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
  237. - correct hierarchy spelling (#7082).
  238. - fix "expect -d ...", format string had int printed as string (#7775).
  239. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  240. - rebuild for sparc baud rates > 38400.
  241. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  242. - handle compressed manpages
  243. * Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
  244. - Make changes from bug number 7602
  245. - Apply patch from bug number 7537
  246. - Apply fix from bug number 7157
  247. - Add fixes from bug #7601 to the runtcl patch
  248. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  249. - fix descriptions
  250. - man pages are compressed (whatapain)
  251. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  252. - fix tclX symlinks.
  253. - compile on systems where SIGPWR == SIGLOST.
  254. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  255. - update tcl/tk to 8.0.5.
  256. - avoid "containing" in Tix (#2332).
  257. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  258. - use /usr/bin/write in kibitz (#1320).
  259. - use cirrus.sprl.umich.edu in weather (#1926).
  260. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  261. - auto rebuild in the new build environment (release 28)
  262. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  263. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  264. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  265. - expect does unaligned access on alpha (#989)
  266. - upgrade tcl/tk/tclX to 8.0.4
  267. - upgrade expect to 5.28.
  268. - add itcl 3.0.1
  269. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  270. - call libtoolize to allow building on the arm
  271. - build for glibc 2.1
  272. - strip binaries
  273. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  274. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  275. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  276. - expect: mkpasswd needs delay before sending password (problem #576)
  277. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  278. - translations modified for de, fr, tr
  279. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  280. - fixed expect binaries exec permissions
  281. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  282. - updated to Tix 4.1.0.006
  283. - updated version numbers of tcl/tk to relflect includsion of p2
  284. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  285. - updated tcl/tk to patch level 2
  286. - updated tclX to 8.0.2
  287. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  288. - fixed filelist for tix... replacing path to the expect binary in scripts
  289. was leaving junk files around.
  290. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  291. - added patch to remove libieee test in configure.in for tcl and tk.
  292. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  293. solution for all systems
  294. - fixed src urls
  295. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  296. - removed version numbers from descriptions
  297. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  298. - updated to tcl/tk 8.0 and related versions of packages
  299. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  300. - built against glibc
  301. - fixed dangling tclx/tkx symlinks