rhythmbox-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.13.3
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libgpod-devel
  15. BuildRequires: libgnomeui-devel >= 2.18.0
  16. BuildRequires: brasero-devel >= 2.32.0
  17. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  18. BuildRequires: gettext, rarian-compat
  19. BuildRequires: totem-pl-parser-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: libffi-devel
  22. BuildRequires: gnome-vfs2-devel >= 2.18.0
  23. BuildRequires: avahi-glib-devel >= 0.6
  24. BuildRequires: libmusicbrainz-devel >= 2.1.0
  25. BuildRequires: libnotify-devel
  26. BuildRequires: libsexy-devel
  27. BuildRequires: libgudev1-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: dbus-devel >= 1.0
  30. BuildRequires: dbus-glib-devel
  31. BuildRequires: gnome-doc-utils >= 0.3.2
  32. BuildRequires: python-devel, pygtk2-devel
  33. BuildRequires: check >= 0.8.2
  34. BuildRequires: intltool >= 0.35.0
  35. BuildRequires: gstreamer-python-devel
  36. BuildRequires: popt-devel
  37. BuildRequires: lirc
  38. BuildRequires: libmtp-devel
  39. BuildRequires: libgnome-keyring-devel >= 2.30.0
  40. BuildRequires: gnome-media-devel
  41. BuildRequires: libSM-devel
  42. Requires: libgpod
  43. Requires: libnotify
  44. Requires: libsexy
  45. Requires: lirc
  46. Requires: libmtp
  47. Requires: libgnomeui
  48. Requires: brasero
  49. Requires: gnome-python gnome-vfs2
  50. Requires: gnome-themes
  51. Requires: libgnome-keyring
  52. Requires: gstreamer-python
  53. %if %{enable_DLNA_UPnP}
  54. Requires: python-Coherence
  55. %endif
  56. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  57. Requires: scrollkeeper GConf2
  58. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  59. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  60. # # respectively.
  61. # Requires: self-build-gstreamer-plugins-ffmpeg
  62. # Requires: self-build-gstreamer-plugins-ugly
  63. %description
  64. Rhythmbox is an integrated music management application based on the powerful
  65. GStreamer media framework. It has a number of features, including an easy to
  66. use music browser, searching and sorting, comprehensive audio format support
  67. through GStreamer, Internet Radio support, playlists and more.
  68. Rhythmbox is extensible through a plugin system.
  69. %description -l ja
  70. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  71. 統合音楽管理アプリケーションです。
  72. 見やすいユーザインターフェースを備え、検索や整列ができ、
  73. GStreamer により数多くの音声フォーマットをサポート、
  74. インターネットラジオをサポート、プレイリスト管理などの
  75. 数多くの特徴を持ちます。
  76. %package devel
  77. Summary: Development tools for rhythmbox applications.
  78. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: pkgconfig
  82. Requires: glib2-devel
  83. Requires: gtk2-devel
  84. Requires: libsoup-devel
  85. Requires: gnome-media-devel
  86. Requires: totem-pl-parser-devel
  87. Requires: gstreamer-devel
  88. %description devel
  89. Header files and libraries for building a extension library for the rhythmbox.
  90. %description devel -l ja
  91. %prep
  92. %setup -q
  93. # autoreconf -i
  94. # Use the installed louie, not the one in Coherence
  95. find plugins/coherence/upnp_coherence/ -type f \
  96. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  97. %build
  98. # work around a gstreamer bug
  99. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  100. %configure --with-ipod \
  101. --with-mtp \
  102. --with-dbus \
  103. --with-mdns=avahi \
  104. --with-libnautilus-burn \
  105. --with-cd-burning \
  106. --with-metadata-helper \
  107. --enable-lirc \
  108. --enable-python \
  109. --disable-vala \
  110. --disable-browser-plugin \
  111. --disable-static \
  112. --disable-scrollkeeper \
  113. --disable-schemas-install \
  114. --without-hal
  115. %__make %{?_smp_mflags}
  116. %install
  117. %__rm -rf $RPM_BUILD_ROOT
  118. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  119. %__make install DESTDIR=$RPM_BUILD_ROOT
  120. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  121. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  122. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  124. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  125. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  126. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  127. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  128. ## Don't package DLNA/UPnP plugin
  129. %if !%{enable_DLNA_UPnP}
  130. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  131. %endif
  132. %find_lang %{name}
  133. # Don't package api docs
  134. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  135. # Don't package scrollkeeper catalogs
  136. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  137. # And don't package vala
  138. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  139. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  140. # save space by linking identical images in translated docs
  141. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  142. for f in $helpdir/C/figures/*.png; do
  143. b="$(basename $f)"
  144. for d in $helpdir/*; do
  145. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  146. g="$d/figures/$b"
  147. if [ -f "$g" ]; then
  148. if cmp -s $f $g; then
  149. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  150. fi
  151. fi
  152. fi
  153. done
  154. done
  155. %clean
  156. %__rm -rf $RPM_BUILD_ROOT
  157. %post
  158. /sbin/ldconfig
  159. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  160. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
  161. update-desktop-database -q
  162. scrollkeeper-update -q
  163. touch --no-create %{_datadir}/icons/hicolor
  164. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  165. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  166. fi
  167. %preun
  168. if [ "$1" -eq 0 ]; then
  169. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  170. gconftool-2 --makefile-uninstall-rule \
  171. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
  172. fi
  173. %postun
  174. /sbin/ldconfig
  175. update-desktop-database -q
  176. scrollkeeper-update -q
  177. touch --no-create %{_datadir}/icons/hicolor
  178. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  179. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  180. fi
  181. %files -f %{name}.lang
  182. %defattr(-, root, root)
  183. %doc AUTHORS COPYING ChangeLog README NEWS
  184. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
  185. %{_bindir}/*
  186. %{_libdir}/lib*.so.*
  187. %{_libdir}/rhythmbox/plugins
  188. %{_datadir}/applications/rhythmbox.desktop
  189. %{_datadir}/applications/rhythmbox-device.desktop
  190. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  191. %{_datadir}/gnome/help/rhythmbox
  192. %{_datadir}/icons/*
  193. %{_datadir}/omf/rhythmbox
  194. %{_datadir}/rhythmbox
  195. %{_mandir}/man1/*
  196. %{_libexecdir}/rhythmbox-metadata
  197. %files devel
  198. %defattr(-, root, root)
  199. %{_includedir}/%{name}/*
  200. %{_libdir}/*.so
  201. %{_libdir}/pkgconfig/*.pc
  202. %changelog
  203. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  204. - new upstream release
  205. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  206. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  207. - new upstream release
  208. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  209. - rebuild with brasero-2.32.0
  210. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  211. - rebuild with rpm-4.8.1 for pkg-config file
  212. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  213. - new upstream release
  214. - fix %files (add rhythmbox-device.desktop)
  215. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  216. - new upstream release
  217. - change BuildRequires: gnome-media-devel instead of gnome-media
  218. - add devel package
  219. - drop Patch0
  220. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  221. - new upstream release
  222. - drop Patch1, Patch2, Patch3
  223. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  224. - change Requires: nautilus-cd-burner -> brasero
  225. - change BuildRequires: hal-devel -> libgudev1-devel
  226. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  227. - change Requires: gnome-keyring -> libgnome-keyring
  228. - add configure option (--without-hal)
  229. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  230. - rebuilt with new environment
  231. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  232. - new upstream release
  233. - dropped upstreamed/obsolete patches
  234. - added patches applied Fedora development
  235. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  236. - new upstream release
  237. - added configure options:
  238. --disable-vala
  239. --disable-browser-plugin
  240. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  241. - added Japanese description
  242. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  243. - new upstream release
  244. - dropped rb-disable-power-plugin-by-default.patch
  245. - added BuildRequires:
  246. - libSM-devel
  247. - gnome-media
  248. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  249. - rebuild with libgpod-0.7.2
  250. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  251. - new upstream release
  252. - corrected License tag
  253. - dropped rhythmbox-0.11.6-libmtp.patch
  254. - added BuildRequires:
  255. - sqlite3-devel
  256. - libffi-devel
  257. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  258. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  259. - applied rhythmbox-0.11.6-libmtp.patch
  260. - added Requires:
  261. - libgpod
  262. - libnotify
  263. - libsexy
  264. - lirc
  265. - libmtp
  266. - libgnomeui
  267. - nautilus-cd-burner
  268. - gstreamer-python
  269. - gnome-vfs2
  270. - gnome-themes
  271. - gnome-keyring
  272. - python-Coherence, if enable_DLNA_UPnP = 1
  273. - added BuildRequires:
  274. - libnotify-devel
  275. - libsexy-devel
  276. - lirc
  277. - libmtp-devel
  278. - gnome-vfs2-devel, instead of gnome-vfs2
  279. - gnome-keyring-devel
  280. - dropped --with-internal-libsexy in configure options
  281. - added in configure options:
  282. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  283. - added %%preun to remove the schema
  284. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  285. - new upstream release
  286. - changed to --with-metadata-helper in configure options
  287. - added BuildRequires:
  288. - gstreamer-python
  289. - intltool >= 0.35.0
  290. - popt-devel
  291. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  292. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  293. - rebuilt with python-2.5.2
  294. - applied new versioning policy
  295. - spec in utf-8
  296. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  297. - rebuilt with libgpod-0.6.0
  298. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  299. - new upstream release
  300. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  301. - new upstream release
  302. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  303. - rebuilt with new toolchain and libgpod-0.4.2
  304. - add BuildRequires: dbus-glib-devel
  305. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  306. - new upstream release
  307. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  308. - rebuilt for VineSeed
  309. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  310. - new upstream release
  311. - added --enable-python option to %%configure
  312. - added Requires: gnome-python
  313. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  314. - new upstream release
  315. - built with libsoup 2.2.99
  316. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  317. - added --with-cd-burner to configure
  318. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  319. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  320. - add BuildRequires:
  321. - gnome-doc-utils >= 0.3.2
  322. - python-devel
  323. - pygtk2-devel
  324. - check >= 0.8.2
  325. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  326. - rebuild with gnutls-1.4.1
  327. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  328. - new upstream release
  329. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  330. - new upstream release
  331. - run scrollkeeper-update at %post and %postun
  332. - added BuildRequires: libnotify-devel
  333. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  334. - new upstream release (dropped patch0)
  335. - added --without-metadata-helper at configure
  336. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  337. - Initial build for Vine Linux based on FC pacakge
  338. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  339. - add patch from James "Doc" Livingston to stop a hang
  340. for new users (bug 183883)
  341. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  342. - bump again for double-long bug on ppc(64)
  343. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  344. - rebuilt for new gcc4.1 snapshot and glibc changes
  345. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  346. - Update to 0.9.3.1
  347. - Use gstreamer (0.10)
  348. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  349. - Remove hack for 173869, as its no longer needed.
  350. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  351. - 0.9.3
  352. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  353. - Newer CVS snapshot
  354. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  355. - Update to latest CVS
  356. - Add hack to workaround bug #173869
  357. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  358. - Rebuild, now that gstreamer08-plugins has been fixed
  359. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  360. - bonobo multilib issue (bug 156982)
  361. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  362. - rebuild with ipod support
  363. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  364. - rebuilt again
  365. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  366. - rebuilt
  367. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  368. - rebuild
  369. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  370. - rebuild for new dbus
  371. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  372. - Update to 0.9.2
  373. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  374. - Update to 0.9.1
  375. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  376. - Add configure flags --with-bonobo --with-dbus
  377. - BR nautilus-cd-burner-devel
  378. - New upstream CVS snapshot for testing
  379. - Drop IDL file and ui .xml
  380. - Add dbus service file
  381. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  382. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  383. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  384. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  385. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  386. cell renderer for playback icon (no longer necessary) and
  387. changes the rating renderer to work with non-b&w icons
  388. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  389. - Rebuild for GCC4
  390. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  391. - New upstream version
  392. - Remove librb-nautilus-context-menu.so, killed upstream
  393. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  394. - PreReq desktop-file-utils >= 0.9
  395. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  396. - New upstream version
  397. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  398. - Fix postun to use correct syntax, thanks Nils Philippsen
  399. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  400. - New upstream version
  401. - Call update-desktop-database in post and postun
  402. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  403. - New upstream version
  404. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  405. - rebuilt
  406. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  407. - New upstream version
  408. - Remove backported patches
  409. - Gratuitiously bump various BuildRequires versions
  410. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  411. - Remove code to unregister GConf schema for now (Closes: #122532)
  412. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  413. - Apply tiny patch from 0.8 arch to fix GConf key used
  414. for initial sorting
  415. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  416. - Apply patch from 0.8 arch tree to fix a number of memleaks
  417. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  418. - Update to 0.8.3: fixes showstopper bug with internet radio
  419. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  420. - Update to 0.8.2
  421. - Fix Source url
  422. - Add smp_mflags
  423. - Bump BuildRequires on gstreamer to 0.8.1
  424. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  425. - Uninstall GConf schemas on removal
  426. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  427. - Update to 0.8.1
  428. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  429. - Update to 0.8.0
  430. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  431. - Update to 0.7.2
  432. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  433. - Remove BuildRequires on autoconf and libvorbis-devel
  434. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  435. - New major version - I know we are past major version slush, but
  436. this should have been done two weeks ago along with the GNOME 2.6
  437. upload. As upstream author as well, I believe this version is
  438. good enough for FC2.
  439. - Remove --disable-mp3
  440. - Remove id3, flac variables
  441. - Remove GStreamer major version patch
  442. - Fix typo in description
  443. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  444. - rebuild for new gstreamer
  445. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  446. - update to 0.6.8
  447. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  448. - rebuilt
  449. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  450. - update to 0.6.7
  451. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  452. - rebuilt
  453. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  454. - New upstream version
  455. - Don't re-run the autotools; upstream incorporates newer versions.
  456. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  457. - new version
  458. - remove smp_flags
  459. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  460. - remove the initial iradio channels as they all are mp3 based.
  461. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  462. - Fix category from Development/Libraries to Applications/Multimedia.
  463. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  464. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  465. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  466. - Removed unnecessary date expansion define.
  467. - Updated description, including mp3 reference removal.
  468. - Added libid3tag and flac optional support for convenient rebuild.
  469. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  470. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  471. - new version
  472. - use %{_sysconfdir} instead of /etc
  473. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  474. - rebuilt
  475. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  476. - gave up on other archs for the Beta
  477. - new version
  478. - remove werror and add missing files
  479. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  480. - update to newer cvs snap
  481. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  482. - update to cvs snap
  483. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  484. - use %%(lang)
  485. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  486. - fix post to actually install the schema
  487. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  488. - Added gconf file
  489. - Added i18n directory
  490. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  491. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  492. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  493. - removed bonobo dependency
  494. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  495. - created new spec file