openssh-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742
  1. %define ver 5.8p1
  2. %define rel 1%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  11. %define no_gnome_askpass 0
  12. # Use GTK2 for gnome-ssh-askpass
  13. %define gtk2 1
  14. # Build position-independent executables (requires toolchain support)?
  15. %define pie 1
  16. # Do we want to link against a static libcrypto? (1=yes 0=no)
  17. %define static_libcrypto 0
  18. # Do we want smartcard support (1=yes 0=no)
  19. %define scard 0
  20. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  21. %define noip6 0
  22. # Do we want kerberos5 support (1=yes 0=no)
  23. %define kerberos5 0
  24. # Reserve options to override askpass settings with:
  25. # rpm -ba|--rebuild --define 'skip_xxx 1'
  26. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  27. # Options for static OpenSSL link:
  28. # rpm -ba|--rebuild --define "static_openssl 1"
  29. %{?static_openssl:%define static_libcrypto 1}
  30. # Options for Smartcard support: (needs libsectok and openssl-engine)
  31. # rpm -ba|--rebuild --define "smartcard 1"
  32. %{?smartcard:%define scard 1}
  33. # Option to disable ipv6
  34. # rpm -ba|--rebuild --define "noipv6 1"
  35. %{?noipv6:%define noip6 1}
  36. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  37. %define rescue 0
  38. %{?build_rescue:%define rescue 1}
  39. # Turn off some stuff for resuce builds
  40. %if %{rescue}
  41. %define kerberos5 0
  42. %endif
  43. Summary: The OpenSSH implementation of SSH.
  44. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  45. Name: openssh
  46. Version: %{ver}
  47. Release: %{rel}
  48. URL: http://www.openssh.com/portable.html
  49. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  50. Patch0: openssh-5.5p1-vine.patch
  51. Patch4: openssh-5.2p1-vendor.patch
  52. Patch12: openssh-selinux.patch
  53. Patch20: openssh-3.9p1-gssapimitm.patch
  54. Patch21: openssh-3.9p1-safe-stop.patch
  55. Patch24: openssh-5.7p1-fromto-remote.patch
  56. Patch26: openssh-5.2p1-pam-no-stack.patch
  57. Patch27: openssh-5.1p1-log-in-chroot.patch
  58. Patch30: openssh-4.0p1-exit-deadlock.patch
  59. # Patch31: openssh-3.9p1-skip-used.patch
  60. Patch35: openssh-4.2p1-askpass-progress.patch
  61. # Vine Patch
  62. Patch100: openssh-norootlogin.patch
  63. Patch120: openssh-4.7p1-sshd.init.patch
  64. License: BSD
  65. Group: Applications/Internet
  66. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  67. Obsoletes: ssh
  68. BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
  69. BuildRequires: util-linux
  70. BuildRequires: db4-devel
  71. BuildRequires: pam-devel
  72. BuildRequires: zlib-devel
  73. %if ! %{no_gnome_askpass}
  74. BuildRequires: libX11-devel
  75. BuildRequires: gtk2-devel
  76. %endif
  77. BuildRequires: xorg-x11-xauth
  78. BuildRequires: groff
  79. BuildRequires: libedit-devel
  80. Vendor: Project Vine
  81. Distribution: Vine Linux
  82. Packager: daisuke
  83. %package clients
  84. Summary: OpenSSH clients.
  85. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  86. Requires: openssh = %{version}-%{release}
  87. Group: Applications/Internet
  88. Obsoletes: ssh-clients
  89. Obsoletes: openssh-contrib
  90. %package server
  91. Summary: The OpenSSH server daemon.
  92. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  93. Group: System Environment/Daemons
  94. Obsoletes: ssh-server
  95. Requires(post): openssh = %{version}-%{release}
  96. Requires(post): chkconfig
  97. Requires(pre): shadow-utils
  98. Requires(post): initscripts >= 5.20
  99. Requires: pam
  100. %package askpass-gnome
  101. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  102. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  103. Group: Applications/Internet
  104. Requires: openssh = %{version}-%{release}
  105. Obsoletes: ssh-extras
  106. Obsoletes: openssh-askpass < 5.5p1-3vl6
  107. Provides: openssh-askpass = %{version}-%{release}
  108. %description
  109. SSH (Secure SHell) is a program for logging into and executing
  110. commands on a remote machine. SSH is intended to replace rlogin and
  111. rsh, and to provide secure encrypted communications between two
  112. untrusted hosts over an insecure network. X11 connections and
  113. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  114. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  115. it up to date in terms of security and features, as well as removing
  116. all patented algorithms to separate libraries.
  117. This package includes the core files necessary for both the OpenSSH
  118. client and server. To make this package useful, you should also
  119. install openssh-clients, openssh-server, or both.
  120. #'
  121. %description -l ja
  122. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  123. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  124. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  125. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  126. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  127. な通信路の中を通すことができます。
  128. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  129. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  130. アルゴリズムは分割したライブラリにわかれています。
  131. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  132. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  133. openssh-clients および/または openssh-server が必要です。
  134. %description clients
  135. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  136. into and executing commands on a remote machine. This package includes
  137. the clients necessary to make encrypted connections to SSH servers.
  138. You'll also need to install the openssh package on OpenSSH clients.
  139. #'
  140. %description -l ja clients
  141. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  142. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  143. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  144. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  145. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  146. な通信路の中を通すことができます。
  147. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  148. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  149. アルゴリズムは分割したライブラリにわかれています。
  150. このパッケージは OpenSSH をクライアントとして使用する場合に
  151. 必要なものを含んでいます。
  152. %description server
  153. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  154. into and executing commands on a remote machine. This package contains
  155. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  156. securely connect to your SSH server. You also need to have the openssh
  157. package installed.
  158. %description -l ja server
  159. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  160. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  161. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  162. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  163. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  164. な通信路の中を通すことができます。
  165. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  166. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  167. アルゴリズムは分割したライブラリにわかれています。
  168. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  169. デーモンなどを含んでいます。
  170. %description askpass-gnome
  171. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  172. into and executing commands on a remote machine. This package contains
  173. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  174. environment.
  175. %description -l ja askpass-gnome
  176. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  177. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  178. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  179. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  180. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  181. な通信路の中を通すことができます。
  182. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  183. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  184. アルゴリズムは分割したライブラリにわかれています。
  185. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  186. %prep
  187. %setup -q
  188. %patch0 -p1 -b .vine
  189. %patch4 -p1 -b .vendor
  190. %if %{WITH_SELINUX}
  191. #SELinux
  192. %patch12 -p1 -b .selinux
  193. %endif
  194. %patch21 -p1 -b .safe-stop
  195. %patch24 -p1 -b .fromto-remote
  196. %patch26 -p1 -b .stack
  197. %patch27 -p1 -b .log-chroot
  198. %patch30 -p1 -b .exit-deadlock
  199. %patch35 -p1 -b .progress
  200. %patch100 -p1 -b .norootlogin
  201. %patch120 -p1 -b .localtime
  202. autoreconf
  203. %build
  204. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  205. %if %{rescue}
  206. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  207. %endif
  208. %if %{pie}
  209. %ifarch s390 s390x sparc sparc64
  210. CFLAGS="$CFLAGS -fPIE"
  211. %else
  212. CFLAGS="$CFLAGS -fpie"
  213. %endif
  214. export CFLAGS
  215. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  216. %endif
  217. %configure \
  218. --sysconfdir=%{_sysconfdir}/ssh \
  219. --libexecdir=%{_libexecdir}/openssh \
  220. --datadir=%{_datadir}/openssh \
  221. --with-tcp-wrappers \
  222. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  223. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  224. --with-privsep-path=%{_var}/empty/sshd \
  225. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  226. --with-libedit \
  227. %if %{scard}
  228. --with-smartcard \
  229. %endif
  230. %if %{noip6}
  231. --with-ipv4-default \
  232. %endif
  233. %if %{rescue}
  234. --without-pam --with-md5-passwords
  235. %else
  236. --with-pam
  237. %endif
  238. %if %{static_libcrypto}
  239. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  240. %endif
  241. make
  242. %if %{gtk2}
  243. gtk2=yes
  244. %else
  245. gtk2=no
  246. %endif
  247. %if ! %{no_gnome_askpass}
  248. pushd contrib
  249. if [ $gtk2 = yes ]; then
  250. make gnome-ssh-askpass2
  251. mv gnome-ssh-askpass2 gnome-ssh-askpass
  252. else
  253. make gnome-ssh-askpass1
  254. mv gnome-ssh-askpass1 gnome-ssh-askpass
  255. fi
  256. popd
  257. %endif
  258. %install
  259. rm -rf $RPM_BUILD_ROOT
  260. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  261. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  262. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  263. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  264. make install DESTDIR=$RPM_BUILD_ROOT
  265. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  266. install -d $RPM_BUILD_ROOT/etc/pam.d/
  267. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  268. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  269. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  270. install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  271. %if ! %{scard}
  272. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  273. %endif
  274. %if ! %{no_gnome_askpass}
  275. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  276. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  277. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  278. %endif
  279. %if %{no_gnome_askpass}
  280. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  281. %endif
  282. # for contrib package
  283. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  284. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  285. mv contrib/README contrib/README.contrib
  286. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  287. %clean
  288. rm -rf $RPM_BUILD_ROOT
  289. %triggerun server -- ssh-server
  290. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  291. touch /var/run/sshd.restart
  292. fi
  293. %triggerun server -- openssh-server < 2.5.0p1
  294. # Count the number of HostKey and HostDsaKey statements we have.
  295. gawk 'BEGIN {IGNORECASE=1}
  296. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  297. END {exit sawhostkey}' /etc/ssh/sshd_config
  298. # And if we only found one, we know the client was relying on the old default
  299. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  300. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  301. # one nullifies the default, which would have loaded both.
  302. if [ $? -eq 1 ] ; then
  303. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  304. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  305. fi
  306. %triggerpostun server -- ssh-server
  307. if [ "$1" != 0 ] ; then
  308. /sbin/chkconfig --add sshd
  309. if test -f /var/run/sshd.restart ; then
  310. rm -f /var/run/sshd.restart
  311. # /sbin/service sshd start > /dev/null 2>&1 || :
  312. /sbin/service sshd start
  313. fi
  314. fi
  315. %pre server
  316. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  317. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  318. -g sshd -M -r sshd 2>/dev/null || :
  319. %post server
  320. /sbin/chkconfig --add sshd
  321. %postun server
  322. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  323. /sbin/service sshd condrestart
  324. exit 0
  325. %preun server
  326. if [ "$1" = 0 ]
  327. then
  328. /sbin/service sshd stop > /dev/null 2>&1 || :
  329. /sbin/chkconfig --del sshd
  330. fi
  331. %files
  332. %defattr(-,root,root)
  333. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
  334. %attr(0755,root,root) %{_bindir}/scp
  335. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  336. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  337. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  338. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  339. %if ! %{rescue}
  340. %attr(0755,root,root) %{_bindir}/ssh-keygen
  341. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  342. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  343. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  344. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  345. %endif
  346. %if %{scard}
  347. %attr(0755,root,root) %dir %{_datadir}/openssh
  348. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  349. %endif
  350. %files clients
  351. %defattr(-,root,root)
  352. %attr(0755,root,root) %{_bindir}/ssh
  353. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  354. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  355. %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  356. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  357. %attr(-,root,root) %{_bindir}/slogin
  358. %if ! %{rescue}
  359. %attr(0755,root,root) %{_bindir}/ssh-agent
  360. %attr(0755,root,root) %{_bindir}/ssh-add
  361. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  362. %attr(0755,root,root) %{_bindir}/sftp
  363. %attr(0755,root,root) %{_bindir}/ssh-copy-id
  364. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
  365. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  366. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  367. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  368. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  369. %attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
  370. %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
  371. %endif
  372. %if ! %{rescue}
  373. %files server
  374. %defattr(-,root,root)
  375. %dir %attr(0711,root,root) %{_var}/empty/sshd
  376. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  377. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  378. %attr(0755,root,root) %{_sbindir}/sshd
  379. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  380. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  381. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  382. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  383. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  384. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  385. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  386. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  387. %endif
  388. %if ! %{no_gnome_askpass}
  389. %files askpass-gnome
  390. %defattr(-,root,root)
  391. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  392. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  393. %endif
  394. %changelog
  395. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
  396. - new upstream release
  397. * Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
  398. - new upstream release
  399. * Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
  400. - new upstream release
  401. - obsolete contrib subpackage, move ssh-copy-id to client subpackage
  402. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
  403. - rebuilt with openssl 1.0.0c
  404. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
  405. - drop x11-askpass, add Obsoletes: openssh-askpass
  406. - add BR: groff
  407. - enable --with-libedit option, add BR: libedit-devel
  408. - remove unrecognized option '--with-rsh'
  409. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
  410. - add BR: xorg-x11-xauth for X11 forwarding support
  411. * Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
  412. - new upstream release
  413. - update patch0,2
  414. - drop patch3,22
  415. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  416. - new upstream release
  417. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  418. - new upstream release
  419. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  420. - rebuild with xorg-x11-7.3
  421. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  422. - new upstream release with security fix (CVE-2008-1483)
  423. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  424. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  425. - new upstream release with security fix ("ForceCommand" Directive)
  426. - turn on daemon restart message
  427. - new versioning policy
  428. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  429. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  430. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  431. - new upstream release
  432. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  433. - build with -fpie/-pie by default.
  434. - enable ipv6 by default.
  435. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  436. - new upstream release
  437. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  438. - new upstream release
  439. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  440. - new upstream release
  441. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  442. - new upstream release
  443. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  444. - new upstream release
  445. - remove build6x stuff
  446. - remove libgnome-devel from BuildRequires
  447. - cleanup BuildRequires
  448. - drop Patch200, it is merged in upstream.
  449. - import patches(25-35) from FC-devel
  450. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  451. - SECURITY FIX: CVE-2006-0225
  452. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  453. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  454. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  455. - When GNOME2 is used, using libgnome-devel
  456. - add BuildPreReq: gtk2-devel for GNOME2
  457. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  458. - rebuild with gtk+-2.8 final
  459. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  460. - new upstream release
  461. - build with gtk+-2.7
  462. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  463. - new upstream release
  464. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  465. - cleanup obsolete patches and added patches from fedora
  466. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  467. - new upstream release
  468. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  469. - new upstream release
  470. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  471. - new upstream release
  472. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  473. - rebuild with openssl-0.9.7d
  474. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  475. - new upstream release
  476. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  477. - create contrib package
  478. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  479. - new upstream release
  480. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  481. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  482. - new upstream release
  483. - fix security issue: http://www.openssh.com/txt/buffer.adv
  484. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  485. - new upstream release
  486. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  487. - rebuild with gtk2
  488. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  489. - new upstream release
  490. * Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  491. - rebuild with new tool chain
  492. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  493. - new upstream release
  494. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  495. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  496. - change some defines in spec files
  497. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  498. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  499. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  500. - new upstream release
  501. - security fix
  502. - drop patch10
  503. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  504. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  505. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  506. - new upstream release
  507. - add {sshd,ssh}_config.5 manpages
  508. - add ssh-keysign
  509. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  510. - new upstream release
  511. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  512. - new upstream release
  513. - drop patch1
  514. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  515. - new upstream release
  516. - merged with rawhide release.
  517. - drop Patch101 (merged in upstream)
  518. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  519. - seurity patch for off-by-one bug
  520. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  521. - merged with Rawhide 3.0.2p1-2
  522. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  523. - updated to 3.0.2p1
  524. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  525. - updated to 3.0.1p1
  526. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  527. - updated to 3.0p1
  528. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  529. - add japanese summery and descriptions.
  530. - update x11-askpass 1.2.5
  531. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  532. - update to openssh-2.9.9p2
  533. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  534. - rebuilt with openssl-0.9.6b
  535. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  536. - do not Permit RootLogin
  537. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  538. - update to openssh-2.5.2p2
  539. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  540. - update to openssh-2.5.2p1
  541. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  542. - update to openssh-2.5.1p2
  543. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  544. - update to openssh-2.5.1p1
  545. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  546. - update to openssh-2.5.1p1
  547. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  548. - remove suid bit from ssh
  549. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  550. - moved man dir to /usr/share/man
  551. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  552. - fixed askpass's link in ssh-add
  553. - partially used rpmmacros
  554. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  555. - update to 2.3.0p1
  556. - update x11-askpass 1.0.3
  557. * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
  558. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  559. Redhat 7.0 spec file
  560. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  561. - rebuild for Vine Linux
  562. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  563. - Use RPM configure macro
  564. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  565. - Some surgery to sshd.init (generate keys at runtime)
  566. - Cleanup of groups and removal of keygen calls
  567. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  568. - Make building of X11-askpass and gnome-askpass optional
  569. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  570. - Glob manpages to catch compressed files
  571. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  572. - Updated for new location
  573. - Updated for new gnome-ssh-askpass build
  574. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  575. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  576. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  577. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  578. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  579. - Added 'Obsoletes' directives
  580. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  581. - Use make install
  582. - Subpackages
  583. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  584. - Added links for slogin
  585. - Fixed perms on manpages
  586. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  587. - Renamed init script
  588. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  589. - Back to old binary names
  590. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  591. - Use autoconf
  592. - New binary names
  593. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  594. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.