djvulibre-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. Summary: DjVu viewers, encoders and utilities.
  2. Summary(ja): DjVu 画像形式ファイル操作用ライブラリ、ツール
  3. Name: djvulibre
  4. Version: 3.5.22
  5. Release: 3%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Libraries
  8. Source0: http://prdownloads.sourceforge.net/djvu/djvulibre-%{version}.tar.gz
  9. #Source1: djview.png
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. URL: http://djvu.sourceforge.net
  12. BuildRequires: qt-devel, qt-designer
  13. BuildRequires: libtiff-devel
  14. BuildRequires: libjpeg-devel
  15. BuildRequires: glibc-devel
  16. Requires: qt, libtiff, libjpeg, glibc-devel
  17. Distribution: Project Vine
  18. Vendor: Vine Linux
  19. %description
  20. DjVu is a web-centric format and software platform for distributing documents
  21. and images. DjVu content downloads faster, displays and renders faster, looks
  22. nicer on a screen, and consume less client resources than competing formats.
  23. DjVu was originally developed at AT&T Labs-Research by Leon Bottou, Yann
  24. LeCun, Patrick Haffner, and many others. In March 2000, AT&T sold DjVu to
  25. LizardTech Inc. who now distributes Windows/Mac plug-ins, and commercial
  26. encoders (mostly on Windows)
  27. In an effort to promote DjVu as a Web standard, the LizardTech management was
  28. enlightened enough to release the reference implementation of DjVu under the
  29. GNU GPL in October 2000. DjVuLibre (which means free DjVu), is an enhanced
  30. version of that code maintained by the original inventors of DjVu. It is
  31. compatible with version 3.5 of the LizardTech DjVu software suite.
  32. DjVulibre-3.5 contains:
  33. - a standalone DjVu viewer based on the Qt library.
  34. - A browser plugin that works with most Unix browsers.
  35. - A full-fledged wavelet-based compressor for pictures.
  36. - A simple compressor for bitonal (black and white) scanned pages.
  37. - A compressor for palettized images (a la GIF/PNG).
  38. - A set of utilities to manipulate and assemble DjVu images and documents.
  39. - A set of decoders to convert DjVu to a number of other formats.
  40. - An up-to-date version of the C++ DjVu Reference Library.
  41. %package devel
  42. Summary: The libraries and header files needed for djvulibre development.
  43. Group: Development/Libraries
  44. Requires: djvulibre = %{version}
  45. %description devel
  46. DjVulibre libraries and header files for development.
  47. %package plugin
  48. Summary: The plug-in files needed for mozilla.
  49. Group: Applications/Internet
  50. Requires: djvulibre = %{version}
  51. %description plugin
  52. DjVulibre plug-in files for mozilla.
  53. %prep
  54. %setup -q
  55. cp gui/nsdejavu/Makefile.in gui/nsdejavu/Makefile.in.orig
  56. sed "s|netscape|mozilla|" gui/nsdejavu/Makefile.in.orig \
  57. > gui/nsdejavu/Makefile.in
  58. %build
  59. %ifarch i386
  60. export CXXFLAGS="-march=i686"
  61. %endif
  62. %configure
  63. # don't set smp option (-j n) with make
  64. make depend
  65. make
  66. %install
  67. rm -rf %{buildroot}
  68. make DESTDIR=%{buildroot} install
  69. # fix to stop ldconfig from complaining
  70. find %{buildroot}%{_libdir} -name "*.so*" -exec chmod 755 {} \;
  71. # cleanup of the docs
  72. rm -rf doc/CVS 2>/dev/null || :
  73. cat > djview.desktop <<EOF
  74. [Desktop Entry]
  75. Encoding=UTF-8
  76. Name=djview
  77. Name[ja]=Djvuビュアー
  78. Comment=Standalone Djvu Viewer
  79. Comment[ja]=スタンドアロンでDjvu画像を表示するツールです
  80. Icon=djview
  81. Terminal=false
  82. Exec=djview
  83. Type=Application
  84. Categories=Application;Graphics;
  85. EOF
  86. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  87. install -m644 djview.desktop $RPM_BUILD_ROOT%{_datadir}/applications/
  88. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
  89. #cp %SOURCE1 $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  90. %clean
  91. rm -rf %{buildroot}
  92. %post
  93. /sbin/ldconfig
  94. if test -x /sbin/update-alternatives ; then
  95. m1=`ls -1 %{_mandir}/man1/djview3.* | head -1`
  96. m2=`echo $m1 | sed -e 's/djview3/djview/'`
  97. /sbin/update-alternatives \
  98. --install %{_bindir}/djview djview %{_bindir}/djview3 103 \
  99. --slave $m2 `basename $m2` $m1
  100. fi
  101. %preun
  102. if test "$1" = 0 ; then
  103. if test -x /sbin/update-alternatives ; then
  104. /sbin/update-alternatives --remove djview %{_bindir}/djview3
  105. fi
  106. fi
  107. %postun
  108. /sbin/ldconfig
  109. %files
  110. %defattr(-, root, root)
  111. %doc README COPYRIGHT COPYING INSTALL NEWS TODO doc
  112. %{_bindir}
  113. %{_libdir}
  114. %exclude %{_libdir}/mozilla
  115. %exclude %{_libdir}/pkgconfig
  116. %exclude %{_libdir}/libdjvulibre.la
  117. %{_datadir}/applications/djview.desktop
  118. #%{_datadir}/pixmaps/djview.png
  119. %{_datadir}/djvu/djview3
  120. %{_datadir}/djvu/pubtext
  121. %{_datadir}/djvu/osi/languages.xml
  122. %{_datadir}/djvu/osi/en
  123. %{_datadir}/djvu/osi/cs/messages.xml
  124. %lang(ja) %{_datadir}/djvu/osi/ja*
  125. %lang(fr) %{_datadir}/djvu/osi/fr*
  126. %lang(de) %{_datadir}/djvu/osi/de*
  127. %lang(zh) %{_datadir}/djvu/osi/zh*
  128. %{_mandir}/man?
  129. %lang(ja) %{_mandir}/ja*
  130. %lang(fr) %{_mandir}/fr*
  131. %lang(de) %{_mandir}/de*
  132. %files devel
  133. %defattr(-, root, root)
  134. %{_includedir}/libdjvu
  135. %{_libdir}/pkgconfig/ddjvuapi.pc
  136. %files plugin
  137. %defattr(-, root, root)
  138. %{_libdir}/mozilla/plugins/nsdejavu.so
  139. %changelog
  140. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.5.22-3
  141. - rebuilt with rpm-4.8.1 for pkg-config
  142. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-2
  143. - rebuilt with new toolchain
  144. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-1
  145. - updated djvulibre to 3.5.22
  146. * Tue Dec 30 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.21-1
  147. - initial build for VineSeed
  148. - spec in utf-8, and applied vine versioning policy
  149. - updated djvulibre to 3.5.21
  150. - added CXXFLAG="-march=i686" if i386
  151. - added djview desktop file
  152. * Tue Apr 03 2007 Shu KONNO <owa@bg.wakwak.com> 3.5.19-uvl1
  153. - updated djvulibre to 3.5.19
  154. - added scripts to alternative djview at %%post, %%preun
  155. * Thu Dec 01 2005 Shu KONNO <owa@bg.wakwak.com> 3.5.16-uvl1
  156. - updated djvulibre to 3.5.16
  157. - changed suffix
  158. - divided into djvulibre, djvulibre-devel, djvulibre-plugin
  159. * Tue Nov 09 2004 Shu KONNO <owa@bg.wakwak.com> 3.5.14-uvl2
  160. - updated djvulibre to 3.5.14 (realese 2)
  161. * Thu Jun 17 2004 Leon Bottou <leon@bottou.org> 3.5.13-4
  162. - changed runtime generation of file list.
  163. * Mon May 31 2004 Leon Bottou <leon@bottou.org> 3.5.13-3
  164. - removed 'make install-desktop-files'
  165. * Wed May 5 2004 Leon Bottou <leon@bottou.org> 3.5.13-2
  166. * Fri Apr 9 2004 Leon Bottou <leon@bottou.org> 3.5.13-1
  167. - added runtime generation of file list.
  168. - using DESTDIR instead of %makeinstall.
  169. - added 'make install-desktop-files'
  170. * Wed Nov 5 2003 Leon Bottou <leon@bottou.org> 3.5.12-3
  171. - added support for i18n
  172. - renamed symlink in mozilla plugin dirs.
  173. * Mon Jul 7 2003 Leon Bottou <leon@bottou.org> 3.5.12-1
  174. * Thu Apr 24 2003 Leon Bottou <leon@bottou.org> 3.5.11-1
  175. * Thu Feb 6 2003 Leon Bottou <leon@bottou.org> 3.5.10-2
  176. * Fri Jan 24 2003 Leon Bottou <leon@bottou.org> 3.5.10-1
  177. * Wed Oct 9 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-2
  178. - fixed logic for uninstalling nsdejavu links.
  179. - learned a few tricks from the freshrpms spec file.
  180. * Sun Oct 6 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-1
  181. - added logic to install nsdejavu for mozilla.
  182. * Wed May 29 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.6-1
  183. * Mon Apr 1 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  184. - changed group to Applications/Publishing.
  185. * Tue Mar 25 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  186. * Tue Jan 22 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.4-2
  187. - added macros to locate man directory.
  188. * Wed Jan 16 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.3-1
  189. * Fri Dec 7 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.2-1
  190. * Wed Dec 5 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.1-1
  191. - created initial file.