IIIMECF-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origver 0.75
  4. %define release 6%{?_dist_release}
  5. %define emacs emacs
  6. %define origname IIIMECF
  7. Summary: Internet/Intranet Input Method Emacs Client Framework
  8. Summary(ja): Emacs クライアント用 Internet/Intranet Input Method フレームワーク
  9. Name: %{origname}
  10. Version: %{origver}
  11. Release: %{release}
  12. License: GPL
  13. Group: Applications/Editors/Emacs
  14. URL: http://www.meadowy.org/~kawabata/iiimecf/
  15. #Source: ftp://ftp.m17n.org/pub/mule/IIIM/%{origname}-%{version}.tar.gz
  16. Source: http://www.meadowy.org/~kawabata/iiimecf/%{origname}-%{version}.tar.gz
  17. Source1: %{origname}-install.sh
  18. Source2: %{origname}-remove.sh
  19. Source3: %{origname}-init.el
  20. Source4: vine-default-%{origname}.el
  21. BuildArch: noarch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. PreReq: emacsen, gzip
  24. %prereq_ge emacsen-common
  25. BuildRequires: emacsen-common
  26. ## 0.7.5: Emacs 21 のみ Mule-UCS が必要です
  27. # PreReq: Mule-UCS
  28. # Requires: Mule-UCS
  29. #Packager: Shoji Matsumoto <shom@vinelinux.org>
  30. Distribution: Vine Linux
  31. Vendor: Project Vine
  32. %description
  33. IIIMECF conforms IIIM Protocol Specification defined by Sun Microsystems,
  34. and consists of a library to create IIIM awared applications and a simple
  35. input method library controlled by IIIM server(s).
  36. If you use IIIMECF on Emacs 21, Mule-UCS is required.
  37. %description -l ja
  38. IIIMECFは、Sun Microsystems社の定めるIIIM Protocolに基づき、Emacs上で
  39. IIIM対応のapplicationを構築するためのlibraryと、それを用いた、Server sideで
  40. 制御されるシンプルなInput Method libraryによって構成されています。
  41. Emacs 21 では Mule-UCS が必要です。
  42. %prep
  43. #% setup -n %{origname}-%{version}
  44. %setup -n iiimecf
  45. %__cp -a %{SOURCE3} %{SOURCE4} .
  46. %install
  47. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  48. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  49. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{origname}
  50. %__mkdir_p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  51. %__mkdir_p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  52. cp -r *.el lisp ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
  53. #
  54. # install script( bytecompile el and install elc , remove )
  55. #
  56. %_installemacsenscript %{origname} %{SOURCE1}
  57. %_removeemacsenscript %{origname} %{SOURCE2}
  58. %post
  59. #
  60. # bytecompile and install
  61. #
  62. if [ "$1" = 2 ]; then
  63. %_emacsenPackageRemove %{origname}
  64. fi
  65. %_addemacsenlist %{origname}
  66. %_emacsenPackageInstall %{origname}
  67. %preun
  68. if [ "$1" = 0 ]; then
  69. %_emacsenPackageRemove %{origname}
  70. %_removeemacsenlist %{origname}
  71. fi
  72. %clean
  73. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING* ChangeLog* README* lisp
  77. %{_datadir}/emacs/site-lisp/%{origname}
  78. %{emacsen_pkgdir}/install/%{origname}
  79. %{emacsen_pkgdir}/remove/%{origname}
  80. %changelog
  81. * Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.75-6
  82. - updated IIIMECF-init.el
  83. - output "Loading vine-default-IIIMECF ..." to the buffer *Messages*
  84. - fixed some comments of vine-default-IIIMECF.el
  85. * Sat Jul 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-5
  86. - updated yatex-install.sh
  87. - *-init.el: changed from hard copy to symbolic link
  88. on /etc/emacs-XX.YY/site-start.d
  89. * Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-4
  90. - fixed some STDOUT messages in IIIMECF-install.sh
  91. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-3
  92. - updated vine-default-IIIMECF.el
  93. * Thu Apr 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-2
  94. - added vine-default-IIIMECF.el, IIIMECF-init.el
  95. - updated wl-install.sh for vine-default-wl.el
  96. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.75-1
  97. - new upstream relase
  98. - spec in utf8
  99. - applied new versioning policy
  100. - added URL:
  101. - added some comments about Mule-UCS in %%description
  102. - dropped Requires: Mule-UCS and BuildRequires: Mule-UCS
  103. - ONLY Emacs 21 needs Mule-UCS
  104. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6-0vl5
  105. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  106. * Sat Jul 22 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6-0vl4
  107. - correct Summary <BTS:VineLinux:65>
  108. - add Summary(ja)
  109. - use License tag instead of CopyLight tag
  110. - change License from distibutable to GPL
  111. - rebuild for VineSeed (4.0)
  112. * Thu Nov 14 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.6-0vl2
  113. - add Prereq: gzip
  114. - Not Support xemacs-21.1.* in IIIMECF-install.sh
  115. * Fri Oct 04 2002 Tomoya TAKA <taka@vinelinux.org> 0.6-0vl1
  116. - add Prereq: Mule-UCS
  117. * Tue Aug 13 2002 Shoji Matsumoto <shom@vinelinux.org> 0.6-0vl0
  118. - created