libdbi-drivers-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. Summary: Database-specific drivers for libdbi
  2. Name: libdbi-drivers
  3. Version: 0.9.0
  4. Release: 2%{?_dist_release}
  5. Group: Development/Libraries
  6. License: LGPLv2+
  7. URL: http://libdbi-drivers.sourceforge.net/
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source: http://prdownloads.sourceforge.net/libdbi-drivers/%{name}-%{version}.tar.gz
  11. # old automake does not offer aarch64
  12. Patch1: libdbi-drivers-aarch64.patch
  13. Requires: libdbi >= 0.9
  14. BuildRequires: libdbi-devel >= 0.9
  15. BuildRequires: autoconf
  16. BuildRequires: openjade docbook-style-dsssl
  17. BuildRequires: docbook-style-dsssl
  18. BuildRequires: libmariadb-devel
  19. BuildRequires: openssl-devel
  20. BuildRequires: libpq-devel
  21. BuildRequires: krb5-devel
  22. BuildRequires: sqlite3-devel
  23. %description
  24. libdbi implements a database-independent abstraction layer in C, similar to the
  25. DBI/DBD layer in Perl. Writing one generic set of code, programmers can
  26. leverage the power of multiple databases and multiple simultaneous database
  27. connections by using this framework.
  28. libdbi-drivers contains the database-specific plugins needed to connect
  29. libdbi to particular database servers.
  30. %package -n libdbi-dbd-mysql
  31. Summary: MySQL plugin for libdbi
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description -n libdbi-dbd-mysql
  35. This plugin provides connectivity to MySQL/MariaDB database servers through
  36. the libdbi database independent abstraction layer. Switching a program's
  37. plugin does not require recompilation or rewriting source code.
  38. %package -n libdbi-dbd-pgsql
  39. Summary: PostgreSQL plugin for libdbi
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n libdbi-dbd-pgsql
  43. This plugin provides connectivity to PostgreSQL database servers through the
  44. libdbi database independent abstraction layer. Switching a program's plugin
  45. does not require recompilation or rewriting source code.
  46. %package -n libdbi-dbd-sqlite
  47. Summary: SQLite plugin for libdbi
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n libdbi-dbd-sqlite
  51. This plugin provides access to an embedded SQL engine using libsqlite3 through
  52. the libdbi database independent abstraction layer. Switching a program's plugin
  53. does not require recompilation or rewriting source code.
  54. %prep
  55. %setup -q -n %{name}-%{version}
  56. %patch1 -p1
  57. autoconf
  58. # mariadb provides headers in a subfolder <mysql/mysql.h>
  59. sed -i -r 's|<(mysql\.h)>|<mysql/\1>|' drivers/mysql/dbd_mysql.c
  60. # exporting LDFLAGS or LIBS or SQLITE3_LIBS before running autoconf or
  61. # ./configure doesn't help => hardcode it
  62. sed -i -r "s|(SQLITE3_LIBS=)-lsqlite[^[:space:]]*|\1$(pkg-config --libs-only-l sqlite3)|" \
  63. configure
  64. %build
  65. # configure is broken, must pass both --with-*sql-libdir _AND_
  66. # --with-*sql-incdir in order for --with-*sql-libdir to be used
  67. %configure --with-mysql --with-pgsql --with-sqlite3 \
  68. --with-mysql-libdir=%{_libdir}/mysql \
  69. --with-mysql-incdir=%{_includedir} \
  70. --with-pgsql-libdir=%{_libdir} \
  71. --with-pgsql-incdir=%{_includedir}/pgsql \
  72. --with-sqlite3-libdir=%{_libdir} \
  73. --with-sqlite3-incdir=%{_includedir} \
  74. --with-dbi-libdir=%{_libdir}
  75. make %{?_smp_mflags}
  76. %install
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.a
  79. rm -f ${RPM_BUILD_ROOT}%{_libdir}/dbd/*.la
  80. # package the docs via %%doc directives
  81. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %files
  85. %license COPYING
  86. %doc AUTHORS ChangeLog README
  87. %doc drivers/mysql/dbd_mysql/*.html
  88. %doc drivers/mysql/*.pdf
  89. %doc drivers/pgsql/dbd_pgsql/*.html
  90. %doc drivers/pgsql/*.pdf
  91. %doc drivers/sqlite3/dbd_sqlite3/*.html
  92. %doc drivers/sqlite3/*.pdf
  93. %dir %{_libdir}/dbd
  94. %files -n libdbi-dbd-mysql
  95. %{_libdir}/dbd/libdbdmysql.*
  96. %files -n libdbi-dbd-pgsql
  97. %{_libdir}/dbd/libdbdpgsql.*
  98. %files -n libdbi-dbd-sqlite
  99. %{_libdir}/dbd/libdbdsqlite3.*
  100. %changelog
  101. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.0-2
  102. - rebuilt with current environment.
  103. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.9.0-1
  104. - initial build for Vine Linux based on fedora
  105. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-3
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  107. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  109. * Thu Jan 23 2014 Jan Pacner <jpacner@redhat.com> - 0.9.0-1
  110. - new release
  111. * Mon Jul 29 2013 Honza Horak <hhorak@redhat.com> 0.8.3-13
  112. - Spec file clean-up
  113. - Add support for aarch64
  114. * Tue Mar 5 2013 Tom Lane <tgl@redhat.com> 0.8.3-12
  115. - Remove unnecessary package-name Requires:, since dependencies on library
  116. sonames should be enough, and we don't want to hard-wire assumptions about
  117. which packages provide which libraries
  118. - isa-ify cross-subpackage Requires:
  119. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-11
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  121. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-10
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  123. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-9
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  125. * Tue Mar 22 2011 Tom Lane <tgl@redhat.com> 0.8.3-8
  126. - Rebuild for libmysqlclient 5.5.10 soname version bump
  127. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  129. * Fri Sep 3 2010 Tom Lane <tgl@redhat.com> 0.8.3-6
  130. - Do not use -ffast-math; it breaks things and seems quite unlikely to offer
  131. any useful performance benefit for this type of package, anyway
  132. Resolves: #629964
  133. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  135. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-4
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  137. * Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 0.8.3-3
  138. - Rebuild for mysql 5.1
  139. * Mon Sep 1 2008 Tom Lane <tgl@redhat.com> 0.8.3-2
  140. - Fix mistaken external reference in libdbdsqlite3.so. (I'm applying this
  141. as a patch, rather than updating to upstream's 0.8.3-1, because that isn't
  142. acceptable as an RPM Version tag.)
  143. Resolves: #460734
  144. * Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
  145. - Update to version 0.8.3.
  146. - Code is now all licensed LGPLv2+, so adjust License tags.
  147. * Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.3
  148. - Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
  149. Resolves: #330691
  150. * Fri Aug 3 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.2
  151. - Correct License tag for sqlite subpackage; it's currently not same license
  152. as the rest of the code.
  153. * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1.1
  154. - Update to version 0.8.2-1.
  155. - Update License tag to match code.
  156. - Remove static libraries and .la files, per packaging guidelines.
  157. - Fix up packaging of documentation.
  158. * Mon Dec 11 2006 Tom Lane <tgl@redhat.com> 0.8.1a-2
  159. - Enable building of sqlite driver
  160. Resolves: #184568
  161. - Rebuild needed anyway for Postgres library update
  162. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.2
  163. - rebuild
  164. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2.1
  165. - bump again for double-long bug on ppc(64)
  166. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1a-1.2
  167. - rebuilt for new gcc4.1 snapshot and glibc changes
  168. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  169. - rebuilt
  170. * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1a-1
  171. - Update to version 0.8.1a.
  172. * Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.7.1-3
  173. - Rebuild for Postgres 8.0.2 (new libpq major version).
  174. * Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.1-2
  175. - Packaging improvements per discussion with sopwith.
  176. * Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.1-1
  177. - Import new libdbi version, splitting libdbi-drivers into a separate SRPM
  178. so we can track new upstream packaging.