gwenhywfar-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240
  1. Summary: A multi-platform helper library for other libraries
  2. Name: gwenhywfar
  3. Version: 4.20.2
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: LGPLv2+
  7. URL: https://www.aquamaniac.de/sites/aqbanking/index.php
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source0: https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: openssl-devel
  13. BuildRequires: gnutls-devel
  14. BuildRequires: libgcrypt-devel
  15. BuildRequires: gettext
  16. %description
  17. This is Gwenhywfar, a multi-platform helper library for networking and
  18. security applications and libraries. It is heavily used by libchipcard
  19. and AqBanking/AqHBCI, the German online banking libraries.
  20. %package devel
  21. Summary: Gwenhywfar development kit
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: %{name}-gui-cpp = %{version}-%{release}
  25. Requires: %{name}-gui-gtk3 = %{version}-%{release}
  26. Requires: %{name}-gui-qt5 = %{version}-%{release}
  27. Requires: pkgconfig
  28. %description devel
  29. This package contains gwenhywfar-config and header files for writing and
  30. compiling programs using Gwenhywfar.
  31. %package gui-cpp
  32. Summary: Gwenhywfar GUI framework for cpp
  33. Group: System Environment/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description gui-cpp
  36. This package contains the cpp gwenhywfar GUI backend.
  37. %package gui-gtk3
  38. Summary: Gwenhywfar GUI framework for GTK3
  39. Group: System Environment/Libraries
  40. BuildRequires: gtk3-devel
  41. Requires: %{name} = %{version}-%{release}
  42. Obsoletes: gui-gtk2
  43. %description gui-gtk3
  44. This package contains the gtk3 gwenhywfar GUI backend.
  45. %package gui-qt5
  46. Summary: Gwenhywfar GUI framework for Qt5
  47. Group: System Environment/Libraries
  48. BuildRequires: qt5-qtbase-devel
  49. Requires: %{name} = %{version}-%{release}
  50. Obsoletes: gui-qt4
  51. %description gui-qt5
  52. This package contains the qt5 gwenhywfar GUI backend.
  53. %prep
  54. %setup -q
  55. autoreconf -iv
  56. %build
  57. # help configure find qt5 lrelease/lupdate
  58. export PATH=$PATH:%{_qt5_bindir}
  59. %configure \
  60. --disable-static \
  61. --enable-system-certs \
  62. --with-openssl-libs=%{_libdir} \
  63. --with-guis="gtk3 qt5" \
  64. --with-qt5-qmake=%{_bindir}/qmake-qt5 \
  65. --with-qt5-moc=%{_bindir}/moc-qt5 \
  66. --with-qt5-uic=%{_bindir}/uic-qt5
  67. # kill rpath
  68. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  69. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  70. make %{?_smp_mflags}
  71. %install
  72. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  73. make DESTDIR=$RPM_BUILD_ROOT install
  74. # use system ca-certificates
  75. rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  76. ln -sf %{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  77. $RPM_BUILD_ROOT%{_datadir}/%{name}/ca-bundle.crt
  78. find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
  79. %find_lang %{name}
  80. %clean
  81. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  82. %post -p /sbin/ldconfig
  83. %postun -p /sbin/ldconfig
  84. %files -f %{name}.lang
  85. %defattr(-,root,root)
  86. %license COPYING
  87. %doc AUTHORS README ChangeLog
  88. %{_bindir}/gct-tool
  89. %{_libdir}/libgwenhywfar.so.*
  90. %{_libdir}/%{name}
  91. %dir %{_datadir}/%{name}
  92. %{_datadir}/%{name}/dialogs
  93. %{_datadir}/%{name}/typemaker2
  94. %exclude %{_datadir}/%{name}/typemaker*
  95. %{_datadir}/%{name}/ca-bundle.crt
  96. %files devel
  97. %defattr(-,root,root)
  98. %exclude %{_bindir}/gct-tool
  99. %{_bindir}/*
  100. %{_includedir}/gwenhywfar4
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/*.pc
  103. %{_libdir}/cmake/*
  104. %{_datadir}/aclocal/gwenhywfar.m4
  105. %{_datadir}/%{name}/typemaker*
  106. %files gui-cpp
  107. %defattr(-,root,root)
  108. %{_libdir}/libgwengui-cpp.so.*
  109. %files gui-gtk3
  110. %defattr(-,root,root)
  111. %{_libdir}/libgwengui-gtk3.so.*
  112. %files gui-qt5
  113. %defattr(-,root,root)
  114. %{_libdir}/libgwengui-qt5.so.*
  115. %changelog
  116. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.20.2-1
  117. - new upstream release.
  118. - switched guis to gtk3 and qt5.
  119. - added a subpackage "gui-cpp".
  120. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.3-2
  121. - rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
  122. * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.3-1
  123. - new upstream release
  124. - add BuildRequires: gtk2-devel, qt4-devel
  125. - create gui-gtk2, gui-qt4 subpackages (based on Fedora)
  126. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.3-3
  127. - rebuilt with openssl-1.0.0d
  128. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.3-2
  129. - rebuilt with rpm-4.8.1 for pkg-config
  130. * Sat Feb 13 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.11.3-1
  131. - new upstream release
  132. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0-1
  133. - new upstream release
  134. - built with gnutls-2.6.3
  135. * Sat Sep 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.1-1
  136. - new upstream release
  137. - applied new versioning policy
  138. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.2-0vl1
  139. - new upstream release
  140. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.1-2vl1
  141. - initial build for VineSeed
  142. * Wed Oct 10 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-2
  143. - fix build, rebuild for buildid
  144. * Fri Aug 3 2007 Bill Nottingham <notting@redhat.com>
  145. - tweak license tag
  146. * Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.1-1
  147. - update to 2.6.1
  148. * Mon Jun 11 2007 Bill Nottingham <notting@redhat.com> - 2.6.0-1
  149. - update to 2.6.0
  150. * Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.5.4-1
  151. - update to 2.5.4
  152. * Thu Feb 22 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-7
  153. - build for Extras
  154. * Wed Jan 10 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-6
  155. - make gwen-public-ca.crt %%config(noreplace)
  156. * Tue Jan 9 2007 Bill Nottingham <notting@redhat.com> - 2.3.0-5
  157. - spec tweaks
  158. * Thu Sep 7 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-4
  159. - rebuild for fixed debuginfo (#205501)
  160. * Tue Sep 5 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-3
  161. - fix multilib conflicts (#205213)
  162. * Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-2
  163. - rather than modifying the m4 file, make gwenhywfar-config use pkgconfig
  164. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.0-1.1
  165. - rebuild
  166. * Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.3.0-1
  167. - update to 2.3.0
  168. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.2
  169. - bump again for double-long bug on ppc(64)
  170. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.2-1.1
  171. - rebuilt for new gcc4.1 snapshot and glibc changes
  172. * Thu Dec 22 2005 Bill Nottingham <notting@redhat.com> 1.99.2-1
  173. - update to 1.99.2
  174. - use the pkgconfig file, not gwenhywfar-config
  175. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  176. - rebuilt
  177. * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> 1.7.2-3
  178. - rebuilt against new openssl
  179. * Wed Mar 2 2005 Bill Nottingham <notting@redhat.com> 1.7.2-2
  180. - rebuild against new openssl
  181. * Wed Feb 9 2005 Bill Nottingham <notting@redhat.com> 1.7.2-1
  182. - initial packaging, adopt upstream package