slang-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The shared library for the S-Lang extension language
  3. Summary(ja): S-Lang 拡張言語ライブラリ
  4. Name: slang
  5. Version: 2.1.4
  6. Release: 3%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Libraries
  9. Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
  10. Patch1: slang-2.1.4-makefile.patch
  11. Patch2: slang-nointerlibc2.patch
  12. URL: http://www.jedsoft.org/slang/
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libpng-devel, oniguruma-devel, pcre-devel
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  18. %description
  19. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  20. that supports a C-like syntax. It has been designed from the beginning
  21. to be easily embedded into a program to make it extensible. Slang also
  22. provides a way to quickly develop and debug the application embedding it
  23. in a safe and efficient manner. Since slang resembles C, it is easy to
  24. recode slang procedures in C if the need arises.
  25. %description -l ja
  26. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  27. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  28. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  29. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  30. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  31. %package slsh
  32. Summary: Interpreter for S-Lang scripts
  33. Summary(ja): S-Lang スクリプトインタプリタ
  34. Group: Development/Languages
  35. Requires: %{name} = %{version}-%{release}
  36. %description slsh
  37. slsh (slang-shell) is a program for interpreting S-Lang scripts.
  38. It supports dynamic loading of S-Lang modules and includes a readline
  39. interface for interactive use.
  40. This package also includes S-Lang modules that are distributed with
  41. the S-Lang distribution.
  42. %package devel
  43. Summary: Development package for %{name}
  44. Summary(ja): %{name} の開発パッケージ
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description devel
  48. This package contains files which you'll need if you want to
  49. develop S-Lang based applications. Documentation which may help
  50. you write S-Lang based applications is also included.
  51. Install the slang-devel package if you want to develop applications
  52. based on the S-Lang extension language.
  53. #'
  54. %description devel -l ja
  55. このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
  56. ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
  57. なるようなドキュメントも含まれています。
  58. もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
  59. インストールしてください。
  60. ## to build compat32 for x86_64 architecture support
  61. %package -n compat32-%{name}
  62. Summary: The shared library for the S-Lang extension language
  63. Summary(ja): S-Lang 拡張言語ライブラリ
  64. Group: System Environment/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. %description -n compat32-%{name}
  67. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  68. that supports a C-like syntax. It has been designed from the beginning
  69. to be easily embedded into a program to make it extensible. Slang also
  70. provides a way to quickly develop and debug the application embedding it
  71. in a safe and efficient manner. Since slang resembles C, it is easy to
  72. recode slang procedures in C if the need arises.
  73. %description -n compat32-%{name} -l ja
  74. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  75. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  76. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  77. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  78. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  79. %package -n compat32-%{name}-devel
  80. Summary: Development package for %{name}
  81. Summary(ja): %{name} の開発パッケージ
  82. Group: Development/Libraries
  83. Requires: compat32-%{name} = %{version}-%{release}
  84. Requires: %{name}-devel = %{version}-%{release}
  85. %description -n compat32-%{name}-devel
  86. This package contains files which you'll need if you want to
  87. develop S-Lang based applications. Documentation which may help
  88. you write S-Lang based applications is also included.
  89. Install the slang-devel package if you want to develop applications
  90. based on the S-Lang extension language.
  91. #'
  92. %prep
  93. %setup -q
  94. %patch1 -p1 -b .makefile
  95. %patch2 -p1 -b .nointerlibc2
  96. %build
  97. %configure --includedir=%{_includedir}/slang
  98. make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
  99. %install
  100. rm -rf ${RPM_BUILD_ROOT}
  101. make install-all INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
  102. rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
  103. %clean
  104. rm -rf ${RPM_BUILD_ROOT}
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %post -n compat32-%{name} -p /sbin/ldconfig
  108. %postun -n compat32-%{name} -p /sbin/ldconfig
  109. %files
  110. %defattr(-,root,root)
  111. %doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
  112. %{_libdir}/libslang*.so.*
  113. %files slsh
  114. %defattr(-,root,root)
  115. %doc slsh/doc/html/slsh*.html
  116. %config(noreplace) %{_sysconfdir}/slsh.rc
  117. %{_bindir}/slsh
  118. %{_libdir}/slang
  119. %{_mandir}/man1/slsh.1*
  120. %{_datadir}/slsh
  121. %files devel
  122. %defattr(-,root,root)
  123. %doc doc/*/cslang*.txt doc/*/cref.txt
  124. %{_libdir}/libslang*.so
  125. %{_libdir}/libslang*.a
  126. %{_includedir}/slang
  127. %if %{build_compat32}
  128. %files -n compat32-%{name}
  129. %defattr(- , root, root)
  130. %{_libdir}/libslang.so.*
  131. %files -n compat32-%{name}-devel
  132. %defattr(- , root, root)
  133. %{_libdir}/libslang.a
  134. %{_libdir}/libslang.so
  135. %endif
  136. %changelog
  137. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
  138. - removed unneccesary %if !%{build_compat32} case condition
  139. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
  140. - rebuilt with oniguruma-5.9.1
  141. * Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
  142. - new upstream release
  143. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
  144. - new upstream release
  145. - drop slang_jp patch
  146. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
  147. - update to slang-1.4.9
  148. - rediffed slang_jp patch
  149. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
  150. - change ./configure to %%configure
  151. - uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
  152. - added compat32-* packages for x86_64 architecture support
  153. * Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
  154. - rebuild with new toolchains
  155. - s/Copyright/License/
  156. * Sat Feb 9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
  157. - bug fixed canna input for jed
  158. - change patch: bug fixed slsng-console.patch
  159. * Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
  160. - rebuild with glibc-2.2.4
  161. * Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
  162. - update to 1.4.4
  163. - use jp0 patch
  164. - use better macros
  165. - use Release No for Vine Linux
  166. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  167. [1.2.2_jp-7]
  168. - Japanese summary and description
  169. - change group
  170. * Mon Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
  171. - rebuild for new environment.
  172. * Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  173. [1.2.2_jp-5]
  174. - Updated to 1.2.2j056
  175. * Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
  176. [1.2.2_jp-4]
  177. - fix box bug with KANJI
  178. * Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  179. [1.2.2_jp-2]
  180. - Updated to 1.2.2j054
  181. * Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
  182. [1.2.2j052-2]
  183. - patch for linux console and kon
  184. - bug fix for no-kanji version
  185. - separate devel
  186. * Sat Jul 4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  187. [1.2.1j-1]
  188. - Updated to 1.2.2 (j052)
  189. * Fri Jun 5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  190. [1.2.1j-1]
  191. - japanize patch added
  192. * Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
  193. [1.2.1-1]
  194. - Updated to 1.2.1
  195. * Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
  196. [1.2.0-1]
  197. - Updated to 1.2.0, the first 1.x non-beta version
  198. * Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
  199. [1.0.3-1]
  200. - Updated to 1.0.3
  201. - Minor fixes
  202. * Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
  203. - Earlier changes were lost, because of misplacement of RPM:
  204. - BuildRoot
  205. - RPM_OPT_FLAGS
  206. - %clean section
  207. - other minor spec file changes
  208. - Should be buildable by non-root now
  209. - Included untic, a very cool terminfo interpreter (this probably out to be
  210. split out eventually)
  211. - Added bug fix from JED
  212. * Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
  213. - upgraded to 1.0.2
  214. * Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
  215. - Apparently so, Donnie. :)
  216. - upgraded to 1.0.0beta
  217. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  218. - spec file cleanups
  219. * Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
  220. - upgraded to 0.99.38 (will it EVER go 1.0???)
  221. - all patches removed (all appear to be in this version)
  222. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  223. - built against glibc