libsigc++-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. %define name libsigc++
  2. %define version 2.2.6
  3. %define release 1%{?_dist_release}
  4. %define lib_name sigc++-2.0
  5. Summary: The Typesafe Signal Framework for C++
  6. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.bz2
  11. License: LGPL
  12. Group: System Environment/Libraries
  13. URL: http://libsigc.sourceforge.net/
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: m4
  17. %description
  18. This library implements a full callback system for use in widget libraries,
  19. abstract interfaces, and general programming. Originally part of the Gtk--
  20. widget set, %{name} is now a seperate library to provide for more general
  21. use. It is the most complete library of its kind with the ablity to connect
  22. an abstract callback to a class method, function, or function object. It
  23. contains adaptor classes for connection of dissimilar callbacks and has an
  24. ease of use unmatched by other C++ callback libraries.
  25. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  26. %package devel
  27. Summary: development tools for the Typesafe Signal Framework for C++
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: pkgconfig
  31. %description devel
  32. The %{name}-devel package contains the static libraries and header files
  33. needed for development with %{name}.
  34. %package examples
  35. Summary: examples and tests for the Typesafe Signal Framework for C++
  36. Group: Development/Libraries
  37. Requires: %{name}-devel = %{version}-%{release}
  38. %description examples
  39. The %{name}-devel package contains source code of example and test
  40. programs for %{name}.
  41. %prep
  42. %setup -q
  43. %build
  44. %configure --disable-static --enable-silent-rules
  45. make %{_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make install DESTDIR=$RPM_BUILD_ROOT
  49. # removed unpackage files
  50. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  51. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  52. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  53. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  54. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
  55. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  56. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  57. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
  58. rm -f $i.*
  59. done
  60. rm -rf docs-toinstall
  61. mkdir -p docs-to-install
  62. cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
  63. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
  64. # devhelp path fix
  65. sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
  66. #sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root,755)
  73. %doc AUTHORS COPYING README NEWS ChangeLog TODO
  74. %attr(755,root,root) %{_libdir}/lib*.so.*
  75. %files devel
  76. %defattr(-,root,root,755)
  77. %{_includedir}/*
  78. %{_libdir}/%{lib_name}/include
  79. %{_libdir}/pkgconfig/*.pc
  80. #{_libdir}/lib*.la
  81. %{_libdir}/lib*.so
  82. %{_datadir}/devhelp/books/%{name}-2.0/*
  83. %doc docs-to-install/index.html docs-to-install/images
  84. %doc docs-to-install/reference docs-to-install/tutorial
  85. %files examples
  86. %defattr(-,root,root,755)
  87. %{_libdir}/%{lib_name}/examples
  88. %{_libdir}/%{lib_name}/tests
  89. %changelog
  90. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
  91. - new upstream release
  92. - built with new toolchain
  93. * Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
  94. - new upstream release
  95. - remove static libraries from devel package
  96. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  97. - new upstream release
  98. - spec in UTF-8
  99. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
  100. - removed .la files from devel package
  101. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
  102. - new upstream release
  103. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
  104. - rebuild with new environment/toolchain
  105. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  106. - new upstream release
  107. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
  108. - rebuild with new libtool
  109. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
  110. - new upstream release
  111. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  112. - new upstream release
  113. * Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
  114. - new upstream release
  115. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
  116. - new upstream release
  117. - added tutorial to devel package
  118. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
  119. - update to 2.0.6
  120. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  121. - update to 1.2.5
  122. - add Requires: pkgconfig
  123. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  124. - rebuild to remove dependance <5371>
  125. - add Japanese summary
  126. - use better macros
  127. - s/Copyright/License/
  128. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  129. - rebuild with new toolchain
  130. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  131. - 1.0.4-0vl1
  132. - Build for Vine Linux 2.5
  133. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  134. - packaged for Vine Linux 2.1
  135. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  136. - updated Url and Source fileds
  137. - 1.0.0 stable release
  138. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  139. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  140. - minor install section cleanup
  141. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  142. - autogen just creates configure, not runs it, so cleaned that up too.
  143. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  144. - minor attr fix
  145. - removed unnecessary curly braces
  146. - fixed Herbert's adjustement
  147. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  148. - minor package dependence fix
  149. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  150. - fixed typo of mine
  151. - added traditional CUSTOM_RELEASE stuff
  152. - added SMP support
  153. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  154. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  155. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  156. - split into three packages: %name, %name-devel and %name-examples
  157. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  158. - updated source field and merged conflicts between revisions.
  159. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  160. - updated Prefix and BuildRoot fields
  161. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  162. - made sure configure works on all alphas
  163. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  164. - Added autoconf macro for sigc.
  165. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  166. - Made into a .in to keep version field up to date
  167. - Still need to do release by hand
  168. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  169. - added Vendor and Packager fields
  170. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  171. - updated to 0.8.0
  172. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  173. - initial revision