libsieve-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. Summary: A library for parsing, sorting and filtering your mail
  2. Summary(ja): メールをパース、ソートまたはフィルタするためのライブラリ
  3. Name: libsieve
  4. Version: 2.2.7
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. # License says LGPL, but source is a mix of many licenses. License breakdown:
  8. # __CMU (MIT)__
  9. # src/sv_interface/message.c
  10. # src/sv_interface/message.h
  11. # src/sv_interface/script.c
  12. # src/sv_interface/script.h
  13. # src/sv_interface/tree.c
  14. # src/sv_interface/tree.h
  15. # src/sv_parser/addr-lex.l
  16. # src/sv_parser/addr.y
  17. # src/sv_parser/comparator.c
  18. # src/sv_parser/comparator.h
  19. # src/sv_parser/sieve-lex.l
  20. # src/sv_parser/sieve.y
  21. # src/sv_test/example.c
  22. #
  23. # __GPLv2+__
  24. # src/config.guess
  25. # src/config.sub
  26. # src/depcomp
  27. # src/ltmain.sh
  28. # src/missing
  29. # src/ylwrap
  30. # src/sv_parser/addr.c
  31. # src/sv_parser/addr.h
  32. # src/sv_parser/header.c
  33. # src/sv_parser/header.h
  34. #
  35. # __LGPLv2__
  36. # src/sv_include/sieve2_error.h
  37. # src/sv_include/sieve2.h
  38. # src/sv_interface/callbacks2.c
  39. # src/sv_interface/callbacks2.h
  40. # src/sv_interface/context2.c
  41. # src/sv_interface/context2.h
  42. # src/sv_interface/message2.c
  43. # src/sv_interface/message2.h
  44. # src/sv_interface/script2.c
  45. # src/sv_parser/header-lex.l
  46. # src/sv_parser/header.y
  47. # src/sv_parser/sieve.c
  48. # src/sv_parser/sieve.h
  49. # src/sv_util/util.c
  50. # src/sv_util/util.h
  51. #
  52. # __LGPLv2+__
  53. # src/sv_regex/regcomp.c
  54. # src/sv_regex/regex.c
  55. # src/sv_regex/regexec.c
  56. # src/sv_regex/regex.h
  57. # src/sv_regex/regex_internal.c
  58. # src/sv_regex/regex_internal.h
  59. #
  60. # __Public Domain__
  61. # src/sv_util/exception.c
  62. # src/sv_util/exception.h
  63. # src/sv_util/md5.c
  64. #
  65. # __MIT__
  66. # src/install-sh
  67. #
  68. License: GPLv2+ and LGPLv2 and LGPLv2+ and MIT and Public Domain
  69. URL: http://libsieve.sourceforge.net/
  70. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  72. BuildRequires: flex, bison
  73. %description
  74. libSieve provides a library to interpret Sieve scripts, and to execute those
  75. scripts over a given set of messages. The return codes from the libSieve
  76. functions let your program know how to handle the message, and then it's up to
  77. you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
  78. IMAP, or anything else work; just how to parse and deal with a buffer full of
  79. emails. The rest is up to you!
  80. %package devel
  81. Summary: Development files for %{name}
  82. Summary(ja): %{name} の開発用ファイル
  83. Group: Development/Libraries
  84. Requires: libsieve = %{version}-%{release}
  85. %description devel
  86. libSieve provides a library to interpret Sieve scripts, and to execute those
  87. scripts over a given set of messages. The return codes from the libSieve
  88. functions let your program know how to handle the message, and then it's up to
  89. you to make it so. libSieve makes no attempt to have knowledge of how SMTP,
  90. IMAP, or anything else work; just how to parse and deal with a buffer full of
  91. emails. The rest is up to you!
  92. These are the development libraries.
  93. %prep
  94. %setup -q
  95. %build
  96. cd src
  97. %configure
  98. make %{?_smp_mflags}
  99. %install
  100. rm -rf $RPM_BUILD_ROOT
  101. cd src && make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
  102. rm -f $RPM_BUILD_ROOT/%{_libdir}/*\.{a,la}
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %files
  108. %defattr(-,root,root,-)
  109. # See license tag section for licensing of binary
  110. %{_libdir}/libsieve.so.*
  111. %doc AUTHORS COPYING NEWS README
  112. %files devel
  113. %defattr(-,root,root,-)
  114. %{_libdir}/*.so
  115. %{_libdir}/pkgconfig/%{name}.pc
  116. %{_includedir}/*
  117. %changelog
  118. * Mon Sep 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.7-1
  119. - initial build for Vine Linux
  120. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  122. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.7-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  124. * Wed Jan 28 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.2.7-1
  125. - v 2.2.7
  126. - package pkgconfig file
  127. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2.6-3
  128. - Autorebuild for GCC 4.3
  129. * Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-2
  130. - add missing BR: flex, bison
  131. - remove repotag
  132. * Sun Oct 26 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.6-1
  133. - 2.2.6
  134. - license clarification
  135. * Tue Feb 06 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.5-1
  136. - 2.2.5
  137. - remove sed surgery since tarball is fixed to pass CFLAGS
  138. * Mon Jan 29 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-2
  139. - add note regarding why license tag is GPL
  140. - sed surgery on Makefile.in files so that CFLAGS is passed properly
  141. * Sun Jan 28 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.2.4-1
  142. - 2.2.4
  143. - change license to GPL based on https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216723#c11
  144. - install files preserving timestamps
  145. * Sat Jan 27 2007 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-4
  146. - add fully versioned dependency on main package for -devel
  147. - remove .a library from -devel
  148. - do not call autoconf, use configure file
  149. - direct download url for source0
  150. - remove buildrequires for autoconf and m4
  151. * Mon Dec 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-3
  152. - added repotag for anyone who may want to use it
  153. - move ldconfig calls to post and postun with -p
  154. - minor spec file cleanups
  155. * Sat Nov 25 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-2
  156. - bump release to -2
  157. - move .so to -devel
  158. - change %%post command to avoid fork of a shell interpreter
  159. * Sat Nov 18 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.1.sc
  160. - start with fedora extras template for spec file
  161. * Wed Oct 11 2006 Bernard Johnson <bjohnson@symetrix.com> - 2.1.13-1.sc
  162. — Initial package