geany-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Summary: A fast and lightweight IDE using GTK2
  2. Summary(ja): GTK2を用いた高速・軽量な統合開発環境(IDE)
  3. Name: geany
  4. Version: 0.19
  5. Release: 1%{?_dist_release}
  6. License: GPL2+
  7. Group: Applications/Development
  8. Source: http://download.geany.org/%{name}-%{version}.tar.bz2
  9. URL: http://geany.uvena.de/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: glib2-devel, gtk2-devel, pango-devel
  12. BuildRequires: desktop-file-utils
  13. BuildRequires: gettext, intltool
  14. BuildRequires: perl-XML-Parser
  15. Requires: glib2, pango
  16. Requires: gtk2 >= 2.8
  17. Requires: vte
  18. %description
  19. Geany is a small and fast editor with basic features
  20. of an integrated development environment.
  21. Some basic features:
  22. * Syntax highlighting
  23. * Code folding
  24. * Symbol name auto-completion
  25. * Construct completion/snippets
  26. * Auto-closing of XML and HTML tags
  27. * Many supported filetypes including C, Java, PHP, HTML, Python, Perl, Pascal (full list)
  28. * Symbol lists
  29. * Code navigation
  30. * Build system to compile and execute your code
  31. * Simple project management
  32. * Plugin interface (see Plugins)
  33. %description -l ja
  34. Geany は統合開発環境としての基本的機能を備えた、小さくて高速なエディタです。
  35. 基本的機能:
  36. * シンタックスハイライト
  37. * コードの折り畳み
  38. * シンボル名の自動補完
  39. * コンピレーション/スニペットの構築
  40. * XMLとHTMLタグを自動で閉じる
  41. * C、Java、PHP、HTML、Python、Perl、Pascal (full list) など多くのファイル形式をサポート
  42. * シンボルリスト
  43. * コードナビゲーション
  44. * 自分のコードをコンパイル&実行するためのビルドシステム
  45. * シンプルなプロジェクト管理
  46. * プラグインインターフェイス
  47. %package devel
  48. Summary: Devel files for building Geany plugins
  49. Summary(ja): Geanyプラグインをビルドするための開発ファイル
  50. Group: Development/Libraries
  51. Requires: geany = %{version}-%{release}
  52. %description devel
  53. This package contains the devel files and pkg-config file needed for building
  54. Geany plugins. You do not need to install this package to use Geany.
  55. %description devel -l ja
  56. このパッケージには Geany プラグインをビルドするために必要な開発ファイル、
  57. 及び pkg-config ファイルが含まれています。
  58. Geany を使うためにこのパッケージをインストールする必要はありません。
  59. %prep
  60. %setup -q
  61. %build
  62. %configure
  63. make %{?_smp_mflags}
  64. %install
  65. %__rm -Rf $RPM_BUILD_ROOT
  66. %makeinstall
  67. %__rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  68. desktop-file-install --delete-original --vendor="vine" \
  69. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  70. --mode 0644 \
  71. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  72. # Remove libtool library archive (*.la) files
  73. rm -rf $RPM_BUILD_ROOT%{_libdir}/geany/*.la
  74. %clean
  75. %__rm -Rf $RPM_BUILD_ROOT
  76. %post
  77. update-desktop-database %{_datadir}/applications
  78. touch --no-create %{_datadir}/icons/hicolor
  79. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  80. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  81. fi
  82. %postun
  83. update-desktop-database %{_datadir}/applications
  84. touch --no-create %{_datadir}/icons/hicolor
  85. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  86. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  87. fi
  88. %files
  89. %defattr(-, root, root, -)
  90. %doc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO THANKS
  91. %{_bindir}/%{name}
  92. %{_datadir}/%{name}
  93. %{_libdir}/%{name}
  94. %{_datadir}/applications/*.desktop
  95. %{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
  96. %{_datadir}/icons/hicolor/*
  97. %{_datadir}/doc/%{name}/
  98. %{_mandir}/man1/geany.1.gz
  99. %files devel
  100. %defattr(-, root, root, -)
  101. %{_includedir}/geany
  102. %{_libdir}/pkgconfig/geany.pc
  103. %changelog
  104. * Sun Jun 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19-1
  105. - new upstream version
  106. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.1-1
  107. - new upstream version
  108. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.18-2
  109. - rebuilt
  110. * Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18-1vl5
  111. - new upstream version
  112. - added update-desktop-database %{_datadir}/applications in %post, %postun
  113. - run gtk-update-icon-cache in %post, %postun
  114. * Sat Jun 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-4vl5
  115. - updated description
  116. - added desktop-file-install
  117. - added BuildRequires: desktop-file-utils
  118. * Sun May 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-3vl5
  119. - fixed BuildRequires: perl-XML-Parser
  120. * Sun May 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-2vl5
  121. - fixed %BuildRoot
  122. - changed Group to Applications/Development
  123. -devel Group to Development/Libraries
  124. - added BuildRequires: gettext, intltool, perl(XML::Parser)
  125. - added Requires: vte
  126. * Sun May 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-1vl5
  127. - new upstream version
  128. - spec in UTF-8
  129. * Mon Feb 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16-1vl5
  130. - new upstream version
  131. - fixed Requires: gtk2 >= 2.8 (minimum required GTK version 2.8)
  132. * Wed Feb 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15-2vl5
  133. - fixed License
  134. - updated Source URL
  135. - modified %build (use "%{?_smp_mflags}")
  136. - splited -devel sub-package (for header files)
  137. - removed *.la files
  138. * Sat Feb 7 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15-1vl5
  139. - initial build for VineSeed