python3-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623
  1. %bcond_with run_test
  2. %bcond_without rpmwheels
  3. %bcond_without flat
  4. %define config_htmldir /var/www/html/python
  5. Summary: An interpreted, interactive, object-oriented programming language.
  6. Summary(ja): オブジェクト指向 Python3 インタプリタ
  7. Name: python3
  8. Version: 3.11.6
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: Python
  14. URL: https://www.python.org/
  15. %define shortver %(echo %{version} | sed -e 's/~//')
  16. %define majorver %(echo %{version} | cut -d . -f 1)
  17. %define libvers %(echo %{version} | cut -d . -f 1-2)
  18. %define binsuffix %{libvers}
  19. %ifarch x86_64
  20. %define python3_purelib %{_prefix}/lib/python%{majorver}
  21. %define python3_platlib %{_libdir}/python%{libvers}
  22. %else
  23. %define python3_purelib %{_libdir}/python%{majorver}
  24. %define python3_platlib %{_libdir}/python%{libvers}
  25. %endif
  26. %global py_SOVERSION 1.0
  27. %global py_INSTSONAME libpython%{libvers}.so.%{py_SOVERSION}
  28. %global python_wheel_dir %{_datadir}/python3-wheels
  29. Provides: python(abi) = 3
  30. # The following versions of setuptools/pip are bundled when this patch is not applied.
  31. # The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
  32. # When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
  33. # In such cases, the patch needs to be amended and the versions updated here:
  34. %global pip_version 23.2.1
  35. %global setuptools_version 65.5.0
  36. #Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
  37. #Source1: https://www.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
  38. Source0: https://www.python.org/ftp/python/%{shortver}/Python-%{shortver}.tar.xz
  39. Source1: https://www.python.org/ftp/python/doc/%{shortver}/python-%{shortver}-docs-html.tar.bz2
  40. # Desktop menu entry for idle3
  41. Source10: idle3.desktop
  42. # AppData file for idle3
  43. Source11: idle3.appdata.xml
  44. # (Patches taken from github.com/fedora-python/cpython)
  45. # 00001 # d06a8853cf4bae9e115f45e1d531d2dc152c5cc8
  46. # Fixup distutils/unixccompiler.py to remove standard library path from rpath
  47. # Was Patch0 in ivazquez' python3000 specfile
  48. Patch1: 00001-rpath.patch
  49. # 00251 # af0f1ba72e01cb93371ff21fb7ca889daa43fa7a
  50. # Change user install location
  51. #
  52. # Set values of base and platbase in sysconfig from /usr
  53. # to /usr/local when RPM build is not detected
  54. # to make pip and similar tools install into separate location.
  55. #
  56. # Set values of prefix and exec_prefix in distutils install command
  57. # to /usr/local if executable is /usr/bin/python* and RPM build
  58. # is not detected to make distutils and pypa/distutils install into separate location.
  59. #
  60. # Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  61. # Downstream only.
  62. #
  63. # We've tried to rework in Fedora 36/Python 3.10 to follow https://bugs.python.org/issue43976
  64. # but we have identified serious problems with that approach,
  65. # see https://bugzilla.redhat.com/2026979 or https://bugzilla.redhat.com/2097183
  66. #
  67. # pypa/distutils integration: https://github.com/pypa/distutils/pull/70
  68. Patch251: 00251-change-user-install-location.patch
  69. # 00328 # 318e500c98f5e59eb1f23e0fcd32db69b9bd17e1
  70. # Restore pyc to TIMESTAMP invalidation mode as default in rpmbuild
  71. #
  72. # Since Fedora 31, the $SOURCE_DATE_EPOCH is set in rpmbuild to the latest
  73. # %%changelog date. This makes Python default to the CHECKED_HASH pyc
  74. # invalidation mode, bringing more reproducible builds traded for an import
  75. # performance decrease. To avoid that, we don't default to CHECKED_HASH
  76. # when $RPM_BUILD_ROOT is set (i.e. when we are building RPM packages).
  77. #
  78. # See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/57#comment-27426
  79. # Downstream only: only used when building RPM packages
  80. # Ideally, we should talk to upstream and explain why we don't want this
  81. Patch328: 00328-pyc-timestamp-invalidation-mode.patch
  82. # 00371 # c1754d9c2750f89cb702e1b63a99201f5f7cff00
  83. # Revert "bpo-1596321: Fix threading._shutdown() for the main thread (GH-28549) (GH-28589)"
  84. #
  85. # This reverts commit 38c67738c64304928c68d5c2bd78bbb01d979b94. It
  86. # introduced regression causing FreeIPA's tests to fail.
  87. #
  88. # For more info see:
  89. # https://bodhi.fedoraproject.org/updates/FEDORA-2021-e152ce5f31
  90. # https://github.com/GrahamDumpleton/mod_wsgi/issues/730
  91. Patch371: 00371-revert-bpo-1596321-fix-threading-_shutdown-for-the-main-thread-gh-28549-gh-28589.patch
  92. # security
  93. # (none)
  94. # vine
  95. Patch10000: python3-flatten.patch
  96. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  97. BuildRequires: autoconf
  98. BuildRequires: bzip2-devel
  99. BuildRequires: expat-devel
  100. BuildRequires: desktop-file-utils
  101. BuildRequires: findutils
  102. BuildRequires: gcc-c++
  103. BuildRequires: gdbm-devel
  104. BuildRequires: glibc-devel
  105. BuildRequires: libdb-devel
  106. BuildRequires: libffi-devel
  107. BuildRequires: libnsl2-devel
  108. BuildRequires: libtirpc-devel
  109. BuildRequires: libxcrypt-devel
  110. BuildRequires: ncurses-devel
  111. BuildRequires: openssl-devel
  112. BuildRequires: pkgconfig
  113. BuildRequires: readline-devel
  114. BuildRequires: sqlite3-devel
  115. BuildRequires: tar
  116. BuildRequires: valgrind-devel
  117. BuildRequires: xz-devel
  118. BuildRequires: zlib-devel
  119. %description
  120. Python is an interpreted, interactive, object-oriented programming
  121. language. It incorporates modules, exceptions, dynamic typing, very high
  122. level dynamic data types, and classes. Python combines remarkable power
  123. with very clear syntax. It has interfaces to many system calls and
  124. libraries, as well as to various window systems, and is extensible in C or
  125. C++. It is also usable as an extension language for applications that need
  126. a programmable interface. Finally, Python is portable: it runs on many
  127. brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
  128. Mac.
  129. %package devel
  130. Summary: The libraries and header files needed for Python development.
  131. Group: programming
  132. Requires: %{name} = %{version}-%{release}
  133. Requires: libtirpc-devel
  134. %description devel
  135. The Python programming language's interpreter can be extended with
  136. dynamically loaded extensions and can be embedded in other programs.
  137. This package contains the header files and libraries needed to do
  138. these types of tasks.
  139. Install python-devel if you want to develop Python extensions. The
  140. python package will also need to be installed. You'll probably also
  141. want to install the python-docs package, which contains Python
  142. documentation.
  143. %package idle
  144. Summary: A basic graphical development environment for Python
  145. Requires: %{name} = %{version}-%{release}
  146. Requires: %{name}-tkinter = %{version}-%{release}
  147. Provides: idle3 = %{version}-%{release}
  148. Provides: idle = %{version}-%{release}
  149. Provides: python3-tools = %{version}-%{release}
  150. Provides: python3-tools%{?_isa} = %{version}-%{release}
  151. Obsoletes: python3-tools < 3.10.0
  152. %description idle
  153. IDLE is Python’s Integrated Development and Learning Environment.
  154. IDLE has the following features: Python shell window (interactive
  155. interpreter) with colorizing of code input, output, and error messages;
  156. multi-window text editor with multiple undo, Python colorizing,
  157. smart indent, call tips, auto completion, and other features;
  158. search within any window, replace within editor windows, and
  159. search through multiple files (grep); debugger with persistent
  160. breakpoints, stepping, and viewing of global and local namespaces;
  161. configuration, browsers, and other dialogs.
  162. %package tkinter
  163. Summary: A graphical user interface for the Python scripting language.
  164. Group: programming
  165. Requires: %{name} = %{version}-%{release}
  166. Requires: tcl, tk, tix
  167. Requires: libX11, libxcb, libXau, libXdmcp
  168. BuildRequires: tcl-devel, tk-devel, tix
  169. BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
  170. %description tkinter
  171. The Tkinter (Tk interface) program is an graphical user interface for
  172. the Python scripting language.
  173. You should install the tkinter package if you'd like to use a graphical
  174. user interface for Python programming.
  175. %package docs
  176. Summary: Documentation for the Python programming language.
  177. Summary(ja): Python プログラミング言語のドキュメント
  178. Group: documentation
  179. %description docs
  180. The python-docs package contains documentation on the Python
  181. programming language and interpreter. The documentation is provided
  182. in ASCII text files and in LaTeX source files.
  183. Install the python-docs package if you'd like to use the documentation
  184. for the Python language.
  185. %debug_package
  186. %prep
  187. %setup -n Python-%{shortver}
  188. %autopatch -p1 -M 9999
  189. %if %{with flat}
  190. %patch10000 -p1
  191. %endif
  192. %if %{with rpmwheels}
  193. rm Lib/ensurepip/_bundled/pip-%{pip_version}-py3-none-any.whl
  194. rm Lib/ensurepip/_bundled/setuptools-%{setuptools_version}-py3-none-any.whl
  195. %endif
  196. # Remove all exe files to ensure we are not shipping prebuilt binaries
  197. # note that those are only used to create Microsoft Windows installers
  198. # and that functionality is broken on Linux anyway
  199. find -name '*.exe' -print -delete
  200. # Remove bundled libraries to ensure that we're using the system copy.
  201. rm -r Modules/expat
  202. # Remove files that should be generated by the build
  203. # (This is after patching, so that we can use patches directly from upstream)
  204. rm configure pyconfig.h.in
  205. # Regenerate the configure script and pyconfig.h.in
  206. autoconf
  207. autoheader
  208. %build
  209. # The build process embeds version info extracted from the Git repository
  210. # into the Py_GetBuildInfo and sys.version strings.
  211. # Our Git repository is artificial, so we don't want that.
  212. # Tell configure to not use git.
  213. export HAS_GIT=not-found
  214. export CFLAGS="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  215. export CFLAGS_NODIST="%{?build_cflags} -D_GNU_SOURCE -fPIC -fwrapv%{?with_no_semantic_interposition: -fno-semantic-interposition}"
  216. export CXXFLAGS="%{?extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
  217. export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
  218. export OPT="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
  219. export LINKCC="gcc"
  220. export CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
  221. export LDFLAGS="%{?extension_ldflags} -g $(pkg-config --libs-only-L openssl)"
  222. export LDFLAGS_NODIST="%{?build_ldflags}%{?with_no_semantic_interposition: -fno-semantic-interposition} -g $(pkg-config --libs-only-L openssl)"
  223. export PYTHON=%{__python3}
  224. %configure \
  225. --with-platlibdir=%{_lib} \
  226. --enable-ipv6 \
  227. --enable-shared \
  228. --with-computed-gotos=yes \
  229. --with-dbmliborder=gdbm:ndbm:bdb \
  230. --with-system-expat \
  231. --with-system-ffi \
  232. --enable-loadable-sqlite-extensions \
  233. --with-lto \
  234. --with-ssl-default-suites=openssl \
  235. --without-static-libpython \
  236. %if %{with rpmwheels}
  237. --with-wheel-pkg-dir=%{python_wheel_dir} \
  238. %endif
  239. --with-valgrind \
  240. --without-ensurepip \
  241. --enable-optimizations \
  242. %{nil}
  243. %global flags_override CFLAGS_NODIST="$CFLAGS_NODIST"
  244. #make %{?_smp_mflags} %{flags_override} regen-all PYTHON_FOR_REGEN="python3"
  245. make %{?_smp_mflags} %{flags_override}
  246. %install
  247. [ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  248. mkdir -p %{buildroot}%{python3_platlib}/site-packages
  249. mkdir -p %{buildroot}%{python3_purelib}/site-packages
  250. %if 0
  251. ln -sf python%{majorver} %{buildroot}%{_prefix}/lib/python%{binsuffix}
  252. %endif
  253. make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
  254. # replace path in pydoc
  255. if [ ! -z "%{binsuffix}" ]
  256. then
  257. (
  258. cd $RPM_BUILD_ROOT%{_bindir}
  259. mv pydoc%{libvers} pydoc.old
  260. sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
  261. pydoc.old > pydoc%{libvers}
  262. chmod 755 pydoc%{libvers}
  263. rm -f pydoc.old
  264. )
  265. fi
  266. # Tools
  267. echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  268. echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  269. echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python3_platlib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  270. echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  271. echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  272. chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
  273. #cp -a Tools $RPM_BUILD_ROOT%{python3_platlib}
  274. mkdir -p %{buildroot}%{_prefix}/lib/debug%{_libdir}
  275. cp -f Tools/gdb/libpython.py %{buildroot}%{_prefix}/lib/debug%{_libdir}/%{py_INSTSONAME}-%{version}-%{release}.%{_arch}.debug-gdb.py
  276. # Install pathfix.py to bindir
  277. # See https://github.com/fedora-python/python-rpm-porting/issues/24
  278. cp -p Tools/scripts/pathfix.py %{buildroot}%{_bindir}/pathfix%{binsuffix}.py
  279. # Install i18n tools to bindir
  280. # They are also in python2, so we version them
  281. # https://bugzilla.redhat.com/show_bug.cgi?id=1571474
  282. for tool in pygettext msgfmt; do
  283. cp -p Tools/i18n/${tool}.py %{buildroot}%{_bindir}/${tool}%{binsuffix}.py
  284. ln -s ${tool}%{binsuffix}.py %{buildroot}%{_bindir}/${tool}3.py
  285. done
  286. # Switch all shebangs to refer to the specific Python version.
  287. # This currently only covers files matching ^[a-zA-Z0-9_]+\.py$,
  288. # so handle files named using other naming scheme separately.
  289. LD_LIBRARY_PATH=./ ./python \
  290. Tools/scripts/pathfix.py \
  291. -i "%{_bindir}/python%{binsuffix}" -pn \
  292. %{buildroot} \
  293. %{buildroot}%{_bindir}/{2to3-,idle,pydoc}%{binsuffix} \
  294. %{buildroot}%{_bindir}/*%{binsuffix}.py \
  295. %{buildroot}%{_libdir}/python%{binsuffix}/cgi.py \
  296. %{buildroot}%{_prefix}/lib/debug%{_libdir}/*.py
  297. # Remove shebang lines from .py files that aren't executable, and
  298. # remove executability from .py files that don't have a shebang line:
  299. find %{buildroot} -name \*.py \
  300. \( \( \! -perm /u+x,g+x,o+x -exec sed -e '/^#!/Q 0' -e 'Q 1' {} \; \
  301. -print -exec sed -i '1d' {} \; \) -o \( \
  302. -perm /u+x,g+x,o+x ! -exec grep -m 1 -q '^#!' {} \; \
  303. -exec chmod a-x {} \; \) \)
  304. # make file lists
  305. rm -f mainpkg.files
  306. find %{buildroot}%{python3_platlib} -type f |
  307. sed "s|^%{buildroot}|/|" |
  308. grep -v \
  309. -e '/python%{libvers}/config$' \
  310. -e '_tkinter.so$' \
  311. -e '_tkinter.cpython-' \
  312. -e '/tkinter/' \
  313. -e '/turtledemo/' \
  314. -e '/idlelib/' \
  315. >> mainpkg.files
  316. rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
  317. find %{buildroot}%{_prefix}/bin -type f -o -type l |
  318. sed "s|^%{buildroot}|/|" |
  319. grep -v \
  320. -e '/idlelib/' \
  321. -e '/bin/2to3-%{binsuffix}$' \
  322. -e '/bin/msgfmt%{binsuffix}.py' \
  323. -e '/bin/pathfix%{binsuffix}.py' \
  324. -e '/bin/pygettext%{binsuffix}.py' \
  325. -e '/bin/idle%{binsuffix}$' \
  326. -e '/bin/idle%{majorver}$' \
  327. >> mainpkg.files
  328. # docs
  329. mkdir -p %{buildroot}%{config_htmldir}
  330. (
  331. cd %{buildroot}%{config_htmldir}
  332. bunzip2 < %{SOURCE1} | tar x
  333. )
  334. # add idle3 to menu
  335. install -D -m 0644 Lib/idlelib/Icons/idle_16.png %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/idle3.png
  336. install -D -m 0644 Lib/idlelib/Icons/idle_32.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/idle3.png
  337. install -D -m 0644 Lib/idlelib/Icons/idle_48.png %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/idle3.png
  338. install -D -m 0644 Lib/idlelib/Icons/idle_256.png %{buildroot}%{_datadir}/icons/hicolor/256x256/apps/idle3.png
  339. desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE10}
  340. # Install and validate appdata file
  341. mkdir -p %{buildroot}%{_datadir}/metainfo
  342. cp -a %{SOURCE11} %{buildroot}%{_datadir}/metainfo
  343. %if %{with run_test}
  344. %check
  345. make test
  346. %endif
  347. %clean
  348. rm -fr $RPM_BUILD_ROOT
  349. %ifarch x86_64
  350. %pre
  351. if [ ! -e %{_prefix}/lib/python%{libvers} ]; then
  352. ln -sf python%{majorver} %{_prefix}/lib/python%{libvers}
  353. fi
  354. %endif
  355. %files -f mainpkg.files
  356. %defattr(-, root, root)
  357. %license LICENSE
  358. %doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
  359. %{_libdir}/libpython*
  360. %{_mandir}/man1/python%{libvers}.1*
  361. %{_mandir}/man1/%{name}.1*
  362. %attr(755,root,root) %dir %{python3_platlib}
  363. %attr(755,root,root) %dir %{python3_platlib}/site-packages
  364. %attr(755,root,root) %dir %{python3_purelib}
  365. %attr(755,root,root) %dir %{python3_purelib}/site-packages
  366. %files devel
  367. %defattr(-,root,root)
  368. %{_bindir}/2to3-%{binsuffix}
  369. %{_bindir}/msgfmt%{binsuffix}.py
  370. %{_bindir}/pathfix%{binsuffix}.py
  371. %{_bindir}/pygettext%{binsuffix}.py
  372. %dir %{_includedir}/python%{libvers}
  373. %dir %{_includedir}/python%{libvers}/cpython
  374. %dir %{_includedir}/python%{libvers}/internal
  375. %{_includedir}/python%{libvers}/*.h
  376. %{_includedir}/python%{libvers}/cpython/*.h
  377. %{_includedir}/python%{libvers}/internal/*.h
  378. %{_libdir}/pkgconfig/*.pc
  379. %{_prefix}/lib/debug%{_libdir}/*.py
  380. %files idle
  381. %{_bindir}/idle*
  382. %{python3_platlib}/idlelib
  383. %{_datadir}/metainfo/idle3.appdata.xml
  384. %{_datadir}/applications/idle3.desktop
  385. %{_datadir}/icons/hicolor/*/apps/idle3.*
  386. %files tkinter
  387. %defattr(-,root,root)
  388. %{python3_platlib}/__pycache__/turtle.*
  389. %{python3_platlib}/tkinter
  390. %{python3_platlib}/turtledemo
  391. %{python3_platlib}/lib-dynload/_tkinter.*.so*
  392. %files docs
  393. %defattr(-,root,root)
  394. %{config_htmldir}/*
  395. %changelog
  396. * Sat Oct 21 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.6-1
  397. - new upstream release.
  398. * Sat Nov 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.0-1
  399. - rebuilt.
  400. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.0-0
  401. - new upstream release.
  402. * Tue Oct 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.0~rc2-1
  403. - new upstream release.
  404. - dropped ldconfig scriptlets.
  405. - flatten noarch modules.
  406. * Tue Jan 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.12-1
  407. - new upstream release.
  408. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-2
  409. - fixed %%files.
  410. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-1
  411. - new upstream release.
  412. - dropped Patch1000: fixed in upstream.
  413. * Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.7-1
  414. - new upstream release.
  415. - dropped Patch1000: fixed in upstream.
  416. - added Patch1000 to fix CVE-2021-3177.
  417. * Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-2
  418. - added Patch1000 to fix CVE-2020-27619.
  419. * Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-1
  420. - new upstream release.
  421. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.5-1
  422. - new upstream release.
  423. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
  424. - new upstream release.
  425. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
  426. - fixed %%files.
  427. * Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-4
  428. - rebuilt with tix-8.4.3-5.
  429. * Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-3
  430. - rebuilt with tcl/tk-8.6.9.
  431. * Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.5.7-2
  432. - rebuild with readline-8.0 and ncurses-6.1
  433. * Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-1
  434. - new upstream release.
  435. - rebuilt with gdbm-1.18.1.
  436. - added R:libtirpc-devel to python3-devel.
  437. * Thu Feb 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-3
  438. - added BR:libxcrypt-devel.
  439. - added BR:libtirpc-devel.
  440. - added BR:libnsl2-devel.
  441. * Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
  442. - rebuilt with new toolchain.
  443. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
  444. - new upstream release.
  445. - really rebuilt with openssl-1.1.1.
  446. * Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  447. - rebuild with openssl-1.1.1
  448. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  449. - new upstream release
  450. - update Patch1 (python-3.5.2-lib64.patch)
  451. * Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
  452. - rebuild with openssl-1.0.2g
  453. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  454. - new upstream release
  455. - add Patch2 (python3-3.4.4-revert-makefile.patch)
  456. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  457. - new upstream release
  458. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
  459. - rebuilt with readline 6.3
  460. - changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
  461. - changed BuildRequires: libdb-devel instead of db4-devel
  462. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  463. - new upstream release
  464. - update Patch1 (python-3.4.2-lib64.patch)
  465. * Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
  466. - remove configure option "--enable-profiling"
  467. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
  468. - rebuild with libffi-3.0.13
  469. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
  470. - new upstream release
  471. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
  472. - updated python to 3.3.2
  473. * Sun Jan 6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
  474. - build with Tcl/Tk 8.5.7-1
  475. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
  476. - updated python to 3.3.0
  477. - update Patch1 (python-3.3.0-lib64.patch)
  478. - add BuildRequires: valgrind-devel
  479. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
  480. - updated python to 3.2
  481. - updated python-*-docs-html to 3.2
  482. - dropt all patchs
  483. - added python-3.2b2-lib64.patch
  484. - referred to the review Python-3.2/Misc/RPM/python-3.2.spec
  485. * Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
  486. - rebuilt with openssl-1.0.0c
  487. * Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
  488. - updated python to 3.1.3
  489. - added python-3.1.3-locale.patch
  490. - dropt python-3.1.2-lib64.patch
  491. - added python-3.1.3-lib64-*.patchs
  492. python-3.1.3-lib64-Makefile.patch
  493. python-3.1.3-lib64-setup.patch
  494. python-3.1.3-lib64-site.patch
  495. python-3.1.3-lib64-install.patch
  496. python-3.1.3-lib64-sysconfig.patch
  497. python-3.1.3-lib64-getpath.patch
  498. python-3.1.3-lib64-test_install.patch
  499. - added run_test macro to run unit test
  500. - added BR: libffi
  501. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
  502. - rebuilt with rpm-4.8.1 for pkg-config
  503. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
  504. - spec in utf-8
  505. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
  506. - added missings in BuildRequires, Requires
  507. * Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
  508. - initial build for VineSeed