vte-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536
  1. Summary: An terminal emulator.
  2. Summary(ja): ターミナルエミュレータ
  3. Name: vte
  4. Version: 0.24.0
  5. Release: 1%{?_dist_release}
  6. License: LGPL
  7. Group: System Environment/Libraries
  8. Source: %{name}-%{version}.tar.bz2
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: gtk2-devel
  11. BuildRequires: python-devel
  12. BuildRequires: pygtk2-devel
  13. BuildRequires: ncurses-devel
  14. %description
  15. VTE is an experimental terminal emulator widget for use with GTK+ 2.0.
  16. %description -l ja
  17. VTE は GTK+2.0 用のターミナルエミュレータウィジェットです。
  18. %package devel
  19. Summary: Files needed for developing applications which use vte.
  20. Summary(ja): VTE を使用したアプリケーションの開発に必要なファイル群
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. Requires: gtk2-devel
  24. %description devel
  25. VTE is an experimental terminal emulator widget for use with GTK+ 2.0. This
  26. package contains the files needed for building applications using VTE.
  27. %prep
  28. %setup -q
  29. %build
  30. if [ -x %{_bindir}/python2.4 ]; then
  31. PYTHON=%{_bindir}/python2.4; export PYTHON
  32. fi
  33. %configure --enable-shared --enable-static --without-glX
  34. make %{?_smp_mflags}
  35. %install
  36. rm -fr $RPM_BUILD_ROOT
  37. make install DESTDIR=$RPM_BUILD_ROOT
  38. %find_lang %{name}
  39. rm -f $RPM_BUILD_ROOT/%{_bindir}/%{name}
  40. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{a,la}
  41. rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/*.la
  42. rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/*.a
  43. %clean
  44. rm -fr $RPM_BUILD_ROOT
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files -f %{name}.lang
  48. %defattr(-,root,root)
  49. %doc ChangeLog COPYING HACKING NEWS README
  50. %doc doc/utmpwtmp.txt doc/boxes.txt src/iso2022.txt doc/openi18n/UTF-8.txt doc/openi18n/wrap.txt
  51. %{_libdir}/*.so.*
  52. %{_datadir}/%{name}
  53. %attr(2711,root,utmp) %{_libexecdir}/gnome-pty-helper
  54. %{_libdir}/python*/site-packages/gtk-2.0/*
  55. %files devel
  56. %defattr(-,root,root)
  57. %{_datadir}/gtk-doc/html/%{name}
  58. %{_includedir}/*
  59. %dir %{_libdir}/%{name}
  60. %{_libdir}/%{name}/*
  61. %{_libdir}/*.so
  62. %{_libdir}/pkgconfig/*
  63. %{_datadir}/pygtk/2.0/defs/vte.defs
  64. %changelog
  65. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  66. - new upstream release
  67. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.5-1
  68. - new upstream release
  69. - add BuildRequires: ncurses-devel
  70. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22.4-3
  71. - rebuilt with gcc-4.4.3-3 on ppc
  72. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.22.4-2
  73. - rebuilt with python-2.6.4-3
  74. * Tue Nov 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22.4-1
  75. - new upstream release
  76. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22.2-1
  77. - new upstream release
  78. - moved %{_datadir}/pygtk/2.0/defs/vte.defs to devel package
  79. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.5-1
  80. - new upstream release
  81. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.2-1
  82. - new upstream release
  83. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.1-1
  84. - new upstream release
  85. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.20.0-1
  86. - new upstream release
  87. - remove static libs
  88. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.4-1
  89. - new upstream release
  90. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.3-1
  91. - new upstream release
  92. - drop patch1 (merged in now upstream)
  93. * Mon Aug 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.14-3
  94. - add Patch1 to fix cjk ambiguous width
  95. * Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.14-2
  96. - rebuilt with python-2.5.2
  97. * Thu Jun 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.14-1
  98. - new upstream release
  99. - spec in UTF-8
  100. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.13-1vl5
  101. - new upstream release
  102. * Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.12-0vl1
  103. - new upstream release
  104. * Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.9-0vl1
  105. - new upstream release
  106. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.8-0vl1
  107. - new upstream release
  108. - changed Group to System Environment/Libraries
  109. - dropped Patch0 merged into upstream
  110. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.3-0vl2
  111. - add Patch0 to fix preedit crash
  112. http://bugzilla.gnome.org/show_bug.cgi?id=433776
  113. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-0vl1
  114. - new upstream release
  115. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.1-0vl1
  116. - new upstream release
  117. * Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.12.2-0vl2
  118. - add BuildRequires: pygtk2-devel
  119. * Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.2-0vl1
  120. - new upstream release
  121. * Thu Apr 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-0vl1
  122. - new upstream release
  123. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.0-0vl1
  124. - new upstream release
  125. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.21-0vl1
  126. - drop Patch10 which are merged in upstream
  127. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.20-0vl2
  128. - add Patch10 to update screen more frequently.
  129. (revert changes introduced in 0.11.19)
  130. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.20-0vl1
  131. - new upstream release
  132. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.15-0vl1
  133. - new upstream release
  134. * Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.12-0vl1
  135. - new upstream version
  136. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.11-0vl2
  137. - import some patches from fedora package.
  138. * Fri May 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.11-0vl1
  139. - new upstream release
  140. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl3
  141. - rebuild with glib2-2.4.0
  142. * Sun Sep 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl2
  143. - import Patch0,1 from rawhide
  144. - don't reset conversion states at end-of-line (GNOME #122156)
  145. - draw the preedit string the way GTK+ wants us to draw it (#104039)
  146. * Thu Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-0vl1
  147. - new upstream release
  148. * Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.9-0vl1
  149. - new upstream release
  150. * Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.6-0vl1
  151. - new upstream release
  152. * Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.28-0vl1
  153. - new upstream release
  154. * Fri Mar 7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.26-0vl1
  155. - new upstream release
  156. * Wed Feb 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.25-0vl1
  157. - new upstream release
  158. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.22-0vl1
  159. - new upstream release
  160. * Fri Feb 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.19-0vl1
  161. - new upstream release
  162. * Sat Feb 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.16-0vl1
  163. - new upstream release
  164. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl3
  165. - fixed permission
  166. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl2
  167. - add missing /usr/libexec/gnome-pty-helper to %%files
  168. * Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.15-0vl1
  169. - new upstream release
  170. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.14-0vl1
  171. - new upstream release
  172. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.12-0vl1
  173. - new upstream release
  174. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.10-0vl1
  175. - new upstream release
  176. * Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.8-0vl1
  177. - new upstream release
  178. * Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.7-0vl1
  179. - build for Vine Linux
  180. - new upstream release (gnome-2.1.4)
  181. * Thu Sep 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.19-1
  182. - possible fix for focusing bugs
  183. * Thu Sep 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.18-1
  184. - fix for worst-case when stripping termcap entries from Brian Cameron
  185. - add docs
  186. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.17-1
  187. - track Xft color deallocation to prevent freeing of colors we don't own
  188. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.16-1
  189. - handle color allocation failures better
  190. * Mon Sep 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.15-1
  191. - cleanups
  192. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.14-1
  193. - get smarter about adjusting our adjustments (#73091)
  194. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.13-1
  195. - restore the IM status window by restoring our own focus-in/focus-out
  196. handlers (#72946)
  197. * Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-1
  198. - cleanups
  199. * Thu Aug 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.11-1
  200. - clean up autoscroll (#70481)
  201. - add Korean text examples to docs
  202. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.10-1
  203. - autoscroll (#70481)
  204. - only perform cr-lf substitutions when pasting (#72639)
  205. - bind GDK_ISO_Left_Tab to "kB" (part of #70340)
  206. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.9-1
  207. - handle forward scrolling again (#73409)
  208. * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.8-1
  209. - fix crashes on resize
  210. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com>
  211. - fix missing spaces on full lines
  212. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.7-1
  213. - fix deadlock when substitutions fail
  214. * Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.6-1
  215. - one-liner segfault bug fix
  216. * Sun Aug 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.5-1
  217. - fix reverse video mode, which broke during the rendering rewrite
  218. * Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.4-1
  219. - prevent up/UP/DO from scrolling
  220. - bind shift+insert to "paste PRIMARY", per xterm/kterm/hanterm
  221. * Thu Aug 22 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.3-1
  222. - track changes to the style's font
  223. - always open fonts right away so that the metric information is correct
  224. - make audible and visual bell independent options
  225. * Wed Aug 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.2-1
  226. - don't perform text substitution on text that is part of a control sequence
  227. * Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.1-1
  228. - dispose of the updated iso2022 context properly when processing incoming text
  229. * Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.0-1
  230. - rework font handling to use just-in-time loading
  231. - handle iso-2022 escape sequences, perhaps as much as they might make sense
  232. in a Unicode environment
  233. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.4-1
  234. - handle massive amounts of invalid data better (the /dev/urandom case)
  235. - munged up patch from Owen to fix language matching
  236. - fix initialization of new rows when deleting lines
  237. * Mon Aug 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.3-1
  238. - more fixes for behavior when not realized
  239. - require bitmap-fonts
  240. - escape a control sequence properly
  241. * Thu Aug 8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.2-1
  242. - fix cursor over reversed text
  243. - fix character positioning in Xft1
  244. - add border padding
  245. - fix lack of shift-in when resetting
  246. * Tue Aug 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.1-1
  247. - rework rendering with Pango
  248. - special-case monospaced Xft1 rendering, hopefully making it faster
  249. - modify pasting to use carriage returns instead of linefeeds
  250. * Thu Aug 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.0-1
  251. - rework drawing to minimize round trips to the server
  252. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.6.0-1
  253. - rework parsing to use tables instead of tries
  254. - implement more xterm-specific behaviors
  255. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.4-1
  256. - fix default PTY size bug
  257. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.3-1
  258. - open PTYs with the proper size (#69606)
  259. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.2-1
  260. - fix imbalanced realize/unrealize routines causing crashes (#69605)
  261. * Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-1
  262. - fix a couple of scrolling artifacts
  263. * Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.0-1
  264. - use gunichars internally
  265. - scroll regions more effectively
  266. - implement part of set-mode/reset-mode (maybe fixes #69143)
  267. - fix corner case in dingus hiliting (#67930, really this time)
  268. * Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 0.4.9-3
  269. - free trip through the build system
  270. * Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-2
  271. - build in different environment
  272. * Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-1
  273. - check for iconv failures properly and report them more aggressively
  274. - guess at a proper default bold color (#68965)
  275. * Mon Jul 15 2002 Nalin Dahyabhai <nalin@redhat.com>
  276. - cosmetic fixes
  277. * Sat Jul 13 2002 Nalin Dahyabhai <nalin@redhat.com>
  278. - fix segfaulting during dingus highlighting when the buffer contains non-ASCII
  279. characters (#67930)
  280. * Fri Jul 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.8-1
  281. - implement BCE (#68414)
  282. - bind F13-F35 per termcap
  283. * Thu Jul 11 2002 Nalin Dahyabhai <nalin@redhat.com>
  284. - rework default color selection
  285. - provide a means for apps to just set the foreground/background text colors
  286. - don't scroll-on-keystroke when it's just alt, hyper, meta, or super (#68986)
  287. * Tue Jul 2 2002 Nalin Dahyabhai <nalin@redhat.com>
  288. - allow shift+click to extend the selection (re: gnome 86246)
  289. * Mon Jul 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.7-1
  290. - recover from encoding errors more gracefully
  291. * Mon Jul 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.6-1
  292. - draw unicode line-drawing characters natively
  293. * Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.5-1
  294. - don't append spaces to multicolumn characters when reading the screen's
  295. contents (part of #67379)
  296. - fix overexpose of neighboring cells (part of #67379)
  297. - prevent backscroll on the alternate screen for consistency with xterm
  298. - bind F10 to "k;", not "k0" (#67133)
  299. * Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.4-1
  300. - clear alternate buffer when switching screens (#67094)
  301. - fix setting of titles, but crept in when cleaning up GIConv usage (#67236)
  302. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.3-1
  303. - correct referencing/dereferencing of I/O channels (#66248)
  304. - correct package description to not mention the sample app which is no longer
  305. included
  306. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.2-1
  307. - fix "cursor mistakenly hidden when app exits" by making cursor visibility
  308. a widget-wide (as opposed to per-screen) setting
  309. * Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.1-1
  310. - fix use of alternate buffer in xterm emulation mode
  311. * Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
  312. - add a means for apps to add environment variables
  313. * Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.30-1
  314. - package up the python module
  315. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.29-1
  316. - compute padding correctly
  317. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.28-1
  318. - finish merging otaylor's Xft2 patch
  319. * Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.27-1
  320. - rework accessibility
  321. * Thu Jun 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.26-1
  322. - don't package up the test program
  323. - emit "child-exited" signals properly
  324. - try to allow building with either pangoxft-with-Xft1 or pangoxft-with-Xft2
  325. * Wed Jun 5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.25-1
  326. - compute font widths better
  327. * Mon Jun 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.24-1
  328. - tweak handling of invalid sequences again
  329. * Fri May 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.23-1
  330. - switch to g_convert (again?)
  331. - fix use of core fonts
  332. * Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.22-1
  333. - plug some memory leaks
  334. * Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.21-1
  335. - fix matching, fix async background updates
  336. * Fri May 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.20-1
  337. - fixes from notting and otaylor
  338. * Tue May 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.19-1
  339. - fixes from andersca and Hidetoshi Tajima
  340. * Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.18-1
  341. - finish implementing matching
  342. * Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.17-1
  343. - tweak finding of selected text
  344. * Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.16-1
  345. - hook up Insert->kI
  346. - convert scroll events to button 4/5 if an app wants mouse events
  347. - don't send drag events when apps only want click events
  348. - fix selection crashbug
  349. * Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.15-1
  350. - fix ce, implement save/restore mode
  351. * Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.14-1
  352. - don't draw nul chars
  353. * Mon May 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.13-1
  354. - fix insert mode, implement visual bells
  355. * Thu May 9 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.12-1
  356. - iconv and remapping from otaylor
  357. - implement custom tabstopping
  358. * Wed May 8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.11-1
  359. - add mouse drag event handling
  360. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.10-1
  361. - do mouse autohide and cursor switching
  362. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.9-1
  363. - start handling mouse events
  364. * Mon May 6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.8-1
  365. - handle window manipulation sequences
  366. * Fri May 3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.7-1
  367. - discard invalid control sequences
  368. - recognize designate-??-character-set correctly
  369. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.6-1
  370. - add a couple of sequence handlers, fix a couple of accessibility crashbugs
  371. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.5-1
  372. - fix cap parsing error and "handle" long invalid multibyte sequences better
  373. * Thu May 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.4-1
  374. - try to speed up sequence recognition a bit
  375. - disable some window_scroll speedups that appear to cause flickering
  376. * Wed May 1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
  377. - include a small default termcap for systems without termcap files
  378. * Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.1-1
  379. - disconnect from the configure_toplevel signal at finalize-time
  380. * Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3-1
  381. - add an accessiblity object
  382. * Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.3-1
  383. - fix color resetting
  384. - fix idle handlers not being disconnected
  385. * Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.2-1
  386. - bug fixes
  387. * Thu Apr 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.1-1
  388. - finish initial packaging, start the changelog