vala-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. Summary: A modern programming language for GNOME
  2. Summary: GNOME 用のモダンなプログラミング言語
  3. Name: vala
  4. Version: 0.8.0
  5. Release: 1%{?_dist_release}
  6. Group: Development/Languages
  7. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  8. License: LGPLv2+ and BSD
  9. URL: http://live.gnome.org/Vala
  10. Source0: http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
  13. Requires: gtk2-devel
  14. %description
  15. Vala is a new programming language that aims to bring modern programming
  16. language features to GNOME developers without imposing any additional
  17. runtime requirements and without using a different ABI compared to
  18. applications and libraries written in C.
  19. valac, the Vala compiler, is a self-hosting compiler that translates
  20. Vala source code into C source and header files. It uses the GObject
  21. type system to create classes and interfaces declared in the Vala source
  22. code. It's also planned to generate GIDL files when gobject-
  23. introspection is ready.
  24. The syntax of Vala is similar to C#, modified to better fit the GObject
  25. type system.
  26. %package devel
  27. Summary: Development files for %{name}
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: pkgconfig
  31. %description devel
  32. Vala is a new programming language that aims to bring modern programming
  33. language features to GNOME developers without imposing any additional
  34. runtime requirements and without using a different ABI compared to
  35. applications and libraries written in C.
  36. This package contains development files for %{name}. This is not necessary for
  37. using the %{name} compiler.
  38. %package tools
  39. Summary: Tools for creating projects and bindings for %{name}
  40. Group: Development/Languages
  41. License: LGPLv2+
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: gnome-common intltool libtool
  44. Provides: %{name}-vapigen = %{version}-%{release}
  45. Obsoletes: %{name}-vapigen < %{version}-%{release}
  46. %description tools
  47. Vala is a new programming language that aims to bring modern programming
  48. language features to GNOME developers without imposing any additional
  49. runtime requirements and without using a different ABI compared to
  50. applications and libraries written in C.
  51. This package contains tools to generate Vala projects, as well as API bindings
  52. from existing C libraries, allowing access from Vala programs.
  53. %package doc
  54. Summary: Documentation for %{name}
  55. Group: Documentation
  56. License: LGPLv2+
  57. Requires: %{name} = %{version}-%{release}
  58. Requires: devhelp
  59. Provides: %{name}-docs = %{version}-%{release}
  60. Obsoletes: %{name}-docs < %{version}-%{release}
  61. %description doc
  62. Vala is a new programming language that aims to bring modern programming
  63. language features to GNOME developers without imposing any additional
  64. runtime requirements and without using a different ABI compared to
  65. applications and libraries written in C.
  66. This package contains documentation in a devhelp HTML book.
  67. %prep
  68. %setup -q
  69. %build
  70. %configure --enable-vapigen
  71. # Don't use rpath!
  72. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  73. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  74. make %{?_smp_mflags}
  75. # checks currently utilize installed Vala, not the one being compiled
  76. #%check
  77. #make check
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. rm $RPM_BUILD_ROOT%{_libdir}/libvala.la
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %files
  87. %defattr(-,root,root,-)
  88. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  89. %{_bindir}/valac
  90. %{_datadir}/vala
  91. %{_libdir}/libvala.so.*
  92. %{_mandir}/*/valac*
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %{_includedir}/vala-1.0
  96. %{_libdir}/libvala.so
  97. %{_libdir}/pkgconfig/vala-1.0.pc
  98. %files tools
  99. %defattr(-,root,root,-)
  100. %{_bindir}/*gen*
  101. %{_bindir}/vapicheck
  102. %{_libdir}/vala
  103. %{_mandir}/*/*gen*
  104. %files doc
  105. %defattr(-,root,root,-)
  106. %{_datadir}/devhelp/books/vala
  107. %changelog
  108. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  109. - new upstream release
  110. - change BuildRequires: gecko-libs -> xulrunner-devel
  111. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  112. - new upstream release
  113. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  114. - new upstream release
  115. * Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  116. - new upstream release
  117. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  118. - initial build for Vine Linux
  119. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  120. - Update to 0.7.5
  121. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  123. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  124. - Patch broken ModuleInit attribute (upstream bug 587444)
  125. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  126. - Update to 0.7.4
  127. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  128. - Update to 0.7.3
  129. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  130. - Update to 0.6.1
  131. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  132. - Update to 0.5.7
  133. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  134. - Update to 0.5.6
  135. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  136. - Update to 0.5.3
  137. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  138. - Fix bug in Emacs version detection
  139. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  140. - Use buildsystem variables to determine available Emacs version
  141. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  142. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  143. - Update to 0.5.2
  144. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  145. - Update to 0.5.1
  146. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  147. - Update to 0.3.5
  148. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  149. - Add vala-mode for editing Vala code in Emacs
  150. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  151. - Update to 0.3.4
  152. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  153. - Update to 0.3.3
  154. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  155. - Update to 0.3.2
  156. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  157. - Update to 0.2.0
  158. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  159. - Update to 0.1.7
  160. - -tool subpackage now requires gnome-common, intltool and libtoolize
  161. for out-of-the-box vala-gen-project support
  162. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  163. - Autorebuild for GCC 4.3
  164. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  165. - Update to 0.1.6
  166. - Revert vapi addition, needed declarations have been inlined (r846)
  167. - Rename -docs subpackage to -doc, to comply with guidelines
  168. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  169. - Manually add Gee vapi file to package (bz #428692)
  170. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  171. - Backport patch to autodetect location of automake shared files
  172. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  173. - Add build dependency on gtk2-devel
  174. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  175. - Enable project generator tool
  176. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  177. - Update to 0.1.5
  178. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  179. - Add build dependency on devhelp
  180. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  181. - Update to 0.1.4
  182. - Put newly-added documentation in its own subpackage (depends on devhelp)
  183. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  184. - vapigen subpackage: add missing Require: on perl-XML-Twig
  185. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  186. - Split -vapigen subpackage. It is functionally self-contained and the license
  187. is more restricted
  188. - Updated license declarations
  189. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  190. - Licensing and URL updates
  191. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  192. - Enable binding generation tools
  193. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  194. - Update to 0.1.3
  195. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  196. - Update to 0.0.8
  197. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  198. - Update to 0.0.7
  199. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  200. - Update to 0.0.6
  201. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  202. - Initial package