totem-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654
  1. # select backend (GStreamer, xine)
  2. #define build_gst 1
  3. %define build_xine 1
  4. # build browser plugins
  5. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  6. # define versions
  7. %define _glib_ver 2.24.0
  8. %define _gtk_ver 2.20.0
  9. %define _gnomevfs_ver 2.24.0
  10. %define _gnomeui_ver 2.24.3
  11. %define _gnomeicon_ver 2.30.0
  12. %define _gnome_desktop_ver 2.30.0
  13. %define _libgnome_ver 2.30.0
  14. %define _gnome_doc_utils_ver 0.20.0
  15. %define _dbus_ver 1.2.24
  16. %define _gst_ver 0.10.19
  17. %define _gstpb_ver 0.10.7
  18. %define _xine_ver 1.1.11.1
  19. %define _xulrunner_ver 1.9
  20. %define _nautilus_ver 2.26.0
  21. %define _shared_mime_info_ver 0.17
  22. %define _unique_ver 1.0
  23. %define _vala_ver 0.7.5
  24. %define _totem_pl_parser_ver 2.30.0
  25. %define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
  26. %define mozplug_dir %{_libdir}/mozilla/plugins
  27. Summary: Movie player for GNOME 2
  28. Summary(ja): GNOME2 用動画プレイヤー
  29. Name: totem
  30. Version: 2.30.0
  31. Release: 1%{?_dist_release}
  32. License: GPL
  33. Group: Applications/Multimedia
  34. URL: http://www.gnome.org/projects/totem/
  35. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/2.30/totem-%{version}.tar.bz2
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. BuildRequires: gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  40. BuildRequires: gnome-desktop-devel >= %{_gnome_desktop_ver}
  41. BuildRequires: gnome-vfs2-devel >= %{_gnomevfs_ver}
  42. BuildRequires: libgnomeui-devel >= %{_gnomeui_ver}
  43. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  44. BuildRequires: libgnome-devel >= %{_libgnome_ver}
  45. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  46. BuildRequires: dbus-devel >= %{_dbus_ver}
  47. BuildRequires: libmusicbrainz-devel
  48. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  49. BuildRequires: gettext, scrollkeeper
  50. BuildRequires: perl-XML-Parser
  51. BuildRequires: iso-codes
  52. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  53. BuildRequires: bluez-libs-devel >= 4.15
  54. BuildRequires: lirc
  55. BuildRequires: unique-devel >= %{_unique_ver}
  56. BuildRequires: vala-devel >= %{_vala_ver}
  57. Requires: %{name}-common = %{version}-%{release}
  58. Requires: %{name}-gstreamer = %{version}-%{release}
  59. %if %{build_plugin}
  60. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  61. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  62. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  63. %endif
  64. %description
  65. Totem is simple movie player for the Gnome desktop. It features a
  66. simple playlist, a full-screen mode, seek and volume controls, as well as
  67. a pretty complete keyboard navigation.
  68. This is virtual package to install totem common package and totem backend
  69. package.
  70. %package gstreamer
  71. Summary: GStramer backend for Totem
  72. Summary(ja): Totem 用 GStreamer バックエンド
  73. Group: Applications/Multimedia
  74. Requires: %{name}-common = %{version}-%{release}
  75. Requires: gstreamer >= %{_gst_ver}
  76. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  77. BuildRequires: gstreamer-devel >= %{_gst_ver}
  78. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  79. BuildRequires: gstreamer-plugins-good
  80. Obsoletes: %{name} < 1.0.2-0vl2, nautilus-media
  81. Provides: %{name} = %{version}-%{release}
  82. Requires(post): alternatives
  83. Requires(postun): alternatives
  84. %description gstreamer
  85. Totem is simple movie player for the Gnome desktop. It features a
  86. simple playlist, a full-screen mode, seek and volume controls, as well as
  87. a pretty complete keyboard navigation.
  88. %if %{build_xine}
  89. %package xine
  90. Summary: Xine backend for Totem
  91. Summary(ja): Totem 用 Xine バックエンド
  92. Group: Applications/Multimedia
  93. Requires: %{name}-common = %{version}-%{release}
  94. Requires: xine-lib >= %{_xine_ver}
  95. BuildRequires: xine-lib-devel >= %{_xine_ver}
  96. Obsoletes: %{name} < 1.0.2-0vl2
  97. Provides: %{name} = %{version}-%{release}
  98. Requires(post): alternatives
  99. Requires(postun): alternatives
  100. %description xine
  101. Totem is simple movie player for the Gnome desktop. It features a
  102. simple playlist, a full-screen mode, seek and volume controls, as well as
  103. a pretty complete keyboard navigation.
  104. %endif
  105. %package common
  106. Summary: common files for Totem
  107. Summary(ja): Totem の共通ファイル
  108. Group: Applications/Multimedia
  109. Requires: gtk2 >= %{_gtk_ver}, glib2 >= %{_glib_ver}
  110. Requires: gnome-desktop-libs >= %{_gnome_desktop_ver}
  111. Requires: gnome-vfs2 >= %{_gnomevfs_ver}
  112. Requires: libgnomeui >= %{_gnomeui_ver}
  113. Requires: libgnome >= %{_libgnome_ver}
  114. Requires: dbus >= %{_dbus_ver}
  115. Requires: iso-codes, libmusicbrainz
  116. Conflicts: %{name} < 1.0.2-0vl2
  117. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  118. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils, alternatives
  119. Requires(preun): GConf2
  120. Requires(triggers): alternatives
  121. %description common
  122. Totem is simple movie player for the Gnome desktop. It features a
  123. simple playlist, a full-screen mode, seek and volume controls, as well as
  124. a pretty complete keyboard navigation.
  125. This package contains common files for Totem (GStreamer/xine backend).
  126. %if %{build_plugin}
  127. %package mozilla
  128. Summary: Totem movie plugin for Mozilla
  129. Summary(ja): Mozilla 用 Totem 動画プラグイン
  130. Group: Applications/Internet
  131. Requires: %{name}-common = %{version}-%{release}
  132. Obsoletes: %{name}-mozilla-common
  133. Obsoletes: %{name}-mozilla-gstreamer
  134. Obsoletes: %{name}-mozilla-xine
  135. Requires(post): alternatives
  136. Requires(postun): alternatives
  137. %description mozilla
  138. Totem is simple movie player for the Gnome desktop. It features a
  139. simple playlist, a full-screen mode, seek and volume controls, as well as
  140. a pretty complete keyboard navigation.
  141. This package contains a Totem video plugin for Mozilla. It allows Totem
  142. movie player to be embedded into a web browser.
  143. ## %package tracker
  144. ## Summary: Tracker-based video search plugin for Totem
  145. ## Summary(ja): Tracker を使った Totem 用動画検索プラグイン
  146. ## Group: Applications/Multimedia
  147. ## Requires: %{name}-common = %{version}-%{release}
  148. ## BuildRequires: tracker-devel
  149. ## %description tracker
  150. ## A plugin to allow searching local videos, based on their tags, metadata,
  151. ## or filenames, as indexing by the Tracker indexer.
  152. %endif
  153. %prep
  154. %setup -q -c
  155. # Whatever needs to be changed in both copies do here
  156. ## remember to update me when changing %doc
  157. for i in AUTHORS COPYING ChangeLog NEWS README TODO;do
  158. cp totem-%{version}/$i .
  159. done
  160. # duplicate sources
  161. cp -a totem-%{version} xine
  162. mv totem-%{version} gstreamer
  163. %build
  164. # build Totem (GStreamer backend)
  165. pushd gstreamer
  166. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  167. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  168. %configure \
  169. --disable-schemas-install \
  170. --disable-scrollkeeper \
  171. %if %{build_plugin}
  172. --enable-browser-plugins \
  173. --enable-nautilus \
  174. --enable-gmp-plugin \
  175. --enable-narrowspace-plugin \
  176. --enable-mully-plugin
  177. %else
  178. --disable-browser-plugins
  179. %endif
  180. make %{?_smp_mflags}
  181. popd
  182. # build Totem (xine backend)
  183. %if %{build_xine}
  184. pushd xine
  185. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  186. %configure \
  187. --disable-schemas-install \
  188. --disable-scrollkeeper \
  189. --disable-nautilus \
  190. --disable-browser-plugins
  191. cd src/backend/
  192. make %{?_smp_mflags}
  193. popd
  194. %endif
  195. %install
  196. rm -rf $RPM_BUILD_ROOT
  197. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  198. # install Totem (GStreamer backend)
  199. pushd gstreamer/
  200. make install DESTDIR=$RPM_BUILD_ROOT
  201. ## mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
  202. ## $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  203. # language hack
  204. %find_lang %{name} --with-gnome
  205. mv %{name}.lang ../
  206. popd
  207. # install Totem (xine backend)
  208. %if %{build_xine}
  209. pushd xine/src/backend/
  210. make install DESTDIR=$RPM_BUILD_ROOT
  211. ## mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
  212. ## $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-xine.so.0.0.0
  213. popd
  214. %endif
  215. # remove unneeded files
  216. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  217. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  218. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  219. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  220. ## %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget*.{a,la}
  221. ## %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget.so
  222. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  223. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  224. %find_lang %{name} --with-gnome
  225. %clean
  226. %__rm -rf %{buildroot}
  227. %post gstreamer
  228. ## %{_syssbindir}/update-alternatives --install \
  229. ## %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
  230. ## %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0 10
  231. /sbin/ldconfig
  232. %postun gstreamer
  233. ## [ "$1" = "1" ] && exit
  234. ## %{_syssbindir}/update-alternatives --remove \
  235. ## totem %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  236. ## [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
  237. /sbin/ldconfig
  238. %if %{build_xine}
  239. %post xine
  240. ## %{_syssbindir}/update-alternatives --install \
  241. ## %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
  242. ## %{_libdir}/libbaconvideowidget-xine.so.0.0.0 15
  243. /sbin/ldconfig
  244. %postun xine
  245. ## [ "$1" = "1" ] && exit
  246. ## %{_syssbindir}/update-alternatives --remove \
  247. ## totem %{_libdir}/libbaconvideowidget-xine.so.0.0.0
  248. ## [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
  249. /sbin/ldconfig
  250. %endif
  251. %post common
  252. %{_bindir}/scrollkeeper-update -q
  253. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  254. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  255. gconftool-2 --makefile-install-rule \
  256. %{_sysconfdir}/gconf/schemas/totem.schemas \
  257. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  258. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  259. >& /dev/null || :
  260. touch %{_datadir}/icons/hicolor
  261. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  262. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  263. fi
  264. %pre common
  265. if [ "$1" -gt 1 ]; then
  266. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  267. gconftool-2 --makefile-uninstall-rule \
  268. %{_sysconfdir}/gconf/schemas/totem.schemas \
  269. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  270. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  271. >& /dev/null || :
  272. fi
  273. %preun common
  274. if [ "$1" -eq 0 ]; then
  275. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  276. gconftool-2 --makefile-uninstall-rule \
  277. %{_sysconfdir}/gconf/schemas/totem.schemas \
  278. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  279. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  280. >& /dev/null || :
  281. fi
  282. %postun common
  283. %{_bindir}/scrollkeeper-update -q
  284. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  285. touch %{_datadir}/icons/hicolor
  286. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  287. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  288. fi
  289. [ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
  290. %triggerpostun common -- %{name} < 1.0.2-0vl2
  291. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  292. for schema in totem totem-video-thumbnail totem-handlers ; do
  293. %{_bindir}/gconftool-2 --makefile-install-rule \
  294. %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
  295. done
  296. [ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
  297. %files
  298. %files gstreamer
  299. %defattr(-,root,root,-)
  300. ## %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  301. %if %{build_xine}
  302. %files xine
  303. %defattr(-,root,root,-)
  304. ## %{_libdir}/libbaconvideowidget-xine.so.0.0.0
  305. %endif
  306. %files common -f %{name}.lang
  307. %defattr(-,root,root,-)
  308. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  309. %config %{_sysconfdir}/gconf/schemas/*.schemas
  310. %{_bindir}/totem
  311. %{_bindir}/totem-audio-preview
  312. %{_bindir}/totem-video-indexer
  313. %{_bindir}/totem-video-thumbnailer
  314. %{_datadir}/applications/%{name}.desktop
  315. %{_datadir}/icons/*/*/apps/*
  316. %{_datadir}/icons/*/*/devices/*
  317. %{_datadir}/%{name}
  318. %{_datadir}/gtk-doc/html/totem
  319. %dir %{_libdir}/totem
  320. %dir %{_libdir}/totem/plugins
  321. %{_libdir}/totem/plugins/brasero-disc-recorder
  322. %{_libdir}/totem/plugins/coherence_upnp
  323. %{_libdir}/totem/plugins/gromit
  324. %{_libdir}/totem/plugins/jamendo
  325. %{_libdir}/totem/plugins/lirc
  326. %{_libdir}/totem/plugins/media-player-keys
  327. %{_libdir}/totem/plugins/ontop
  328. %{_libdir}/totem/plugins/opensubtitles
  329. %{_libdir}/totem/plugins/properties
  330. %{_libdir}/totem/plugins/pythonconsole
  331. %{_libdir}/totem/plugins/screensaver
  332. %{_libdir}/totem/plugins/screenshot
  333. %{_libdir}/totem/plugins/skipto
  334. %{_libdir}/totem/plugins/thumbnail
  335. ## %{_libdir}/totem/plugins/youtube
  336. ## %{_libdir}/totem/plugins/totem
  337. ## %{_libdir}/totem/plugins/tracker
  338. %{_libdir}/totem/plugins/brasero-disc-recorder
  339. %{_libdir}/totem/plugins/dbus
  340. %{_libdir}/totem/plugins/gromit
  341. %{_libdir}/totem/plugins/iplayer
  342. %{_libdir}/totem/plugins/jamendo
  343. %{_libdir}/totem/plugins/lirc
  344. %{_libdir}/totem/plugins/media-player-keys
  345. %{_libdir}/totem/plugins/ontop
  346. %{_libdir}/totem/plugins/opensubtitles
  347. %{_libdir}/totem/plugins/properties
  348. %{_libdir}/totem/plugins/pythonconsole
  349. %{_libdir}/totem/plugins/sample-vala
  350. %{_libdir}/totem/plugins/screensaver
  351. %{_libdir}/totem/plugins/screenshot
  352. %{_libdir}/totem/plugins/skipto
  353. %{_libdir}/totem/plugins/thumbnail
  354. %if %{build_plugin}
  355. %{_libdir}/nautilus/extensions-2.0/*.so*
  356. %endif
  357. ## %{_libdir}/libbaconvideowidget.so*
  358. %{_libexecdir}/%{name}/totem-bugreport.py
  359. %{_mandir}/man1/*
  360. %if %{build_plugin}
  361. %files mozilla
  362. %defattr(-,root,root,-)
  363. %{mozplug_dir}/*
  364. %{_libexecdir}/totem-plugin-viewer
  365. ## %files tracker
  366. ## %defattr(-, root, root)
  367. ## %{_libdir}/totem/plugins/tracker
  368. %endif
  369. %changelog
  370. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  371. - new upstream release
  372. - drop totem-tracker package
  373. - add BuildRequires: unique-devel
  374. - remove BuildRequires: hal-devel
  375. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  376. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  377. - remove unneeded autoreconf
  378. - add BR: lirc
  379. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  380. - new upstream release
  381. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  382. - remove bemused plugin
  383. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  384. - new upstream release
  385. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  386. - added tracker video search sub-package
  387. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  388. - new upstream release
  389. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  390. - new upstream release
  391. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  392. - remove libxine dependency from totem-common
  393. - build xine backend with minimum dependency
  394. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  395. - add BR: bluez-libs-devel >= 4.15
  396. - fix typo in %%postun xine
  397. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  398. - rebuild with bluez-libs-devel-4.15
  399. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  400. - new upstream release
  401. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  402. - new upstream release
  403. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  404. - new upstream release
  405. - add patch1 to build with xulrunner-1.9
  406. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  407. - new upstream release
  408. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  409. - new upstream release
  410. - disabled devel package (replaced by totem-pl-parser-devel)
  411. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  412. - new upstream release
  413. - update version macros
  414. - enable browser plugins on x86_64
  415. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  416. - new upstream release
  417. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  418. - upstream release
  419. - drop obsolete ja.po.patch (patch0)
  420. - revert change of 1.4.4-0vl2
  421. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  422. - upstream release
  423. - enable browser plugins (exclude x86_64 arch)
  424. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  425. - upstream release
  426. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  427. - update configure options
  428. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  429. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  430. - fix mistranslation (patch0)
  431. - add icon symlink
  432. - add BuildRequires: gstreamer-plugins-good
  433. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  434. - upstream release
  435. - update %%_glib_ver, %%_xine_ver
  436. - add BuildRequires: hal
  437. - update %%configure options
  438. - update %%files
  439. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  440. - upstream release
  441. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  442. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  443. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  444. - upstream release
  445. - drop obsolete patch0
  446. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  447. - upstream release
  448. - add patch0 to build with intltool-0.35
  449. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  450. - upstream release
  451. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  452. - upstream release
  453. - update alternatives entry
  454. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  455. - upstream release
  456. - drop fix-sort-function.patch (was merged to upstream, #331426)
  457. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  458. - rebuild with gnome-2.14rc
  459. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  460. - upstream release
  461. - add macros
  462. - _gtk_ver, _glib_ver
  463. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  464. - _dbus_ver
  465. - _gst_ver, gstpb_ver, _xine_ver
  466. - add fix-sort-function.patch to build with glib < 2.9.1
  467. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  468. - upstream release
  469. - add BuildRequires:
  470. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  471. - gnome-vfs2-devel >= 2.9.92
  472. - dbus-devel >= 0.35
  473. - use gstreamer-0.10 as backend for totem-gstreamer
  474. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  475. - use gstreamer08 instead of gstreamer
  476. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  477. - upstream release
  478. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  479. - fix missing links
  480. - update file list
  481. - update update-alternatives scripts
  482. - fix totem-gstreamer's %%postun script
  483. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  484. - upstream release
  485. - add BuildRequires: iso-codes, libmusicbrainz-devel
  486. - add Requires: iso-codes, libmusicbrains to -common package
  487. - remove BuildRequires: nautilus-cd-burner
  488. - remove Requires: nautilus-cd-burner from -common package
  489. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  490. - totem-gstreamer obsoletes nautilus-media
  491. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  492. - upstream release
  493. - add Requires(post,postun): alternatives for gstreamer,xine
  494. - add Requires(postun,triggers): alternatives for common
  495. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  496. - upstream release
  497. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  498. - build xine backend
  499. - move common files to common package
  500. - move GStreamer related files to gstreamer package
  501. - install xine related files to xine package
  502. - fix scripts
  503. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  504. - upstream release
  505. - update URL
  506. - move *.{a,la} to devel package
  507. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  508. - fix %%{post,preun} script (video-thumbnail.schemas)
  509. - sync with Fedora Core's 1.0.1-1
  510. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  511. - Update to upstream version 1.0.1
  512. - Break out devel package
  513. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  514. - add %%{post,pre}un script
  515. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  516. - initial build for Vine Linux
  517. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  518. - fix %%post
  519. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  520. - Obsolete nautilus-media
  521. - Install property page and thumbnailer
  522. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  523. - Update to 0.101
  524. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  525. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  526. missing menu entry (144088)
  527. - Remove workaround for desktop file being misinstalled, fixed
  528. by above patch
  529. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  530. - New upstream version 0.100
  531. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  532. - update to 0.99.22
  533. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  534. - Add patch to remove removed items from package from help
  535. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  536. - New upstream 0.99.19
  537. - Fixes crasher with CD playback (see NEWS)
  538. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  539. - Call update-desktop-database in post
  540. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  541. - update to 0.99.18
  542. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  543. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>