rhythmbox-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.12.8
  8. Release: 1%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source: http://download.gnome.org/sources/rhythmbox/0.12/%{name}-%{version}.tar.bz2
  13. # https://bugzilla.gnome.org/show_bug.cgi?id=596615
  14. Patch0: rb-no-HEAD-for-podcasts.patch
  15. # https://bugzilla.redhat.com/show_bug.cgi?id=540672
  16. # https://bugzilla.gnome.org/show_bug.cgi?id=602140
  17. Patch1: rb-webkit-crasher.patch
  18. # https://bugzilla.redhat.com/show_bug.cgi?id=546188
  19. Patch2: 0001-Fix-crasher-when-MusicBrainz-can-t-read-a-disc.patch
  20. # https://bugzilla.gnome.org/show_bug.cgi?id=601524
  21. # https://bugzilla.gnome.org/show_bug.cgi?id=602957
  22. Patch3: rb-playbin2-track-changes.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: libgpod-devel
  25. BuildRequires: libgnomeui-devel >= 2.18.0
  26. BuildRequires: brasero-devel
  27. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  28. BuildRequires: gettext, rarian-compat
  29. BuildRequires: totem-pl-parser-devel
  30. BuildRequires: sqlite3-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: gnome-vfs2-devel >= 2.18.0
  33. BuildRequires: avahi-glib-devel >= 0.6
  34. BuildRequires: libmusicbrainz-devel >= 2.1.0
  35. BuildRequires: libnotify-devel
  36. BuildRequires: libsexy-devel
  37. BuildRequires: libgudev1-devel
  38. BuildRequires: libsoup-devel
  39. BuildRequires: dbus-devel >= 1.0
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: gnome-doc-utils >= 0.3.2
  42. BuildRequires: python-devel, pygtk2-devel
  43. BuildRequires: check >= 0.8.2
  44. BuildRequires: intltool >= 0.35.0
  45. BuildRequires: gstreamer-python
  46. BuildRequires: popt-devel
  47. BuildRequires: lirc
  48. BuildRequires: libmtp-devel
  49. BuildRequires: libgnome-keyring-devel >= 2.30.0
  50. BuildRequires: gnome-media
  51. BuildRequires: libSM-devel
  52. Requires: libgpod
  53. Requires: libnotify
  54. Requires: libsexy
  55. Requires: lirc
  56. Requires: libmtp
  57. Requires: libgnomeui
  58. Requires: brasero
  59. Requires: gnome-python gnome-vfs2
  60. Requires: gnome-themes
  61. Requires: libgnome-keyring
  62. Requires: gstreamer-python
  63. %if %{enable_DLNA_UPnP}
  64. Requires: python-Coherence
  65. %endif
  66. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  67. Requires: scrollkeeper GConf2
  68. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  69. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  70. # # respectively.
  71. # Requires: self-build-gstreamer-plugins-ffmpeg
  72. # Requires: self-build-gstreamer-plugins-ugly
  73. %description
  74. Rhythmbox is an integrated music management application based on the powerful
  75. GStreamer media framework. It has a number of features, including an easy to
  76. use music browser, searching and sorting, comprehensive audio format support
  77. through GStreamer, Internet Radio support, playlists and more.
  78. Rhythmbox is extensible through a plugin system.
  79. %description -l ja
  80. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  81. 統合音楽管理アプリケーションです。
  82. 見やすいユーザインターフェースを備え、検索や整列ができ、
  83. GStreamer により数多くの音声フォーマットをサポート、
  84. インターネットラジオをサポート、プレイリスト管理などの
  85. 数多くの特徴を持ちます。
  86. %prep
  87. %setup -q
  88. %patch0 -p1 -b .http-head
  89. ## %patch1 -p1 -b .webkit
  90. ## %patch2 -p1 -b .mb-crasher
  91. ## %patch3 -p1 -b .track-change-hang
  92. # autoreconf -i
  93. # Use the installed louie, not the one in Coherence
  94. find plugins/coherence/upnp_coherence/ -type f \
  95. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  96. %build
  97. # work around a gstreamer bug
  98. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  99. %configure --with-ipod \
  100. --with-mtp \
  101. --with-dbus \
  102. --with-mdns=avahi \
  103. --with-libnautilus-burn \
  104. --with-cd-burning \
  105. --with-metadata-helper \
  106. --enable-lirc \
  107. --enable-python \
  108. --disable-vala \
  109. --disable-browser-plugin \
  110. --disable-static \
  111. --disable-scrollkeeper \
  112. --disable-schemas-install \
  113. --without-hal
  114. %__make %{?_smp_mflags}
  115. %install
  116. %__rm -rf $RPM_BUILD_ROOT
  117. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  118. %__make install DESTDIR=$RPM_BUILD_ROOT
  119. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  120. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  121. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  122. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  123. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  124. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  125. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  126. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  127. ## Don't package DLNA/UPnP plugin
  128. %if !%{enable_DLNA_UPnP}
  129. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  130. %endif
  131. %find_lang %{name}
  132. # Don't package api docs
  133. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  134. # Don't package scrollkeeper catalogs
  135. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  136. # And don't package vala
  137. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  138. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  139. # save space by linking identical images in translated docs
  140. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  141. for f in $helpdir/C/figures/*.png; do
  142. b="$(basename $f)"
  143. for d in $helpdir/*; do
  144. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  145. g="$d/figures/$b"
  146. if [ -f "$g" ]; then
  147. if cmp -s $f $g; then
  148. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  149. fi
  150. fi
  151. fi
  152. done
  153. done
  154. %clean
  155. %__rm -rf $RPM_BUILD_ROOT
  156. %post
  157. /sbin/ldconfig
  158. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  159. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/rhythmbox.schemas >/dev/null
  160. update-desktop-database -q
  161. scrollkeeper-update -q
  162. touch --no-create %{_datadir}/icons/hicolor
  163. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  164. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  165. fi
  166. %preun
  167. if [ "$1" -eq 0 ]; then
  168. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  169. gconftool-2 --makefile-uninstall-rule \
  170. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas > /dev/null || :
  171. fi
  172. %postun
  173. /sbin/ldconfig
  174. update-desktop-database -q
  175. scrollkeeper-update -q
  176. touch --no-create %{_datadir}/icons/hicolor
  177. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  178. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  179. fi
  180. %files -f %{name}.lang
  181. %defattr(-, root, root)
  182. %doc AUTHORS COPYING ChangeLog README NEWS
  183. %{_sysconfdir}/gconf/schemas/rhythmbox.schemas
  184. %{_bindir}/*
  185. %{_libdir}/lib*.so*
  186. %{_libdir}/rhythmbox/plugins
  187. %{_datadir}/applications/rhythmbox.desktop
  188. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  189. %{_datadir}/gnome/help/rhythmbox
  190. %{_datadir}/icons/*
  191. %{_datadir}/omf/rhythmbox
  192. %{_datadir}/rhythmbox
  193. %{_mandir}/man1/*
  194. %{_libexecdir}/rhythmbox-metadata
  195. %changelog
  196. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
  197. - new upstream release
  198. - drop Patch1, Patch2, Patch3
  199. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  200. - change Requires: nautilus-cd-burner -> brasero
  201. - change BuildRequires: hal-devel -> libgudev1-devel
  202. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  203. - change Requires: gnome-keyring -> libgnome-keyring
  204. - add configure option (--without-hal)
  205. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  206. - rebuilt with new environment
  207. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  208. - new upstream release
  209. - dropped upstreamed/obsolete patches
  210. - added patches applied Fedora development
  211. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  212. - new upstream release
  213. - added configure options:
  214. --disable-vala
  215. --disable-browser-plugin
  216. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  217. - added Japanese description
  218. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  219. - new upstream release
  220. - dropped rb-disable-power-plugin-by-default.patch
  221. - added BuildRequires:
  222. - libSM-devel
  223. - gnome-media
  224. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  225. - rebuild with libgpod-0.7.2
  226. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  227. - new upstream release
  228. - corrected License tag
  229. - dropped rhythmbox-0.11.6-libmtp.patch
  230. - added BuildRequires:
  231. - sqlite3-devel
  232. - libffi-devel
  233. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  234. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  235. - applied rhythmbox-0.11.6-libmtp.patch
  236. - added Requires:
  237. - libgpod
  238. - libnotify
  239. - libsexy
  240. - lirc
  241. - libmtp
  242. - libgnomeui
  243. - nautilus-cd-burner
  244. - gstreamer-python
  245. - gnome-vfs2
  246. - gnome-themes
  247. - gnome-keyring
  248. - python-Coherence, if enable_DLNA_UPnP = 1
  249. - added BuildRequires:
  250. - libnotify-devel
  251. - libsexy-devel
  252. - lirc
  253. - libmtp-devel
  254. - gnome-vfs2-devel, instead of gnome-vfs2
  255. - gnome-keyring-devel
  256. - dropped --with-internal-libsexy in configure options
  257. - added in configure options:
  258. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  259. - added %%preun to remove the schema
  260. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  261. - new upstream release
  262. - changed to --with-metadata-helper in configure options
  263. - added BuildRequires:
  264. - gstreamer-python
  265. - intltool >= 0.35.0
  266. - popt-devel
  267. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  268. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  269. - rebuilt with python-2.5.2
  270. - applied new versioning policy
  271. - spec in utf-8
  272. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  273. - rebuilt with libgpod-0.6.0
  274. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  275. - new upstream release
  276. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  277. - new upstream release
  278. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  279. - rebuilt with new toolchain and libgpod-0.4.2
  280. - add BuildRequires: dbus-glib-devel
  281. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  282. - new upstream release
  283. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  284. - rebuilt for VineSeed
  285. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  286. - new upstream release
  287. - added --enable-python option to %%configure
  288. - added Requires: gnome-python
  289. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  290. - new upstream release
  291. - built with libsoup 2.2.99
  292. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  293. - added --with-cd-burner to configure
  294. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  295. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  296. - add BuildRequires:
  297. - gnome-doc-utils >= 0.3.2
  298. - python-devel
  299. - pygtk2-devel
  300. - check >= 0.8.2
  301. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  302. - rebuild with gnutls-1.4.1
  303. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  304. - new upstream release
  305. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  306. - new upstream release
  307. - run scrollkeeper-update at %post and %postun
  308. - added BuildRequires: libnotify-devel
  309. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  310. - new upstream release (dropped patch0)
  311. - added --without-metadata-helper at configure
  312. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  313. - Initial build for Vine Linux based on FC pacakge
  314. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  315. - add patch from James "Doc" Livingston to stop a hang
  316. for new users (bug 183883)
  317. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  318. - bump again for double-long bug on ppc(64)
  319. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  320. - rebuilt for new gcc4.1 snapshot and glibc changes
  321. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  322. - Update to 0.9.3.1
  323. - Use gstreamer (0.10)
  324. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  325. - Remove hack for 173869, as its no longer needed.
  326. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  327. - 0.9.3
  328. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  329. - Newer CVS snapshot
  330. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  331. - Update to latest CVS
  332. - Add hack to workaround bug #173869
  333. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  334. - Rebuild, now that gstreamer08-plugins has been fixed
  335. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  336. - bonobo multilib issue (bug 156982)
  337. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  338. - rebuild with ipod support
  339. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  340. - rebuilt again
  341. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  342. - rebuilt
  343. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  344. - rebuild
  345. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  346. - rebuild for new dbus
  347. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  348. - Update to 0.9.2
  349. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  350. - Update to 0.9.1
  351. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  352. - Add configure flags --with-bonobo --with-dbus
  353. - BR nautilus-cd-burner-devel
  354. - New upstream CVS snapshot for testing
  355. - Drop IDL file and ui .xml
  356. - Add dbus service file
  357. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  358. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  359. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  360. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  361. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  362. cell renderer for playback icon (no longer necessary) and
  363. changes the rating renderer to work with non-b&w icons
  364. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  365. - Rebuild for GCC4
  366. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  367. - New upstream version
  368. - Remove librb-nautilus-context-menu.so, killed upstream
  369. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  370. - PreReq desktop-file-utils >= 0.9
  371. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  372. - New upstream version
  373. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  374. - Fix postun to use correct syntax, thanks Nils Philippsen
  375. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  376. - New upstream version
  377. - Call update-desktop-database in post and postun
  378. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  379. - New upstream version
  380. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  381. - rebuilt
  382. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  383. - New upstream version
  384. - Remove backported patches
  385. - Gratuitiously bump various BuildRequires versions
  386. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  387. - Remove code to unregister GConf schema for now (Closes: #122532)
  388. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  389. - Apply tiny patch from 0.8 arch to fix GConf key used
  390. for initial sorting
  391. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  392. - Apply patch from 0.8 arch tree to fix a number of memleaks
  393. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  394. - Update to 0.8.3: fixes showstopper bug with internet radio
  395. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  396. - Update to 0.8.2
  397. - Fix Source url
  398. - Add smp_mflags
  399. - Bump BuildRequires on gstreamer to 0.8.1
  400. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  401. - Uninstall GConf schemas on removal
  402. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  403. - Update to 0.8.1
  404. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  405. - Update to 0.8.0
  406. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  407. - Update to 0.7.2
  408. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  409. - Remove BuildRequires on autoconf and libvorbis-devel
  410. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  411. - New major version - I know we are past major version slush, but
  412. this should have been done two weeks ago along with the GNOME 2.6
  413. upload. As upstream author as well, I believe this version is
  414. good enough for FC2.
  415. - Remove --disable-mp3
  416. - Remove id3, flac variables
  417. - Remove GStreamer major version patch
  418. - Fix typo in description
  419. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  420. - rebuild for new gstreamer
  421. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  422. - update to 0.6.8
  423. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  424. - rebuilt
  425. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  426. - update to 0.6.7
  427. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  428. - rebuilt
  429. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  430. - New upstream version
  431. - Don't re-run the autotools; upstream incorporates newer versions.
  432. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  433. - new version
  434. - remove smp_flags
  435. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  436. - remove the initial iradio channels as they all are mp3 based.
  437. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  438. - Fix category from Development/Libraries to Applications/Multimedia.
  439. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  440. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  441. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  442. - Removed unnecessary date expansion define.
  443. - Updated description, including mp3 reference removal.
  444. - Added libid3tag and flac optional support for convenient rebuild.
  445. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  446. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  447. - new version
  448. - use %{_sysconfdir} instead of /etc
  449. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  450. - rebuilt
  451. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  452. - gave up on other archs for the Beta
  453. - new version
  454. - remove werror and add missing files
  455. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  456. - update to newer cvs snap
  457. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  458. - update to cvs snap
  459. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  460. - use %%(lang)
  461. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  462. - fix post to actually install the schema
  463. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  464. - Added gconf file
  465. - Added i18n directory
  466. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  467. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  468. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  469. - removed bonobo dependency
  470. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  471. - created new spec file