gtk-vnc-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223
  1. # Plugin isn't ready for real world use yet - it needs
  2. # a security audit at very least
  3. %define with_plugin 0
  4. Summary: A GTK widget for VNC clients
  5. Summary(ja): VNCクライアント用 GTK ウィジェット
  6. Name: gtk-vnc
  7. Version: 0.3.10
  8. Release: 1%{?_dist_release}
  9. License: LGPLv2+
  10. Group: Development/Libraries
  11. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  12. Patch100: gtk-vnc-0.3.8-fast.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. URL: http://gtk-vnc.sf.net/
  15. BuildRequires: gtk2-devel pygtk2-devel python-devel zlib-devel
  16. BuildRequires: gnutls-devel gtkglext-devel cyrus-sasl-devel
  17. %if %{with_plugin}
  18. BuildRequires: xulrunner-devel
  19. %endif
  20. %description
  21. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  22. allowing it to be completely asynchronous while remaining single threaded.
  23. %package devel
  24. Summary: Development filesdor gtk-vnc library
  25. Summary(ja): gtk-vnc ライブラリの開発ファイル
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}
  28. Requires: pkgconfig
  29. Requires: pygtk2-devel gtk2-devel gnutls-devel
  30. %description devel
  31. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  32. allowing it to be completely asynchronous while remaining single threaded.
  33. Libraries, includes, etc. to compile with the gtk-vnc library
  34. %package python
  35. Summary: Python bindings for the gtk-vnc library
  36. Summary(ja): gtk-vnc ライブラリの python バインディング
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}
  39. %description python
  40. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  41. allowing it to be completely asynchronous while remaining single threaded.
  42. A module allowing use of the GTK-VNC widget from python
  43. %if %{with_plugin}
  44. %package plugin
  45. Summary: Mozilla plugin for the gtk-vnc library
  46. Summary(ja): gtk-vnc ライブラリの mozilla プラグイン
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. %description plugin
  50. gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
  51. allowing it to be completely asynchronous while remaining single threaded.
  52. This package provides a web browser plugin for Mozilla compatible
  53. browsers.
  54. %endif
  55. %prep
  56. %setup -q
  57. %patch100 -p1
  58. %build
  59. %if %{with_plugin}
  60. %configure --enable-plugin=yes
  61. %else
  62. %configure
  63. %endif
  64. %__make %{?_smp_mflags}
  65. %install
  66. rm -fr %{buildroot}
  67. %__make install DESTDIR=%{buildroot}
  68. rm -f %{buildroot}%{_libdir}/*.a
  69. rm -f %{buildroot}%{_libdir}/*.la
  70. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.a
  71. rm -f %{buildroot}%{_libdir}/python*/site-packages/*.la
  72. %if %{with_plugin}
  73. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.a
  74. rm -f %{buildroot}%{_libdir}/mozilla/plugins/%{name}-plugin.la
  75. %endif
  76. %find_lang %{name}
  77. %clean
  78. rm -fr %{buildroot}
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %files -f %{name}.lang
  82. %defattr(-, root, root)
  83. %doc AUTHORS ChangeLog NEWS README COPYING.LIB
  84. %{_libdir}/lib*.so.*
  85. %files devel
  86. %defattr(-, root, root)
  87. %doc examples/gvncviewer.c
  88. %{_libdir}/lib*.so
  89. %dir %{_includedir}/%{name}-1.0/
  90. %{_includedir}/%{name}-1.0/*.h
  91. %{_libdir}/pkgconfig/%{name}-1.0.pc
  92. %files python
  93. %defattr(-, root, root)
  94. %doc examples/gvncviewer.py
  95. %{_libdir}/python*/site-packages/gtkvnc.so
  96. %if %{with_plugin}
  97. %files plugin
  98. %defattr(-, root, root)
  99. %{_libdir}/mozilla/plugins/%{name}-plugin.so
  100. %endif
  101. %changelog
  102. * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.10-1
  103. - new upstream release
  104. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.9-2
  105. - rebuild with python-2.6
  106. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-1
  107. - new upstream release
  108. - add Patch100 to speed up
  109. - add BR: cyrus-sasl-devel
  110. * Mon Jan 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-2
  111. - rebuild with gnutls-2.6.3
  112. * Wed Dec 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-1
  113. - new upstream release
  114. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-1
  115. - initial build for Vine Linux
  116. * Fri Sep 5 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.7-1
  117. - Update to 0.3.7
  118. * Thu Aug 28 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-4.fc9
  119. - Fix key/mouse event propagation (rhbz #454627)
  120. * Mon Jul 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3.6-3
  121. - fix conditional comparison
  122. * Wed Jun 25 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-2.fc10
  123. - Rebuild for GNU TLS ABI change
  124. * Wed May 7 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.6-1.fc10
  125. - Updated to 0.3.6 release
  126. * Fri Apr 25 2008 Matthias Clasen <mclasen@redhat.com> - 0.3.5-1.fc9
  127. - Update to 0.3.5
  128. * Fri Apr 4 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-4.fc9
  129. - Remove bogus chunk of render patch
  130. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-3.fc9
  131. - Fix OpenGL rendering artifacts (rhbz #440184)
  132. * Thu Apr 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-2.fc9
  133. - Fixed endianness conversions
  134. - Fix makecontext() args crash on x86_64
  135. - Fix protocol version negotiation
  136. * Thu Mar 6 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.4-1.fc9
  137. - Update to 0.3.4 release
  138. - Fix crash with OpenGL scaling code
  139. * Sun Feb 3 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.3-1.fc9
  140. - Update to 0.3.3 release
  141. * Mon Jan 14 2008 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-2.fc9
  142. - Track keystate to avoid stuck modifier keys
  143. * Mon Dec 31 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.2-1.fc9
  144. - Update to 0.3.2 release
  145. - Added dep on zlib-devel
  146. * Thu Dec 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.3.1-1.fc9
  147. - Update to 0.3.1 release
  148. * Thu Oct 10 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-4.fc8
  149. - Fixed coroutine cleanup to avoid SEGV (rhbz #325731)
  150. * Thu Oct 4 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-3.fc8
  151. - Fixed coroutine caller to avoid SEGV
  152. * Wed Sep 26 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-2.fc8
  153. - Remove use of PROT_EXEC for coroutine stack (rhbz #307531 )
  154. * Thu Sep 13 2007 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1.fc8
  155. - Update to 0.2.0 release
  156. * Wed Aug 29 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-5.fc8
  157. - Fixed handling of mis-matched client/server colour depths
  158. * Wed Aug 22 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-4.fc8
  159. - Fix mixed endian handling & BGR pixel format (rhbz #253597)
  160. - Clear widget areas outside of framebuffer (rhbz #253599)
  161. - Fix off-by-one in python demo
  162. * Thu Aug 16 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-3.fc8
  163. - Tweaked post scripts
  164. - Removed docs from sub-packages
  165. - Explicitly set license to LGPLv2+
  166. - Remove use of macro for install rule
  167. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-2.fc8
  168. - Added gnutls-devel requirement to -devel package
  169. * Wed Aug 15 2007 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1.fc8
  170. - Initial official release