ulogd-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334
  1. %bcond_with doc
  2. Summary: Userspace logging daemon for netfilter
  3. Name: ulogd
  4. Version: 2.0.7
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Daemons
  8. URL: http://www.netfilter.org/projects/%{name}/
  9. Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
  10. Source1: %{name}.init
  11. Source2: %{name}.logrotate
  12. BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
  13. BuildRequires: libnetfilter_log-devel >= 1.0.0
  14. BuildRequires: libnfnetlink-devel >= 0.0.39
  15. BuildRequires: libnetfilter_acct-devel >= 1.0.1
  16. BuildRequires: libmnl-devel
  17. %if %{with doc}
  18. BuildRequires: linuxdoc-tools
  19. BuildRequires: texlive-collection-fontsrecommended
  20. %endif
  21. Requires(post): /sbin/service
  22. Requires(post): /sbin/chkconfig
  23. Requires(preun): /sbin/chkconfig
  24. Requires(preun): /sbin/service
  25. Requires(postun): /sbin/service
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: tomop
  29. %description
  30. %{name} is a logging daemon that reads event messages coming from the Netfilter
  31. connection tracking and the Netfilter packet logging subsystem. You have to
  32. enable support for connection tracking event delivery; ctnetlink and the NFLOG
  33. target in your Linux kernel 2.6.x or load their respective modules. The
  34. deprecated ULOG target (which has been superseded by NFLOG) is also supported.
  35. %package libdbi
  36. Summary: Libdbi framework output plugin for %{name}
  37. Group: System Environment/Daemons
  38. BuildRequires: libdbi-devel
  39. Requires: %{name} = %{version}
  40. %description libdbi
  41. %{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
  42. firewall information through a libdbi interface.
  43. %package mysql
  44. Summary: MySQL output plugin for %{name}
  45. Group: System Environment/Daemons
  46. BuildRequires: libmariadb-devel
  47. Requires: %{name} = %{version}
  48. %description mysql
  49. %{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
  50. firewall information into a MySQL database.
  51. %package pgsql
  52. Summary: PostgreSQL output plugin for %{name}
  53. Group: System Environment/Daemons
  54. BuildRequires: libpq-devel
  55. Requires: %{name} = %{version}
  56. %description pgsql
  57. %{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
  58. firewall information into a PostgreSQL database.
  59. %package pcap
  60. Summary: PCAP output plugin for %{name}
  61. Group: System Environment/Daemons
  62. BuildRequires: libpcap-devel
  63. Requires: %{name} = %{version}
  64. %description pcap
  65. %{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
  66. file. PCAP is a standard format that can be later analyzed by a lot of tools
  67. such as tcpdump and wireshark.
  68. %package sqlite
  69. Summary: SQLITE output plugin for %{name}
  70. Group: System Environment/Daemons
  71. BuildRequires: sqlite3-devel
  72. Requires: %{name} = %{version}
  73. %description sqlite
  74. %{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
  75. firewall information into an SQLITE database.
  76. %prep
  77. %setup -q
  78. %{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
  79. %build
  80. %configure \
  81. --disable-static \
  82. --enable-shared \
  83. --with-dbi-lib=%{_libdir} \
  84. --with-pcap-lib=%{_libdir} \
  85. --with-sqlite3-lib=%{_libdir}
  86. %{__make} %{?_smp_mflags}
  87. %if %{with doc}
  88. %{__make} %{?_smp_mflags} -C doc
  89. %endif
  90. %install
  91. %{__rm} -rf %{buildroot}
  92. %{__make} DESTDIR=%{buildroot} install
  93. %{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
  94. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
  95. %{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
  96. %{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
  97. %{__install} -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  98. %{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
  99. %{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  100. %post
  101. /sbin/chkconfig --add %{name}
  102. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  103. %preun
  104. # if we are uninstalling...
  105. if [ "$1" = 0 ]; then
  106. /sbin/service %{name} stop > /dev/null 2>&1 ||:
  107. /sbin/chkconfig --del %{name}
  108. fi
  109. %postun
  110. # if we are upgrading...
  111. if [ "$1" -ge "1" ]; then
  112. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  113. fi
  114. %check
  115. %{__make} %{?_smp_mflags} check
  116. %clean
  117. %{__rm} -rf %{buildroot}
  118. %files
  119. %defattr(0755,root,root,0755)
  120. %{_sbindir}/%{name}
  121. %{_initrddir}/%{name}
  122. %{_libdir}/%{name}
  123. %defattr(0644,root,root,0755)
  124. %license COPYING
  125. %doc AUTHORS README
  126. %if %{with doc}
  127. %doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
  128. %endif
  129. %doc %{_mandir}/man?/*
  130. %config(noreplace) %{_sysconfdir}/%{name}.conf
  131. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  132. %dir %{_localstatedir}/log/%{name}
  133. %exclude %{_libdir}/%{name}/*.la
  134. %exclude %{_libdir}/%{name}/%{name}_output_DBI.so
  135. %exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
  136. %exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
  137. %exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
  138. %exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  139. %files libdbi
  140. %defattr(0755,root,root,0755)
  141. %{_libdir}/%{name}/%{name}_output_DBI.so
  142. %defattr(0644,root,root,0755)
  143. %license COPYING
  144. %files mysql
  145. %defattr(0755,root,root,0755)
  146. %{_libdir}/%{name}/%{name}_output_MYSQL.so
  147. %defattr(0644,root,root,0755)
  148. %license COPYING
  149. %files pgsql
  150. %defattr(0755,root,root,0755)
  151. %{_libdir}/%{name}/%{name}_output_PGSQL.so
  152. %defattr(0644,root,root,0755)
  153. %license COPYING
  154. %files pcap
  155. %defattr(0755,root,root,0755)
  156. %{_libdir}/%{name}/%{name}_output_PCAP.so
  157. %defattr(0644,root,root,0755)
  158. %license COPYING
  159. %files sqlite
  160. %defattr(0755,root,root,0755)
  161. %{_libdir}/%{name}/%{name}_output_SQLITE3.so
  162. %defattr(0644,root,root,0755)
  163. %license COPYING
  164. %changelog
  165. * Sun Aug 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
  166. - new upstream release.
  167. - added Source2: dropped in upstream.
  168. - disabled to build documents: raised tooooo many errors.
  169. * Sun Feb 25 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
  170. - new upstream release.
  171. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-3
  172. - rebuild with libdbi-0.9.0
  173. * Mon Jul 14 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
  174. - fixed configuration for logrotate.
  175. * Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  176. - new upstream release.
  177. - initial build for Vine Linux.
  178. * Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
  179. - added accidentaly removed dist suffix in release
  180. - fixed up bogus dates in changelog
  181. * Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
  182. - update version
  183. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  185. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  187. * Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  189. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  191. * Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
  192. - update version.
  193. - spec review.
  194. - (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
  195. * Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
  196. - rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
  197. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  199. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
  200. - rebuilt with new openssl
  201. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  203. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  205. * Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
  206. - rebuild for mysql
  207. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
  208. - Autorebuild for GCC 4.3
  209. * Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
  210. - Support for libpcap added
  211. * Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
  212. - Rebuild for deps
  213. * Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
  214. - Fix the deprecated way of getting the DSO initializers run, causing
  215. builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
  216. * Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
  217. - add patch to fix bug 247345
  218. - update URL
  219. - fix initscript (bug 247083)
  220. - unmark init script as %%config (Fedora policy)
  221. * Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
  222. - rebuild
  223. * Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
  224. - rebuild
  225. * Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
  226. - version 1.24
  227. - drop patch3 (applied upstream)
  228. - drop patch4 (upstream uses mysql-config to detect libdir now)
  229. - drop patch5 (applied upstream)
  230. * Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
  231. - rebuild for FC5
  232. * Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
  233. - compress rotated logs
  234. - start after mysql in the init process
  235. - use dist tag
  236. * Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
  237. - version 1.23
  238. - change release tag for FC4
  239. - add patch for GCC4 (upstream bug #323)
  240. * Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  241. - rebuilt
  242. * Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
  243. - version 1.22
  244. - add gpg signature to sources
  245. * Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
  246. - version 1.21
  247. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
  248. - revise x86_64 patch to remove more hardcoded /lib badness
  249. * Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
  250. - x86_64, patch configure to look for mysql/pgsql below %%_libdir.
  251. - delete undefined %%epoch in mysql/pgsql sub package dep.
  252. * Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
  253. - apply Michael Schwendt's suggestions in bug 1598
  254. * Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
  255. - enable MySQL and PostgreSQL in subpackages
  256. - add man page from Debian
  257. * Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
  258. - apply QA suggestions (bug 1598)
  259. * Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
  260. - disable parallel builds
  261. - add chkconfig to Requires(pre,post)
  262. - set the right mode for /etc/logrotate.d/ulogd
  263. - rotate weekly
  264. * Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
  265. - Add Epoch: 0