libomp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 17.0.2
  9. %define shortver %(echo %{version} | cut -d. -f1)
  10. Release: 1%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: NCSA
  15. URL: https://llvm.org/
  16. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  17. # patches
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: libffi-devel >= 3.3
  22. BuildRequires: elfutils-libelf-devel
  23. BuildRequires: clang-tools-extra
  24. # The AMDGCN device RTL requires clang and llvm-link to build
  25. BuildRequires: clang
  26. BuildRequires: llvm
  27. # libomptarget needs the llvm cmake files
  28. BuildRequires: llvm-devel
  29. BuildRequires: llvm-static
  30. %description
  31. The package contains the OpenMP runtime for clang.
  32. %package devel
  33. Summary: OpenMP header files
  34. Summary(ja): OpenMPヘッダファイル
  35. Group: programming
  36. Requires: clang-devel%{?isa} = %{version}
  37. %description devel
  38. The package contains the OpenMP header files.
  39. %debug_package
  40. %prep
  41. %autosetup -p2 -n openmp-%{version}.src
  42. %build
  43. # LTO causes build failures in this package. Disable LTO for now
  44. %define _lto_cflags %{nil}
  45. %cmake \
  46. -GNinja \
  47. -DLIBOMP_INSTALL_ALIASES=OFF \
  48. -DCMAKE_MODULE_PATH=%{_datadir}/llvm/cmake/Modules \
  49. -DLLVM_DIR=%{_libdir}/cmake/llvm \
  50. -DCMAKE_INSTALL_INCLUDEDIR=%{_libdir}/clang/%{shortver}/include \
  51. %if 0%{?__isa_bits} == 64
  52. -DOPENMP_LIBDIR_SUFFIX=64 \
  53. %else
  54. -DOPENMP_LIBDIR_SUFFIX= \
  55. %endif
  56. -DCMAKE_SKIP_RPATH:BOOL=ON \
  57. -DLIBOMP_HAVE_VERSION_SCRIPT_FLAG:BOOL=ON
  58. %cmake_build
  59. %install
  60. rm -rf %{buildroot}
  61. %cmake_install
  62. # Remove static libraries with equivalent shared libraries
  63. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  64. %if %{with test}
  65. %check
  66. %cmake_build --target check-openmp
  67. %endif
  68. %clean
  69. rm -rf %{buildroot}
  70. %files
  71. %license LICENSE.TXT
  72. %{_libdir}/libarcher.so
  73. %{_libdir}/libomp.so
  74. %{_libdir}/libompd.so
  75. %ifnarch %{ix86} %{arm}
  76. %{_libdir}/libomptarget.so.*
  77. %{_libdir}/libomptarget.rtl.*.so*
  78. %endif
  79. %files devel
  80. %ifnarch %{ix86} %{arm}
  81. %{_libdir}/libomptarget.devicertl.a
  82. %endif
  83. %{_libdir}/clang/%{shortver}/include/omp.h
  84. %{_libdir}/clang/%{shortver}/include/omp-tools.h
  85. %{_libdir}/clang/%{shortver}/include/ompt.h
  86. %{_libdir}/clang/%{shortver}/include/ompt-multiplex.h
  87. %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
  88. %ifnarch %{ix86} %{arm}
  89. %{_libdir}/libomptarget.so
  90. %{_libdir}/libomptarget.rtl.*.so
  91. %{_libdir}/libomptarget-*.bc
  92. %endif
  93. %changelog
  94. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  95. - new upstream release.
  96. * Sun Oct 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  97. - new upstream release.
  98. * Mon May 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  99. - new upstream release.
  100. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  101. - new upstream release.
  102. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  103. - new upstream release.
  104. * Thu Sep 08 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  105. - new upstream release.
  106. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  107. - new upstream release.
  108. - updated Patch0.
  109. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  110. - new upstream release.
  111. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  112. - new upstream release.
  113. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  114. - new upstream release.
  115. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  116. - devided libomp from llvm.
  117. - new upstream release.
  118. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  119. - enabled to build utils.
  120. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  121. - new upstream release.
  122. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  123. - new upstream release.
  124. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  125. - rebuilt with libffi-3.3.
  126. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  127. - new upstream release.
  128. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  129. - new upstream release.
  130. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  131. - dropped all patches.
  132. - switched build-system to ninja.
  133. - switched python to python3.
  134. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  135. - new upstream release.
  136. - added OpenMP.
  137. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  138. - fixed %%files.
  139. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  140. - new upstream release.
  141. - dropped Patch0, 4, 5, 100 and 200.
  142. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  143. - renamed a subpackage "llvm-libs".
  144. - added a subpackage "lld".
  145. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  146. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  147. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  148. - new upstream release.
  149. - dropped Patch1 and 2: fixed in upstream.
  150. - imported Patch0, 3-5, 100 and 200 from rawhide.
  151. - disabled Patch1002: no longer needed?
  152. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  153. - new upstream release.
  154. - switched to cmake.
  155. - disable ocaml binding as default.
  156. - updated Patch1000 and 1002.
  157. - disabled Patch1000 as default.
  158. - cleanup patches.
  159. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  160. - rebuild with gcc-5.4.0
  161. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  162. - new upstream release
  163. - added BR: ocaml-ctypes
  164. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  165. - new upstream release
  166. - dropt Patch 1, 201 and 1001
  167. - updated Patch 1000
  168. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  169. - updated to 3.5.1
  170. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  171. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  172. - obsoleted clang-doc
  173. - built with ocaml 4.02.1
  174. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  175. - fix <BTS:2832>
  176. - fix configure option "--with-c-include-dirs"
  177. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  178. - update Patch1001: clang-3.5.0-driver-lib64.patch
  179. - update Patch1002: clang-3.5.0-driver-vine.patch
  180. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  181. - update to 3.5.0
  182. - remove Patch11 (clang-hardfloat-hack.patch)
  183. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  184. - rebuild with libffi-3.0.13
  185. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  186. - update to 3.3
  187. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  188. - ld.gold (patch1000,1001)
  189. - add /%{_lib} to ld search path
  190. - add support *-vine-linux gcc (patch1002)
  191. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  192. - update to 3.1
  193. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  194. - updated to 3.0 release
  195. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  196. - added patch 2-4 to support -O4 link-time optimization
  197. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  198. - disable -fno-var-tracking-assignments on ppc
  199. (seems like gcc-4.4.5 still doesn't support this)
  200. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  201. - new upstream release
  202. - add BR: libffi-devel
  203. - add R: libffi-devel to -devel
  204. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  205. - initial build for Vine Linux
  206. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  207. - Update to final 2.7 release
  208. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  209. - Update to first 2.7 pre-release
  210. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  211. - Update to 2.6 pre-release2
  212. - -devel subpackage now virtually provides -static
  213. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  214. - Disable var tracking assignments on PPC
  215. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  216. - Don't adjust clang include dir; files there are noarch (bz#521893)
  217. - Enable clang unit tests
  218. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  219. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  220. - Package Clang's static analyzer tools
  221. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  222. - PIC is now enabled by default; explicitly disable on %%{ix86}
  223. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  224. - First 2.6 prerelease
  225. - Enable Clang front-end
  226. - Enable debuginfo generation
  227. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  228. - Disable assertions (needed by OpenGTL, bz#521261)
  229. - Align spec file with upstream build instructions
  230. - Enable unit tests
  231. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  232. - Only disable PIC on %%ix86; ppc actually needs it
  233. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  234. - Disable use of position-independent code on 32-bit platforms
  235. (buggy in LLVM <= 2.5)
  236. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  237. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  238. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  239. - Remove build scripts; they require the build directory to work
  240. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  241. - Update to 2.5
  242. - Package build scripts (bug #457881)
  243. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  244. - Patched build process for the OCaml binding
  245. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  246. - Update to 2.4
  247. - Package Ocaml binding
  248. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  249. - Add dependency on groff
  250. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  251. - LLVM 2.3
  252. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  253. - fix license tags
  254. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  255. - Fix compilation problems with gcc 4.3
  256. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  257. - Autorebuild for GCC 4.3
  258. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  259. - Fix review comments
  260. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  261. - Initial version