lldb-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. Summary: Next generation high-performance debugger
  5. Summary(ja): 高性能デバッガー
  6. Name: lldb
  7. Version: 17.0.2
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: NCSA
  13. URL: https://llvm.org/
  14. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
  15. # patches
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: binutils-devel
  18. BuildRequires: cmake
  19. BuildRequires: ninja
  20. BuildRequires: llvm-devel = %{version}
  21. BuildRequires: llvm-static = %{version}
  22. BuildRequires: clang-devel = %{version}
  23. BuildRequires: clang-tools-extra = %{version}
  24. BuildRequires: ncurses-devel
  25. BuildRequires: swig
  26. BuildRequires: libffi-devel >= 3.3
  27. BuildRequires: zlib-devel
  28. BuildRequires: libxml2-devel
  29. BuildRequires: libedit-devel
  30. BuildRequires: python3-devel
  31. Requires: python3-lldb = %{version}-%{release}
  32. %description
  33. LLDB is a next generation, high-performance debugger. It is built as a set
  34. of reusable components which highly leverage existing libraries in the
  35. larger LLVM Project, such as the Clang expression parser and LLVM
  36. disassembler.
  37. %package devel
  38. Summary: Header files for LLDB
  39. Summary(ja): LLDB のヘッダファイル
  40. Group: programming
  41. Requires: lldb = %{version}-%{release}
  42. %description devel
  43. This package contains header files for the LLDB debugger.
  44. %package -n python3-lldb
  45. Summary: Python3 module for LLDB
  46. Summary(ja): LLDB用Python3モジュール
  47. Group: programming
  48. BuildRequires: python3-devel
  49. Requires: python3-six
  50. Requires: lldb = %{version}-%{release}
  51. %description -n python3-lldb
  52. The package contains the LLDB Python3 module.
  53. %debug_package
  54. %prep
  55. %autosetup -p2 -n lldb-%{version}.src
  56. %build
  57. CFLAGS="%{optflags} -Wno-error=format-security"
  58. CXXFLAGS="%{optflags} -Wno-error=format-security"
  59. %cmake \
  60. -GNinja \
  61. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  62. -DCMAKE_SKIP_RPATH:BOOL=ON \
  63. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  64. -DLLVM_CONFIG:FILEPATH=/usr/bin/llvm-config-%{__isa_bits} \
  65. -DLLVM_COMMON_CMAKE_UTILS=%{_datadir}/llvm/cmake \
  66. \
  67. -DLLDB_DISABLE_CURSES:BOOL=OFF \
  68. -DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
  69. -DLLDB_DISABLE_PYTHON:BOOL=OFF \
  70. %if 0%{?__isa_bits} == 64
  71. -DLLVM_LIBDIR_SUFFIX=64 \
  72. %else
  73. -DLLVM_LIBDIR_SUFFIX= \
  74. %endif
  75. \
  76. -DPYTHON_EXECUTABLE:STRING=%{__python3} \
  77. -DPYTHON_VERSION_MAJOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.major)") \
  78. -DPYTHON_VERSION_MINOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.minor)") \
  79. -DCLANG_LINK_CLANG_DYLIB=ON \
  80. -DLLVM_LIT_ARGS="-sv \
  81. --path %{_libdir}/llvm" \
  82. %{nil}
  83. %cmake_build
  84. %install
  85. rm -rf %{buildroot}
  86. %cmake_install
  87. # remove static libraries
  88. rm -fv %{buildroot}%{_libdir}/liblldb*.a
  89. # python: fix binary libraries location
  90. liblldb=$(basename $(readlink -e %{buildroot}%{_libdir}/liblldb.so))
  91. ln -vsf "../../../${liblldb}" %{buildroot}%{python3_sitearch}/lldb/_lldb.so
  92. # remove bundled six.py
  93. rm -f %{buildroot}%{python3_sitearch}/six.*
  94. %if %{with test}
  95. %check
  96. %endif
  97. %clean
  98. rm -rf %{buildroot}
  99. %files
  100. %defattr(-,root,root,-)
  101. #doc %{llvmdocdir lldb}/
  102. %{_bindir}/lldb*
  103. %{_libdir}/liblldb*.so.*
  104. %{_libdir}/liblldbIntelFeatures.so.*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_includedir}/lldb
  108. %{_libdir}/*.so
  109. %files -n python3-lldb
  110. %{python3_sitearch}/lldb
  111. %changelog
  112. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  113. - new upstream release.
  114. * Sun Oct 01 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  115. - new upstream release.
  116. * Mon May 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  117. - new upstream release.
  118. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  119. - new upstream release.
  120. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  121. - new upstream release.
  122. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  123. - new upstream release.
  124. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  125. - new upstream release.
  126. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  127. - new upstream release.
  128. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  129. - new upstream release.
  130. - dropped all patches.
  131. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  132. - new upstream release.
  133. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  134. - devided lldb from llvm.
  135. - new upstream release.
  136. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  137. - enabled to build utils.
  138. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  139. - new upstream release.
  140. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  141. - new upstream release.
  142. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  143. - rebuilt with libffi-3.3.
  144. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  145. - new upstream release.
  146. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  147. - new upstream release.
  148. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  149. - dropped all patches.
  150. - switched build-system to ninja.
  151. - switched python to python3.
  152. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  153. - new upstream release.
  154. - added OpenMP.
  155. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  156. - fixed %%files.
  157. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  158. - new upstream release.
  159. - dropped Patch0, 4, 5, 100 and 200.
  160. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  161. - renamed a subpackage "llvm-libs".
  162. - added a subpackage "lld".
  163. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  164. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  165. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  166. - new upstream release.
  167. - dropped Patch1 and 2: fixed in upstream.
  168. - imported Patch0, 3-5, 100 and 200 from rawhide.
  169. - disabled Patch1002: no longer needed?
  170. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  171. - new upstream release.
  172. - switched to cmake.
  173. - disable ocaml binding as default.
  174. - updated Patch1000 and 1002.
  175. - disabled Patch1000 as default.
  176. - cleanup patches.
  177. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  178. - rebuild with gcc-5.4.0
  179. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  180. - new upstream release
  181. - added BR: ocaml-ctypes
  182. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  183. - new upstream release
  184. - dropt Patch 1, 201 and 1001
  185. - updated Patch 1000
  186. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  187. - updated to 3.5.1
  188. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  189. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  190. - obsoleted clang-doc
  191. - built with ocaml 4.02.1
  192. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  193. - fix <BTS:2832>
  194. - fix configure option "--with-c-include-dirs"
  195. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  196. - update Patch1001: clang-3.5.0-driver-lib64.patch
  197. - update Patch1002: clang-3.5.0-driver-vine.patch
  198. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  199. - update to 3.5.0
  200. - remove Patch11 (clang-hardfloat-hack.patch)
  201. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  202. - rebuild with libffi-3.0.13
  203. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  204. - update to 3.3
  205. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  206. - ld.gold (patch1000,1001)
  207. - add /%{_lib} to ld search path
  208. - add support *-vine-linux gcc (patch1002)
  209. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  210. - update to 3.1
  211. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  212. - updated to 3.0 release
  213. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  214. - added patch 2-4 to support -O4 link-time optimization
  215. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  216. - disable -fno-var-tracking-assignments on ppc
  217. (seems like gcc-4.4.5 still doesn't support this)
  218. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  219. - new upstream release
  220. - add BR: libffi-devel
  221. - add R: libffi-devel to -devel
  222. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  223. - initial build for Vine Linux
  224. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  225. - Update to final 2.7 release
  226. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  227. - Update to first 2.7 pre-release
  228. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  229. - Update to 2.6 pre-release2
  230. - -devel subpackage now virtually provides -static
  231. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  232. - Disable var tracking assignments on PPC
  233. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  234. - Don't adjust clang include dir; files there are noarch (bz#521893)
  235. - Enable clang unit tests
  236. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  237. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  238. - Package Clang's static analyzer tools
  239. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  240. - PIC is now enabled by default; explicitly disable on %%{ix86}
  241. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  242. - First 2.6 prerelease
  243. - Enable Clang front-end
  244. - Enable debuginfo generation
  245. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  246. - Disable assertions (needed by OpenGTL, bz#521261)
  247. - Align spec file with upstream build instructions
  248. - Enable unit tests
  249. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  250. - Only disable PIC on %%ix86; ppc actually needs it
  251. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  252. - Disable use of position-independent code on 32-bit platforms
  253. (buggy in LLVM <= 2.5)
  254. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  255. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  256. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  257. - Remove build scripts; they require the build directory to work
  258. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  259. - Update to 2.5
  260. - Package build scripts (bug #457881)
  261. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  262. - Patched build process for the OCaml binding
  263. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  264. - Update to 2.4
  265. - Package Ocaml binding
  266. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  267. - Add dependency on groff
  268. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  269. - LLVM 2.3
  270. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  271. - fix license tags
  272. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  273. - Fix compilation problems with gcc 4.3
  274. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  275. - Autorebuild for GCC 4.3
  276. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  277. - Fix review comments
  278. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  279. - Initial version