clang-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. %define _unpackaged_files_terminate_build 1
  8. Summary: A C language family front-end for LLVM
  9. Summary(ja): LLVM の C 言語フロントエンド
  10. Name: clang
  11. Version: 17.0.2
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: NCSA
  17. URL: https://llvm.org/
  18. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
  19. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
  20. # multilib fixes
  21. Source11: clang-config.h
  22. # Patches for clang
  23. Patch1: 0001-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
  24. Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
  25. Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
  26. # Drop the following patch after debugedit adds support to DWARF-5:
  27. # https://sourceware.org/bugzilla/show_bug.cgi?id=28728
  28. Patch4: 0001-Produce-DWARF4-by-default.patch
  29. # Workaround a bug in ORC on ppc64le.
  30. # More info is available here: https://reviews.llvm.org/D159115#4641826
  31. Patch5: 0001-Workaround-a-bug-in-ORC-on-ppc64le.patch
  32. # RHEL specific patches
  33. # Avoid unwanted dependency on python-recommonmark
  34. Patch101: 0009-disable-recommonmark.patch
  35. %if %{without compat_build}
  36. # Patches for clang-tools-extra
  37. # See https://reviews.llvm.org/D120301
  38. Patch201: 0001-clang-tools-extra-Make-test-dependency-on-LLVMHello-.patch
  39. %endif
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  41. BuildRequires: cmake
  42. BuildRequires: ninja
  43. BuildRequires: llvm-devel = %{version}
  44. BuildRequires: llvm-static = %{version}
  45. BuildRequires: libatomic
  46. BuildRequires: libxml2-devel
  47. BuildRequires: perl
  48. BuildRequires: ncurses-devel
  49. BuildRequires: python3
  50. BuildRequires: python3-devel
  51. Requires: llvm = %{version}-%{release}
  52. # clang requires gcc, clang++ requires libstdc++-devel
  53. Requires: libstdc++-devel
  54. # LLVM is not supported on PPC64
  55. # http://llvm.org/bugs/show_bug.cgi?id=3729
  56. ExcludeArch: ppc64
  57. %description
  58. clang: noun
  59. 1. A loud, resonant, metallic sound.
  60. 2. The strident call of a crane or goose.
  61. 3. C-language family front-end toolkit.
  62. The goal of the Clang project is to create a new C, C++, Objective C
  63. and Objective C++ front-end for the LLVM compiler. Its tools are built
  64. as libraries and designed to be loosely-coupled and extensible.
  65. %Package libs
  66. Summary: Runtime library for clang
  67. Summary(ja): Clang のランタイムライブラリ
  68. Group: system
  69. %description libs
  70. Runtime library for clang.
  71. %description libs -l ja
  72. Clang のランタイムライブラリです.
  73. %package devel
  74. Summary: Header files for clang
  75. Summary(ja): Clang のヘッダファイル
  76. Group: programming
  77. Requires: clang = %{version}-%{release}
  78. %description devel
  79. This package contains header files for the Clang compiler.
  80. %description devel -l ja
  81. Clang コンパイラのヘッダファイル集です.
  82. %package analyzer
  83. Summary: A source code analysis framework
  84. Summary(ja): ソースコード分析フレームワーク
  85. License: NCSA
  86. Group: programming
  87. Requires: clang = %{version}-%{release}
  88. # not picked up automatically since files are currently not instaled
  89. # in standard Python hierarchies yet
  90. Requires: python3
  91. %description analyzer
  92. The Clang Static Analyzer consists of both a source code analysis
  93. framework and a standalone tool that finds bugs in C and Objective-C
  94. programs. The standalone tool is invoked from the command-line, and is
  95. intended to run in tandem with a build of a project or code base.
  96. %package -n python3-clang
  97. Summary: Python3 bindings for clang
  98. Group: programming
  99. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  100. Requires: python3
  101. %description -n python3-clang
  102. Python3 bindings for clang
  103. %package tools-extra
  104. Summary: Extra tools for clang
  105. Group: programming
  106. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  107. %description tools-extra
  108. A set of extra tools built using Clang's tooling API.
  109. %debug_package
  110. %prep
  111. %setup -T -q -b 1 -n clang-tools-extra-%{version}.src
  112. %autopatch -m200 -p2
  113. # failing test case
  114. rm test/clang-tidy/checkers/altera/struct-pack-align.cpp
  115. pathfix%{python3_version}.py -i %{__python3} -pn \
  116. clang-tidy/tool/ \
  117. clang-include-fixer/find-all-symbols/tool/run-find-all-symbols.py
  118. %setup -q -n clang-%{version}.src
  119. %autopatch -M200 -p2
  120. # failing test case
  121. rm test/CodeGen/profile-filter.c
  122. pathfix%{python3_version}.py -i %{__python3} -pn \
  123. tools/clang-format/ \
  124. tools/clang-format/git-clang-format \
  125. utils/hmaptool/hmaptool \
  126. tools/scan-view/bin/scan-view \
  127. tools/scan-view/share/Reporter.py \
  128. tools/scan-view/share/startfile.py \
  129. tools/scan-build-py/bin/* \
  130. tools/scan-build-py/libexec/*
  131. sed -i -e 's/"i686-linux-gnu",/"i686-linux-gnu","i686-vine-linux","i686-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  132. sed -i -e 's/"x86_64-linux-gnu",/"x86_64-linux-gnu","x86_64-vine-linux","x86_64-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  133. #sed -i -e 's/"ld"/"ld.gold"/' include/clang/Driver/ToolChain.h
  134. %build
  135. # lto builds with gcc 11 fail while running the lit tests.
  136. %define _lto_cflags %{nil}
  137. %ifarch s390 s390x %{arm} %ix86
  138. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  139. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  140. %endif
  141. %cmake \
  142. -GNinja \
  143. -DCLANG_DEFAULT_PIE_ON_LINUX=OFF \
  144. -DLLVM_PARALLEL_LINK_JOBS=1 \
  145. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  146. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  147. -DPYTHON_EXECUTABLE=%{__python3} \
  148. -DCMAKE_SKIP_RPATH:BOOL=ON \
  149. %ifarch %ix86
  150. -DCMAKE_C_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  151. -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  152. %endif
  153. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  154. -DCLANG_INCLUDE_TESTS:BOOL=OFF \
  155. -DLLVM_BUILD_UTILS:BOOL=ON \
  156. -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../clang-tools-extra-%{version}.src \
  157. -DLLVM_CMAKE_DIR=%{_libdir}/cmake/llvm \
  158. -DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
  159. %if 0%{?__isa_bits} == 64
  160. -DLLVM_LIBDIR_SUFFIX=64 \
  161. %else
  162. -DLLVM_LIBDIR_SUFFIX= \
  163. %endif
  164. \
  165. -DLLVM_TABLEGEN_EXE:FILEPATH=%{_bindir}/llvm-tblgen \
  166. -DLLVM_COMMON_CMAKE_UTILS=%{_datadir}/llvm/cmake \
  167. -DLLVM_CMAKE_DIR=%{_libdir}/cmake/llvm \
  168. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  169. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  170. -DCLANG_PLUGIN_SUPPORT:BOOL=OFF \
  171. -DLLVM_ENABLE_PLUGINS:BOOL=OFF \
  172. -DENABLE_LINKER_BUILD_ID:BOOL=ON \
  173. -DLLVM_ENABLE_EH=ON \
  174. -DLLVM_ENABLE_RTTI=ON \
  175. -DLLVM_BUILD_DOCS=ON \
  176. -DLLVM_ENABLE_SPHINX=OFF \
  177. -DLLVM_INCLUDE_TESTS:BOOL=OFF \
  178. -DCLANG_LINK_CLANG_DYLIB=ON \
  179. \
  180. -DCLANG_LINK_CLANG_DYLIB=ON \
  181. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  182. -DBUILD_SHARED_LIBS=OFF \
  183. -DCLANG_REPOSITORY_STRING="Vine Linux %{version}-%{release}" \
  184. -DCLANG_DEFAULT_UNWINDLIB=libgcc
  185. %cmake_build
  186. %install
  187. rm -rf %{buildroot}
  188. %cmake_install
  189. # remove static libraries
  190. rm -fv %{buildroot}%{_libdir}/libclang*.a
  191. # Add clang++-{version} symlink
  192. ln -s clang++ %{buildroot}%{_bindir}/clang++-%{ver_suffix}
  193. # install clang python bindings
  194. mkdir -p %{buildroot}%{python3_sitelib}/clang/
  195. install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
  196. # install scanbuild-py to python sitelib.
  197. mv %{buildroot}%{_libdir}/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
  198. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  199. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  200. # TODO: Package html docs
  201. rm -Rvf %{buildroot}%{_docdir}/clang/html
  202. rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
  203. rm -Rvf %{buildroot}%{_datadir}/clang/index.js
  204. # remove git integration
  205. rm -vf %{buildroot}%{_bindir}/git-clang-format
  206. # remove editor integrations (bbedit, sublime, emacs, vim)
  207. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  208. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  209. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  210. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  211. # remove diff reformatter
  212. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  213. rm -f %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
  214. rm -f %{buildroot}%{_datadir}/clang/clang-rename.el
  215. rm -f %{buildroot}%{_datadir}/clang/clang-rename.py
  216. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.el
  217. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.py
  218. # Remove clang-tidy headers. We don't ship the libraries for these.
  219. rm -Rvf %{buildroot}%{_includedir}/clang-tidy/
  220. %if %{with test}
  221. %check
  222. %ctest check-clang
  223. %endif
  224. %clean
  225. rm -rf %{buildroot}
  226. %files
  227. %defattr(-,root,root,-)
  228. #doc %{llvmdocdir clang}/
  229. %{_bindir}/clang
  230. %{_bindir}/clang++
  231. %{_bindir}/clang-%{ver_suffix}
  232. %{_bindir}/clang++-%{ver_suffix}
  233. %{_bindir}/clang-cl
  234. %{_bindir}/clang-cpp
  235. %files libs
  236. %defattr(-,root,root,-)
  237. %{_libdir}/clang
  238. %{_libdir}/libclang.so.*
  239. %{_libdir}/libclang-cpp.so.*
  240. %files devel
  241. %defattr(-,root,root,-)
  242. #doc %{llvmdocdir clang-devel}/
  243. %{_libdir}/libclang.so
  244. %{_libdir}/libclang-cpp.so
  245. %{_includedir}/clang
  246. %{_includedir}/clang-c
  247. %dir %{_datadir}/clang/
  248. %{_libdir}/cmake/*
  249. %files analyzer
  250. %defattr(-,root,root,-)
  251. %{_bindir}/analyze-build
  252. %{_bindir}/intercept-build
  253. %{_bindir}/scan-build
  254. %{_bindir}/scan-build-py
  255. %{_bindir}/scan-view
  256. %{_libexecdir}/ccc-analyzer
  257. %{_libexecdir}/c++-analyzer
  258. %{_libexecdir}/analyze-c++
  259. %{_libexecdir}/analyze-cc
  260. %{_libexecdir}/intercept-c++
  261. %{_libexecdir}/intercept-cc
  262. %{_datadir}/scan-view
  263. %{_datadir}/scan-build
  264. %{_mandir}/man1/scan-build.1.*
  265. %{python3_sitelib}/libear
  266. %{python3_sitelib}/libscanbuild
  267. %files -n python3-clang
  268. %{python3_sitelib}/clang/
  269. %files tools-extra
  270. %{_bindir}/amdgpu-arch
  271. %{_bindir}/c-index-test
  272. %{_bindir}/clang*
  273. %exclude %{_bindir}/clang
  274. %exclude %{_bindir}/clang++
  275. %exclude %{_bindir}/clang-%{ver_suffix}
  276. %exclude %{_bindir}/clang++-%{ver_suffix}
  277. %exclude %{_bindir}/clang-cl
  278. %exclude %{_bindir}/clang-cpp
  279. %{_bindir}/diagtool
  280. %{_bindir}/find-all-symbols
  281. %{_bindir}/hmaptool
  282. %{_bindir}/modularize
  283. %{_bindir}/nvptx-arch
  284. %{_bindir}/pp-trace
  285. %{_bindir}/run-clang-tidy
  286. %{_datadir}/clang/clang-tidy-diff.py*
  287. %{_datadir}/clang/run-find-all-symbols.py*
  288. %changelog
  289. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  290. - new upstream release.
  291. * Sat Sep 30 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  292. - new upstream release.
  293. * Sun May 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  294. - new upstream release.
  295. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  296. - new upstream release.
  297. * Wed Oct 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  298. - new upstream release.
  299. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  300. - new upstream release.
  301. * Wed Jun 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  302. - new upstream release.
  303. - dropped patch5.
  304. - updated Patch1.
  305. - imported Patch5-202 from rawhide.
  306. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  307. - new upstream release.
  308. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  309. - new upstream release.
  310. - refreshed patches.
  311. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  312. - new upstream release.
  313. - refreshed patches.
  314. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  315. - devided clang from llvm.
  316. - new upstream release.
  317. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  318. - enabled to build utils.
  319. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  320. - new upstream release.
  321. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  322. - new upstream release.
  323. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  324. - rebuilt with libffi-3.3.
  325. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  326. - new upstream release.
  327. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  328. - new upstream release.
  329. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  330. - dropped all patches.
  331. - switched build-system to ninja.
  332. - switched python to python3.
  333. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  334. - new upstream release.
  335. - added OpenMP.
  336. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  337. - fixed %%files.
  338. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  339. - new upstream release.
  340. - dropped Patch0, 4, 5, 100 and 200.
  341. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  342. - renamed a subpackage "llvm-libs".
  343. - added a subpackage "lld".
  344. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  345. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  346. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  347. - new upstream release.
  348. - dropped Patch1 and 2: fixed in upstream.
  349. - imported Patch0, 3-5, 100 and 200 from rawhide.
  350. - disabled Patch1002: no longer needed?
  351. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  352. - new upstream release.
  353. - switched to cmake.
  354. - disable ocaml binding as default.
  355. - updated Patch1000 and 1002.
  356. - disabled Patch1000 as default.
  357. - cleanup patches.
  358. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  359. - rebuild with gcc-5.4.0
  360. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  361. - new upstream release
  362. - added BR: ocaml-ctypes
  363. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  364. - new upstream release
  365. - dropt Patch 1, 201 and 1001
  366. - updated Patch 1000
  367. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  368. - updated to 3.5.1
  369. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  370. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  371. - obsoleted clang-doc
  372. - built with ocaml 4.02.1
  373. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  374. - fix <BTS:2832>
  375. - fix configure option "--with-c-include-dirs"
  376. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  377. - update Patch1001: clang-3.5.0-driver-lib64.patch
  378. - update Patch1002: clang-3.5.0-driver-vine.patch
  379. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  380. - update to 3.5.0
  381. - remove Patch11 (clang-hardfloat-hack.patch)
  382. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  383. - rebuild with libffi-3.0.13
  384. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  385. - update to 3.3
  386. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  387. - ld.gold (patch1000,1001)
  388. - add /%{_lib} to ld search path
  389. - add support *-vine-linux gcc (patch1002)
  390. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  391. - update to 3.1
  392. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  393. - updated to 3.0 release
  394. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  395. - added patch 2-4 to support -O4 link-time optimization
  396. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  397. - disable -fno-var-tracking-assignments on ppc
  398. (seems like gcc-4.4.5 still doesn't support this)
  399. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  400. - new upstream release
  401. - add BR: libffi-devel
  402. - add R: libffi-devel to -devel
  403. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  404. - initial build for Vine Linux
  405. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  406. - Update to final 2.7 release
  407. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  408. - Update to first 2.7 pre-release
  409. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  410. - Update to 2.6 pre-release2
  411. - -devel subpackage now virtually provides -static
  412. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  413. - Disable var tracking assignments on PPC
  414. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  415. - Don't adjust clang include dir; files there are noarch (bz#521893)
  416. - Enable clang unit tests
  417. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  418. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  419. - Package Clang's static analyzer tools
  420. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  421. - PIC is now enabled by default; explicitly disable on %%{ix86}
  422. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  423. - First 2.6 prerelease
  424. - Enable Clang front-end
  425. - Enable debuginfo generation
  426. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  427. - Disable assertions (needed by OpenGTL, bz#521261)
  428. - Align spec file with upstream build instructions
  429. - Enable unit tests
  430. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  431. - Only disable PIC on %%ix86; ppc actually needs it
  432. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  433. - Disable use of position-independent code on 32-bit platforms
  434. (buggy in LLVM <= 2.5)
  435. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  436. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  437. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  438. - Remove build scripts; they require the build directory to work
  439. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  440. - Update to 2.5
  441. - Package build scripts (bug #457881)
  442. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  443. - Patched build process for the OCaml binding
  444. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  445. - Update to 2.4
  446. - Package Ocaml binding
  447. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  448. - Add dependency on groff
  449. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  450. - LLVM 2.3
  451. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  452. - fix license tags
  453. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  454. - Fix compilation problems with gcc 4.3
  455. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  456. - Autorebuild for GCC 4.3
  457. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  458. - Fix review comments
  459. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  460. - Initial version