vino-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. %define gtk3_version 3.14.0
  2. %define libgcrypt_version 1.4.6
  3. %define avahi_version 0.6.31
  4. Summary: A remote desktop system for GNOME
  5. Summary(ja): GNOME 用リモートデスクトップシステム
  6. Name: vino
  7. Version: 3.14.2
  8. Release: 1%{?_dist_release}
  9. URL: http://www.gnome.org
  10. License: GPL
  11. Group: User Interface/Desktops
  12. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gtk3 >= %{gtk3_version}
  15. Requires: libgcrypt >= %{libgcrypt_version}
  16. Requires: avahi >= %{avahi_version}
  17. Requires: avahi-glib >= %{avahi_version}
  18. Requires: NetworkManager >= 0.8
  19. BuildRequires: gtk3-devel >= %{gtk3_version}
  20. BuildRequires: dbus-devel >= 1.4.0
  21. BuildRequires: libsoup-devel >= 2.32.0
  22. BuildRequires: libnotify-devel >= 0.4.5
  23. BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
  24. BuildRequires: avahi-devel >= %{avahi_version}
  25. BuildRequires: avahi-glib-devel >= %{avahi_version}
  26. BuildRequires: libgnome-keyring-devel >= 2.32
  27. BuildRequires: NetworkManager-glib-devel >= 0.8
  28. BuildRequires: unique3-devel >= 3.0.0
  29. BuildRequires: libSM-devel
  30. BuildRequires: libXtst-devel
  31. BuildRequires: libjpeg-turbo-devel
  32. BuildRequires: desktop-file-utils
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. Vino is a VNC server for GNOME. It allows remote users to
  37. connect to a running GNOME session using VNC.
  38. %description -l ja
  39. Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
  40. VNC を利用して稼働中のGNOME セッション接続することができるよう
  41. になります。
  42. %prep
  43. %setup -q
  44. %build
  45. %configure \
  46. --disable-schemas-install \
  47. --enable-avahi \
  48. --disable-gnutls \
  49. --disable-session-support \
  50. --disable-telepathy \
  51. --enable-libnotify \
  52. --enable-network-manager \
  53. --enable-gnome-keyring \
  54. --disable-http-server \
  55. --enable-libunique=yes
  56. %__make %{?_smp_mflags}
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. # stuff we don't want
  61. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  62. %find_lang %{name}
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %post
  66. touch --no-create %{_datadir}/icons/hicolor
  67. %postun
  68. touch --no-create %{_datadir}/icons/hicolor
  69. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  70. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  71. fi
  72. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  73. %posttrans
  74. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  75. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  76. %files -f %{name}.lang
  77. %defattr(-,root,root)
  78. %doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
  79. %{_libexecdir}/*
  80. %{_datadir}/GConf/gsettings/org.gnome.Vino.convert
  81. %{_datadir}/applications/vino-server.desktop
  82. %{_datadir}/dbus-1/services/*
  83. %{_datadir}/glib-2.0/schemas/*.xml
  84. %changelog
  85. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  86. - new upstream release
  87. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  88. - new upstream release
  89. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  90. - new upstream release
  91. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  92. - new upstream release
  93. * Thu Feb 20 2014 NAKAMURA Kenta <kenta@vinelinux.org> 3.10.1-3
  94. - rebuilt with gnutls-3.2 and libgcrypt-1.6
  95. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  96. - rebuild with VineSeed environment
  97. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  98. - new upstream release
  99. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  100. - new upstream release
  101. - add BuildRequires: libjpeg-turbo-devel
  102. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  103. - new upstream release
  104. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  105. - new upstream release
  106. - remove BuildRequires: GConf2-devel
  107. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  108. - new upstream release
  109. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  110. - new upstream release
  111. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  112. - new upstream release
  113. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  114. - new upstream release
  115. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  116. - new upstream release
  117. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  118. - new upstream release
  119. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  120. - new upstream release
  121. - add BuildRequires: libXtst-devel
  122. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  123. - new upstream release
  124. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  125. - new upstream release
  126. - change BuildRequires: unique3-devel instead of unique-devel
  127. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  128. - new upstream release
  129. - change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
  130. * Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  131. - new upstream release
  132. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  133. - new upstream release
  134. * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  135. - new upstream release
  136. - add BuildRequires: libSM-devel, desktop-file-utils
  137. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  138. * Sun Nov 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  139. - new upstream release
  140. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  141. - new upstream release
  142. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  143. - new upstream release
  144. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  145. - new upstream release
  146. * Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  147. - new upstream release
  148. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  149. - new upstream release
  150. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  151. - new upstream release
  152. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
  153. - applied new versioning policy, spec in utf-8
  154. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  155. - new upstream release
  156. * Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
  157. - run gtk-update-icon-cache in %%post script.
  158. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
  159. - enable avahi, add BuildRequires: avahi-devel
  160. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
  161. - new upstream release
  162. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  163. - new upstream release
  164. * Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  165. - new upstream version
  166. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  167. - initial build for Vine Linux
  168. - add japanese summary and description.
  169. * Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
  170. - Update to 2.8.1
  171. - Remove backported fixes
  172. * Thu Oct 7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
  173. - Don't hang with metacity's "reduced resources" mode (#134240)
  174. - Improve the key repeat rate situation a good deal (#134451)
  175. * Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
  176. - Update to 2.8.0.1
  177. * Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
  178. - Update to 2.8.0
  179. - Remove upstreamed work-without-gnutls patch
  180. * Tue Sep 7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
  181. - Disable help button until there is help (#131632)
  182. * Wed Sep 1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
  183. - Add patch to fix hang without GNU TLS (bug #131354)
  184. * Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
  185. - Update to 2.7.92
  186. * Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
  187. - Update to 2.7.91
  188. * Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
  189. - Define libgcrypt_version
  190. * Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
  191. - Update to 2.7.90
  192. * Wed Aug 4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
  193. - Update to 2.7.4
  194. * Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
  195. - Initial build.