nginx-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.9.11
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3.5
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 5.0.24
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. # to fix https://svn.boost.org/trac/boost/ticket/8731
  60. Patch100: boost-changeset_84950.diff
  61. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  62. BuildRequires: pcre-devel
  63. BuildRequires: zlib-devel
  64. BuildRequires: openssl-devel
  65. BuildRequires: gd-devel
  66. BuildRequires: perl
  67. BuildRequires: perl(ExtUtils::Embed)
  68. BuildRequires: libxml2-devel
  69. BuildRequires: libxslt-devel
  70. BuildRequires: curl-devel
  71. %if %{with geoip}
  72. BuildRequires: GeoIP-devel
  73. %endif
  74. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  75. # for /usr/sbin/useradd
  76. Requires(pre): shadow-utils
  77. Requires(post): chkconfig
  78. # for /sbin/service
  79. Requires(preun): chkconfig, initscripts
  80. Requires(postun): initscripts
  81. %if "%{_dist_release}" > "vl6"
  82. Requires(pre): www-common
  83. %endif
  84. Provides: webserver
  85. Vendor: Project Vine
  86. Distribution: Vine Linux
  87. Packager: daisuke
  88. %description
  89. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  90. proxy server written by Igor Sysoev.
  91. %description -l ja
  92. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  93. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  94. - HTTP(S) サーバ
  95. - HTTP(S) リバースプロキシサーバ
  96. - IMAP/POP3 プロキシサーバ
  97. %package passenger
  98. Summary: Nginx with mod_passenger support
  99. Summary(ja): Passenger サポート入りの Nginx
  100. Group: System Environment/Daemons
  101. BuildRequires: ruby, rubygem-rake
  102. Requires: ruby, rubygem-rake
  103. %if "%{_dist_release}" >= "vl7"
  104. BuildRequires: ruby-devel, ruby-rubygems
  105. Requires: ruby-rubygems
  106. %else
  107. BuildRequires: rubygems
  108. Requires: rubygems
  109. %endif
  110. Requires: nginx
  111. %description passenger
  112. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  113. This package contains nginx server with passenger support.
  114. %description -l ja passenger
  115. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  116. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  117. - HTTP(S) サーバ
  118. - HTTP(S) リバースプロキシサーバ
  119. - IMAP/POP3 プロキシサーバ
  120. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  121. %prep
  122. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  123. %patch0 -p0
  124. # pushd passenger-%{passenger_version}/ext/
  125. # %patch100 -p2
  126. # popd
  127. %build
  128. # nginx does not utilize a standard configure script. It has its own
  129. # and the standard configure options cause the nginx configure script
  130. # to error out. This is is also the reason for the DESTDIR environment
  131. # variable. The configure script(s) have been patched (Patch1 and
  132. # Patch2) in order to support installing into a build environment.
  133. export DESTDIR=%{buildroot}
  134. CONFIGOPTS="\
  135. --user=%{nginx_user} \
  136. --group=%{nginx_group} \
  137. --prefix=%{nginx_datadir} \
  138. --sbin-path=%{_sbindir}/%{name} \
  139. --conf-path=%{nginx_confdir}/%{name}.conf \
  140. --error-log-path=%{nginx_logdir}/error.log \
  141. --http-log-path=%{nginx_logdir}/access.log \
  142. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  143. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  144. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  145. --pid-path=%{_localstatedir}/run/%{name}.pid \
  146. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  147. --with-file-aio \
  148. --with-ipv6 \
  149. --with-http_ssl_module \
  150. --with-http_v2_module \
  151. --with-http_realip_module \
  152. --with-http_addition_module \
  153. --with-http_xslt_module \
  154. --with-http_image_filter_module \
  155. %if %{with geoip}
  156. --with-http_geoip_module \
  157. %endif
  158. --with-http_sub_module \
  159. --with-http_dav_module \
  160. --with-http_flv_module \
  161. --with-http_mp4_module \
  162. --with-http_gunzip_module \
  163. --with-http_gzip_static_module \
  164. --with-http_auth_request_module \
  165. --with-http_random_index_module \
  166. --with-http_secure_link_module \
  167. --with-http_degradation_module \
  168. --with-http_stub_status_module \
  169. --with-http_perl_module \
  170. --with-mail \
  171. --with-mail_ssl_module \
  172. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  173. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  174. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  175. %if %{with wsgi}
  176. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  177. %endif
  178. %ifarch i686
  179. --with-cpu-opt=pentiumpro \
  180. --with-zlib-asm=pentiumpro \
  181. --with-md5-asm \
  182. --with-sha1-asm \
  183. %endif
  184. "
  185. ## build with passenger
  186. ./configure \
  187. $CONFIGOPTS \
  188. --with-cc-opt="%{optflags}" \
  189. --add-module=passenger-%{passenger_version}/src/nginx_module
  190. make %{?_smp_mflags}
  191. mv objs/nginx objs/nginx.passenger
  192. ## build without passenger
  193. ./configure \
  194. $CONFIGOPTS \
  195. --with-cc-opt="%{optflags}"
  196. make %{?_smp_mflags}
  197. %install
  198. rm -rf %{buildroot}
  199. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  200. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  201. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  202. find %{buildroot} -type f -empty -exec rm -f {} \;
  203. find %{buildroot} -type f -exec chmod 0644 {} \;
  204. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  205. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  206. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  207. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  208. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  209. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  210. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  211. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  212. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  213. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  214. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  215. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  216. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  217. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  218. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  219. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  220. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  221. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  222. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  223. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  224. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  225. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  226. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  227. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  228. %if %{with wsgi}
  229. %{__install} -p -m 0644 \
  230. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  231. %{buildroot}%{nginx_confdir}
  232. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  233. %endif
  234. # upstream fair module document
  235. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  236. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  237. # convert to UTF-8 all files that give warnings.
  238. for textfile in CHANGES
  239. do
  240. mv $textfile $textfile.old
  241. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  242. rm -f $textfile.old
  243. done
  244. %clean
  245. rm -rf %{buildroot}
  246. %post
  247. if [ $1 == 1 ]; then
  248. /sbin/chkconfig --add %{name}
  249. fi
  250. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  251. %post passenger
  252. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  253. %preun
  254. if [ $1 = 0 ]; then
  255. /sbin/service %{name} stop >/dev/null 2>&1
  256. /sbin/chkconfig --del %{name}
  257. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  258. fi
  259. %preun passenger
  260. if [ $1 = 0 ]; then
  261. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  262. fi
  263. %postun
  264. if [ $1 == 2 ]; then
  265. /sbin/service %{name} upgrade || :
  266. fi
  267. %files
  268. %defattr(-,root,root,-)
  269. %doc LICENSE CHANGES README
  270. %doc README.upstream_fair
  271. %doc %{?with_wsgi:README.mod_wsgi}
  272. %{nginx_datadir}/
  273. %{_sbindir}/%{name}.normal
  274. %{_mandir}/man3/%{name}.3pm.gz
  275. %{_initrddir}/%{name}
  276. %dir %{nginx_confdir}
  277. %dir %{nginx_confdir}/conf.d
  278. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  279. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  280. %config(noreplace) %{nginx_confdir}/sites.d/*
  281. %config(noreplace) %{nginx_confdir}/win-utf
  282. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  283. %config(noreplace) %{nginx_confdir}/mime.types.default
  284. %config(noreplace) %{nginx_confdir}/fastcgi_params
  285. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  286. %config(noreplace) %{nginx_confdir}/koi-win
  287. %config(noreplace) %{nginx_confdir}/koi-utf
  288. %config(noreplace) %{nginx_confdir}/%{name}.conf
  289. %config(noreplace) %{nginx_confdir}/mime.types
  290. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  291. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  292. %config(noreplace) %{nginx_confdir}/scgi_params
  293. %config(noreplace) %{nginx_confdir}/scgi_params.default
  294. %config(noreplace) %{nginx_confdir}/uwsgi_params
  295. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  296. %if %{with wsgi}
  297. %config(noreplace) %{nginx_confdir}/wsgi_vars
  298. %endif
  299. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  300. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  301. %dir %{perl_vendorarch}/auto/%{name}
  302. %{perl_vendorarch}/%{name}.pm
  303. %{perl_vendorarch}/auto/%{name}/%{name}.so
  304. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  305. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  306. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  307. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  308. %files passenger
  309. %defattr(-,root,root,-)
  310. %doc passenger-%{passenger_version}/doc/*.md
  311. %doc passenger-%{passenger_version}/doc/*.txt
  312. %doc passenger-%{passenger_version}/doc/*.html
  313. %doc passenger-%{passenger_version}/doc/templates
  314. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  315. %doc passenger-%{passenger_version}/doc/images
  316. %{_sbindir}/%{name}.passenger
  317. %changelog
  318. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  319. - new upstream release
  320. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  321. - update to 1.9.10
  322. - update passenger to 5.0.24
  323. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  324. - update passenger to 5.0.23
  325. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  326. - new upstream release
  327. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  328. - new upstream release
  329. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  330. - new upstream release
  331. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  332. - new upstream release
  333. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  334. - update to 1.9.3
  335. - update passenger to 5.0.11
  336. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  337. - updated Source4 (ssl.conf).
  338. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  339. - update to 1.9.2
  340. - update passenger to 5.0.10
  341. - update ngx-fancyindex to 0.3.5
  342. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  343. - update to 1.6.2
  344. - update passenger to 4.0.52
  345. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  346. - new upstream release
  347. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  348. - rebuild with new environment
  349. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  350. - update passenger to 4.0.45
  351. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  352. - update to 1.6.0 (stable)
  353. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  354. - update fancyindex to 0.3.3
  355. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  356. - update to 1.5.10
  357. - update passenger to 4.0.37
  358. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  359. - rebuilt with GeoIP-1.6.0.
  360. - added Patch100.
  361. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  362. - update to 1.5.6
  363. - update passenger to 4.0.21
  364. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  365. - rebuilt with gd-2.1.0.
  366. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  367. - update to 1.4.1
  368. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  369. - update to 1.4.0
  370. - enable SPDY module
  371. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  372. - new upstream release
  373. - update passenger to 3.0.19
  374. - update ngx-fancyindex to upstream git master
  375. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  376. - new upstream release
  377. - update passenger to 3.0.17
  378. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  379. - rebuild with pcre-8.31
  380. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  381. - added http_geoip_module.
  382. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  383. - update to 1.2.4
  384. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  385. - update to 1.2.2
  386. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  387. - update to 1.2.1
  388. - change nginx user from nginx to www-data
  389. - R(pre): www-common
  390. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  391. - update to 1.2.0
  392. - update passenger to 3.0.12
  393. - drop http_upstream_keepalive
  394. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  395. - new upstream release
  396. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  397. - update to 1.0.12
  398. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  399. - update to 1.0.11
  400. - update passenger to 3.0.11
  401. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  402. - update to 1.0.10
  403. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  404. - update passenger to 3.0.9
  405. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  406. - update to 1.0.6
  407. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  408. - update to 1.0.4
  409. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  410. - add gnosek-nginx-upstream-fair module
  411. - add ngx_http_upstream_keepalive module
  412. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  413. - add nginx-passenger sub pakckage
  414. - use alternatives to choose nginx with or without passenger
  415. - add BR: ruby, rubygems, rubygem-rake
  416. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  417. - update to 1.0.2
  418. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  419. - update to 1.0.1
  420. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  421. - add bcond_with wsgi for mod_wsgi
  422. - add bcond_with passenger
  423. - you need to install rake.gem to build with this option.
  424. - add Provides: webserver
  425. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  426. - new upstream release 1.0.0!
  427. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  428. - rebuild with perl-5.12.3
  429. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  430. - update to 0.8.54
  431. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  432. - update to 0.8.53
  433. - add nginx_accept_language_module
  434. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  435. - update to 0.8.50
  436. - update ngx-fancyindex to 0.3
  437. - add BR: libxml2-devel, libxslt-devel
  438. - add scgi_params* and uwsgi_params* to %%files
  439. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  440. - update to 0.8.35 (development version)
  441. - add sites.d/ to store vitualhost settings
  442. - split out default server settings to sites.d/default
  443. - add fancyindex module
  444. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  445. - new upstream release
  446. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  447. - update to 0.7.62 (included security fix: VU#180065)
  448. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  449. - fix typo
  450. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  451. - add translated descriptions
  452. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  453. - update 404.html/50x.html to use powered by vine logo.
  454. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  455. - initial build for Vine Linux
  456. - update to 0.7.61
  457. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  458. - init script updates from Gena Makhomed
  459. - remove nginx-upstream-fair
  460. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  461. - update to 0.6.36
  462. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  463. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  464. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  465. - rebuild
  466. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  467. - update to 0.6.35
  468. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  469. - rebuild with new openssl
  470. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  471. - update to 0.6.34
  472. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  473. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  474. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  475. - update to 0.6.33
  476. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  477. - update to 0.6.32
  478. - nginx now supports DESTDIR so removed the patches that enabled it
  479. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  480. - init script fixes
  481. - resolve 'listen 80 default' [#447873]
  482. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  483. - update to 0.6.31
  484. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  485. - upate to new upstream stable branch 0.6
  486. - added 3rd party module nginx-upstream-fair
  487. - added default webpages
  488. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  489. - update init script to match recommended guidelines
  490. - add /etc/nginx/conf.d support [#443280]
  491. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  492. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  493. - add Requires for versioned perl (libperl.so)
  494. - drop silly file Requires
  495. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  496. - Autorebuild for GCC 4.3
  497. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  498. - update to 0.5.35
  499. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  500. - update to 0.5.34
  501. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  502. - Rebuild for deps
  503. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  504. - update to 0.5.33
  505. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  506. - updated to 0.5.32
  507. - fixed rpmlint UTF-8 complaints.
  508. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  509. - added --with-http_stub_status_module build option.
  510. - added --with-http_sub_module build option.
  511. - added use of pcre-config --cflags
  512. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  513. - Update to 0.5.31
  514. - specify license is BSD
  515. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  516. - Add BuildRequires: perl-devel - fixing rawhide build
  517. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  518. - Update to 0.5.30
  519. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  520. - Update to 0.5.29
  521. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  522. - Update to 0.5.28
  523. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  524. - Update to 0.5.27
  525. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  526. - Update to 0.5.26
  527. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  528. - Update to 0.5.19
  529. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  530. - Update to 0.5.17
  531. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  532. - Update to 0.5.16
  533. - add ownership of /usr/share/nginx/html (#233950)
  534. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  535. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  536. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  537. - fixed package review bugs (#233522) given by kevin@tummy.com
  538. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  539. - create patches to assist with building for Fedora
  540. - initial packaging for Fedora