gd-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390
  1. %bcond_with libvpx
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: A graphics library for drawing .png files.
  4. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  5. Name: gd
  6. Version: 2.3.3
  7. Release: 2%{_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: BSD-style
  13. URL: http://www.libgd.org/
  14. Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/libgd-%{version}.tar.xz
  15. # https://github.com/libgd/libgd/issues/610
  16. Source1: https://raw.githubusercontent.com/libgd/libgd/master/config/getlib.sh
  17. Patch0: gd-2.1.0-multilib.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: freetype2-devel
  20. BuildRequires: fontconfig-devel
  21. BuildRequires: gettext-devel
  22. BuildRequires: libjpeg-turbo-devel
  23. BuildRequires: libpng-devel
  24. BuildRequires: libtiff-devel
  25. %if %{with libvpx}
  26. BuildRequires: libvpx-devel
  27. %endif
  28. BuildRequires: libX11-devel
  29. BuildRequires: libXpm-devel
  30. BuildRequires: zlib-devel
  31. BuildRequires: pkgconfig
  32. # for test
  33. BuildRequires: TrueType-vlgothic
  34. %description
  35. Gd is a graphics library for drawing .png files. Gd allows your code to
  36. quickly draw images (lines, arcs, text, multiple colors, cutting and
  37. pasting from other images, flood fills) and write out the result as a
  38. .png file. Gd is particularly useful in web applications, where .pngs
  39. are commonly used as inline images. Note, however, that gd is not a
  40. paint program.
  41. Install gd if you are developing applications which need to draw .png
  42. files. If you install gd, you'll also need to install the gd-devel
  43. package.
  44. %description -l ja
  45. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  46. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  47. 簡単に描写して、PNGファイルへ結果を出力することができます。
  48. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  49. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  50. ん。
  51. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  52. Gdをインストールしてください。gdをインストールした場合、gd-devel
  53. パッケージも必要になります。
  54. %package progs
  55. Summary: Utility programs that use libgd.
  56. Summary(ja): libgd を用いたユーティリティプログラム
  57. Group: graphics
  58. Requires: gd = %{version}
  59. Requires: perl
  60. %description progs
  61. These are utility programs supplied with gd, the .png graphics library.
  62. If you install these, you must install gd.
  63. %description progs -l ja
  64. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  65. プログラムです。これをインストールするには, gdをインストールする必要
  66. があります。
  67. %package devel
  68. Summary: The development libraries and header files for gd.
  69. Summary(ja): Gd用の開発ライブラリとヘッダファイル
  70. Group: programming
  71. Requires: gd = %{version}
  72. Requires: freetype2-devel
  73. Requires: fontconfig-devel
  74. Requires: libjpeg-turbo-devel
  75. Requires: libpng-devel
  76. Requires: libtiff-devel
  77. %if %{with libvpx}
  78. Requires: libvpx-devel
  79. %endif
  80. Requires: libX11-devel
  81. Requires: libXpm-devel
  82. Requires: zlib-devel
  83. %description devel
  84. These are the development libraries and header files for gd, the .png
  85. graphics library.
  86. If you're installing the gd graphics library, you must install gd-devel.
  87. %description devel -l ja
  88. これらは開発ライブラリです。
  89. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  90. です。
  91. gdをインストールした場合、gd-develパッケージも必要になります。
  92. ## to build compat32 for x86_64 architecture support
  93. %package -n compat32-%{name}
  94. Summary: A graphics library for drawing .png files.
  95. Group: system,legacy
  96. %description -n compat32-%{name}
  97. Gd is a graphics library for drawing .png files. Gd allows your code to
  98. quickly draw images (lines, arcs, text, multiple colors, cutting and
  99. pasting from other images, flood fills) and write out the result as a
  100. .png file. Gd is particularly useful in web applications, where .pngs
  101. are commonly used as inline images. Note, however, that gd is not a
  102. paint program.
  103. Install gd if you are developing applications which need to draw .png
  104. files. If you install gd, you'll also need to install the gd-devel
  105. package.
  106. %package -n compat32-%{name}-devel
  107. Summary: The development libraries and header files for gd.
  108. Group: programming,legacy
  109. Requires: compat32-freetype2-devel
  110. Requires: compat32-fontconfig-devel
  111. Requires: compat32-libjpeg-turbo-devel
  112. Requires: compat32-libpng-devel
  113. Requires: compat32-libtiff-devel
  114. %if %{with libvpx}
  115. Requires: compat32-libvpx-devel
  116. %endif
  117. Requires: compat32-libX11-devel
  118. Requires: compat32-libXpm-devel
  119. Requires: compat32-zlib-devel
  120. %description -n compat32-%{name}-devel
  121. These are the development libraries and header files for gd, the .png
  122. graphics library.
  123. If you're installing the gd graphics library, you must install gd-devel.
  124. %debug_package
  125. %prep
  126. %setup -q -n libgd-%{version}
  127. #patch0 -p1 -b .mlib
  128. #cp %{SOURCE1} ./config/
  129. #chmod 755 ./config/getlib.sh
  130. # regenerate autotool stuff
  131. if [ -f configure ]; then
  132. libtoolize --copy --force
  133. autoreconf -vif
  134. else
  135. ./bootstrap.sh
  136. fi
  137. %build
  138. # Provide a correct default font search path
  139. CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
  140. /usr/share/fonts/alias/TrueType/:\
  141. /usr/share/fonts/TrueType-vlgothic/:\
  142. /usr/share/fonts/bitstream-vera/:\
  143. /usr/share/fonts/TrueType-dejavu/:\
  144. /usr/share/fonts/TrueType-ipafont/:\
  145. /usr/share/fonts/TrueType-ipaexfont/:\
  146. /usr/share/fonts/default/Type1/:\
  147. /usr/share/X11/fonts/Type1/:\
  148. /usr/share/fonts/TrueType-linux-liberation/\
  149. \"'"
  150. %configure \
  151. --with-freetype \
  152. --with-tiff=%{_prefix} \
  153. %if %{with libvpx}
  154. --with-vpx=%{_prefix} \
  155. %endif
  156. --disable-rpath
  157. make %{?_smp_mflags}
  158. %install
  159. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  160. make DESTDIR=$RPM_BUILD_ROOT install
  161. ## remove unuse files
  162. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  163. %check
  164. %ifarch x86_64
  165. TMP=/tmp make %{?_smp_mflags} check
  166. %endif
  167. %clean
  168. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  169. %files
  170. %defattr(-,root,root)
  171. %license COPYING
  172. %doc README.md CHANGELOG.md docs/*
  173. %{_libdir}/*.so.*
  174. %files progs
  175. %defattr(-,root,root)
  176. %{_bindir}/*
  177. %files devel
  178. %defattr(-,root,root)
  179. %{_includedir}/*
  180. %{_libdir}/*.so
  181. %{_libdir}/pkgconfig/*.pc
  182. %if %{build_compat32}
  183. %files -n compat32-%{name}
  184. %defattr(-,root,root)
  185. %{_libdir}/*.so.*
  186. %files -n compat32-%{name}-devel
  187. %defattr(-,root,root)
  188. %{_libdir}/*.so
  189. %endif
  190. %changelog
  191. * Tue Jul 04 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.3-2
  192. - rebuilt with libtiff-4.5.
  193. * Mon Sep 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.3-1
  194. - new upstream release.
  195. - dropped Patch1000 and 1001: fixed in upstream.
  196. * Fri Sep 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-2
  197. - imported Patch1000 and 1001 from upstream to fix CVE-2021-40145.
  198. * Thu Aug 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  199. - new upstream release.
  200. - dropped ldconfig scriptlets.
  201. - imported Patch1000 from upstream to fix CVE-2021-38115.
  202. - dropped Patch1 and 2: fixed in upstream.
  203. * Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-2
  204. - add Patch1 and 2 to fix drawing text.
  205. * Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
  206. - new upstream release.
  207. * Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
  208. - new upstream release.
  209. - dropped %%patch1 and 2: fixed in upstream.
  210. * Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  211. - new upstream release.
  212. - made to skip %%check on i686.
  213. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  214. - new upstream release.
  215. - removed Patch1000 (fixed in upstream).
  216. * Wed May 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
  217. - added Patch1000 to fix CVE-2016-3074.
  218. * Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  219. - new upstream release.
  220. * Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
  221. - BR: freetype2-devel instead of freetype-devel on devel package
  222. * Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
  223. - fixed version in gd.h.
  224. - added fontconfig and tiff support.
  225. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  226. - new upstream release.
  227. - dropped unnecessary patches.
  228. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
  229. - import patches from fedora package
  230. - modified font path patch for Vine Linux
  231. - drop static library
  232. - remove "-DJISX0208"
  233. - add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
  234. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
  235. - move gdlib-config from gd-progs subpackage to gd-devel subpackage
  236. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  237. - build on current VineSeed
  238. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  239. - fix build_compat32 if-endif sections
  240. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  241. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  242. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  243. - updated URL
  244. - changed progs Group to Applications/Graphics
  245. - added %%postun section
  246. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  247. - removed *.la
  248. - spec in utf-8
  249. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  250. - add patch1 from centos5
  251. - new versioning policy
  252. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  253. - new upstream release with security fix (CVE-2007-2756)
  254. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  255. - new upstream release with security fix
  256. - change source tarball format gz -> bz2
  257. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  258. - added compat32-* packages for x86_64 architecture support
  259. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  260. - source upgrade
  261. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  262. - source update
  263. - added -DJISX0208 flag
  264. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  265. - source upgrade
  266. - BuildPrereq: XOrg-devel instead of XFree86-devel
  267. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  268. - source upgrade
  269. - remove patch0 (no need for freetype2-2.1.7)
  270. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  271. - add patch0 to build against freetype2-2.1.7
  272. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  273. - source upgrade
  274. - add URL
  275. - remove all patches
  276. - use %%configure script
  277. - add BuildPrereq: freetype2-devel XFree86-devel
  278. - remove BuildPrereq: VFlib-devel
  279. - update %%files
  280. - update Requires:
  281. - use License tag instead of Copyright
  282. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  283. - rebuild with libpng-devel-1.2.5-0vl1
  284. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  285. - rebuild with new toolchain
  286. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  287. - 1.8.3-0vl2
  288. - symlink to libgd.so.1 (for backward compatibility)
  289. * Tue Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  290. - first gd 1.8.x release for Vine from rawhide.
  291. - enable freetype support and defined JISX208 macro.
  292. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  293. - break out a -progs subpackage
  294. - disable freetype support
  295. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  296. - update to latest version (1.8.2)
  297. - disable xpm support
  298. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  299. - auto rebuild in the new build environment (release 6)
  300. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  301. - auto rebuild in the new build environment (release 5)
  302. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  303. - buiuld for glibc 2.1
  304. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  305. - built for 5.2