rest-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define package_version 0.7.93
  3. %define package_release 2%{?_dist_release}
  4. Name: rest
  5. Version: %{package_version}
  6. Release: %{package_release}
  7. Summary: RESTful web api query library
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://git.gnome.org/browse/librest
  11. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: glib2-devel
  14. BuildRequires: gobject-introspection-devel
  15. BuildRequires: libsoup-devel
  16. BuildRequires: ca-certificates
  17. BuildRequires: gtk-doc
  18. Requires: ca-certificates
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: Takemikaduchi
  22. %description
  23. This library has been designed to make it easier to access web services that
  24. claim to be "RESTful". A reasonable definition of what this means can be found
  25. on Wikipedia [1]. However a reasonable description is that a RESTful service
  26. should have urls that represent remote objects which methods can then be
  27. called on.
  28. %package devel
  29. Summary: Development tools for rest
  30. Summary(ja): rest の開発環境
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: pkgconfig
  34. Requires: glib2-devel
  35. Requires: libsoup-devel
  36. Requires: libxml2-devel
  37. %description devel
  38. Header files and libraries for building a extension library for the
  39. rest.
  40. %package doc
  41. Summary: Documentation for rest
  42. Summary(ja): rest 用のドキュメント
  43. Group: Documentation
  44. Requires: %{name} = %{version}-%{release}
  45. BuildArch: noarch
  46. %description doc
  47. This package contains documentation for rest.
  48. # compat32
  49. %package -n compat32-%{name}
  50. Summary: RESTful web api query library
  51. Group: System Environment/Libraries
  52. %description -n compat32-%{name}
  53. This library has been designed to make it easier to access web services that
  54. claim to be "RESTful". A reasonable definition of what this means can be found
  55. on Wikipedia [1]. However a reasonable description is that a RESTful service
  56. should have urls that represent remote objects which methods can then be
  57. called on.
  58. %prep
  59. %setup -q
  60. %build
  61. %configure \
  62. --enable-gtk-doc \
  63. --disable-static \
  64. --enable-introspection=yes
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make DESTDIR=$RPM_BUILD_ROOT install
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %post -n compat32-%{name} -p /sbin/ldconfig
  75. %postun -n compat32-%{name} -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc ChangeLog AUTHORS COPYING NEWS README
  79. %{_libdir}/*.so.*
  80. %{_libdir}/girepository-1.0/*.typelib
  81. %files devel
  82. %defattr(-, root, root)
  83. %{_includedir}/%{name}-0.7
  84. %{_libdir}/*.so
  85. %{_libdir}/pkgconfig/*.pc
  86. %{_datadir}/gir-1.0/*.gir
  87. %files doc
  88. %defattr(-, root, root)
  89. %{_datadir}/gtk-doc/html/%{name}-0.7
  90. %if %{build_compat32}
  91. %files -n compat32-%{name}
  92. %defattr(-,root,root,-)
  93. %{_libdir}/*.so.*
  94. %endif
  95. %changelog
  96. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-2
  97. - create compat32-rest subpakcage
  98. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-1
  99. - new upstream release
  100. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.92-1
  101. - new upstream release
  102. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.91-1
  103. - new upstream release
  104. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-2
  105. - rebuild with VineSeed environment
  106. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-1
  107. - new upstream release
  108. - change BuildRequires: ca-certificates instead of openssl-devel
  109. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-2
  110. - fix URL
  111. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
  112. - new upstream release
  113. - add BuildRequires: openssl
  114. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
  115. - new upstream release
  116. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
  117. - initial build for Vine Linux