libxslt-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Library providing the Gnome XSLT engine
  3. Summary(ja): XSLT エンジンライブラリ
  4. Name: libxslt
  5. Version: 1.1.29
  6. Release: 1%{_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://xmlsoft.org/XSLT/
  10. Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libxml2-devel >= 2.6.27
  13. BuildRequires: zlib-devel >= 1.1.4
  14. BuildRequires: python python-devel perl libxml2-python
  15. Requires: libxml2 >= 2.6.27
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. This C library allows to transform XML files into other XML files
  20. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  21. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  22. installed. The xsltproc command is a command line interface to the XSLT engine
  23. %description -l ja
  24. XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
  25. %package devel
  26. Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
  27. Summary(ja): XSLT 開発用ファイル
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: libxml2-devel >= 2.6.27
  31. %description devel
  32. This C library allows to transform XML files into other XML files
  33. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  34. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  35. installed.
  36. %description devel -l ja
  37. XSLTのための開発用ファイルです。
  38. %package static
  39. Summary: Static library for %{name}
  40. Summary(ja): %{name} のスタティックライブラリ
  41. Group: Development/Libraries
  42. Requires: libxslt-devel = %{version}-%{release}
  43. %description static
  44. The libxslt-static package contains the static library for libxslt.
  45. %package python
  46. Summary: Python bindings for the libxslt library
  47. Group: Development/Libraries
  48. Requires: libxslt = %{version}-%{release}
  49. Requires: libxml2 >= 2.6.27
  50. Requires: python
  51. %description python
  52. The libxslt-python package contains a module that permits applications
  53. written in the Python programming language to use the interface
  54. supplied by the libxslt library to apply XSLT transformations.
  55. This library allows to parse sytlesheets, uses the libxml2-python
  56. to load and save XML and HTML files. Direct access to XPath and
  57. the XSLT transformation context are possible to extend the XSLT language
  58. with XPath functions written in Python.
  59. # compat32
  60. %package -n compat32-%{name}
  61. Summary: Library providing the Gnome XSLT engine
  62. Summary(ja): XSLT エンジンライブラリ
  63. Group: System Environment/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: compat32-libxml2 >= 2.6.27
  66. %description -n compat32-%{name}
  67. This C library allows to transform XML files into other XML files
  68. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  69. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  70. installed. The xsltproc command is a command line interface to the XSLT engine
  71. %description -n compat32-%{name} -l ja
  72. XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
  73. %package -n compat32-%{name}-devel
  74. Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
  75. Summary(ja): XSLT 開発用ファイル
  76. Group: Development/Libraries
  77. Requires: %{name}-devel = %{version}-%{release}
  78. Requires: compat32-%{name} = %{version}-%{release}
  79. Requires: compat32-libxml2-devel >= 2.6.27
  80. %description -n compat32-%{name}-devel
  81. This C library allows to transform XML files into other XML files
  82. (or HTML, text, ...) using the standard XSLT stylesheet transformation
  83. mechanism. To use it you need to have a version of libxml2 >= 2.6.15
  84. installed.
  85. %description -n compat32-%{name}-devel -l ja
  86. XSLTのための開発用ファイルです。
  87. %prep
  88. %setup -q
  89. %build
  90. %configure --without-crypto
  91. make %{?_smp_mflags}
  92. %install
  93. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  94. make DESTDIR=$RPM_BUILD_ROOT install
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
  97. #
  98. # this is a bit ugly but tries to generate the bindings for all versions
  99. # of python installed
  100. #for i in %{prefix}/include/python*
  101. #do
  102. # py_version=`echo $i | sed "s+%{prefix}/include/python++"`
  103. # if test -x %{prefix}/bin/python$py_version
  104. # then
  105. # echo generating bindings for Python $py_version
  106. # (cd python ; make clean ; \
  107. # make PYTHON="%{prefix}/bin/python$py_version" \
  108. # PYTHON_VERSION="$py_version"; \
  109. # make PYTHON="%{prefix}/bin/python$py_version" \
  110. # PYTHON_VERSION="$py_version" \
  111. # prefix=$RPM_BUILD_ROOT%{prefix} \
  112. # mandir=$RPM_BUILD_ROOT%{_mandir} install)
  113. # fi
  114. #done
  115. %clean
  116. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  117. %post -p /sbin/ldconfig
  118. %postun -p /sbin/ldconfig
  119. %post -n compat32-%{name} -p /sbin/ldconfig
  120. %postun -n compat32-%{name} -p /sbin/ldconfig
  121. %files
  122. %defattr(-, root, root)
  123. %doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
  124. %doc doc/*.html doc/html doc/tutorial doc/EXSLT
  125. %{_bindir}/xsltproc
  126. %{_libdir}/lib*.so.*
  127. %{_mandir}/man1/xsltproc.1*
  128. %files devel
  129. %defattr(-, root, root)
  130. %doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
  131. %{_includedir}/*
  132. %{_libdir}/lib*.so
  133. %{_libdir}/*.sh
  134. %{_libdir}/pkgconfig/*.pc
  135. %{_bindir}/xslt-config
  136. %{_datadir}/aclocal/*.m4
  137. %{_mandir}/man3/*
  138. %files static
  139. %defattr(-, root, root)
  140. %{_libdir}/lib*.a
  141. %files python
  142. %defattr(-, root, root)
  143. %doc AUTHORS ChangeLog NEWS README Copyright FEATURES
  144. %doc python/TODO
  145. %doc python/libxsltclass.txt
  146. %doc python/tests/*.py
  147. %doc python/tests/*.xml
  148. %doc python/tests/*.xsl
  149. %{_libdir}/python*/site-packages/libxslt.py
  150. %{_libdir}/python*/site-packages/libxsltmod*
  151. # compat32
  152. %if %{build_compat32}
  153. %files -n compat32-%{name}
  154. %defattr(-, root, root)
  155. %{_libdir}/lib*.so.*
  156. %files -n compat32-%{name}-devel
  157. %defattr(-, root, root)
  158. %{_libdir}/lib*.so
  159. %{_libdir}/lib*.a
  160. %{_libdir}/*.sh
  161. %endif
  162. %changelog
  163. * Wed Jun 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
  164. - updated to 1.1.29.
  165. - dropped Patch0.
  166. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-2
  167. - add Patch0 (libxslt-1.1.28-CVE-2015-7995.patch)
  168. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-1
  169. - update to 1.1.28
  170. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
  171. - rebuild with VineSeed environment
  172. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
  173. - new upstream release
  174. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
  175. - rebuild with python-2.7.2
  176. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
  177. - build with rpm-4.8.1-1 for pkg-config file
  178. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
  179. - rebuilt with gcc-4.4.3-3 on ppc
  180. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
  181. - removed %%{_libdir}/python*/site-packages/*.{a,la}
  182. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
  183. - rebuild with python-2.6
  184. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
  185. - rebuilt with new toolchain
  186. * Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
  187. - new upstream release
  188. - split static libraries to subpackage
  189. * Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
  190. - added compat32 package for x86_64 arch support
  191. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
  192. - rebuilt with python-2.5.2
  193. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
  194. - new upstream release
  195. - remove *.la file from devel package
  196. * Wed Oct 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
  197. - new upstream release
  198. * Sun Feb 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
  199. - new upstream release
  200. - updated BuildRequires: libxml2-devel >= 2.6.27
  201. - updated Requires: libxml2 >= 2.6.27
  202. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
  203. - added --libdir=%%{_libdir} to ./configure option
  204. * Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
  205. - new upstream release
  206. - updated libxml2 dependancy
  207. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
  208. - new upstream release
  209. * Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
  210. - new upstream release
  211. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
  212. - rebuild with python-2.4.1-0vl1
  213. * Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
  214. - build without libgcrypt (add --without-crypto to configure option)
  215. - remove lines about snapshot release
  216. - use %%makeinstall
  217. - add %%{_libdir}/python*/site-packages/libxsltmod* to python package
  218. * Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
  219. - source upgrade (security fix)
  220. - BuildPrereq: libxml2-devel >= 2.6.15
  221. - Requires: libxml2 >= 2.6.15
  222. - add doc/EXSLT to %%doc
  223. * Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
  224. - new upstream version
  225. * Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
  226. - source upgrade
  227. - BuildPrereq: libxml2-devel >= 2.6.8
  228. - Requires: libxml2 >= 2.6.8
  229. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
  230. - rebuild with python-2.3.3-0vl1
  231. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
  232. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  233. * Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
  234. - new upstream release
  235. * Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
  236. - new upstream release
  237. - BuildPrereq: libxml2-devel >= 2.6.3
  238. - Requires: libxml2 >= 2.6.3
  239. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
  240. - new upstream release
  241. * Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
  242. - source upgrade
  243. * Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
  244. - source upgrade
  245. * Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
  246. - source upgrade
  247. - BuildPrereq: libxml2-devel >= 2.5.2
  248. - Requires: libxml2 >= 2.5.2
  249. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
  250. - source upgrade
  251. - build with new toolchains
  252. * Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
  253. - source update to 1.0.22
  254. - BuildPrereq: libxml2-devel >= 2.4.23
  255. - Requires: libxml2 >= 2.4.23
  256. * Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
  257. - merged with 1.0.17-1
  258. -- Fri Feb 8 2002 Daniel.Veillard <veillard@redhat.com>
  259. - added the python module
  260. - clean up spec
  261. - BuildPrereq: libxml2-devel >= 2.4.17
  262. - Requires: libxml2 >= 2.4.17
  263. * Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
  264. - changed License to MIT (not LGPL)
  265. - add BuildPrereq: zlib-devel >= 1.1.4 perl
  266. * Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
  267. - source update
  268. - BuildPrereq: libxml2-devel >= 2.4.13
  269. * Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
  270. - add gtk-doc to BuildPrereq
  271. * Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
  272. - 1.0.1-1vl2
  273. - Build for VineSeed
  274. * Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
  275. - 1.0.1-1vl1
  276. - cleaning
  277. * Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
  278. - 1.0.1-1vl0
  279. - modify for Vine Linux 2.1x
  280. * Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
  281. - created based on libxml2 spec file