chicken-vl.spec 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. %define pkg_name chicken
  2. %define pkg_version 4.11.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Practical and portable Scheme system - compiler
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD-style
  9. Group: Applications/Languages
  10. URL: https://www.call-cc.org/
  11. Source: http://code.call-cc.org/releases/%{version}/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Packager: ara_t
  16. %description
  17. CHICKEN is a compiler for the Scheme programming language.
  18. It produces portable and efficient C and supports the R5RS
  19. and R7RS (work in progress) standards, and many extensions.
  20. %prep
  21. %{__rm} -rf ${RPM_BUILD_ROOT}
  22. %setup -q
  23. %build
  24. %{__make} \
  25. PLATFORM=linux \
  26. PREFIX=%{_prefix} \
  27. IDOCDIR=%{_docdir}/%{name}-%{version}
  28. %install
  29. %{__make} install \
  30. PLATFORM=linux \
  31. PREFIX=%{_prefix} \
  32. IDOCDIR=%{_docdir}/%{name}-%{version} \
  33. DESTDIR=${RPM_BUILD_ROOT}
  34. %check
  35. %{__make} check PLATFORM=linux
  36. %clean
  37. %{__rm} -rf ${RPM_BUILD_ROOT}
  38. %post -p %{_syssbindir}/ldconfig
  39. %postun -p %{_syssbindir}/ldconfig
  40. %files
  41. %defattr(-, root, root)
  42. %{_bindir}/
  43. %{_includedir}/
  44. /usr/lib/libchicken.so*
  45. /usr/lib//libchicken.a
  46. /usr/lib/chicken
  47. %{_datadir}/chicken
  48. %{_mandir}/man1/
  49. %{_docdir}/%{name}-%{version}
  50. %changelog
  51. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 4.11.0-1
  52. - update to 4.11.0
  53. - add %{__make} check for VineSeed
  54. * Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 4.10.0-1
  55. - new package