iproute-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499
  1. ##%define date_version 070710
  2. %define cbq_version v0.7.3
  3. Summary: Advanced IP routing and network device configuration tools
  4. Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
  5. Name: iproute
  6. Version: 2.6.38.1
  7. Release: 1%{?_dist_release}
  8. Group: Applications/System
  9. Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}.tar.bz2
  10. URL: http://linux-net.osdl.org/index.php/Iproute2
  11. Patch0: man-pages.patch
  12. Patch1: iproute2-2.6.29-kernel.patch
  13. Patch2: iproute2-ss050901-opt_flags.patch
  14. Patch3: iproute2-2.6.25-segfault.patch
  15. Patch4: iproute2-sharepath.patch
  16. Patch5: iproute2-2.6.31-tc_modules.patch
  17. Patch6: iproute2-2.6.29-IPPROTO_IP_for_SA.patch
  18. Patch7: iproute2-example-cbq-service.patch
  19. Patch8: iproute2-2.6.35-print-route.patch
  20. Patch9: iproute2-print-route-u32.patch
  21. Patch10:iproute2-2.6.33-create-peer-veth-without-a-name.patch
  22. # VINE
  23. Patch100: iproute2-2.6.15-platex.patch
  24. License: GPLv2+
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  26. BuildRequires: flex psutils db4-devel bison
  27. BuildRequires: iptables-devel >= 1.4.10
  28. Requires: iptables >= 1.4.10
  29. %description
  30. The iproute package contains networking utilities (ip and rtmon, for
  31. example) which are designed to use the advanced networking
  32. capabilities of the Linux 2.4.x and 2.6.x kernel.
  33. %description -l ja
  34. このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
  35. ネットワーク技術を使うように設計された、ネットワーキングユーティリ
  36. ティが収録されています(例えばipやrtmonなどが収録されています)。
  37. %package devel
  38. Summary: Libraries, includes, etc. to develop iptables
  39. Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}
  42. %description devel
  43. Libraries, include files, etc you can use to develop iproute2.
  44. %prep
  45. %setup -q -n iproute2-%{version}
  46. %patch0 -p1
  47. sed -i "s/_VERSION_/%{version}/" man/man8/ss.8
  48. %patch1 -p1 -b .kernel
  49. %patch2 -p1 -b .opt_flags
  50. %patch3 -p1 -b .seg
  51. %patch4 -p1 -b .share
  52. %patch5 -p1 -b .ipt
  53. %patch6 -p1 -b .ipproto
  54. %patch7 -p1 -b .fix_cbq
  55. %patch8 -p1 -b .print-route
  56. %patch9 -p1 -b .print-route-u32
  57. %patch10 -p1 -b .peer-veth-without-name
  58. %patch100 -p1 -b .platex
  59. %build
  60. export LIBDIR=%{_libdir}
  61. export IPT_LIB_DIR=/%_lib}/xtables
  62. make %{?_smp_mflags}
  63. %install
  64. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  65. mkdir -p $RPM_BUILD_ROOT/sbin \
  66. $RPM_BUILD_ROOT%{_sbindir} \
  67. $RPM_BUILD_ROOT%{_mandir}/man8 \
  68. $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2 \
  69. $RPM_BUILD_ROOT%{_datadir}/tc \
  70. $RPM_BUILD_ROOT%{_libdir}/tc \
  71. $RPM_BUILD_ROOT%{_libdir}/iproute2 \
  72. $RPM_BUILD_ROOT%{_includedir}/iproute2
  73. install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
  74. install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
  75. #netem is static
  76. #install -m 755 tc/q_netem.so $RPM_BUILD_ROOT%{_libdir}/tc
  77. #install -m 755 tc/q_atm.so $RPM_BUILD_ROOT%{_libdir}/tc
  78. install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
  79. install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
  80. rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
  81. iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
  82. install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
  83. install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
  84. install -m 644 lib/lib*.a $RPM_BUILD_ROOT%{_libdir}/iproute2
  85. install -m 644 include/*.h $RPM_BUILD_ROOT%{_includedir}/iproute2
  86. install -m 644 etc/iproute2/* $RPM_BUILD_ROOT%{_sysconfdir}/iproute2
  87. cp -f etc/iproute2/* $RPM_BUILD_ROOT/%{_sysconfdir}/iproute2
  88. rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
  89. #create example avpkt file
  90. cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/cbq-0000.example
  91. DEVICE=eth0,10Mbit,1Mbit
  92. RATE=128Kbit
  93. WEIGHT=10Kbit
  94. PRIO=5
  95. RULE=192.168.1.0/24
  96. EOF
  97. cat <<EOF > $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq/avpkt
  98. AVPKT=3000
  99. EOF
  100. %clean
  101. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  102. %files
  103. %defattr(-,root,root,-)
  104. %dir %{_sysconfdir}/iproute2
  105. %doc README.decnet README.iproute2+tc RELNOTES README.distribution README.lnstat
  106. %doc iproute2-%{version}/examples
  107. /sbin/*
  108. %{_mandir}/man8/*
  109. %attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
  110. %{_sbindir}/*
  111. %dir %{_datadir}/tc
  112. %{_datadir}/tc/*
  113. %dir %{_libdir}/tc/
  114. #%{_libdir}/tc/*
  115. %dir %{_sysconfdir}/sysconfig/cbq
  116. %config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
  117. %files devel
  118. %defattr(-,root,root)
  119. %{_libdir}/iproute2/lib*.a
  120. %dir %{_includedir}/iproute2
  121. %{_includedir}/iproute2/*.h
  122. %changelog
  123. * Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
  124. - update to 2.6.38.1
  125. - build with iptables-1.4.10
  126. - add BR: iptables-devel
  127. * Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
  128. - don't build/include documents. (almost same as man pages...)
  129. - remove BR: texlive ,linuxdoc-tools
  130. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
  131. - rebuilt with rpm-4.8.1-3
  132. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
  133. - rebuilt with gcc-4.4.3-3 on ppc
  134. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
  135. - rebuilt with rpm-4.8.0-3 (on ppc)
  136. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
  137. - new upstream release
  138. - import patches from fedora package
  139. - build with db4-4.8
  140. * Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
  141. - updated to 2.6.25 based on 2.6.25-1 from Fedora
  142. - build with db4-4.6.21
  143. - keep Patch100 from 2.6.16-1vl5
  144. -changelogs for previous Vine package as follows:
  145. - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
  146. - apply new versioning policy.
  147. - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
  148. - updated to 2.6.16 and merged several patches from FC 2.6.16-6
  149. (Patch10 not applied until VineSeed kernel goes higher versions)
  150. - rebuilt with new toolchain and db4-4.3.x
  151. - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
  152. - added Patch5 to make documents without errors
  153. - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
  154. - update to 2.6.15-060110
  155. - Mon Jun 6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
  156. - added BuildRequires: linuxdoc-tools
  157. - Mon Jun 6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
  158. - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
  159. - Sun Jun 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
  160. - new upstream release
  161. - changed Group: of devel package
  162. - applyed patches from Fedora development
  163. - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
  164. - Took tons of manpages from debian, much more complete (#123952).
  165. - added Japanese translation from spec translation project :-)
  166. - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
  167. - 2.2.4-14vl2
  168. - rename package name iproute to iproute2
  169. - rebuild development version
  170. * Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
  171. - update
  172. - remove patch for backward compatibility
  173. - add patch for AEAD compatibility
  174. * Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
  175. - add creating ps file again. Fix was done in texlive
  176. * Wed Feb 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
  177. - rebuild without tetex files. It isn't working in rawhide yet. Added
  178. new source for ps files.
  179. - #431179 backward compatibility for previous iproute versions
  180. * Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
  181. - rebuild with fix tetex and linuxdoc-tools -> manual pdf
  182. - clean unnecessary patches
  183. - add into spec *.so objects, new BR linux-atm-libs-devel
  184. * Tue Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
  185. - new version from upstrem 2.3.23
  186. * Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
  187. - move files from /usr/lib/tc to /usr/share/tc
  188. - remove listing files twice
  189. * Fri Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
  190. - package review #225903
  191. * Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
  192. - rebuild for new db4
  193. * Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
  194. - upgrade to 2.6.22
  195. * Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
  196. - fix broken tc-pfifo man page (#232891)
  197. * Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
  198. - upgrade to 2.6.20
  199. * Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
  200. - upgrade to 2.6.19
  201. * Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
  202. - fix snapshot version
  203. * Fri Dec 1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
  204. - spec file cleanup
  205. - one more rebuilt against db4
  206. * Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
  207. - fix defective manpage for tc-pfifo (#215399)
  208. * Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
  209. - rebuilt against new db4
  210. * Tue Oct 3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
  211. - upgrade to upstream 2.6.18
  212. - initcwnd patch merged
  213. - bug fix for xfrm monitor
  214. - alignment fixes for cris
  215. - documentation corrections
  216. * Mon Oct 2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
  217. - fix ip.8 man page, add initcwnd option
  218. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
  219. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  220. * Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
  221. - fix crash when resolving ip address
  222. * Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
  223. - add LOWER_UP and DORMANT flags (#202199)
  224. - use dist tag
  225. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
  226. - rebuild
  227. * Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
  228. - improve handling of initcwnd value (#179719)
  229. * Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
  230. - fix BuildRequires: flex (#193403)
  231. * Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
  232. - upgrade to 2.6.16-060323
  233. - don't hardcode /usr/lib in tc (#186607)
  234. * Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
  235. - own /usr/lib/tc (#181953)
  236. - obsoletes shapecfg (#182284)
  237. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
  238. - bump again for double-long bug on ppc(64)
  239. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
  240. - rebuilt for new gcc4.1 snapshot and glibc changes
  241. * Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
  242. - upgrade to 2.6.15-060110
  243. * Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
  244. - rebuilt
  245. * Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
  246. - remove backup of config files (#175302)
  247. * Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
  248. - use tc manpages and cbq.init from source tarball (#172851)
  249. * Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
  250. - new upstream source
  251. * Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
  252. - add warning to ip tunnel add command (#128107)
  253. * Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
  254. - update from upstream (appears to fix #170111)
  255. * Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
  256. - update from upstream
  257. - fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
  258. * Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
  259. - add RPM_OPT_FLAGS
  260. * Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
  261. - forget to apply the patch :(
  262. * Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
  263. - make ip help work again (#168449)
  264. * Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
  265. - upgrade to ss050901 for 2.6.14 kernel headers
  266. * Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
  267. - added /sbin/cbq script and sample configuration files (#166301)
  268. * Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
  269. - upgrade to iproute2-050816
  270. * Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
  271. - update to snapshot for 2.6.13+ kernel
  272. * Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
  273. - removed useless initvar patch (#150798)
  274. - new upstream source
  275. * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
  276. - update to iproute-2.6.11
  277. * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
  278. - gcc4 rebuilt
  279. * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
  280. - update to iproute-2.6.10
  281. * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
  282. - added arpd into sbin
  283. * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
  284. - debug info removed from makefile and from spec (#140891)
  285. * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
  286. - source file updated from snapshot version
  287. - endian patch adding <endian.h>
  288. * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
  289. - added installation of netem module for tc
  290. * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
  291. - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
  292. * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
  293. - updated to iproute-2.6.9, spec file change, patches cleared
  294. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  295. - rebuilt
  296. * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
  297. - Took tons of manpages from debian, much more complete (#123952).
  298. * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
  299. - rebuilt
  300. * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
  301. - Built security errata version for FC1.
  302. * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
  303. - Fixed -f option for ss (#118355).
  304. - Small description fix (#110997).
  305. - Added initialization of some vars (#74961).
  306. - Added patch to initialize "default" rule as well (#60693).
  307. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  308. - rebuilt
  309. * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
  310. - Security errata for netlink (CAN-2003-0856).
  311. * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
  312. - Updated to latest version. Used by other distros, so seems stable. ;-)
  313. - Quite a few patches needed updating in that turn.
  314. - Added ss (#107363) and several other new nifty tools.
  315. * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
  316. - rebuilt
  317. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  318. - rebuilt
  319. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  320. - rebuilt
  321. * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
  322. - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
  323. * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
  324. - remove flags patch at author's request
  325. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  326. - automated rebuild
  327. * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
  328. - Don't forcibly strip binaries
  329. * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
  330. - Fixed missing diffserv and atm support in config (#57278).
  331. - Fixed inconsistent numeric base problem for command line (#65473).
  332. * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
  333. - Added patch to fix crosscompiling by Adrian Linkins.
  334. * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
  335. - Update to latest stable release 2.4.7-now-ss010824.
  336. - Added simple man page for ip.
  337. * Wed Aug 8 2001 Bill Nottingham <notting@redhat.com>
  338. - allow setting of allmulti & promisc flags (#48669)
  339. * Mon Jul 02 2001 Than Ngo <than@redhat.com>
  340. - fix build problem in beehive if kernel-sources is not installed
  341. * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
  342. - updated to iproute2-2.2.4-now-ss001007.tar.gz
  343. - bzip2 source tar file
  344. - "License" replaces "Copyright"
  345. - added "BuildPrereq: tetex-latex tetex-dvips psutils"
  346. - rebuilt for 7.2
  347. * Tue May 1 2001 Bill Nottingham <notting@redhat.com>
  348. - use the system headers - the included ones are broken
  349. - ETH_P_ECHO went away
  350. * Sat Jan 6 2001 Jeff Johnson <jbj@redhat.com>
  351. - test for specific KERNEL_INCLUDE directories.
  352. * Thu Oct 12 2000 Than Ngo <than@redhat.com>
  353. - rebuild for 7.1
  354. * Thu Oct 12 2000 Than Ngo <than@redhat.com>
  355. - add default configuration files for iproute (Bug #10549, #18887)
  356. * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
  357. - fix include-glibc/ to cope with glibc 2.2 new resolver headers
  358. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  359. - automatic rebuild
  360. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  361. - rebuilt in the new build environment
  362. - use RPM macros
  363. - handle RPM_OPT_FLAGS
  364. * Sat Jun 03 2000 Than Ngo <than@redhat.de>
  365. - fix iproute to build with new glibc
  366. * Fri May 26 2000 Ngo Than <than@redhat.de>
  367. - update to 2.2.4-now-ss000305
  368. - add configuration files
  369. * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
  370. - strip binaries
  371. * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
  372. - first build