xorg-x11-xsm-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define pkgname xsm
  2. Summary: X.Org X11 X Session Manager
  3. Summary(ja): X.Org X11 X セッションマネージャ
  4. Name: xorg-x11-%{pkgname}
  5. # NOTE: The Version field should be the version of the xsm tarball.
  6. Version: 1.0.2
  7. # Bump the release on rebuilds/bugfixes/etc.
  8. Release: 3%{?_dist_release}
  9. License: MIT
  10. Group: User Interface/X
  11. URL: http://www.x.org
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.2.tar.bz2
  14. Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.4.tar.bz2
  15. Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
  16. # Patches for xsm (10-19)
  17. Patch10: xsm-1.0.2-xsm-installation-location-fixes.patch
  18. # Patches for smproxy (20-29)
  19. # Patches for rstart (30-39)
  20. Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
  21. # FIXME: Temporary dependency on automake/autoconf while they're still needed.
  22. BuildRequires: automake autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: xorg-x11-util-macros
  25. BuildRequires: xorg-x11-proto-devel
  26. BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
  27. BuildRequires: rsh
  28. # NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
  29. # monolithic X releases to modular X releases to work properly.
  30. Requires(pre): xorg-x11-filesystem
  31. # rstart script invokes xauth, rsh
  32. Requires: xauth, rsh
  33. Provides: xsm, smproxy, rstart, rstartd
  34. # NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
  35. Obsoletes: XFree86, xorg-x11
  36. %description
  37. X.Org X11 X Session Manager
  38. %prep
  39. %setup -q -c %{name}-%{version} -a1 -a2
  40. %patch10 -p0 -b .xsm-installation-location-fixes
  41. %patch30 -p0 -b .rstart-installation-location-fixes
  42. %build
  43. # Build everything
  44. {
  45. for pkg in xsm smproxy rstart ; do
  46. pushd $pkg-*
  47. sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
  48. aclocal ; automake ; autoconf
  49. %configure --disable-xprint
  50. make
  51. popd
  52. done
  53. }
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. # Install everything
  57. {
  58. for pkg in xsm smproxy rstart ; do
  59. pushd $pkg-*
  60. make install DESTDIR=$RPM_BUILD_ROOT
  61. popd
  62. done
  63. }
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %files
  67. %defattr(-,root,root,-)
  68. # FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
  69. # can't use the %%version macro here until a upstream xsm is released as
  70. # version 1.0.2 or higher.
  71. #%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
  72. #%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
  73. %doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
  74. %doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
  75. %{_bindir}/rstart
  76. %{_bindir}/rstartd
  77. %{_bindir}/smproxy
  78. %{_bindir}/xsm
  79. %dir %{_datadir}/X11
  80. %dir %{_datadir}/X11/rstart
  81. %dir %{_datadir}/X11/rstart/commands
  82. %{_datadir}/X11/rstart/commands/@List
  83. %{_datadir}/X11/rstart/commands/ListContexts
  84. %{_datadir}/X11/rstart/commands/ListGenericCommands
  85. %dir %{_datadir}/X11/rstart/commands/x11r6
  86. %{_datadir}/X11/rstart/commands/x11r6/@List
  87. %{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
  88. %{_datadir}/X11/rstart/commands/x11r6/Terminal
  89. %dir %{_datadir}/X11/rstart/contexts
  90. %{_datadir}/X11/rstart/contexts/@List
  91. %{_datadir}/X11/rstart/contexts/default
  92. %{_datadir}/X11/rstart/contexts/x
  93. %{_datadir}/X11/rstart/contexts/x11
  94. %{_datadir}/X11/rstart/contexts/x11r6
  95. %{_datadir}/X11/app-defaults/XSm
  96. %dir %{_libdir}/X11
  97. %dir %{_libdir}/X11/rstart
  98. # NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
  99. %{_libdir}/X11/rstart/rstartd.real
  100. #%dir %{_mandir}/man1x
  101. %{_mandir}/man1/rstart.1*
  102. %{_mandir}/man1/rstartd.1*
  103. %{_mandir}/man1/smproxy.1*
  104. %{_mandir}/man1/xsm.1*
  105. %dir %{_sysconfdir}/X11
  106. %dir %{_sysconfdir}/X11/rstart
  107. %config %{_sysconfdir}/X11/rstart/config
  108. %dir %{_sysconfdir}/X11/xsm
  109. %config %{_sysconfdir}/X11/xsm/system.xsm
  110. %changelog
  111. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
  112. - xsm-1.0.2
  113. - smproxy-1.0.4
  114. - rstart-1.0.4
  115. - update Patch10, Patch30
  116. - fix %%files
  117. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  118. - smproxy-1.0.3
  119. - rstart-1.0.3
  120. * Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  121. - initial build for Vine Linux
  122. * Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
  123. - Fix license tag.
  124. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
  125. - Autorebuild for GCC 4.3
  126. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
  127. - Rebuild for build id
  128. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
  129. - Fix man page globs and rebuild for FC7.
  130. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
  131. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  132. - Add 'dist' tag to package release string.
  133. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
  134. - rebuild
  135. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  136. - Added xsm documentation to doc macro.
  137. - The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
  138. an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
  139. in a few places temporarily until xsm-1.0.2 is available.
  140. * Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
  141. - Fix BuildRequires (#191802)
  142. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  143. - Update smproxy and rstart
  144. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  145. - bump again for double-long bug on ppc(64)
  146. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  147. - rebuilt for new gcc4.1 snapshot and glibc changes
  148. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  149. - Updated all apps to version 1.0.1 from X11R7.0
  150. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  151. - Updated all apps to version 1.0.0 from X11R7 RC4.
  152. - Changed manpage dir from man1x to man1 to match upstream default.
  153. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
  154. - Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
  155. - Added rstart-0.99.1-rstart-installation-location-fixes.patch and
  156. xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
  157. /etc and data files in /usr/share where they belong.
  158. - Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
  159. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  160. - require newer filesystem package (#172610)
  161. * Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
  162. - Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
  163. - Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
  164. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  165. - Initial build of xsm, smproxy, and rstart from X11R7 RC1