trac-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. ## %define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
  2. %define name trac
  3. %define version 0.11.6
  4. %define release 1%{?_dist_release}
  5. %define japanize ja1
  6. Summary: A web-based software project management and bug/issue tracking system
  7. Summary(ja): Web ベースのソフトウェアプロジェクト管理およびバグ追跡システム
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: http://www.i-act.co.jp/project/products/downloads/Trac-%{version}.%{japanize}.zip
  12. Patch0: trac-0.11.4.ja1-default_charset.patch
  13. Patch1: trac-0.11.3.ja1-fix_sourceforge2trac.py.patch
  14. License: modified BSD-style License
  15. Group: Applications/Development
  16. URL: http://trac.edgewall.org/
  17. BuildArch: noarch
  18. Requires: python, python-genshi >= 0.5, python-setuptools >= 0.6b1
  19. #Requires: pysqlite
  20. BuildRequires: python-devel, python-genshi >= 0.5, python-setuptools >= 0.6b1
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. Trac is an enhanced wiki and issue tracking system for software
  26. development projects. Trac uses a minimalistic approach to
  27. web-based software project management. Our mission is to help
  28. developers write great software while staying out of the way.
  29. Trac should impose as little as possible on a team's established
  30. development process and policies.
  31. %description -l ja
  32. Trac はソフトウェア開発プロジェクトのマネージメントにおける
  33. 最小限のアプローチを提供する Web アプリケーションです。
  34. ソフトウェア開発の上でのチケット解決、機能追加、および
  35. すべての工程において、効果的なトラッキングとハンドリングを
  36. 簡素化することを目標としています。
  37. Trac の全てのアスペクトは、一つの目標のもとに設計されています。
  38. 古びた方法でプロジェクトを運営している、ソフトウェア開発者の
  39. 助けとなること。そのために、チームが既に確立している
  40. 開発プロセスと開発ポリシーに影響をなるべく与えないこと。
  41. %prep
  42. %setup -q -n Trac-%{version}.%{japanize}
  43. %patch0 -p1
  44. %patch1 -p1
  45. %build
  46. %{__python} setup.py build
  47. %install
  48. rm -rf ${RPM_BUILD_ROOT}
  49. %{__python} setup.py install --root=${RPM_BUILD_ROOT}
  50. ## deleting files
  51. %{__rm} -f contrib/trac-post-commit-hook.cmd
  52. %{__rm} -rf contrib/rpm
  53. %clean
  54. rm -rf $RPM_BUILD_ROOT
  55. %files
  56. %defattr(-,root,root)
  57. %doc AUTHORS COPYING* ChangeLog* README* RELEASE* TESTING-README* THANKS* UPGRADE*
  58. %doc doc sample-plugins wiki-macros contrib
  59. %{_bindir}/*
  60. %{python_sitelib}/Trac-*.egg-info
  61. %{python_sitelib}/trac
  62. %changelog
  63. * Wed Mar 17 2010 Shu KONNO <owa@bg.wakwak.com> 0.11.6-1
  64. - updated Trac to 0.11.6.ja1
  65. - rebuilt with python-2.6
  66. - dropt BR: pysqlite (included in python-2.6)
  67. * Sat Apr 25 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.4-1
  68. - new upstream release
  69. - update default charset patch (Patch0)
  70. - add patching default wiki page
  71. * Mon Apr 6 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.3-2
  72. - add Requires: pysqlite
  73. - fix 0.11.3-1 changelog
  74. - update Requires and BuildRequires
  75. * Sun Apr 5 2009 IWAI, Masaharu <iwai@alib.jp> 0.11.3-1
  76. - new upstream release
  77. - update License value
  78. - update default_charset patch (Patch0)
  79. - update %%files section
  80. - add fix sourceforge2trac.py.patch (Patch1)
  81. - update Requires
  82. - drop clearsilver, silvercity, pysqlite, python-pyxml, subversion-python
  83. - add python-genshi >= 0.5, python-setuptools >= 0.6b1
  84. - update BuildRequires
  85. - add python-genshi >= 0.5, python-setuptools >= 0.6b1
  86. * Mon Oct 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-2
  87. - added %%python_sitelib macro to be independent of platforms
  88. - added BuildArch: noarch
  89. * Mon Oct 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.10.5-1
  90. - upgraded to 0.10.5, the newest 0.10.x line, including security and bug fixes
  91. - spec in UTF-8
  92. - modified Patch0 to set utf-8 as default encoding
  93. * Wed Aug 22 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.4-0vl1
  94. - initial build for Vine Linux
  95. - add Patch0 to change default_charset to euc-jp