lilypond-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405
  1. %define buildinfo yes
  2. %define name lilypond
  3. %define version 2.4.5
  4. %define release 0vl2
  5. %define iconsdir /usr/share/pixmaps
  6. # %define infodir %{_infodir}/%{name}
  7. %define infodir %{_infodir}/lilypond
  8. Summary: A program for printing sheet music.
  9. Summary(ja): 楽譜作成プログラム
  10. Name: %{name}
  11. Version: %{version}
  12. Release: %{release}
  13. License: GPL
  14. Group: Applications/Publishing
  15. URL: http://lilypond.org/
  16. Source0: http://ftp.cs.uu.nl/pub/GNU/LilyPond/development/lilypond-%{version}.tar.gz
  17. Patch0: lilypond-platex-2.4.5.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: gcc-c++ python python-devel
  20. BuildRequires: gettext netpbm-progs
  21. BuildRequires: tetex xdvik ghostscript
  22. BuildRequires: ec-fonts-mftraced
  23. Buildrequires: which t1utils bison m4 flex mftrace ImageMagick-devel
  24. Buildrequires: texinfo >= 4.7
  25. BuildRequires: guile-devel >= 1.6.4
  26. BuildRequires: t1lib-devel
  27. BuildRequires: glibc-devel groff
  28. BuildRequires: potrace >= 1.3 fontforge
  29. Requires: chkfontpath XOrg
  30. %description
  31. LilyPond is a music typesetter. It produces beautiful sheet music using a
  32. high level description file as input. Lilypond is part of the GNU project.
  33. LilyPond is split into two packages. The package "lilypond" provides the
  34. core package, containing the utilities for converting the music source
  35. (.ly) files into printable output. The package "lilypond-documentation"
  36. provides the full documentation, example .ly files for various features and
  37. the Mutopia project files (musical equivalent of the Gutenberg project - see
  38. http://www.mutopiaproject.org for details).
  39. If you are new to lilypond, you will almost certainly want to install the
  40. "lilypond-documentation" package in addition to the "lilypond" package.
  41. %description -l ja
  42. LilyPond は GNU プロジェクトで開発されている楽譜作成ソフトです。高解像度の
  43. とてもきれいな楽譜を作ることができます。
  44. LiLyPond は2つのパッケージにわかれています。"lilypond"パッケージがメインパッ
  45. ケージ"で、楽譜ソースファイル(.ly)を印刷可能な形式に変換するプログラムが入っ
  46. てます。tex, html等に簡単に楽譜を挿入するための lilypond-book コマンドもあり
  47. ます.(Vine用パッケージでは,platexでの利用も可能に変更してあります.)
  48. "lilypond-documentation" にはマニュアルやいろいろなサンプルファイル(.ly)、
  49. Mutopiaプロジェクトによるいつくかのファイルが入ってます。Mutopia プロジェクト
  50. (musical equivalent of the Gutenberg project)については
  51. http://www.mutopiaproject.orgを見てください。
  52. %package -n liblilypond
  53. Summary: Lilypond libraries
  54. Summary(ja): Lilypond ライブラリ
  55. Group: System Environment/Libraries
  56. Requires: lilypond >= %{version}
  57. %description -n liblilypond
  58. Lilypond libs
  59. %package documentation
  60. Summary: LilyPond documentation, examples and Mutopia files.
  61. Summary(ja): LilyPond のマニュアル, サンプル,Mutopiaファイル
  62. Group: Applications/Documentation
  63. Requires: %{name}
  64. %description documentation
  65. The documentation of LilyPond, both in HTML and PostScript, along with
  66. example input files and the files from the Mutopia project.
  67. %description documentation -l ja
  68. LiLyPond のマニュアルです.HTML ,PostScript, PDF の形式のものがあります.
  69. サンプルや Mutopiaプロジェクトによるファイルも入ってます.
  70. %prep
  71. rm -rf $RPM_BUILD_ROOT
  72. %setup -q
  73. #%patch -p1
  74. %build
  75. # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
  76. # so we can't do make prefixix=/tmp/ install.
  77. # In fact, do not take out the spaces between % and { in the above comment,
  78. # because RPM will gladly do a substitution anyway.
  79. ./configure --disable-checking --prefix=%{_prefix} --libdir=%{_libdir} \
  80. --enable-optimising
  81. %{__make} all
  82. %{__make} web
  83. %{__make} -C Documentation/user omf
  84. %install
  85. %{__rm} -rf %{buildroot}
  86. %{makeinstall} MAKE_PFA_FILES=1 local_lilypond_libdir=%{buildroot}/%{_libdir}/%{name}/%{version}
  87. ########## install emacs els
  88. %{__mkdir} -p %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
  89. %{__install} -m 644 elisp/lilypond-init.el %{buildroot}%{_datadir}/emacs/site-lisp/site-start.d
  90. ######### gzip mans
  91. %{__gzip} -9fn %{buildroot}%{_mandir}/man1/*
  92. ########## install profiles
  93. #mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
  94. #cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
  95. #cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
  96. ########## move items to texmf dir
  97. %define texmfdir %{buildroot}/usr/share/texmf/
  98. mkdir -p %{texmfdir}/{tex,dvips,fonts}
  99. pushd %{buildroot}%{_datadir}/%{name}/%{version}/
  100. for d in dvips tex; do
  101. mv $d %{texmfdir}/$d/lilypond
  102. done
  103. for d in afm source tfm; do
  104. mkdir %{texmfdir}/fonts/$d
  105. mv fonts/$d %{texmfdir}/fonts/$d/lilypond
  106. done
  107. popd
  108. ############################################
  109. ########## install docs
  110. %{__make} prefix="%{buildroot}%{_prefix}" \
  111. infodir="%{buildroot}%{_infodir}" \
  112. webdir="%{buildroot}%{_docdir}/lilypond-documentation-%{version}/" web-install
  113. %{__rm} -f %{buildroot}/%{_infodir}/dir
  114. %{__gzip} -9fn `find %{buildroot}%{_infodir}/ -name '*.info'`
  115. ########## install icons
  116. install -d $RPM_BUILD_ROOT/%{iconsdir}
  117. install -m 644 Documentation/pictures/out-www/lelie-logo.png $RPM_BUILD_ROOT/%{iconsdir}/%{name}.png
  118. %clean
  119. %{__rm} -rf %{buildroot}
  120. %post
  121. touch /tmp/.lilypond-install
  122. %{__rm} `find /var/lib/texmf -name 'feta*pk' -or -name 'feta*tfm' -or -name 'parmesan*pk' -or -name 'parmesan*tfm' -print` /tmp/.lilypond-install
  123. /sbin/install-info %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
  124. /sbin/install-info %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
  125. if [ -x /usr/bin/texhash ]; then /usr/bin/env - /usr/bin/texhash 2> /dev/null ;fi
  126. if [ -x /usr/bin/updmap ]; then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
  127. /usr/X11R6/bin/mkfontdir %{_datadir}/lilypond/%{version}/fonts/type1/
  128. /usr/sbin/chkfontpath -q --add=%{_datadir}/lilypond/%{version}/fonts/type1/
  129. %preun
  130. if [ $1 = 0 ] ; then
  131. if [ -f /usr/share/lilypond/%{version}/ls-R ]; then
  132. %{__rm} -f /usr/share/lilypond/%{version}/ls-R
  133. fi
  134. fi
  135. if [ $1 = 0 ]; then
  136. /sbin/install-info --delete %{_infodir}/lilypond/lilypond.info.gz %{_infodir}/dir
  137. /sbin/install-info --delete %{_infodir}/lilypond/music-glossary.info.gz %{_infodir}/dir
  138. fi
  139. if [ -x /usr/bin/chkfontpath ] ; then
  140. chkfontpath --remove=%{_datadir}/lilypond/%{version}/fonts/type1/
  141. fi
  142. %postun
  143. # %{clean_menus}
  144. if [ -x /usr/bin/texhash ] ;then /usr/bin/env - /usr/bin/texhash 2> /dev/null;fi
  145. if [ -x /usr/bin/updmap ] ;then /usr/bin/env - /usr/bin/updmap 2> /dev/null;fi
  146. if [ -x /usr/bin/scrollkeeper-update ] ;then /usr/bin/env - /usr/bin/scrollkeeper-update 2> /dev/null;fi
  147. %post documentation
  148. if [ -x /usr/bin/scrollkeeper-update ] ; then
  149. scrollkeeper-update
  150. fi
  151. %postun documentation
  152. if [ -x /usr/bin/scrollkeeper-update ] ; then
  153. scrollkeeper-update
  154. fi
  155. %files
  156. %defattr(-, root, root)
  157. %doc AUTHORS.txt COPYING ChangeLog DEDICATION INSTALL.txt NEWS.txt README.txt
  158. %doc ROADMAP THANKS
  159. %{_datadir}/emacs/site-lisp/site-start.d/lilypond-*
  160. %{_datadir}/emacs/site-lisp/lilypond*
  161. %{_bindir}/*
  162. %{_infodir}/*
  163. %{_mandir}/man1/*
  164. %{_datadir}/%{name}/%{version}/
  165. %{_datadir}/locale/*/LC_MESSAGES/lilypond.mo
  166. %{_datadir}/texmf/dvips/lilypond/
  167. %{_datadir}/texmf/tex/lilypond/
  168. %{_datadir}/texmf/fonts/afm/lilypond/
  169. %{_datadir}/texmf/fonts/source/lilypond/
  170. %{_datadir}/texmf/fonts/tfm/lilypond/
  171. # %{_prefix}/../etc/profile.d/lilypond.*
  172. %iconsdir/%{name}.*
  173. %files -n liblilypond
  174. %defattr(-,root,root)
  175. %{_libdir}/%{name}/%{version}/python/*.so
  176. %files documentation
  177. %defattr(-, root, root)
  178. %{_docdir}/*
  179. %{_datadir}/omf/lilypond/%{version}
  180. %changelog
  181. * Sun Jul 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl2
  182. - rebuilt for VineSeed
  183. * Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 2.4.5-0vl1
  184. - build on Vine 3.1
  185. * Wed Mar 24 2004 Jun Nishii <jun@vinelinux.org> 2.0.3-0vl1
  186. - build for Vine Linux
  187. - many fixes in post/postun scripts
  188. * Fri Mar 12 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.30-1thac
  189. - Updated to latest devel release
  190. * Wed Mar 10 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.29-1thac
  191. - Updated to latest devel release
  192. * Wed Feb 25 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.27-1thac
  193. - Updated to latest devel release
  194. * Thu Feb 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.25-1thac
  195. - Updated to latest devel release
  196. * Tue Feb 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.24-1thac
  197. - Updated to latest devel release
  198. * Fri Feb 13 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.21-1thac
  199. - Updated to latest devel release
  200. - Built against latest pfaedit-040211 and mftrace-1.0.27
  201. - Added requirement for potrace
  202. * Mon Feb 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.20-1thac
  203. - Updated to latest devel release
  204. * Tue Jan 27 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.15-1thac
  205. - Updated to latest devel release
  206. * Sat Jan 24 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.14-1thac
  207. - Updated to latest devel release
  208. * Mon Jan 19 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.12-1thac
  209. - Updated to latest devel release
  210. * Sun Jan 18 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.11-1thac
  211. - Updated to latest devel release
  212. * Sat Jan 17 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.10-1thac
  213. - Updated to latest devel release
  214. * Thu Jan 15 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.9-1thac
  215. - Updated to latest devel release
  216. * Fri Jan 09 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.8-1thac
  217. - Updated to latest devel release
  218. * Tue Jan 06 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.7-1thac
  219. - Updated to latest devel release
  220. * Mon Jan 05 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.6-1thac
  221. - Updated to latest devel release
  222. * Fri Jan 02 2004 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.4-1thac
  223. - Updated to latest devel release
  224. * Sun Dec 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.3-1thac
  225. - Updated to latest devel release
  226. * Sun Dec 21 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.2-1thac
  227. - Updated to latest devel release
  228. * Thu Dec 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.1-1thac
  229. - Updated to latest devel release
  230. * Thu Oct 30 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-2thac
  231. - Rebuilt for Mandrake 9.2
  232. * Fri Oct 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.1.0-1thac
  233. - Updated to latest devel release
  234. * Mon Oct 06 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.1-1thac
  235. - Updated to latest devel release
  236. * Thu Sep 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 2.0.0-1thac
  237. - Updated to latest devel release
  238. - removed lilypond-words
  239. * Tue Sep 23 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.9-1thac
  240. - Updated to latest devel release
  241. - fixed lilypond.word install
  242. * Wed Sep 17 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.6-1thac
  243. - Updated to latest devel release
  244. * Thu Sep 11 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.5-1thac
  245. - Updated to latest devel release
  246. - Built against pyton2.3
  247. * Sun Sep 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.4-1thac
  248. - Updated to latest devel release
  249. * Sun Aug 31 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.3-1thac
  250. - Updated to latest devel release
  251. * Thu Aug 28 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.2-1thac
  252. - Updated to latest devel release
  253. * Wed Aug 27 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.9.1-1thac
  254. - Updated to latest devel release
  255. - Changed naming to differ from Mandrake cooker
  256. * Mon Aug 25 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-3mdk
  257. - Fixed documentation path
  258. - Added some of Heikki Johannes Junes suggestions
  259. * Sun Aug 24 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.8.1-2mdk
  260. - Added Heikki Johannes Junes fix for confilcting PHP variable
  261. out=/dev/vc/ by adding unset out before compiling
  262. - Compiled with recent guile = 1.6.4 and mftrace = 1.0.17
  263. - Changed icon to lilypond.png
  264. - Added menu and icons again
  265. * Thu Aug 23 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.8.1-1mdk
  266. - removed menu and icons, sync with redhat-spec
  267. * Thu Jun 12 2003 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.23-1mdk
  268. - refreshed dependencies and file list.
  269. * Sat Feb 01 2003 Torbjorn Turpeinen <tobbe@nyvalls.se> 1.7.12-1mdk
  270. - Built for Mandrake 9.1
  271. * Fri Dec 01 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.9-1mdk
  272. - set menu-items to lilypond-info and lilypond-documentation.
  273. * Fri Nov 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.8-4mdk
  274. - add pre/post-dependencies and menus with icon from source.
  275. * Fri Oct 28 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.7.4-1mdk
  276. - info, commented menu
  277. * Fri Aug 30 2002 Heikki Johannes Junes <hjunes@cc.hut.fi> 1.6.0-1mdk
  278. - Adapted from lilypond.redhat.skel and skeleton found in Mandrake's RPM-docs.
  279. - TODO: info (?) and dependencies.
  280. * Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
  281. - updated by Michael Brown <mbrown@linux-mandrake.com> :
  282. - Upgraded to 1.4.2
  283. - Changed URL
  284. - Removed /etc/profile.d scripts: all TeX bits are now located properly
  285. - Rearranged documentation
  286. - Tidied spec file
  287. - Updated README.first
  288. * Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
  289. - added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
  290. - Removed info files completely (couldn't get info reader to read them)
  291. - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
  292. * Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
  293. - Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
  294. - Added mktexlsr to post-install and post-uninstall scripts
  295. - Patched scripts in /etc/profile.d to reflect changes to font locations
  296. - Added QuickStart guide and Points to note sections to README.first (well worth reading)
  297. - Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
  298. * Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
  299. - First Mandrake package
  300. - spec file heavily adapted from PowerPC contribs.
  301. - Note HTML documentation may contain duff links and may be incomplete. Lots of warnings appear when building HTML docs.
  302. - PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
  303. - Created README.first file