python-whoosh-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. %global with_python3 1
  2. # For bootstrapping sphinxcontrib-websupport
  3. %bcond_with docs
  4. %global mod_name Whoosh
  5. Name: python-whoosh
  6. Version: 2.7.4
  7. Release: 13%{?_dist_release}
  8. Summary: Fast, pure-Python full text indexing, search, and spell checking library
  9. License: BSD
  10. URL: http://pythonhosted.org/Whoosh/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source0: https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
  14. BuildArch: noarch
  15. BuildRequires: python-rpm-macros
  16. BuildRequires: python-devel
  17. BuildRequires: python-setuptools
  18. %if %{with docs}
  19. BuildRequires: python-sphinx
  20. %endif
  21. %{?python_provide:%python_provide python2-whoosh}
  22. %if 0%{?with_python3}
  23. BuildRequires: python3-rpm-macros
  24. BuildRequires: python3-devel
  25. BuildRequires: python3-setuptools
  26. %endif
  27. %description
  28. Whoosh is a fast, featureful full-text indexing and searching library
  29. implemented in pure Python. Programmers can use it to easily add search
  30. functionality to their applications and websites. Every part of how Whoosh
  31. works can be extended or replaced to meet your needs exactly.
  32. %if 0%{?with_python3}
  33. %package -n python3-whoosh
  34. Summary: Fast, Python3 full text indexing, search, and spell checking library
  35. %{?python_provide:%python_provide python%{python3_pkgversion}-whoosh}
  36. %description -n python3-whoosh
  37. Whoosh is a fast, featureful full-text indexing and searching library
  38. implemented in pure Python. Programmers can use it to easily add search
  39. functionality to their applications and websites. Every part of how Whoosh
  40. works can be extended or replaced to meet your needs exactly.
  41. %endif
  42. %prep
  43. %setup -q -n %{mod_name}-%{version}
  44. %build
  45. %py_build
  46. %if %{with docs}
  47. sphinx-build docs/source docs/html
  48. rm -f docs/html/.buildinfo
  49. rm -rf docs/html/.doctrees
  50. %endif
  51. %if 0%{?with_python3}
  52. %py3_build
  53. rm -f docs/html/.buildinfo
  54. rm -rf docs/html/.doctrees
  55. %endif
  56. %install
  57. %py_install
  58. %if 0%{?with_python3}
  59. %py3_install
  60. %endif
  61. %check
  62. %{__python} setup.py test
  63. %if 0%{?with_python3}
  64. %{__python3} setup.py test
  65. %endif
  66. %files
  67. %license LICENSE.txt
  68. %doc README.txt
  69. %if %{with docs}
  70. %doc docs/html/
  71. %endif
  72. %{python_sitelib}/*.egg-info/
  73. %{python_sitelib}/whoosh
  74. %if 0%{?with_python3}
  75. %files -n python%{python3_pkgversion}-whoosh
  76. %license LICENSE.txt
  77. %doc README.txt
  78. %if %{with docs}
  79. %doc docs/html/
  80. %endif
  81. %{python3_sitelib}/whoosh
  82. %{python3_sitelib}/*.egg-info/
  83. %endif
  84. %changelog
  85. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-13
  86. - initial build for Vine Linux.
  87. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-12
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  89. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-11
  90. - Rebuilt for Python 3.7
  91. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-10
  92. - Bootstrap for Python 3.7
  93. * Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.4-9
  94. - Update Python 2 dependency declarations to new packaging standards
  95. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  96. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-8
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  98. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-7
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  100. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-6
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  102. * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-5
  103. - Enable tests
  104. * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-4
  105. - Rebuild for Python 3.6
  106. - Disable python3 tests for now
  107. * Wed Oct 12 2016 Orion Poplawski <orion@cora.nwra.com> - 2.7.4-3
  108. - Ship python2-whoosh
  109. - Build python3 package for EPEL7
  110. - Modernize spec
  111. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-2
  112. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  113. * Sun May 01 2016 Robert Kuska <rkuska@gmail.com> - 2.7.4-1
  114. - Update to version 2.7.4
  115. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  117. * Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> 2.7.0-1
  118. - Update to version 2.7.0
  119. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-5
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  121. * Wed Jul 30 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-4
  122. - Change spec for el6 and epel7
  123. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-3
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  125. * Fri May 16 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  127. * Mon Mar 03 2014 Robert Kuska <rkuska@redhat.com> - 2.5.7-1
  128. - Rebase to 2.5.7
  129. * Mon Jan 27 2014 Robert Kuska <rkuska@redhat.com> - 2.5.6-1
  130. - Rebase to 2.5.6
  131. * Tue Nov 19 2013 Robert Kuska <rkuska@redhat.com> - 2.5.5-1
  132. - Rebase to 2.5.5
  133. * Mon Sep 09 2013 Robert Kuska <rkuska@redhat.com> - 2.5.3-1
  134. - Rebase to 2.5.3
  135. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  137. * Mon Jul 08 2013 Robert Kuska <rkuska@redhat.com> - 2.5.1-1
  138. - Update source
  139. - Add python3 subpackage (rhbz#979235)
  140. * Mon Apr 08 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-2
  141. - Review fixes
  142. * Fri Apr 05 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-1
  143. - Initial package