python-virtualenv-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %global oname virtualenv
  2. Summary: Tool to create isolated Python environments
  3. Summary(ja): 隔離されたPython環境を構築するためのツール
  4. Name: python-%{oname}
  5. Version: 15.1.0
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. License: MIT
  9. URL: http://pypi.python.org/pypi/%{oname}
  10. Source0: http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
  11. # virtualenv -p "/usr/bin/python3" venv fails if there are not packages installed
  12. # under /usr/local/lib/pythonX.Y/site-packages. Check if exec_dir exists before
  13. # listing it's content.
  14. Patch0: check-exec_dir.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildArch: noarch
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: yasumichi
  20. BuildRequires: python-rpm-macros
  21. BuildRequires: python3-rpm-macros
  22. BuildRequires: python-devel
  23. Requires: python-devel
  24. BuildRequires: python-setuptools
  25. Requires: python-setuptools
  26. %description
  27. virtualenv is a tool to create isolated Python environments. virtualenv
  28. is a successor to workingenv, and an extension of virtual-python. It is
  29. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  30. licensed under an MIT-style permissive license.
  31. %package -n python3-virtualenv
  32. Summary: Tool to create isolated Python environments
  33. Summary(ja): 隔離されたPython環境を構築するためのツール
  34. Requires: python3-setuptools
  35. Requires: python3-devel
  36. %description -n python3-virtualenv
  37. virtualenv is a tool to create isolated Python environments. virtualenv
  38. is a successor to workingenv, and an extension of virtual-python. It is
  39. written by Ian Bicking, and sponsored by the Open Planning Project. It is
  40. licensed under an MIT-style permissive license
  41. %prep
  42. %setup -q -n %{oname}-%{version}
  43. %{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
  44. %patch0 -p1
  45. %build
  46. # Build code
  47. %{py_build}
  48. %{py3_build}
  49. %install
  50. rm -rf %{buildroot}
  51. %{py3_install}
  52. # rename binaries to use python3
  53. mv %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/py3-virtualenv
  54. # The versioned 3.x script was removed from upstream. Add it back.
  55. cp %{buildroot}/%{_bindir}/py3-virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python3_version}
  56. cp %{buildroot}/%{_bindir}/py3-virtualenv %{buildroot}/%{_bindir}/virtualenv-3
  57. %{py_install}
  58. # The versioned 2.x script was removed from upstream. Add it back.
  59. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python_version}
  60. cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-2
  61. %clean
  62. rm -rf %{buildroot}
  63. %files
  64. %defattr(-,root,root,-)
  65. %license LICENSE.txt
  66. %doc docs/*rst PKG-INFO AUTHORS.txt
  67. %{python_sitelib}/*
  68. %{_bindir}/virtualenv
  69. %{_bindir}/virtualenv-2
  70. %{_bindir}/virtualenv-%{python_version}
  71. %files -n python3-virtualenv
  72. %license LICENSE.txt
  73. %doc docs/*rst PKG-INFO AUTHORS.txt
  74. %{_bindir}/py3-virtualenv
  75. %{_bindir}/virtualenv-3
  76. %{_bindir}/virtualenv-%{python3_version}
  77. %{python3_sitelib}/virtualenv.py
  78. %{python3_sitelib}/virtualenv_support/
  79. %{python3_sitelib}/virtualenv-*.egg-info/
  80. %{python3_sitelib}/__pycache__/*
  81. %changelog
  82. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.1.0-1
  83. - new upstream release.
  84. - added Patch0.
  85. - made to use python{,3}-rpm-macros.
  86. - added a sub-package for python3.
  87. * Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
  88. - new upstream release
  89. - add Vendor, Distribution and Packager
  90. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
  91. - rebuild with python-2.7.2
  92. * Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
  93. - updated virtualenv to 1.5.1
  94. * Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
  95. - initial build for Vine Linux
  96. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
  97. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  98. * Wed Jul 7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
  99. - Fixed EPEL installation issue from BZ#611536
  100. * Tue Jun 8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
  101. - Only replace the python shebang on the first line (Robert Buchholz)
  102. * Wed Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
  103. - update pip to 0.7
  104. - move regen-docs into bin/
  105. - Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
  106. unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
  107. - unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
  108. - use the activate.sh in virtualenv.py via running bin/rebuild-script.py
  109. - add warning message if PYTHONHOME is set
  110. * Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
  111. - allow script creation without setuptools
  112. - fix problem with --relocate when bin/ has subdirs (fixes #12)
  113. - Allow more flexible .pth file fixup
  114. - make nt a required module, along with posix. it may not be a builtin module on jython
  115. - don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
  116. * Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
  117. - Updated for upstream release.
  118. * Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
  119. - Updated for upstream release.
  120. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  122. * Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
  123. - Updated for upstream release.
  124. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  126. * Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
  127. - Updated for upstream release.
  128. * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
  129. - Rebuild for Python 2.6
  130. * Mon Dec 1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
  131. - Added missing dependencies.
  132. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
  133. - Rebuild for Python 2.6
  134. * Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
  135. - Updated for upstream release
  136. * Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
  137. - Updated for upstream release
  138. * Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
  139. - Updated for upstream release
  140. * Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
  141. - Updated from review notes
  142. * Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
  143. - Updated from review notes
  144. * Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
  145. - Initial Version