python-urllib3-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %global srcname urllib3
  2. # When bootstrapping Python, we cannot test this yet
  3. %bcond_without tests
  4. Name: python-%{srcname}
  5. Version: 1.25.8
  6. Release: 1%{?_dist_release}
  7. Summary: Python HTTP library with thread-safe connection pooling and file post
  8. License: MIT
  9. URL: https://github.com/urllib3/urllib3
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
  13. # Unbundle ssl_match_hostname since we depend on it
  14. Source1: ssl_match_hostname_py3.py
  15. BuildArch: noarch
  16. %{?python_provide:%python_provide python2-%{srcname}}
  17. Requires: ca-certificates
  18. # Previously bundled things:
  19. Requires: python-six
  20. #Requires: python-backports-ssl_match_hostname
  21. # Secure extra requirements
  22. Requires: python-ipaddress
  23. Requires: python-pysocks
  24. BuildRequires: python-devel
  25. BuildRequires: python-rpm-macros
  26. BuildRequires: python-setuptools
  27. %description
  28. Python HTTP module with connection pooling and file POST abilities.
  29. %package -n python3-%{srcname}
  30. Summary: Python3 HTTP library with thread-safe connection pooling and file post
  31. BuildRequires: python3-devel
  32. BuildRequires: python3-rpm-macros
  33. BuildRequires: python3-setuptools
  34. Requires: ca-certificates
  35. Requires: python3-six
  36. Requires: python3-pysocks
  37. %description -n python3-%{srcname}
  38. Python3 HTTP module with connection pooling and file POST abilities.
  39. %prep
  40. %autosetup -p1 -n %{srcname}-%{version}
  41. # Drop the dummyserver tests in koji. They fail there in real builds, but not
  42. # in scratch builds (weird).
  43. rm -rf test/with_dummyserver/
  44. # Don't run the Google App Engine tests
  45. rm -rf test/appengine/
  46. # Lots of these tests started failing, even for old versions, so it has something
  47. # to do with Fedora in particular. They don't fail in upstream build infrastructure
  48. rm -rf test/contrib/
  49. # Tests for Python built without SSL, but Fedora builds with SSL. These tests
  50. # fail when combined with the unbundling of backports-ssl_match_hostname
  51. rm -f test/test_no_ssl.py
  52. %build
  53. %py_build
  54. %py3_build
  55. %install
  56. %py_install
  57. %py3_install
  58. # Unbundle the Python 2 build
  59. rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/six.py*
  60. #rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname/
  61. mkdir -p %{buildroot}/%{python_sitelib}/urllib3/packages/
  62. ln -s %{python_sitelib}/six.py %{buildroot}/%{python_sitelib}/urllib3/packages/six.py
  63. ln -s %{python_sitelib}/six.pyc %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyc
  64. ln -s %{python_sitelib}/six.pyo %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyo
  65. #ln -s %{python_sitelib}/backports/ssl_match_hostname \
  66. # %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname
  67. # Unbundle the Python 3 build
  68. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py*
  69. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/six*
  70. rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
  71. mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
  72. cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
  73. ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
  74. ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc \
  75. %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
  76. ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc \
  77. %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
  78. %files
  79. %license LICENSE.txt
  80. %doc CHANGES.rst README.rst CONTRIBUTORS.txt
  81. %{python_sitelib}/urllib3/
  82. %{python_sitelib}/urllib3-*.egg-info
  83. %files -n python3-%{srcname}
  84. %license LICENSE.txt
  85. %doc CHANGES.rst README.rst CONTRIBUTORS.txt
  86. %{python3_sitelib}/urllib3/
  87. %{python3_sitelib}/urllib3-*.egg-info
  88. %changelog
  89. * Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.8-1
  90. - new upstream release.
  91. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.24.1-3
  92. - initial build for Vine Linux.
  93. * Tue Nov 13 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-2
  94. - Adjust unbundling of ssl_match_hostname
  95. * Mon Oct 29 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-1
  96. - Update to v1.24.1
  97. * Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 1.23-4
  98. - Removed unneeded dependency python[23]-psutil
  99. * Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-3
  100. - Rebuilt for Python 3.7
  101. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-2
  102. - Bootstrap for Python 3.7
  103. * Tue Jun 05 2018 Jeremy Cline <jeremy@jcline.org> - 1.23-1
  104. - Update to the latest upstream release (rhbz 1586072)
  105. * Wed May 30 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-10
  106. - Backport patch to support Python 3.7 (rhbz 1584112)
  107. * Thu May 03 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.22-9
  108. - Do not lowercase hostnames with custom-protocol (rhbz 1567862)
  109. - upstream: https://github.com/urllib3/urllib3/issues/1267
  110. * Wed Apr 18 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-8
  111. - Drop the dependency on idna and cryptography (rhbz 1567862)
  112. * Mon Apr 16 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-7
  113. - Drop the dependency on PyOpenSSL, it's not needed (rhbz 1567862)
  114. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-6
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  116. * Wed Jan 31 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.22-5
  117. - Update Python 2 dependency declarations to new packaging standards
  118. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  119. * Thu Jan 25 2018 Tomas Hoger <thoger@redhat.com> - 1.22-4
  120. - Fix FTBFS - Move RECENT_DATE to 2017-06-30
  121. * Fri Dec 01 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-3
  122. - Symlink the Python 3 bytecode for six (rbhz 1519147)
  123. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  125. * Fri Jul 21 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-1
  126. - Update to 1.22 (#1473293)
  127. * Wed May 17 2017 Jeremy Cline <jeremy@jcline.org> - 1.21.1-1
  128. - Update to 1.21.1 (#1445280)
  129. * Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 1.20-1
  130. - Update to 1.20 (#1414775)
  131. * Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.19.1-2
  132. - Rebuild for Python 3.6
  133. * Thu Nov 17 2016 Jeremy Cline <jeremy@jcline.org> 1.19.1-1
  134. - Update to 1.19.1
  135. - Clean up the specfile to only support Fedora 26
  136. * Wed Aug 10 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-3
  137. - Rebuild now that python-requests is ready to update.
  138. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-2
  139. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  140. * Wed Jun 15 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-1
  141. - Update to 1.16
  142. * Thu Jun 02 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-3
  143. - Create python2 subpackage to comply with guidelines.
  144. * Wed Jun 01 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-2
  145. - Remove broken symlinks to unbundled python3-six files
  146. https://bugzilla.redhat.com/show_bug.cgi?id=1295015
  147. * Fri Apr 29 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-1
  148. - Removed patch for ipv6 support, now applied upstream.
  149. - Latest version.
  150. - New dep on pysocks.
  151. * Fri Feb 26 2016 Ralph Bean <rbean@redhat.com> - 1.13.1-3
  152. - Apply patch from upstream to fix ipv6.
  153. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  155. * Mon Dec 21 2015 Ralph Bean <rbean@redhat.com> - 1.13.1-1
  156. - new version
  157. * Fri Dec 18 2015 Ralph Bean <rbean@redhat.com> - 1.13-1
  158. - new version
  159. * Mon Dec 14 2015 Ralph Bean <rbean@redhat.com> - 1.12-1
  160. - new version
  161. * Thu Oct 15 2015 Robert Kuska <rkuska@redhat.com> - 1.10.4-7
  162. - Rebuilt for Python3.5 rebuild
  163. * Sat Oct 10 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-6
  164. - Sync from PyPI instead of a git checkout.
  165. * Tue Sep 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-5.20150503gita91975b
  166. - Drop requirement on python-backports-ssl_match_hostname on F22 and newer.
  167. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.4-4.20150503gita91975b
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  169. * Mon Jun 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-3.20150503gita91975b
  170. - Apply pyopenssl injection for an outdated cpython as per upstream advice
  171. https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
  172. https://urllib3.readthedocs.org/en/latest/security.html#pyopenssl
  173. * Tue May 19 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-2.20150503gita91975b
  174. - Specify symlinks for six.py{c,o}, fixing rhbz #1222142.
  175. * Sun May 03 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-1.20150503gita91975b
  176. - Latest release for python-requests-2.7.0
  177. * Wed Apr 29 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-2.20150429git585983a
  178. - Grab a git snapshot to get around this chunked encoding failure.
  179. * Wed Apr 22 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-1
  180. - new version
  181. * Thu Feb 26 2015 Ralph Bean <rbean@redhat.com> - 1.10.2-1
  182. - new version
  183. * Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
  184. - new version
  185. * Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
  186. - new version
  187. * Mon Jan 05 2015 Ralph Bean <rbean@redhat.com> - 1.10-2
  188. - Copy in a shim for ssl_match_hostname on python3.
  189. * Sun Dec 14 2014 Ralph Bean <rbean@redhat.com> - 1.10-1
  190. - Latest upstream 1.10, for python-requests-2.5.0.
  191. - Re-do unbundling without patch, with symlinks.
  192. - Modernize python2 macros.
  193. - Remove the with_dummyserver tests which fail only sometimes.
  194. * Wed Nov 05 2014 Ralph Bean <rbean@redhat.com> - 1.9.1-1
  195. - Latest upstream, 1.9.1 for latest python-requests.
  196. * Mon Aug 4 2014 Tom Callaway <spot@fedoraproject.org> - 1.8.2-4
  197. - fix license handling
  198. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  200. * Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.8.2-2
  201. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  202. * Mon Apr 21 2014 Arun S A G <sagarun@gmail.com> - 1.8.2-1
  203. - Update to latest upstream version
  204. * Mon Oct 28 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-2
  205. - Update patch to find ca_certs in the correct location.
  206. * Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
  207. - Latest upstream with support for a new timeout class and py3.4.
  208. * Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
  209. - Bump release again, just to push an unpaired update.
  210. * Mon Aug 26 2013 Ralph Bean <rbean@redhat.com> - 1.7-2
  211. - Bump release to pair an update with python-requests.
  212. * Thu Aug 22 2013 Ralph Bean <rbean@redhat.com> - 1.7-1
  213. - Update to latest upstream.
  214. - Removed the accept-header proxy patch which is included in upstream now.
  215. - Removed py2.6 compat patch which is included in upstream now.
  216. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
  217. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  218. * Tue Jun 11 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-6
  219. - Fix Requires of python-ordereddict to only apply to RHEL
  220. * Fri Mar 1 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-5
  221. - Unbundling finished!
  222. * Fri Mar 01 2013 Ralph Bean <rbean@redhat.com> - 1.5-4
  223. - Upstream patch to fix Accept header when behind a proxy.
  224. - Reorganize patch numbers to more clearly distinguish them.
  225. * Wed Feb 27 2013 Ralph Bean <rbean@redhat.com> - 1.5-3
  226. - Renamed patches to python-urllib3-*
  227. - Fixed ssl check patch to use the correct cert path for Fedora.
  228. - Included dependency on ca-certificates
  229. - Cosmetic indentation changes to the .spec file.
  230. * Tue Feb 5 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
  231. - python3-tornado BR and run all unittests on python3
  232. * Mon Feb 04 2013 Toshio Kuratomi <toshio@fedoraproject.org> 1.5-1
  233. - Initial fedora build.