python-sqlalchemy-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549
  1. %global with_python3 1
  2. %global srcname SQLAlchemy
  3. Name: python-sqlalchemy
  4. Version: 1.2.14
  5. Release: 1%{?_dist_release}
  6. Summary: Modular and flexible ORM library for python
  7. Group: Development/Libraries
  8. License: MIT
  9. URL: http://www.sqlalchemy.org/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: https://files.pythonhosted.org/packages/source/S/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildRequires: gcc
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python-devel >= 2.7
  16. BuildRequires: python-setuptools
  17. %if 0%{?with_python3}
  18. BuildRequires: python3-rpm-macros
  19. BuildRequires: python3-devel
  20. BuildRequires: python3-setuptools
  21. %endif
  22. %{?python_provide:%python_provide python2-sqlalchemy}
  23. %description
  24. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  25. high-level interface to SQL databases. Database and domain concepts are
  26. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  27. provides a powerful mapping layer that can work as automatically or as manually
  28. as you choose, determining relationships based on foreign keys or letting you
  29. define the join conditions explicitly, to bridge the gap between database and
  30. domain.
  31. This package includes the python 2 version of the module.
  32. %package doc
  33. Summary: Documentation for SQLAlchemy
  34. BuildArch: noarch
  35. %description doc
  36. Documentation for SQLAlchemy
  37. %if 0%{?with_python3}
  38. %package -n python3-sqlalchemy
  39. Summary: Modular and flexible ORM library for python
  40. Group: Development/Libraries
  41. %{?python_provide:%python_provide python%{python3_pkgversion}-sqlalchemy}
  42. %description -n python3-sqlalchemy
  43. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  44. high-level interface to SQL databases. Database and domain concepts are
  45. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  46. provides a powerful mapping layer that can work as automatically or as manually
  47. as you choose, determining relationships based on foreign keys or letting you
  48. define the join conditions explicitly, to bridge the gap between database and
  49. domain.
  50. This package includes the python 3 version of the module.
  51. %endif # with_python3
  52. %prep
  53. %setup -n %{srcname}-%{version}
  54. %build
  55. %py_build
  56. %if 0%{?with_python3}
  57. %py3_build
  58. %endif
  59. %install
  60. %py_install
  61. %if 0%{?with_python3}
  62. %py3_install
  63. %endif
  64. # remove unnecessary scripts for building documentation
  65. rm -rf doc/build
  66. %files doc
  67. %doc doc examples
  68. %files
  69. %license LICENSE
  70. %doc README.rst
  71. %{python_sitearch}/*
  72. %if 0%{?with_python3}
  73. %files -n python3-sqlalchemy
  74. %license LICENSE
  75. %doc README.rst
  76. %{python3_sitearch}/*
  77. %endif # with_python3
  78. %changelog
  79. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.14-1
  80. - new upstream release.
  81. - initial build for Vine Linux.
  82. * Tue Oct 30 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.12-1
  83. - version 1.2.12
  84. * Tue Aug 21 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.11-1
  85. - version 1.2.11
  86. * Sun Jul 22 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.10-1
  87. - version 1.2.10
  88. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.8-4
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  90. * Sun Jun 17 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.8-3
  91. - rename patch, apply with backups
  92. - fix failing test for sqlite 3.24 instead of skipping it
  93. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.8-2
  94. - Rebuilt for Python 3.7
  95. * Tue Jun 05 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.8-1
  96. - version 1.2.8
  97. * Sun Apr 22 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.7-1
  98. - version 1.2.7
  99. * Sat Mar 31 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.6-1
  100. - version 1.2.6
  101. * Mon Mar 19 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.5-1
  102. - version 1.2.5
  103. * Tue Feb 27 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.4-1
  104. - version 1.2.4
  105. * Tue Feb 20 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.3-2
  106. - require gcc for building
  107. * Tue Feb 20 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.3-1
  108. - version 1.2.3
  109. * Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2.2-3
  110. - Update Python 2 dependency declarations to new packaging standards
  111. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  112. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  114. * Tue Jan 30 2018 Nils Philippsen <nils@tiptoe.de> - 1.2.2-1
  115. - version 1.2.2
  116. * Sun Dec 31 2017 Nils Philippsen <nils@tiptoe.de> - 1.2.0-1
  117. - version 1.2.0
  118. - fix version-releases in changelog
  119. * Fri Sep 29 2017 Troy Dawson <tdawson@redhat.com> - 1.1.13-2
  120. - Cleanup spec file conditionals
  121. * Sat Aug 05 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.13-1
  122. - version 1.1.13
  123. * Tue Aug 01 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.12-1
  124. - version 1.1.12
  125. - remove comments with macros
  126. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.11-2
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  128. * Mon Jun 26 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.11-1
  129. - version 1.1.11
  130. * Sat May 27 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.10-1
  131. - version 1.1.10
  132. * Thu Apr 6 2017 hguemar <hguemar@fedoraproject.org> - 1.1.9-1
  133. - Upstream 1.1.9 (RHBZ#1436464)
  134. * Wed Mar 15 2017 Nils Philippsen <nils@tiptoe.de> - 1.1.6-1
  135. - version 1.1.6
  136. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.5-2
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  138. * Fri Feb 03 2017 Nils Philippsen <nils@redhat.com> - 1.1.5-1
  139. - version 1.1.5
  140. * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-3
  141. - Enable tests
  142. * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-2
  143. - Rebuild for Python 3.6
  144. - Disable python3 tests for now
  145. * Wed Nov 23 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.4-1
  146. - Update to 1.1.4. Fixes bug #1395470
  147. * Tue Nov 8 2016 Orion Poplawski <orion@cora.nwra.com> - 1.1.3-2
  148. - Ship python2-sqlalchemy
  149. - Move docs into sub-package
  150. - Modernize spec
  151. * Mon Oct 31 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.3-1
  152. - Update to 1.1.3. Fixes bug #1389638
  153. * Tue Oct 18 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.2-1
  154. - Update to 1.1.2. Fixes bug #1385990
  155. * Mon Oct 10 2016 Nils Philippsen <nils@redhat.com> - 1.1.1-1
  156. - version 1.1.1
  157. * Thu Oct 06 2016 Kevin Fenzi <kevin@scrye.com> - 1.1.0-1
  158. - Update to 1.1.0. Fixes bug #1382203
  159. * Thu Aug 18 2016 Nils Philippsen <nils@redhat.com> - 1.0.14-1
  160. - version 1.0.14
  161. * Tue May 31 2016 Nils Philippsen <nils@redhat.com> - 1.0.14-1
  162. - fix source URL
  163. * Tue May 17 2016 Nils Philippsen <nils@redhat.com> - 1.0.13-1
  164. - version 1.0.13
  165. * Thu Feb 25 2016 Nils Philippsen <nils@redhat.com> - 1.0.12-1
  166. - version 1.0.12
  167. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.11-2
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  169. * Fri Jan 08 2016 Kevin Fenzi <kevin@scrye.com> - 1.0.11-1
  170. - Update to 1.0.11. Fixes bug #1296757
  171. * Sat Dec 12 2015 Kevin Fenzi <kevin@scrye.com> - 1.0.10-1
  172. - Update to 1.0.10. Fixes bug #1290945
  173. * Thu Nov 12 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.9-2
  174. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  175. * Wed Oct 21 2015 Nils Philippsen <nils@redhat.com> - 1.0.9-1
  176. - version 1.0.9, upstream feature and bugfix release
  177. * Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> - 1.0.8-2
  178. - Rebuilt for Python3.5 rebuild
  179. * Fri Jul 24 2015 Nils Philippsen <nils@redhat.com> 1.0.8-1
  180. - version 1.0.8, upstream bugfix release
  181. * Tue Jul 21 2015 Fedora Release Monitoring <release-monitoring@fedoraproject.org> - 1.0.7-1
  182. - Update to 1.0.7 (#1244991)
  183. * Mon Jun 29 2015 Nils Philippsen <nils@redhat.com> 1.0.6-1
  184. - version 1.0.6, upstream feature and bugfix release
  185. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  187. * Sun Jun 07 2015 Kevin Fenzi <kevin@scrye.com> 1.0.4-1
  188. - Update to 1.0.5. Fixes bug #1229067
  189. * Fri May 08 2015 Nils Philippsen <nils@redhat.com> 1.0.4-1
  190. - version 1.0.4, upstream bugfix release
  191. * Sat May 02 2015 Kevin Fenzi <kevin@scrye.com> 1.0.3-1
  192. - Update to 1.0.3. Fixes bug #1217761
  193. * Sat Apr 25 2015 Nils Philippsen <nils@redhat.com> - 1.0.2-1
  194. - version 1.0.2, upstream bugfix release
  195. * Fri Apr 24 2015 Nils Philippsen <nils@redhat.com> - 1.0.1-1
  196. - version 1.0.1, upstream bugfix release
  197. * Fri Apr 17 2015 Nils Philippsen <nils@redhat.com> - 1.0.0-1
  198. - version 1.0.0, upstream feature release
  199. * Fri Apr 10 2015 Nils Philippsen <nils@redhat.com> - 0.9.9-1
  200. - version 0.9.9, upstream feature and bugfix release
  201. * Wed Oct 15 2014 Nils Philippsen <nils@redhat.com> - 0.9.8-1
  202. - version 0.9.8, upstream feature and bugfix release
  203. - avoid using unversioned python macros
  204. - use py.test instead of nose for tests
  205. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.7-2
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  207. * Tue Jul 29 2014 Nils Philippsen <nils@redhat.com> - 0.9.7-1
  208. - version 0.9.7, upstream feature and bugfix release
  209. * Mon Jun 30 2014 Nils Philippsen <nils@redhat.com> - 0.9.6-1
  210. - version 0.9.6, upstream feature and bugfix release
  211. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-3
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  213. * Fri May 16 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.9.4-2
  214. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  215. * Thu May 15 2014 Nils Philippsen <nils@redhat.com> - 0.9.4-1
  216. - version 0.9.4, upstream feature and bugfix release
  217. * Thu Feb 20 2014 Nils Philippsen <nils@redhat.com> - 0.9.3-1
  218. - version 0.9.3, upstream feature and bugfix release
  219. * Wed Feb 05 2014 Nils Philippsen <nils@redhat.com> - 0.9.2-1
  220. - version 0.9.2, upstream feature and bugfix release
  221. * Tue Jan 07 2014 Nils Philippsen <nils@redhat.com> - 0.9.1-1
  222. - version 0.9.1, upstream feature and bugfix release
  223. - no need to use 2to3 for python 3.x anymore
  224. - build C extension for python 3.x
  225. - require python2-devel >= 2.6 for building
  226. * Mon Dec 09 2013 Nils Philippsen <nils@redhat.com> - 0.8.4-1
  227. - version 0.8.4, upstream bugfix release
  228. * Tue Oct 29 2013 Nils Philippsen <nils@redhat.com> - 0.8.3-1
  229. - version 0.8.3, upstream bugfix release
  230. * Wed Aug 14 2013 Nils Philippsen <nils@redhat.com> - 0.8.2-1
  231. - version 0.8.2, upstream bugfix release
  232. - drop obsolete sqlalchemy-test-bidirectional-order patch
  233. - fix bogus date in changelog
  234. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  235. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  236. * Mon Apr 29 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.1-1
  237. - Upstream bugfix
  238. - Stop calling sa2to3 explicitly on the library. It seems to break mapper.py's
  239. import of collections.deque
  240. * Fri Apr 12 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.0-1
  241. - Final release of 0.8.0
  242. - Fix for a unittest that assumes order in dicts
  243. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-0.2.b1
  244. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  245. * Thu Nov 1 2012 Toshio Kuratomi <toshio@fedoraproject.org> - 0.8.0-0.1.b1
  246. - Update to 0.8.0 beta
  247. * Mon Aug 13 2012 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.8-4.20120813hg8535
  248. - Update to a snapshot to fix unittest errors with python-3.3
  249. * Fri Aug 3 2012 David Malcolm <dmalcolm@redhat.com> - 0.7.8-3
  250. - remove rhel logic from with_python3 conditional
  251. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.8-2
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  253. * Mon Jun 18 2012 Nils Philippsen <nils@redhat.com> - 0.7.8-1
  254. - Upstream bugfix release
  255. * Tue May 15 2012 Nils Philippsen <nils@redhat.com> - 0.7.7-1
  256. - Upstream bugfix release
  257. * Tue Mar 20 2012 Nils Philippsen <nils@redhat.com> - 0.7.6-1
  258. - Upstream bugfix release
  259. * Mon Jan 30 2012 Nils Philippsen <nils@redhat.com> - 0.7.5-1
  260. - Upstream bugfix release
  261. - package README.rst instead of README as documentation
  262. * Tue Jan 10 2012 Nils Philippsen <nils@redhat.com> - 0.7.3-2
  263. - rebuild for gcc 4.7
  264. * Mon Oct 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.3-1
  265. - Upstream bugfix release
  266. * Mon Aug 1 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.2-1
  267. - Upstream bugfix release
  268. * Mon Jun 06 2011 Nils Philippsen <nils@redhat.com> - 0.7.1-1
  269. - 0.7.1 Upstream release
  270. - no need to fix examples/dynamic_dict/dynamic_dict.py anymore
  271. - use sqla_nose.py to fix %%check
  272. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-2
  273. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  274. * Mon Jan 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.6-1
  275. - 0.6.6 Upstream release
  276. * Fri Dec 3 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-1
  277. - 0.6.5 Upstream release
  278. * Wed Sep 29 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-2
  279. - Filter out the C extensions from provides
  280. * Tue Sep 07 2010 Luke Macken <lmacken@redhat.com> - 0.6.4-1
  281. - 0.6.4 upstream release
  282. * Mon Aug 23 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.3-1
  283. - 0.6.3 upstream release
  284. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com>
  285. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  286. * Thu Jun 24 2010 Nils Philippsen <nils@redhat.com> - 0.6.1-1
  287. - 0.6.1 upstream release
  288. * Tue Apr 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.4.beta3
  289. - Build beta3
  290. * Fri Mar 19 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.3.beta2
  291. - Build beta2 with cextension
  292. * Sun Mar 7 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.2.beta1
  293. - Build python3 package
  294. * Tue Mar 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.1.beta1
  295. - 0.6 beta1 upstream release
  296. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-3
  297. - One last cleanup
  298. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-2
  299. - just some cleanups to older styles of building packages.
  300. * Mon Feb 1 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-1
  301. - Upstream bugfix release 0.5.8
  302. * Fri Aug 14 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.5-2
  303. - Upstream bugfix release 0.5.5
  304. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.4-2.p2
  305. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  306. * Fri Jun 12 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.4-1.p2
  307. - Upstream bugfix release 0.5.4p2.
  308. * Thu Apr 16 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.3-1
  309. - Upstream bugfix release.
  310. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  312. * Wed Feb 11 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.2-1
  313. - Update to 0.5.2
  314. * Wed Jan 21 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.1-1
  315. - Update to 0.5.1.
  316. * Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5-0.1.rc4
  317. - Update to 0.5.0rc4 which works with the new pysqlite
  318. - And update test cases to work with the new pysqlite
  319. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.7-2
  320. - Rebuild for Python 2.6
  321. * Sun Jul 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.7-1
  322. - Update to 0.4.7.
  323. * Sun Jun 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.6-1
  324. - Update to 0.4.6.
  325. * Tue Apr 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.5-1
  326. - Update to 0.4.5.
  327. * Fri Feb 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.3-1
  328. - Update to 0.4.3.
  329. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.2-1.p3
  330. - Update to 0.4.2p3.
  331. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.1-1
  332. - Update to 0.4.1.
  333. * Wed Oct 17 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.0-1
  334. - SQLAlchemy-0.4.0 final
  335. - Run the testsuite
  336. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> 0.4.0-0.4.beta6
  337. - SQLAlchemy-0.4.0beta6
  338. * Tue Sep 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta5
  339. - Update to 0.4beta5.
  340. * Fri Sep 07 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta4
  341. - setuptools has been fixed.
  342. * Fri Aug 31 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.3.beta4
  343. - setuptools seems to be broken WRT having an active and inactive version
  344. of an egg. Have to make both versions inactive and manually setup a copy
  345. that can be started via import. (Necessary for the sqlalchemy0.3 compat
  346. package.)
  347. * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.2.beta4
  348. - Modify setuptools to handle the -devel subpackage split in F-8.
  349. * Mon Aug 27 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.0-0.1.beta4
  350. - Update to 0.4 beta4.
  351. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-2
  352. - Remove python-abi Requires. This is automatic since FC4+.
  353. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-1
  354. - Update to new upstream version 0.3.10
  355. * Fri Mar 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.6-1
  356. - Update to new upstream version 0.3.6
  357. * Sat Mar 10 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.5-1
  358. - Update to new upstream version 0.3.5
  359. - Simplify the files listing
  360. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-2
  361. - Remember to upload the source tarball to the lookaside cache.
  362. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-1
  363. - Update to new upstream version 0.3.4
  364. * Mon Jan 01 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.3-1
  365. - Update to new upstream version 0.3.3
  366. * Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-2
  367. - Bump and rebuild for python 2.5 on devel.
  368. - BuildRequire: python-devel as a header is missing otherwise.
  369. * Fri Nov 24 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-1
  370. - Update to new upstream version 0.3.1
  371. * Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 0.2.7-2
  372. - Rebuild for FC6
  373. * Thu Aug 17 2006 Shahms E. King <shahms@shahms.com> 0.2.7-1
  374. - Update to new upstream version
  375. * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.2.6-2
  376. - Include, don't ghost .pyo files per new guidelines
  377. * Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 0.2.6-1
  378. - Update to new upstream version
  379. * Fri Jul 07 2006 Shahms E. King <shahms@shahms.com> 0.2.4-1
  380. - Update to new upstream version
  381. * Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.2.3-1
  382. - Update to new upstream version
  383. * Wed May 31 2006 Shahms E. King <shahms@shahms.com> 0.2.1-1
  384. - Update to new upstream version