python-simplejson-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %global _use_internal_dependency_generator 0
  3. %global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
  4. %global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
  5. Name: python-simplejson
  6. Version: 3.4.1
  7. Release: 1%{?_dist_release}
  8. Summary: Simple, fast, extensible JSON encoder/decoder for Python
  9. Group: System Environment/Libraries
  10. # The main code is licensed MIT.
  11. # The docs include jquery which is licensed MIT or GPLv2
  12. License: MIT and (MIT or GPLv2)
  13. URL: http://undefined.org/python/#simplejson
  14. Source0: http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: python-devel
  17. BuildRequires: python-setuptools
  18. BuildRequires: python-nose
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. simplejson is a simple, fast, complete, correct and extensible JSON
  23. <http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
  24. with no dependencies, but includes an optional C extension for a serious speed
  25. boost.
  26. simplejson is the externally maintained development version of the json library
  27. included with Python 2.6 and Python 3.0, but maintains backwards compatibility
  28. with Python 2.5.
  29. The encoder may be subclassed to provide serialization in any kind of
  30. situation, without any special support by the objects to be serialized
  31. (somewhat like pickle).
  32. The decoder can handle incoming JSON strings of any specified encoding (UTF-8
  33. by default).
  34. %prep
  35. %setup -q -n simplejson-%{version}
  36. %build
  37. %{__python} setup.py build
  38. %install
  39. %__rm -rf $RPM_BUILD_ROOT
  40. %{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
  41. %check
  42. nosetests -q
  43. %clean
  44. %__rm -rf $RPM_BUILD_ROOT
  45. %files
  46. %defattr(-,root,root,-)
  47. %doc CHANGES.txt LICENSE.txt
  48. %dir %{python_sitearch}/simplejson
  49. %{python_sitearch}/simplejson-*.egg-info
  50. %{python_sitearch}/simplejson/*.py*
  51. %{python_sitearch}/simplejson/tests/*.py*
  52. %{python_sitearch}/simplejson/_speedups.so
  53. %changelog
  54. * Sat May 03 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.1-1
  55. - new upstream release
  56. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-3
  57. - rebuild with VineSeed environment
  58. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-2
  59. - rebuild with python-2.7.2
  60. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
  61. - updated simplejson to 2.1.2
  62. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
  63. - initial build based on Fedora development
  64. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
  65. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  66. * Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
  67. - Filter unnecessary provides
  68. - License tag update
  69. - Minor spec file cleanups
  70. * Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
  71. - Update to 2.1.1
  72. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  74. * Fri Jun 5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
  75. - Remove ill-advised gcc BuildRequires
  76. * Thu Jun 4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
  77. - Update to 2.0.9
  78. - Make sure to require gcc to the speedups get compiled
  79. - Fix description since we're not "pure" python
  80. - Change to pypi instead of cheesehop
  81. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  83. * Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
  84. - Update to 2.0.7
  85. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
  86. - Rebuild for Python 2.6
  87. * Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
  88. - Use nose to run the simplejson test suite
  89. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
  90. - update to 2.0.3
  91. * Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
  92. - Update to 2.0.1, which contains many optimizations and bugfixes
  93. * Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
  94. - Update to 1.9.3, which includes a significant decoding speed boost, and
  95. various bug fixes.
  96. * Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
  97. - Update to 1.9.1
  98. * Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
  99. - Update to 1.8.1
  100. * Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
  101. - Update to 1.7.4
  102. * Fri Feb 8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
  103. - Rebuild for gcc 4.3
  104. * Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
  105. - Include the LICENSE.txt
  106. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
  107. - 1.7.3
  108. * Sun Sep 2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
  109. - Update for python-setuptools changes in rawhide
  110. * Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
  111. - Rebuild
  112. * Sun Jul 8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
  113. - 1.7.1
  114. * Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
  115. - Use python_sitearch instead of sitelib
  116. * Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
  117. - 1.7 (Bug #233212)
  118. * Sat Mar 3 2007 Luke Macken <lmacken@redhat.com> - 1.5
  119. - 1.5
  120. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
  121. - Add python-devel to BuildRequires
  122. * Sat Dec 9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
  123. - Rebuild for new python
  124. * Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
  125. - 1.4
  126. * Sun Sep 3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
  127. - Rebuild for FC6
  128. * Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
  129. - Include .pyo's instead of just ghosting them
  130. * Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
  131. - Add --single-version-externally-managed flag to install
  132. * Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
  133. - Initial package