python-requests-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. Summary: Python HTTP for Humans
  2. Name: python-requests
  3. Version: 2.23.0
  4. Release: 1%{?_dist_release}
  5. License: ASLv2
  6. Group: Development/Languages
  7. URL: https://pypi.python.org/pypi/requests
  8. Source0: https://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
  9. # Explicitly use the system certificates in ca-certificates.
  10. # https://bugzilla.redhat.com/show_bug.cgi?id=904614
  11. Patch0: patch-requests-certs.py-to-use-the-system-CA-bundle.patch
  12. # https://bugzilla.redhat.com/show_bug.cgi?id=1450608
  13. Patch2: Remove-tests-that-use-the-tarpit.patch
  14. # Use 127.0.0.1 not localhost for socket.bind() in the Server test
  15. # class, to fix tests in Koji's no-network environment
  16. # This probably isn't really upstreamable, because I guess localhost
  17. # could technically be IPv6 or something, and our no-network env is
  18. # a pretty odd one so this is a niche requirement.
  19. Patch3: requests-2.12.4-tests_nonet.patch
  20. # https://bugzilla.redhat.com/show_bug.cgi?id=1567862
  21. Patch4: Don-t-inject-pyopenssl-into-urllib3.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. Requires: python
  24. Requires: python-urllib3
  25. Requires: python-chardet
  26. Requires: python-idna
  27. BuildRequires: python-devel
  28. BuildRequires: python-rpm-macros
  29. BuildRequires: python-setuptools
  30. BuildRequires: python3-devel
  31. BuildRequires: python3-rpm-macros
  32. BuildRequires: python3-setuptools
  33. BuildArch: noarch
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. Packager: iwaim
  37. %description
  38. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  39. %package -n python3-requests
  40. Summary: Python HTTP for Humans
  41. Group: Development/Languages
  42. Requires: python3
  43. Requires: python3-urllib3
  44. Requires: python3-chardet
  45. Requires: python3-idna
  46. %description -n python3-requests
  47. Requests is an Apache2 Licensed HTTP library, written in Python, for human beings.
  48. %prep
  49. %autosetup -p1 -n requests-%{version}
  50. # Unbundle the certificate bundle from mozilla.
  51. rm -rf requests/cacert.pem
  52. # env shebang in nonexecutable file
  53. sed -i '/#!\/usr\/.*python/d' requests/certs.py
  54. %build
  55. %py_build
  56. %py3_build
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. %py_install
  60. %py3_install
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %defattr(-,root,root,-)
  65. %license LICENSE
  66. %doc README* HISTORY*
  67. %{python_sitelib}/requests
  68. %{python_sitelib}/requests-%{version}-py*.egg-info
  69. %files -n python3-requests
  70. %defattr(-,root,root,-)
  71. %license LICENSE
  72. %doc README* HISTORY*
  73. %{python3_sitelib}/requests
  74. %{python3_sitelib}/requests-%{version}-py*.egg-info
  75. %changelog
  76. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.23.0-1
  77. - new upstream release.
  78. - updated patches.
  79. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-2
  80. - fixed R:.
  81. - imported Patch0-4 from rawhide.
  82. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.20.1-1
  83. - new upstream release.
  84. - add python2 support.
  85. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.1-2
  86. - rebuild with python3-3.5.2
  87. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 2.5.1-1
  88. - Initial build.