python-pysocks-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. %global pypi_name PySocks
  2. %global modname pysocks
  3. %global sum A Python SOCKS client module
  4. Name: python-%{modname}
  5. Version: 1.6.8
  6. Release: 7%{?_dist_release}
  7. Summary: %{sum}
  8. License: BSD
  9. URL: https://github.com/Anorov/%{pypi_name}
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: https://files.pythonhosted.org/packages/source/P/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Patch0: https://github.com/Anorov/PySocks/commit/d74c3f1d34d07a001656453823a153ea0c865449.patch
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. BuildRequires: python-rpm-macros
  18. %{?python_provide:%python_provide python2-%{modname}}
  19. %global _description \
  20. A fork of SocksiPy with bug fixes and extra features.\
  21. \
  22. Acts as a drop-in replacement to the socket module. Featuring:\
  23. \
  24. - SOCKS proxy client for Python 2.6 - 3.x\
  25. - TCP and UDP both supported\
  26. - HTTP proxy client included but not supported or recommended (you should use\
  27. urllib2's or requests' own HTTP proxy interface)\
  28. - urllib2 handler included.
  29. %description
  30. %_description
  31. %package -n python3-%{modname}
  32. Summary: %{sum}
  33. BuildRequires: python3-devel
  34. BuildRequires: python3-setuptools
  35. BuildRequires: python3-rpm-macros
  36. %{?python_provide:%python_provide python3-%{modname}}
  37. %description -n python3-%{modname}
  38. %_description
  39. This package is for Python3 version %{python3_version} only.
  40. %prep
  41. %autosetup -n %{pypi_name}-%{version}
  42. # drop useless 3rdparty code
  43. rm -rfv test/bin
  44. %build
  45. %py_build
  46. %py3_build
  47. %install
  48. %py_install
  49. %py3_install
  50. %check
  51. %files
  52. %doc README.md
  53. %license LICENSE
  54. %{python_sitelib}/socks.py*
  55. %{python_sitelib}/sockshandler.py*
  56. %{python_sitelib}/%{pypi_name}-%{version}*
  57. %files -n python3-%{modname}
  58. %doc README.md
  59. %license LICENSE
  60. %{python3_sitelib}/socks.py*
  61. %{python3_sitelib}/sockshandler.py*
  62. %{python3_sitelib}/__pycache__/*socks*
  63. %{python3_sitelib}/%{pypi_name}-%{version}-*
  64. %changelog
  65. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.8-7
  66. - initial build for Vine Linux.
  67. * Sun Nov 11 2018 Kevin Fenzi <kevin@scrye.com> - 1.6.8-6
  68. - Add upstream patch to avoid DeprecationWarning. Fixes bug #1648583
  69. * Wed Oct 03 2018 Raphael Groner <projects.rg@smart.ms> - 1.6.8-5
  70. - add python3_other subpackage for epel7
  71. - prepare removal of python2 subpackage in Fedora
  72. - use pypi macros
  73. - try to enable tests provided actually from tarball
  74. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-4
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  76. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.6.8-3
  77. - Rebuilt for Python 3.7
  78. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.8-2
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  80. * Fri Dec 22 2017 Kevin Fenzi <kevin@scrye.com> - 1.6.8-1
  81. - Update to 1.6.8. Fixes bug #1528490
  82. * Mon Sep 11 2017 Carl George <carl@george.computer> - 1.6.7-1
  83. - Latest upstream
  84. - Add setuptools dependency
  85. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-5
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  87. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.7-4
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  89. * Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.7-3
  90. - Rebuild for Python 3.6
  91. * Mon Nov 28 2016 Tim Orling <ticotimo@gmail.com> - 1.5.7-2
  92. - Ship python34-pysocks in EL6
  93. * Sat Sep 17 2016 Kevin Fenzi <kevin@scrye.com> - 1.5.7-1
  94. - Update to 1.5.7
  95. * Fri Sep 16 2016 Orion Poplawski <orion@cora.nwra.com> - 1.5.6-6
  96. - Ship python34-pysocks in EPEL7
  97. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-5
  98. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  99. * Fri Jul 15 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-4
  100. - Change our conflicts on python-SocksiPy to an obsoletes/provides.
  101. https://bugzilla.redhat.com/show_bug.cgi?id=1334407
  102. * Mon May 09 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-3
  103. - Fix typo in explicit conflicts.
  104. * Tue May 03 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-2
  105. - We don't actually need setuptools here.
  106. * Mon May 02 2016 Ralph Bean <rbean@redhat.com> - 1.5.6-1
  107. - Initial package for Fedora