python-pycurl-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. %define modname pycurl
  2. Name: python-%{modname}
  3. Version: 7.43.0.2
  4. Release: 1%{?_dist_release}
  5. Summary: A Python interface to libcurl
  6. Summary(ja): libcurl の Python インタフェース
  7. Group: Development/Languages
  8. License: LGPLv2+
  9. URL: http://pycurl.sourceforge.net/
  10. Source0: http://pycurl.sourceforge.net/download/pycurl-%{version}.tar.gz
  11. # fix programming mistakes detected by static analyzers
  12. # upstream pull request: https://github.com/pycurl/pycurl/pull/550
  13. Patch1: 0001-python-pycurl-7.43.0.2-static-analysis.patch
  14. # drop link-time vs. run-time TLS backend check (#1446850)
  15. Patch2: 0002-python-pycurl-7.43.0-tls-backend.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: python-devel
  18. BuildRequires: python-rpm-macros
  19. BuildRequires: curl-devel >= 7.19.0
  20. BuildRequires: openssl-devel
  21. BuildRequires: openldap-devel
  22. # During its initialization, PycURL checks that the actual libcurl version
  23. # is not lower than the one used when PycURL was built.
  24. # Yes, that should be handled by library versioning (which would then get
  25. # automatically reflected by rpm).
  26. # For now, we have to reflect that dependency.
  27. %define libcurl_sed '/^#define LIBCURL_VERSION "/!d;s/"[^"]*$//;s/.*"//;q'
  28. %define curlver_h /usr/include/curl/curlver.h
  29. %define libcurl_ver %(sed %{libcurl_sed} %{curlver_h} 2>/dev/null || echo 0)
  30. Requires: curl >= %{libcurl_ver}
  31. Provides: %{modname} = %{version}-%{release}
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. PycURL is a Python interface to libcurl. PycURL can be used to fetch
  36. objects identified by a URL from a Python program, similar to the
  37. urllib Python module. PycURL is mature, very fast, and supports a lot
  38. of features.
  39. %package -n python3-%{modname}
  40. Summary: A Python3 interface to libcurl
  41. Summary(ja): libcurl の Python3 インタフェース
  42. BuildRequires: python3-devel
  43. BuildRequires: python3-rpm-macros
  44. %description -n python3-%{modname}
  45. PycURL is a Python interface to libcurl. PycURL can be used to fetch
  46. objects identified by a URL from a Python program, similar to the
  47. urllib Python module. PycURL is mature, very fast, and supports a lot
  48. of features.
  49. %prep
  50. %autosetup -n %{modname}-%{version} -p1
  51. # remove binaries packaged by upstream
  52. rm -f tests/fake-curl/libcurl/*.so
  53. # remove a test-case that relies on sftp://web.sourceforge.net being available
  54. rm -f tests/ssh_key_cb_test.py
  55. # remove a test-case that fails in Koji
  56. rm -f tests/seek_cb_test.py
  57. # remove tests depending on the 'flaky' nose plug-in
  58. grep '^import flaky' -r tests | cut -d: -f1 | xargs rm -fv
  59. # drop options that are not supported by nose
  60. sed -e 's/ --show-skipped//' \
  61. -e 's/ --with-flaky//' \
  62. -i tests/run.sh
  63. %build
  64. %py_build -- --with-openssl
  65. %py3_build -- --with-openssl
  66. %check
  67. #export PYTHONPATH=$PWD/build/lib*
  68. #%{__python} tests/test_internals.py -q
  69. %install
  70. rm -rf %{buildroot}
  71. export PYCURL_SSL_LIBRARY=openssl
  72. %py_install
  73. %py3_install
  74. rm -rf %{buildroot}%{_datadir}/doc/pycurl
  75. %clean
  76. rm -rf %{buildroot}
  77. %files
  78. %defattr(-,root,root,-)
  79. %license COPYING-LGPL COPYING-MIT
  80. %doc ChangeLog README.rst examples doc tests
  81. %{python_sitearch}/*
  82. %files -n python3-%{modname}
  83. %defattr(-,root,root,-)
  84. %license COPYING-LGPL COPYING-MIT
  85. %doc ChangeLog README.rst examples doc tests
  86. %{python3_sitearch}/*
  87. %changelog
  88. * Wed Apr 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0.2-1
  89. - new upstream release.
  90. - added python3 support.
  91. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-5
  92. - rebuild with VineSeed environment
  93. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.19.0-4
  94. - rebuild with python-2.7.2
  95. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 7.19.0-3
  96. - rebuild with python-2.6
  97. * Sat Aug 8 2009 Shu KONNO <owa@bg.wakwak.com> - 7.19.0-2
  98. - spec in utf-8
  99. - added BR: openldap-devel
  100. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 7.19.0-1
  101. - initial build for VineSeed
  102. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.19.0-4
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  104. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-3
  105. - fix typo in the previous change
  106. * Fri Apr 17 2009 Stepan Kasal <skasal@redhat.com> - 7.19.0-2
  107. - add a require to reflect a dependency on libcurl version (#496308)
  108. * Thu Mar 5 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.19.0-1
  109. - Update to 7.19.0
  110. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.18.2-3
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  112. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 7.18.2-2
  113. - Rebuild for Python 2.6
  114. * Thu Jul 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.2-1
  115. - Update to 7.18.2
  116. - Thanks to Ville Skytt辰 re-enable the tests and fix a minor problem
  117. with the setup.py. (Bug # 45400)
  118. * Thu Jun 5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.18.1-1
  119. - Update to 7.18.1
  120. - Disable tests because it's not testing the built library, it's trying to
  121. test an installed library.
  122. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.16.4-3
  123. - Autorebuild for GCC 4.3
  124. * Thu Jan 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-2
  125. - BR openssl-devel
  126. * Wed Aug 29 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.4-1
  127. - Update to 7.16.4
  128. - Update license tag.
  129. * Sat Jun 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.2.1-1
  130. - Update to released version.
  131. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.16.0-0.1.20061207
  132. - Update to a CVS snapshot since development has a newer version of curl than is in FC <= 6
  133. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-4
  134. - Add -DHAVE_CURL_OPENSSL to fix PPC build problem.
  135. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-3
  136. - Don't forget to Provide: pycurl!!!
  137. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-2
  138. - Remove INSTALL from the list of documentation
  139. - Use python_sitearch for all of the files
  140. * Thu Dec 7 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 7.15.5.1-1
  141. - First version for Fedora Extras