python-polib-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. Name: python-polib
  2. Version: 1.0.3
  3. Release: 1%{?_dist_release}
  4. Summary: A library to parse and manage gettext catalogs
  5. Group: Development/Languages
  6. License: MIT
  7. URL: http://bitbucket.org/izi/polib/
  8. Source0: http://bitbucket.org/izi/polib/downloads/polib-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. BuildArch: noarch
  11. BuildRequires: python-devel
  12. %description
  13. polib allows you to manipulate, create, modify gettext files (pot, po and
  14. mo files). You can load existing files, iterate through it's entries, add,
  15. modify entries, comments or metadata, etc... or create new po files from
  16. scratch.
  17. polib provides a simple and pythonic API, exporting only three convenience
  18. functions 'pofile', 'mofile' and 'detect_encoding', and the 4 core classes:
  19. POFile, MOFile, POEntry and MOEntry for creating new files/entries.
  20. %prep
  21. %setup -q -n polib-%{version}
  22. %build
  23. %{__python} setup.py build
  24. %check
  25. %{__python} setup.py check
  26. %install
  27. rm -rf $RPM_BUILD_ROOT
  28. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  29. %clean
  30. rm -rf $RPM_BUILD_ROOT
  31. %files
  32. %defattr(-,root,root,-)
  33. %doc LICENSE README.rst
  34. %{python_sitelib}/*
  35. %changelog
  36. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
  37. - initial build for Vine Linux
  38. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-3
  39. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  40. * Tue Jul 16 2013 Ding-Yi Chen <dchen@redhat.com> - 1.0.3-2
  41. - Fix the build for EL6 and EL5 (without python3-polib)
  42. * Tue Jul 16 2013 Ding-Yi Chen <dchen@redhat.com> - 1.0.3-1
  43. - python3 binding is available (python3-polib)
  44. - Fixed Bug 978672 - This package should be updated.
  45. - Upstream update to 1.0.3
  46. - Version 1.0.3 (2013/02/09)
  47. Fixed issue #38: POFile.append() raised a duplicate exception when you tried to add a new entry with the same msgid and a different msgctxt (only when check_for_duplicates option is set to True)
  48. Fixed issue #39: Added __init__.py file for convenience
  49. Fixed issue #41: UnicodeDecodeError when running setup.py build on python3 with C locale
  50. polib is now fully PEP8 compliant
  51. Small improvements: remove unused "typ" var (thanks Rodrigo Silva), mproved Makefile, Make sure _BaseFile.__contains__ returns a boolean value
  52. - Version 1.0.2 (2012/10/23)
  53. allow empty comments, flags or occurences lines
  54. - Version 1.0.1 (2012/09/11)
  55. speed up POFile.merge method (thanks @encukou)
  56. allow comments starting with two '#' characters (thanks @goibhniu)
  57. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  59. * Mon Jul 30 2012 Ding-Yi Chen <dchen@redhat.com> - 1.0.0-1
  60. - Upstream update to 1.0.0
  61. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-4
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  63. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  65. * Tue Nov 01 2011 Ding-Yi Chen <dchen@redhat.com> - 0.7.0-2
  66. - Update to upstream commit dbafdc621bf4, which include following:
  67. * Add check for unescaped quotes at the beginning of the string + unit tests
  68. * Fixed issue #27 (polib didn't check unescaped double quote) + better error handling
  69. * Fixed typos in previous commit
  70. * Fixed issue #26 IOError when parsing empty comments (thanks Türker Sezer)
  71. * Do not hardcode polib version in doc conf
  72. * Fri Oct 28 2011 Ding-Yi Chen <dchen@redhat.com> - 0.7.0-1
  73. - Correct URLs
  74. - Replace README with README.rst
  75. - Update to 0.7.0:
  76. From Version 0.7.0 (2011/07/14)
  77. This version adds support for python 3 (thanks to Vinay Sajip).
  78. polib now supports out-of-the-box any version of python ranging
  79. from 2.4 to latest 3.X version.
  80. From Version 0.6.4 (2011/07/13)
  81. * Better api, autodetected_encoding is no longer required to
  82. explicitely set the encoding (fixes issue #23),
  83. * Fixed issue #24 Support indented PO files (thanks to
  84. François Poirotte).
  85. From Version 0.6.3 (2011/02/19)
  86. * Fixed issue #19 (Disappearing newline characters due to
  87. textwrap module),
  88. * ensure wrapping works as expected.
  89. From Version 0.6.2 (2011/02/09)
  90. * Backported textwrap.TextWrapper._wrap_chunks that has support
  91. for the drop_whitespace parameter added in Python 2.6 (Fixes
  92. #18: broken compatibility with python 2.5, thanks @jezdez).
  93. From Version 0.6.1 (2011/02/09)
  94. * fixed regression that prevented POFile initialization from
  95. data to work (issue #17).
  96. From Version 0.6.0 (2011/02/07)
  97. * polib is now fully documented,
  98. * switched from doctests to unit tests to keep the polib.py
  99. file clean,
  100. * fixed issue #7 (wrapping issues, thanks @jezdez),
  101. * added a __eq__ method to _BaseFile (thanks @kost BebiX),
  102. * handle msgctxt correctly when compiling mo files,
  103. * compiled mo files are now exactly the same as those compiled
  104. by msgfmt without using hash tables.
  105. From Version 0.5.5 (2010/10/30)
  106. * Removed multiline handling code, it was a mess and was the
  107. source of potential bugs like issue #11,
  108. * Fixed typo in README and CHANGELOG, fixes issue #13.
  109. From Version 0.5.4 (2010/10/02)
  110. * fixed an issue with detect_encoding(), in some cases it could
  111. return an invalid charset.
  112. From Version 0.5.3 (2010/08/29)
  113. * correctly unescape lines containing both \\n and \n
  114. (thanks to Martin Geisler),
  115. * fixed issue #6: __str__() methods are returning unicode instead
  116. of str,
  117. * fixed issue #8: POFile.merge error when an entry is obsolete in
  118. a .po, that this entry reappears in the .pot and that we merge
  119. the two,
  120. * added support to instanciate POFile objects using data instead
  121. of file path (thanks to Diego Búrigo Zacarão),
  122. * fixed issue #9: POFile.merge drop fuzzy attributes from
  123. translations (thanks to Tim Gerundt),
  124. * fixed issue #10: Finding entries with the same msgid and
  125. different context (msgctxt).
  126. From Version 0.5.2 (2010/06/09)
  127. * fixed issue #1: untranslated_entries() also show fuzzy message,
  128. * write back the fuzzy header if present in the pofile,
  129. * added support for previous msgctxt, previous msgid and previous
  130. msgid_plural comments (fixes issue #5),
  131. * better handling of lines wrapping.
  132. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-3
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  134. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.5.1-2
  135. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  136. * Mon Dec 14 2009 Diego Búrigo Zacarão <diegobz@gmail.com> - 0.5.1-1
  137. - Updated to 0.5.1 release
  138. * Wed Aug 19 2009 Diego Búrigo Zacarão <diegobz@gmail.com> - 0.4.2-1
  139. - Updated to 0.4.2 release
  140. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2.20080217svnr60
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  142. * Wed Feb 18 2009 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> 0.4.0-1.20080217svnr60
  143. - Initial RPM release