python-packaging-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %bcond_with test
  2. %global pypi_name packaging
  3. #global build_wheel 1
  4. %global with_python3 1
  5. Name: python-%{pypi_name}
  6. Version: 18.0
  7. Release: 1%{?dist}
  8. Summary: Core utilities for Python packages
  9. License: BSD or ASL 2.0
  10. URL: https://github.com/pypa/packaging
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Source0: https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  14. BuildArch: noarch
  15. # Dependencies with different names in Fedora and Epel7
  16. BuildRequires: python-rpm-macros
  17. BuildRequires: python-setuptools
  18. BuildRequires: python-devel
  19. BuildRequires: python-pyparsing
  20. BuildRequires: python-six
  21. %if %{with test}
  22. BuildRequires: python-pytest
  23. BuildRequires: python-pretend
  24. %endif
  25. # Build Python 3 subpackage only for Fedora
  26. %if 0%{?with_python3}
  27. BuildRequires: python3-rpm-macros
  28. BuildRequires: python3-setuptools
  29. BuildRequires: python3-devel
  30. BuildRequires: python3-pyparsing
  31. BuildRequires: python3-six
  32. %if %{with test}
  33. BuildRequires: python3-pytest
  34. BuildRequires: python3-pretend
  35. %endif
  36. %endif
  37. Requires: python-pyparsing
  38. Requires: python-six
  39. %{?python_provide:%python_provide python2-%{pypi_name}}
  40. %description
  41. python-packaging provides core utilities for Python packages like utilities for
  42. dealing with versions, specifiers, markers etc.
  43. %if 0%{?with_python3}
  44. %package -n python3-%{pypi_name}
  45. Summary: %{summary}
  46. %{?python_provide:%python_provide python3-%{pypi_name}}
  47. Requires: python3-pyparsing
  48. Requires: python3-six
  49. %description -n python3-%{pypi_name}
  50. python3-packaging provides core utilities for Python packages like utilities for
  51. dealing with versions, specifiers, markers etc.
  52. %endif
  53. %prep
  54. %autosetup -n %{pypi_name}-%{version}
  55. # Remove bundled egg-info
  56. rm -rf %{pypi_name}.egg-info
  57. %build
  58. %py_build
  59. %if 0%{?with_python3}
  60. %py3_build
  61. %endif
  62. %install
  63. %py_install
  64. %if 0%{?with_python3}
  65. %py3_install
  66. %endif
  67. %check
  68. %if %{with test}
  69. %{__python} -m pytest tests/
  70. %{__python3} -m pytest tests/
  71. %endif
  72. %files
  73. %license LICENSE LICENSE.APACHE LICENSE.BSD
  74. %doc README.rst CHANGELOG.rst CONTRIBUTING.rst
  75. %{python_sitelib}/%{pypi_name}/
  76. %{python_sitelib}/%{pypi_name}-*-info/
  77. %if 0%{?with_python3}
  78. %files -n python3-%{pypi_name}
  79. %license LICENSE LICENSE.APACHE LICENSE.BSD
  80. %doc README.rst CHANGELOG.rst CONTRIBUTING.rst
  81. %{python3_sitelib}/%{pypi_name}/
  82. %{python3_sitelib}/%{pypi_name}-*-info/
  83. %endif
  84. %changelog
  85. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 18.0-1
  86. - new upstream release.
  87. - initial build for Vine Linux.
  88. * Tue Jul 31 2018 Charalampos Stratakis <cstratak@redhat.com> - 17.1-1
  89. - Update to 17.1
  90. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-11
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  92. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-10
  93. - Rebuilt for Python 3.7
  94. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-9
  95. - Bootstrap for Python 3.7
  96. * Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 16.8-8
  97. - Update Python 2 dependency declarations to new packaging standards
  98. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  99. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-7
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  101. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-6
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  103. * Wed Mar 22 2017 Lumir Balhar <lbalhar@redhat.com> - 16.8-5
  104. - Epel7 compatible spec/package
  105. * Mon Feb 13 2017 Charalampos Stratakis <cstratak@redhat.com> - 16.8-4
  106. - Rebuild as wheel
  107. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-3
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  109. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 16.8-2
  110. - Rebuild for Python 3.6
  111. * Wed Nov 02 2016 Lumir Balhar <lbalhar@redhat.com> - 16.8-1
  112. - New upstream version
  113. * Fri Sep 16 2016 Lumir Balhar <lbalhar@redhat.com> - 16.7-1
  114. - Initial package.