poedit-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. %define name poedit
  2. %define version 1.5.5
  3. %define release 3%{?_dist_release}
  4. Summary: Gettext catalogs editor
  5. Summary(ja): Gettext カタログの翻訳用エディタ
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Source0: %{name}-%{version}.tar.gz
  10. Patch0: del_comment_desktop.patch
  11. Patch1: poedit-1.5.5-wx28.patch
  12. License: MIT
  13. Group: Applications/Development
  14. URL: http://www.poedit.net/
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: wxGTK-devel >= 2.8.0
  17. BuildRequires: gtkspell-devel >= 2.0, libdb-cxx-devel
  18. BuildRequires: libboost-devel
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. %description
  21. Poedit is cross-platform gettext catalogs (.po files) editor.
  22. It is built with wxWidgets toolkit and can run on any platform
  23. supported by it (although it was only tested on Unix with GTK+
  24. and Windows).
  25. It aims to provide more convenient approach to editing catalogs
  26. than launching vi and editing the file by hand.
  27. %description -l ja
  28. Poedit はクロス・プラットフォームな gettext カタログ (.po ファイル)
  29. 用のエディタです。Toolkit に wxWidgets を使っており、この Toolkit
  30. がサポートする環境であればどんなプラットフォームでも動作します。
  31. (実際には GTK+ を使った Unix と Windows でしかテストされていませんが)
  32. このプログラムは、vi を使ってファイルを編集するよりも、もっと簡単に
  33. カタログを編集する方法を提供することを目指しています。
  34. %prep
  35. %setup -q
  36. %patch0 -p1
  37. %patch1 -p1
  38. %build
  39. %configure
  40. %{__make} %{?_smp_mflags}
  41. %install
  42. %{__rm} -rf ${RPM_BUILD_ROOT}
  43. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  44. # Remove a few unnecessary locations where the makefile may install
  45. # copies of icons and .desktop files
  46. rm -rf \
  47. $RPM_BUILD_ROOT%{_datadir}/applnk \
  48. $RPM_BUILD_ROOT%{_datadir}/mimelnk \
  49. $RPM_BUILD_ROOT%{_datadir}/gnome \
  50. $RPM_BUILD_ROOT%{_datadir}/mime-info
  51. # Install the desktop file
  52. desktop-file-install \
  53. --delete-original \
  54. --add-category=GTK \
  55. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  56. $RPM_BUILD_ROOT%{_datadir}/applications/poedit.desktop
  57. %find_lang %{name}
  58. # work around for https://bugzilla.redhat.com/show_bug.cgi?id=866058
  59. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/*/mimetypes/text-x-gettext-translation.*
  60. %clean
  61. %{__rm} -rf ${RPM_BUILD_ROOT}
  62. %post
  63. update-desktop-database &> /dev/null ||:
  64. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  65. %postun
  66. update-desktop-database &> /dev/null ||:
  67. if [ $1 -eq 0 ] ; then
  68. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  69. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  70. fi
  71. %posttrans
  72. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  73. %files -f %{name}.lang
  74. %defattr(-,root,root)
  75. %doc AUTHORS COPYING NEWS README TODO
  76. %{_bindir}/poedit
  77. %{_datadir}/applications/poedit.desktop
  78. %{_datadir}/icons/hicolor/*/apps/
  79. %{_datadir}/icons/hicolor/*/mimetypes/
  80. %{_datadir}/pixmaps/poedit.png
  81. #%{_datadir}/poedit/help
  82. %{_datadir}/poedit/icons
  83. %{_mandir}/man1/poedit.1.gz
  84. %changelog
  85. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-3
  86. - rebuilt with new toolchain.
  87. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.5-2
  88. - add BuildRequires: libdb-cxx-devel
  89. - remove BuildRequires: db4-devel
  90. * Sun Feb 10 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.5-1
  91. - new upstream release
  92. - added Patch1 from gentoo to fix build error
  93. - deleted unnecessary files
  94. - fixed file conflict with virtaal-0.7.1
  95. * Sun Oct 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.4-1
  96. - new upstream release
  97. - added patch0 to suppress error in installing desktop file
  98. * Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.2-2
  99. - new upstream release
  100. - added BuildRequires: desktop-file-utils, libboost-devel
  101. - changed BuildRequires: wxGTK-devel >= 2.6.0 to 2.8.0
  102. - used %%{?_smp_mflags}
  103. - run gtk-update-icon-cache and update-desktop-database in %%post, %%postun
  104. * Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.6.1-2
  105. - changed BuildRequires: wx-gtk2-devel >= 2.6.0 to wxGTK-devel >= 2.6.0
  106. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6.1-1
  107. - new upstream release
  108. * Wed Apr 01 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.2-1
  109. - new upstream release
  110. * Sun Aug 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-1
  111. - spec in UTF-8; new versioning policy
  112. * Tue Jan 1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl1
  113. - rebuild for VineSeed.
  114. * Tue Jan 1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl0
  115. - initial build for Vine Linux.
  116. * Tue Jan 1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl0
  117. - initial build for Vine Linux.