physfs-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. Summary: Library to provide abstract access to various archives
  2. Summary(ja): 様々なアーカイブへの抽象的アクセスを提供するライブラリ
  3. Name: physfs
  4. Version: 2.0.3
  5. Release: 2%{?_dist_release}
  6. Source0: http://icculus.org/physfs/downloads/%{name}-%{version}.tar.bz2
  7. License: zlib
  8. Group: System Environment/Libraries
  9. URL: http://icculus.org/physfs/
  10. BuildRequires: zlib-devel, readline-devel, doxygen
  11. BuildRequires: cmake
  12. BuildRequires: wxGTK-devel
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %description
  15. PhysicsFS is a library to provide abstract access to various archives. It is
  16. intended for use in video games, and the design was somewhat inspired by Quake
  17. 3's file subsystem. The programmer defines a "write directory" on the physical
  18. filesystem. No file writing done through the PhysicsFS API can leave that
  19. write directory, for security. For example, an embedded scripting language
  20. cannot write outside of this path if it uses PhysFS for all of its I/O, which
  21. means that untrusted scripts can run more safely. Symbolic links can be
  22. disabled as well, for added safety. For file reading, the programmer lists
  23. directories and archives that form a "search path". Once the search path is
  24. defined, it becomes a single, transparent hierarchical filesystem. This makes
  25. for easy access to ZIP files in the same way as you access a file directly on
  26. the disk, and it makes it easy to ship a new archive that will override a
  27. previous archive on a per-file basis. Finally, PhysicsFS gives you
  28. platform-abstracted means to determine if CD-ROMs are available, the user's
  29. home directory, where in the real filesystem your program is running, etc.
  30. %package devel
  31. Summary: Development libraries and headers for physfs
  32. Summary(ja): Physfs の開発用ライブラリ並びにヘッダファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. This package contains the libraries and headers necessary for developing
  37. packages with physfs functionality.
  38. %prep
  39. %setup -q
  40. %build
  41. %ifarch x86_64
  42. mv CMakeLists.txt CMakeLists.txt.orig
  43. cat CMakeLists.txt.orig \
  44. | sed "s/LIBRARY DESTINATION lib/LIBRARY DESTINATION %{_lib}/" \
  45. | sed "s/ARCHIVE DESTINATION lib/ARCHIVE DESTINATION %{_lib}/" \
  46. > CMakeLists.txt
  47. %endif
  48. cmake -D CMAKE_INSTALL_PREFIX=%{_prefix} .
  49. make %{?_smp_mflags}
  50. doxygen
  51. %install
  52. %{__rm} -rf ${RPM_BUILD_ROOT}
  53. make DESTDIR=${RPM_BUILD_ROOT} install
  54. %{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.la
  55. %{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.a
  56. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  57. install -m0644 docs/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
  58. # Handle man page conflicts (bz #183705) from Fedora
  59. mv $RPM_BUILD_ROOT%{_mandir}/man3/author.3 \
  60. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-author.3
  61. mv $RPM_BUILD_ROOT%{_mandir}/man3/description.3 \
  62. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-description.3
  63. mv $RPM_BUILD_ROOT%{_mandir}/man3/extension.3 \
  64. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-extension.3
  65. mv $RPM_BUILD_ROOT%{_mandir}/man3/major.3 \
  66. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-major.3
  67. mv $RPM_BUILD_ROOT%{_mandir}/man3/minor.3 \
  68. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-minor.3
  69. mv $RPM_BUILD_ROOT%{_mandir}/man3/patch.3 \
  70. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-patch.3
  71. mv $RPM_BUILD_ROOT%{_mandir}/man3/url.3 \
  72. $RPM_BUILD_ROOT%{_mandir}/man3/physfs-url.3
  73. %clean
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %post -p /sbin/ldconfig
  76. %postun -p /sbin/ldconfig
  77. %files
  78. %defattr(-,root,root,-)
  79. %doc CHANGELOG.txt CREDITS.txt LICENSE.txt TODO.txt
  80. %{_libdir}/*.so.*
  81. %{_bindir}/test_physfs
  82. %files devel
  83. %defattr(-,root,root,-)
  84. %doc docs/html/ docs/latex/
  85. %{_includedir}/physfs.h
  86. %{_libdir}/*.so
  87. %{_mandir}/man3/*
  88. %changelog
  89. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.3-2
  90. - rebuilt with readline 6.3
  91. - fixed License to zlib
  92. - added Japanese summary
  93. * Mon Sep 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.3-1
  94. - update to 2.0.3
  95. - remove Patch0,1
  96. * Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.0.2-1
  97. - new upstream release
  98. - added Patch0,1 from Debian sid
  99. - added BuildRequires: wxGTK-devel
  100. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
  101. - applied new versioning policy
  102. * Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl3
  103. - updated CMakeLists.txt for lib64
  104. * Fri Sep 07 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl2
  105. - remove "-D PHYSFS_BUILD_TEST:BOOL=OFF" from cmake option.
  106. - add test_physfs to %%files.
  107. * Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
  108. - new upstream release.
  109. - add "BuildRequires: cmake".
  110. - to use cmake instead of %%configure.
  111. - update %%files.
  112. - temporarily remove test_physfs from %%files.
  113. - remove libphysfs.la from %%files devel.
  114. * Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
  115. - initial build for Vine Linux 4.1
  116. * Mon Oct 17 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vlmp2
  117. - change Group: System Environment/Libraries
  118. * Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.0-0vlmp1
  119. - initial build for Vine Linux 3.2
  120. # end of file