perl-namespace-clean-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. # Run optional test
  2. %bcond_with perl_namespace_clean_enables_optional_test
  3. Name: perl-namespace-clean
  4. Summary: Keep your namespace tidy
  5. Version: 0.27
  6. Release: 11%{?_dist_release}
  7. License: GPL+ or Artistic
  8. URL: https://metacpan.org/release/namespace-clean
  9. Source0: https://cpan.metacpan.org/authors/id/R/RI/RIBASUSHI/namespace-clean-%{version}.tar.gz
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. # Module Build
  14. BuildRequires: coreutils
  15. BuildRequires: findutils
  16. BuildRequires: make
  17. BuildRequires: perl >= 2:5.26.2
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(File::Spec)
  20. BuildRequires: perl(File::Temp)
  21. # Module Runtime
  22. BuildRequires: perl(B::Hooks::EndOfScope)
  23. BuildRequires: perl(base)
  24. BuildRequires: perl(constant)
  25. BuildRequires: perl(Exporter)
  26. BuildRequires: perl(Package::Stash)
  27. BuildRequires: perl(strict)
  28. BuildRequires: perl(vars)
  29. BuildRequires: perl(warnings)
  30. # Test Suite
  31. BuildRequires: perl(Config)
  32. BuildRequires: perl(DB)
  33. BuildRequires: perl(File::Glob)
  34. BuildRequires: perl(FindBin)
  35. BuildRequires: perl(IPC::Open2)
  36. BuildRequires: perl(lib)
  37. BuildRequires: perl(sort)
  38. BuildRequires: perl(Test::More)
  39. %if %{with perl_namespace_clean_enables_optional_test}
  40. # Optional Tests
  41. BuildRequires: perl(Variable::Magic)
  42. %endif
  43. # Runtime
  44. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  45. Requires: perl(B::Hooks::EndOfScope)
  46. Requires: perl(Package::Stash)
  47. # Avoid unwanted requires/provides that come with the test suite
  48. %{?perl_default_filter}
  49. # namespace::clean::_Util is a private package
  50. %global __requires_exclude %{?__requires_exclude:__requires_exclude|}^perl\\(namespace::clean::_Util\\)
  51. %description
  52. When you define a function, or import one, into a Perl package, it will
  53. naturally also be available as a method. This does not per se cause
  54. problems, but it can complicate subclassing and, for example, plugin
  55. classes that are included via multiple inheritance by loading them as
  56. base classes.
  57. The 'namespace::clean' pragma will remove all previously declared or
  58. imported symbols at the end of the current package's compile cycle.
  59. Functions called in the package itself will still be bound by their
  60. name, but they won't show up as methods on your class or instances.
  61. %prep
  62. %setup -q -n namespace-clean-%{version}
  63. %build
  64. perl Makefile.PL INSTALLDIRS=vendor
  65. make %{?_smp_mflags}
  66. %install
  67. make pure_install DESTDIR=%{buildroot}
  68. find %{buildroot} -type f -name .packlist -delete
  69. %{_fixperms} -c %{buildroot}
  70. %check
  71. make test
  72. %files
  73. %doc Changes t/
  74. %{perl_vendorlib}/namespace/
  75. %{_mandir}/man3/namespace::clean.3*
  76. %changelog
  77. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.27-11
  78. - initial build for Vine Linux.
  79. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-10
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  81. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-9
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  83. * Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-8
  84. - Perl 5.28 rebuild
  85. * Fri Feb 9 2018 Paul Howarth <paul@city-fan.org> - 0.27-7
  86. - BR: perl-generators unconditionally
  87. * Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.27-6
  88. - Escape macros in %%changelog
  89. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-5
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  91. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-4
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  93. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-3
  94. - Perl 5.26 rebuild
  95. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-2
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  97. * Thu May 19 2016 Paul Howarth <paul@city-fan.org> - 0.27-1
  98. - Update to 0.27
  99. - Allow packages to be cleaned multiple times
  100. - Ensure the debugger workarounds are applied only when DB::sub is actively
  101. used (they are superfluous otherwise)
  102. - Work around P5#72210, resulting in fails on 5.8.8 -Duselongdouble
  103. - Fix incorrect name in META (CPAN RT#107813)
  104. - BR: perl-generators where available
  105. - Simplify find command using -delete
  106. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-3
  107. - Perl 5.24 rebuild
  108. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  110. * Wed Oct 7 2015 Paul Howarth <paul@city-fan.org> - 0.26-1
  111. - Update to 0.26
  112. - Exclusively use Package::Stash::PP on perls < 5.8.7 until a fixed
  113. Package::Stash::XS ships - breakage keeps getting re-introduced
  114. (CPAN RT#74151, CPAN RT#107343)
  115. - Explicitly document the late runtime binding of 'sort SUBNAME ...'
  116. (CPAN RT#101247)
  117. - No longer rely on Sub::Identify - either use Sub::Util or B (CPAN RT#96945)
  118. - Classify buildreqs by usage
  119. - Filter dependency on private package namespace::clean::_Util
  120. - Drop EL-6 support since build requirements can't be met there
  121. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-5
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  123. * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-4
  124. - Perl 5.22 rebuild
  125. * Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-3
  126. - Perl 5.20 rebuild
  127. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  129. * Wed Mar 5 2014 Paul Howarth <paul@city-fan.org> - 0.25-1
  130. - Update to 0.25
  131. - Fix incorrect ExtUtils::CBuilder detection routine leading to Makefile.PL
  132. crashes when EU::CB is not available
  133. - Drop obsoletes/provides for old tests sub-package
  134. - Drop EL-5 support since build requirements can't be met there
  135. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-4
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  137. * Mon Jul 29 2013 Petr Pisar <ppisar@redhat.com> - 0.24-3
  138. - Perl 5.18 rebuild
  139. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  141. * Wed Dec 5 2012 Paul Howarth <paul@city-fan.org> - 0.24-1
  142. - Update to 0.24
  143. - Properly skip debugger test when optional deps not available
  144. - Make sure pure-perl tests pass correctly on space-containing paths
  145. (CPAN RT#77528)
  146. - Remove all the pure-perl fallback code and depend on PP-capable
  147. B::H::EOS 0.12
  148. - Module no longer attempts to use Hash::Util::FieldHash, so drop filters
  149. - BR: perl(Sub::Identify) and perl(Sub::Name) unconditionally
  150. - BR: perl(base), perl(ExtUtils::CBuilder) and perl(lib)
  151. - Drop BR: perl(FindBin), not dual-lived upstream
  152. - Update patch for building with old Test::More versions
  153. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-3
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  155. * Tue Jun 19 2012 Petr Pisar <ppisar@redhat.com> - 0.23-2
  156. - Perl 5.16 rebuild
  157. * Sun Mar 11 2012 Paul Howarth <paul@city-fan.org> - 0.23-1
  158. - Update to 0.23
  159. - Rely on B::Hooks::EndOfScope version 0.10 to fix issues with new
  160. Module::Runtime versions (≥ 0.012) on perl 5.10 due to incorrect hook
  161. firing due to %%^H localisation
  162. - Fix failures on 5.13.6 due to incorrect version number threshold
  163. (CPAN RT#74683)
  164. - Don't need to remove empty directories from buildroot
  165. - Drop %%defattr, redundant since rpm 4.4
  166. * Fri Jan 27 2012 Paul Howarth <paul@city-fan.org> - 0.22-1
  167. - Update to 0.22
  168. - Limit the debugger workarounds to perls between 5.8.8 and 5.14, extend
  169. debugger support to all perl versions (CPAN RT#69862)
  170. - If possible, automatically install (but not load) the debugger workaround
  171. libraries on perls between 5.8.8 and 5.14 (CPAN RT#72368)
  172. - Add back dropped NAME section (CPAN RT#70259)
  173. - Simplify the ≥ 5.10 PP variant even more - move the hook from DESTROY
  174. into DELETE
  175. - Force explicit callback invocation order on 5.8 PP
  176. - Replace the %%^H tie approach with fieldhashes, which fixes all known
  177. corner cases and caveats on supported perls ≥ 5.8.1 (CPAN RT#73402)
  178. - Compile away the debugger fixup on perls ≥ 5.15.5
  179. - Only BR:/R: Sub::Identify and Sub::Name for perl versions where they're
  180. actually needed
  181. - Reinstate compatibility with old distributions like EL-5
  182. - Patch test suite to work with Test::More < 0.88 if necessary
  183. - Filter dependency on Hash::Util::FieldHash on perl 5.8.x
  184. - Add back buildroot definition, %%clean section, %%defattr etc.
  185. - Only include tests if we have %%{perl_default_filter} to avoid the unwanted
  186. requires/provides that come with them
  187. - Drop redundant buildreq perl(CPAN)
  188. - Make %%files list more explicit
  189. - Use tabs
  190. * Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> - 0.21-3
  191. - Drop tests subpackage; move tests to main package documentation
  192. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.21-2
  193. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  194. * Sun Oct 02 2011 Iain Arnell <iarnell@gmail.com> - 0.21-1
  195. - Update to latest upstream version
  196. - Clean up spec for modern rpmbuild
  197. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.20-3
  198. - Perl mass rebuild
  199. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-2
  200. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  201. * Sat Jan 08 2011 Iain Arnell <iarnell@gmail.com> - 0.20-1
  202. - Update to latest upstream version
  203. - Update BR perl(Package::Stash) >= 0.22
  204. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-2
  205. - Rebuild to fix problems with vendorarch/lib (#661697)
  206. * Sun Aug 01 2010 Iain Arnell <iarnell@gmail.com> - 0.18-1
  207. - Update by Fedora::App::MaintainerTools 0.006
  208. - Updating to latest GA CPAN version (0.18)
  209. - Added a new br on perl(Exporter) (version 0)
  210. - Altered br on perl(ExtUtils::MakeMaker) (6.42 => 6.31)
  211. - Added a new br on perl(Package::Stash) (version 0.03)
  212. - Added a new br on perl(constant) (version 0)
  213. - Added a new br on perl(vars) (version 0)
  214. - Dropped old BR on perl(Symbol)
  215. - Dropped old requires on perl(Symbol)
  216. - Manually drop unnecessary requires
  217. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.14-1
  218. - Mass rebuild with perl-5.12.0 & update
  219. * Tue Feb 23 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.13-2
  220. - Update by Fedora::App::MaintainerTools 0.003
  221. - PERL_INSTALL_ROOT => DESTDIR
  222. * Fri Feb 05 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.13-1
  223. - Update filtering perl_default_filter
  224. - Auto-update to 0.13 (by cpan-spec-update 0.01)
  225. - Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  226. - Added a new br on perl(Sub::Identify) (version 0.04)
  227. - Added a new br on perl(Sub::Name) (version 0.04)
  228. - Altered br on perl(Test::More) (0.62 => 0.88)
  229. - Added a new br on CPAN (inc::Module::AutoInstall found)
  230. - Added a new req on perl(B::Hooks::EndOfScope) (version 0.07)
  231. - Added a new req on perl(Sub::Identify) (version 0.04)
  232. - Added a new req on perl(Sub::Name) (version 0.04)
  233. - Added a new req on perl(Symbol) (version 0)
  234. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
  235. - Rebuild against perl 5.10.1
  236. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
  237. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  238. * Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
  239. - Update to 0.11
  240. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  242. * Tue Dec 02 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09-1
  243. - Update to 0.09
  244. - Note BR change from Scope::Guard to B::Hooks::EndOfScope
  245. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.08-2
  246. - Bump
  247. * Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.08-1
  248. - Initial Fedora packaging
  249. - Generated with cpan2dist (CPANPLUS::Dist::Fedora version 0.0.1)