perl-XML-DOM-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. Name: perl-XML-DOM
  2. Version: 1.46
  3. Release: 11%{?_dist_release}
  4. Summary: DOM extension to XML::Parser
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/XML-DOM/
  8. Source0: http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. # perl(XML::Parser::PerlSAX)
  14. BuildRequires: perl-libxml-perl
  15. BuildRequires: perl-XML-RegExp
  16. # for testing perl(LWP::UserAgent)
  17. BuildRequires: perl-libwww-perl
  18. Requires: perl-XML-Parser
  19. Requires: perl-libwww-perl
  20. Requires: perl >= %(eval "`%{__perl} -V:version`"; echo $version)
  21. #Obsoletes: perl-libxml-enno <= 1.02
  22. Conflicts: perl-libxml-enno <= 1.02
  23. %description
  24. This is a Perl extension to XML::Parser. It adds a new 'Style' to
  25. XML::Parser, called 'Dom', that allows XML::Parser to build an Object
  26. Oriented datastructure with a DOM Level 1 compliant interface. For a
  27. description of the DOM (Document Object Model), see
  28. http://www.w3.org/DOM/
  29. %prep
  30. %setup -q -n XML-DOM-%{version}
  31. cat <<EOF > %{name}-prov
  32. #!/bin/sh
  33. %{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
  34. EOF
  35. %define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
  36. chmod +x %{__perl_provides}
  37. %build
  38. %{__perl} Makefile.PL INSTALLDIRS=vendor
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  43. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  44. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  45. chmod -R u+w $RPM_BUILD_ROOT/*
  46. %check
  47. make test
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %files
  51. %defattr(-,root,root,-)
  52. %doc BUGS Changes README
  53. %{perl_vendorlib}/XML/
  54. %{_mandir}/man3/XML::*.3*
  55. %changelog
  56. * Mon May 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.46-1
  57. - new upstream release.
  58. - rebuilt with perl-5.26.
  59. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.44-10
  60. - rebuilt with perl-5.16.3.
  61. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.44-9
  62. - build with perl 5.12.3
  63. - add Vendor and Distribution tags
  64. * Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-8
  65. - s/Obsoletes/Conflicts/
  66. * Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
  67. - Initial build for Vine Linux
  68. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  70. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  72. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
  73. - Rebuild for perl 5.10 (again)
  74. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
  75. - rebuild for new perl
  76. * Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
  77. - correct license tag
  78. - add BR: perl(ExtUtils::MakeMaker)
  79. * Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
  80. - Bump for new perl version (#196667)
  81. * Sat Nov 5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
  82. - First Fedora Extras release (#172331).
  83. * Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
  84. - First build (#128879).