perl-Test-Simple-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644
  1. %bcond_with perl_Test_Simple_enables_optional_test
  2. Name: perl-Test-Simple
  3. Summary: Basic utilities for writing tests
  4. Version: 1.302164
  5. Release: 2%{?_dist_release}
  6. # CC0: lib/ok.pm
  7. # Public Domain: lib/Test/Tutorial.pod
  8. # GPL+ or Artistic: the rest of the distribution
  9. License: (GPL+ or Artistic) and CC0 and Public Domain
  10. URL: https://metacpan.org/release/Test-Simple
  11. Source0: https://cpan.metacpan.org/modules/by-module/Test/Test-Simple-%{version}.tar.gz
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. BuildArch: noarch
  15. # Module Build
  16. BuildRequires: coreutils
  17. BuildRequires: make
  18. BuildRequires: perl >= 2:5.26.2
  19. BuildRequires: perl(ExtUtils::MakeMaker)
  20. # Module Runtime
  21. BuildRequires: perl(base)
  22. BuildRequires: perl(Carp)
  23. BuildRequires: perl(Config)
  24. BuildRequires: perl(Data::Dumper)
  25. BuildRequires: perl(Exporter)
  26. BuildRequires: perl(File::Spec)
  27. BuildRequires: perl(File::Temp)
  28. BuildRequires: perl(IO::Handle)
  29. BuildRequires: perl(List::Util)
  30. BuildRequires: perl(overload)
  31. BuildRequires: perl(PerlIO)
  32. BuildRequires: perl(POSIX)
  33. BuildRequires: perl(Scalar::Util)
  34. BuildRequires: perl(Storable)
  35. BuildRequires: perl(strict)
  36. BuildRequires: perl(Symbol)
  37. BuildRequires: perl(Term::ANSIColor)
  38. BuildRequires: perl(Term::Table)
  39. BuildRequires: perl(vars)
  40. BuildRequires: perl(warnings)
  41. # Test Suite
  42. BuildRequires: perl(Cwd)
  43. BuildRequires: perl(File::Basename)
  44. BuildRequires: perl(IO::Pipe)
  45. BuildRequires: perl(lib)
  46. BuildRequires: perl(threads)
  47. # Optional Tests
  48. BuildRequires: perl(CPAN::Meta)
  49. BuildRequires: perl(CPAN::Meta::Requirements)
  50. BuildRequires: perl(IPC::Open3)
  51. BuildRequires: perl(Module::Metadata)
  52. BuildRequires: perl(POSIX)
  53. BuildRequires: perl(Test::Harness)
  54. %if !%{defined perl_bootstrap}
  55. %if %{with perl_Test_Simple_enables_optional_test}
  56. BuildRequires: perl(Test::Class)
  57. BuildRequires: perl(Test::Pod)
  58. BuildRequires: perl(Test::Script)
  59. %endif
  60. %endif
  61. # Runtime
  62. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  63. Requires: perl(Data::Dumper)
  64. Requires: perl(Term::ANSIColor)
  65. Requires: perl(Term::Table)
  66. %{?perl_default_filter}
  67. %description
  68. This package provides the bulk of the core testing facilities. For more
  69. information, see perldoc for Test::Simple, Test::More, etc.
  70. This package is the CPAN component of the dual-lifed core package Test-Simple.
  71. %prep
  72. %setup -q -n Test-Simple-%{version}
  73. %build
  74. perl Makefile.PL INSTALLDIRS=vendor NO_PERLLOCAL=1 NO_PACKLIST=1
  75. %{make_build}
  76. %install
  77. %{make_install}
  78. %{_fixperms} -c %{buildroot}
  79. %check
  80. make test AUTHOR_TESTING=1
  81. %files
  82. %license LICENSE
  83. %doc Changes README examples/ t/
  84. %dir %{perl_vendorlib}/Test/
  85. %{perl_vendorlib}/ok.pm
  86. %{perl_vendorlib}/Test/Builder.pm
  87. %{perl_vendorlib}/Test/Builder/
  88. %{perl_vendorlib}/Test/More.pm
  89. %{perl_vendorlib}/Test/Simple.pm
  90. %{perl_vendorlib}/Test/Tester.pm
  91. %{perl_vendorlib}/Test/Tester/
  92. %doc %{perl_vendorlib}/Test/Tutorial.pod
  93. %{perl_vendorlib}/Test/use/
  94. %{perl_vendorlib}/Test2.pm
  95. %{perl_vendorlib}/Test2/
  96. %exclude %{_mandir}/man3/*
  97. %changelog
  98. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.302164-2
  99. - initial build for Vine Linux.
  100. * Sun Apr 28 2019 Paul Howarth <paul@city-fan.org> - 2:1.302164-1
  101. - Update to 1.302164
  102. - Do not use threads::shared in Test::Tester::Capture (GH#826)
  103. - Add missing version info to Info/Table
  104. - Fix event in global destruction bug (GH#827)
  105. - Proper fix for todo = '' (GH#812, GH#829)
  106. - Modernize spec using %%{make_build} and %%{make_install}
  107. - Drop obsoletes/provides for perl-Test2 dating back to Fedora 25
  108. * Wed Feb 6 2019 Paul Howarth <paul@city-fan.org> - 2:1.302162-1
  109. - Update to 1.302162
  110. - Remove SHM Optimization
  111. - Typo fixes in documentation
  112. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.302160-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  114. * Sat Jan 19 2019 Paul Howarth <paul@city-fan.org> - 2:1.302160-1
  115. - Update to 1.302160
  116. - Fix minor typos and missing doc sections
  117. - Add table support in info facet and TAP formatter
  118. - Fix TAP test on Windows
  119. - Fix math errors in table indentation
  120. - Devel requires Term::Table
  121. - Add table support to ctx->fail and ctx->fail_and_return
  122. - Fix Instance.t on haiku-os
  123. * Tue Jan 8 2019 Paul Howarth <paul@city-fan.org> - 2:1.302156-1
  124. - Update to 1.302156
  125. - Fix Windows fork+test failure (GH#814)
  126. - Documentation updates (GH#819)
  127. - Fix verbose TAP newline regression (GH#810)
  128. - Fix local $TODO bugs (GH#812, GH#817)
  129. - Fix shm read warning (GH#815)
  130. - Merge doc fix PR's from magnolia-k
  131. - Fix failure to check error code on shmwrite (GH#815)
  132. - Fix localization error in new test (GH#820)
  133. - Fix SHM test to work on machines without SHM
  134. - Fix locale errors in Instance.t
  135. - Windows test fixes
  136. - Perl 5.6 test fixes
  137. - Add trace to SHM error when possible
  138. - Fix test not to fail in non-english locales
  139. * Sun Dec 2 2018 Paul Howarth <paul@city-fan.org> - 2:1.302141-1
  140. - Update to 1.302141
  141. - Fix bug where IPC init failed in preload+fork environments
  142. * Tue Aug 14 2018 Paul Howarth <paul@city-fan.org> - 2:1.302140-1
  143. - Update to 1.302140
  144. - Mask warning from the recent IPC fix generated when threaded Test tools are
  145. loaded at run-time
  146. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.302138-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  148. * Thu Jul 12 2018 Paul Howarth <paul@city-fan.org> - 2:1.302138-1
  149. - Update to 1.302138
  150. - Make it safe to fork before events in IPC
  151. * Sat Jun 30 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2:1.302136-3
  152. - Perl 5.28 re-rebuild of bootstrapped packages
  153. * Tue Jun 26 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2:1.302136-2
  154. - Perl 5.28 rebuild
  155. * Thu Apr 19 2018 Paul Howarth <paul@city-fan.org> - 1:1.302136-1
  156. - Update to 1.302136
  157. - Add test2_add_callback_testing_done to Test2::API
  158. * Fri Mar 30 2018 Paul Howarth <paul@city-fan.org> - 1:1.302135-1
  159. - Update to 1.302135
  160. - Make sure all hubs, events, and contexts get a unique (per run) id
  161. - Use a common generator for unique(enough) id's (not UUIDs)
  162. * Mon Mar 12 2018 Paul Howarth <paul@city-fan.org> - 1:1.302133-1
  163. - Update to 1.302133
  164. - Make sure event puts the uuid into the about facet
  165. - Add method to validate facet data
  166. - Add Test2::Event::V2 event class, and context helpers
  167. - Improve how events handle facets
  168. - Break out meta_facet_data
  169. - Document and fix Facets2Legacy
  170. - Fix nested and in_subtest to look at hub facets
  171. - Fix event->related and trace with uuid
  172. * Thu Mar 8 2018 Paul Howarth <paul@city-fan.org> - 1:1.302130-1
  173. - Update to 1.302130
  174. - Make hubs tag events with a new facet
  175. * Tue Mar 06 2018 Petr Pisar <ppisar@redhat.com> - 1:1.302128-1
  176. - Update to 1.302128
  177. - Add optional UUID tagging
  178. * Thu Feb 22 2018 Paul Howarth <paul@city-fan.org> - 1:1.302125-1
  179. - Update to 1.302125
  180. - Make it possible to disable IPC
  181. - Fix a test to skip without threads
  182. * Tue Feb 6 2018 Paul Howarth <paul@city-fan.org> - 1:1.302122-1
  183. - Update to 1.302122
  184. - Add 'mode' to render facet
  185. * Mon Feb 5 2018 Paul Howarth <paul@city-fan.org> - 1:1.302121-1
  186. - Update to 1.302121
  187. - Update Copyright
  188. - Add 'render' facet
  189. * Thu Nov 30 2017 Paul Howarth <paul@city-fan.org> - 1:1.302120-1
  190. - Update to 1.302120
  191. - Fix IPC reload bug
  192. * Wed Nov 29 2017 Paul Howarth <paul@city-fan.org> - 1:1.302118-1
  193. - Update to 1.302118
  194. - Added pre-subtest hook to Test2::API (GH#801)
  195. - ipc_wait now reports exit and signal values
  196. - Add better interface for ipc_wait
  197. - Fix event Out of Order bug
  198. - Add driver_abort() hook for IPC Drivers
  199. * Tue Nov 21 2017 Paul Howarth <paul@city-fan.org> - 1:1.302113-1
  200. - Update to 1.302113
  201. - Fix test on threaded 5.8
  202. - Fix SIGPIPE in IPC test
  203. - Mark t/Test2/regression/gh_16.t as usually AUTHOR_TESTING only
  204. * Mon Nov 20 2017 Paul Howarth <paul@city-fan.org> - 1:1.302111-1
  205. - Update to 1.302111
  206. - Fix some fragile tests
  207. - Apply p5p test patch from Craig A. Berry
  208. - Allow regexp in Test::Tester
  209. * Mon Oct 23 2017 Paul Howarth <paul@city-fan.org> - 1:1.302106-1
  210. - Update to 1.302106
  211. - Combine multiple diags into one event
  212. - Make version number in HashBase sane
  213. * Mon Oct 16 2017 Paul Howarth <paul@city-fan.org> - 1:1.302103-1
  214. - Update to 1.302103
  215. - Fix some TODO edge cases that were not previously accounted for
  216. * Fri Oct 13 2017 Paul Howarth <paul@city-fan.org> - 1:1.302101-1
  217. - Update to 1.302101
  218. - Bump Test::Builder::IO::Scalar version for core
  219. * Wed Oct 11 2017 Paul Howarth <paul@city-fan.org> - 1:1.302100-1
  220. - Update to 1.302100
  221. - Fix run_subtest inherit_trace option
  222. * Tue Oct 3 2017 Paul Howarth <paul@city-fan.org> - 1:1.302098-1
  223. - Update to 1.302098
  224. - Add docs for test2_stdout and test2_stderr
  225. - Fix 5.6 support
  226. * Tue Oct 3 2017 Paul Howarth <paul@city-fan.org> - 1:1.302097-1
  227. - Update to 1.302097
  228. - Fix hub->process bug that could let an error pass
  229. - Fix modification of read only value (#789)
  230. - Fix typo in Test::Builder when looking for IPC (#777)
  231. - Fix clone_io broke on scalar io layer (#791)
  232. - Fix Exception event stringify exception (#756, #790)
  233. - Localize $^E in context (#780)
  234. - Fix test that failed in verbose mode (#770)
  235. * Mon Sep 11 2017 Paul Howarth <paul@city-fan.org> - 1:1.302096-1
  236. - Update to 1.302096
  237. - Introduce 'Facets' for events
  238. - Performance enhancements
  239. - Upgrade inline HashBase
  240. - Move Test2::Util::Trace to Test2::EventFacet::Trace
  241. - Track hub id in Trace
  242. - Remove Info event
  243. - Add Pass and Fail events
  244. - Remove Event JSON interface
  245. - Fix tests on perl 5.25+ with newer Data::Dumper
  246. - Fix plan in buffered subtest so that the facts say it is buffered
  247. - Fix test that unintentionally required Test2::Suite
  248. - Add 'new_root' constructor for formatters
  249. - Add intercept_deep() to the API
  250. - Fix bug in Version event
  251. - Add 'number' attribute to assertion facet
  252. - Fix bug in Facets for TodoDiag
  253. - Add API command to reset after a fork
  254. - Add 'important' flag to info event facet
  255. - Make sure Test::Builder does not initialize Test2 too soon
  256. - Fix Test::Builder in a preload scenario
  257. - Make several tests work with preload
  258. - Fix to work with subref-in-stash optimization
  259. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.302086-2
  260. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  261. * Wed Jun 21 2017 Paul Howarth <paul@city-fan.org> - 1:1.302086-1
  262. - Update to 1.302086
  263. - Make it possible to turn off result logging in Test::Builder
  264. * Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.302085-2
  265. - Perl 5.26 rebuild
  266. * Tue May 2 2017 Paul Howarth <paul@city-fan.org> - 1.302085-1
  267. - Update to 1.302085
  268. - Better IO management
  269. - Allow access to the STDERR/STDOUT Test2::API uses
  270. - Formatters should use the Test2::API handles
  271. * Sat Apr 15 2017 Paul Howarth <paul@city-fan.org> - 1.302083-1
  272. - Update to 1.302083
  273. - Fixes for '. in @INC' changes (#768)
  274. - Timeout when waiting for child procs and threads (#765)
  275. - Fix SIGSYS localization issue (#758)
  276. - Fix outdated docs (#759, #754)
  277. - Fix bail-out in buffered subtest (#747)
  278. - Fix threads timeout for older perls (as best we can)
  279. - Fix test that incorrectly called private function as method
  280. - Update some breakage info for Test::More::Prefix and
  281. Test::DBIx::Class::Schema
  282. * Thu Mar 2 2017 Paul Howarth <paul@city-fan.org> - 1.302078-1
  283. - Update to 1.302078
  284. - Fix crash when TB->reset used inside subtest
  285. - Fix #762, newlines for todo subtest
  286. - Revisit #637, fix rare race condition it created
  287. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.302075-2
  288. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  289. * Wed Jan 11 2017 Paul Howarth <paul@city-fan.org> - 1.302075-1
  290. - Update to 1.302075
  291. - Add 'cid' to trace
  292. - Add signatures to trace
  293. - Add related() to events
  294. - Now it is possible to check if events are related
  295. - Add 'no_fork' option to run_subtest()
  296. * Mon Dec 19 2016 Paul Howarth <paul@city-fan.org> - 1.302073-1
  297. - Update to 1.302073
  298. - Add TO_JSON and from_json methods to Test2::Event and Test2::Trace::Util to
  299. facilitate transferring event data between processes (#741)
  300. - Generate HashBase from Object::HashBase, which has been split out
  301. - When a subtest is marked as todo, all of its contained Ok and Subtest
  302. events are now updated so that they return true for $e->effective_pass
  303. (#742)
  304. - Added two new event classes, Test2::Event::Encoding and
  305. Test2::Event::TAP::Version; these are primarily being added for the benefit
  306. of Test2::Harness now, but they could be useful for other Test2 event
  307. consumer tools in the future (#743)
  308. - Expose tools.pl as Test2::Tools::Tiny
  309. * Thu Nov 24 2016 Paul Howarth <paul@city-fan.org> - 1.302067-1
  310. - Update to 1.302067
  311. - Fix double release when 'throw' is used in context_do()
  312. - Repo management improvements
  313. - Better handling of info vs. diag in ->send_event
  314. - Fix test that used 'parent'
  315. - Better handling of non-bumping failures (#728)
  316. - Set the TEST_ACTIVE env var to true
  317. - Set the TEST2_ACTIVE env var to true
  318. - Fix cmp_ok output in some confusing cases (#6)
  319. - Update travis config
  320. - Add missing author deps
  321. - Fix handling of negative pids on Windows
  322. - Add can() to Test::Tester::Delegate (despite deprecation)
  323. - Fix some minor test issues
  324. - Handle cases where SysV IPC can be available but not enabled
  325. - Import 'context' into Test2::IPC; it is used by 'cull'
  326. - Propagate warnings settings to use_ok (#736)
  327. - Fix context test for recent blead
  328. * Thu Oct 20 2016 Paul Howarth <paul@city-fan.org> - 1.302062-1
  329. - Update to 1.302062
  330. - Formatters now have terminate() and finalize() methods; these are called
  331. when there is a skip_all or bail event (terminate), or when a test suite is
  332. exiting normally (finalize), which allows formatters to finalize their
  333. output - this is important for any sort of document-oriented format (as
  334. opposed to a stream format like TAP) (#723)
  335. - Removed a warning when using a non-TAP formatter with Test::Builder about
  336. the formatter not supporting "no_header" and "no_diag"; this happened even
  337. if the alternative formatter class implemented these attributes
  338. * Mon Sep 26 2016 Paul Howarth <paul@city-fan.org> - 1.302059-1
  339. - Update to 1.302059
  340. - Documentation fixes
  341. - Win32 color support in Test::Builder::Tester
  342. - Support v-strings in is_deeply
  343. - A streamed subtest run inside a buffered subtest will automatically be
  344. converted to a buffered subtest; otherwise, the output from inside the
  345. subtest is lost entirely (#721)
  346. - Mask warning when comparing $@ in Test2::API::Context
  347. - Drop obsoletes/provides for perl-Test-Tester and perl-Test-use-ok, which
  348. were integrated into this package in Fedora 22
  349. * Tue Sep 13 2016 Paul Howarth <paul@city-fan.org> - 1.302056-1
  350. - Update to 1.302056
  351. - Fix skip_all in require in intercept (#696)
  352. - Documentation of what is better in Test2 (#663)
  353. - Document Test::Builder::Tester plan limitations
  354. - Document limitations in is_deeply (#595)
  355. - Better documentation of done_testing purpose (#151)
  356. - Make ctx->send_event detect termination events (#707)
  357. - Allow '#' and '\n' in ok names
  358. - Fix special case of ok line ending in backslash
  359. - Improve a test that captures STDERR/STDOUT
  360. * Sun Aug 14 2016 Paul Howarth <paul@city-fan.org> - 1.302052-1
  361. - Update to 1.302052
  362. - Add contact info to main doc and readme
  363. - Fix setting hub when getting context
  364. * Fri Jul 29 2016 Paul Howarth <paul@city-fan.org> - 1.302049-1
  365. - Update to 1.302049
  366. - Add 'active' attribute to hub
  367. * Sat Jul 23 2016 Paul Howarth <paul@city-fan.org> - 1.302047-1
  368. - Update to 1.302047
  369. - Restore traditional note/diag return values (#694)
  370. * Tue Jul 19 2016 Paul Howarth <paul@city-fan.org> - 1.302045-1
  371. - Update to 1.302045
  372. - Work around IPC bug on windows
  373. - Fix IPC event ordering bug
  374. - Fix TODO in mixed T2/TB subtests
  375. - Fix test that segv'd on older perls
  376. * Sun Jul 10 2016 Paul Howarth <paul@city-fan.org> - 1.302040-1
  377. - Update to 1.302040
  378. - Fix broken MANIFEST.SKIP entries (#689)
  379. - Add Info event for better diagnostics
  380. * Mon Jul 4 2016 Paul Howarth <paul@city-fan.org> - 1.302037-1
  381. - Update to 1.302037
  382. - Restore PerlIO layer cloning on STDERR and STDOUT
  383. - Bump obsoletes/provides versions for perl-Test2 to maintain upgrade path from
  384. packages in third-party repositories
  385. * Tue Jun 28 2016 Paul Howarth <paul@city-fan.org> - 1.302035-1
  386. - Update to 1.302035
  387. - Fix some breakage info
  388. - POD fixes
  389. * Fri Jun 24 2016 Paul Howarth <paul@city-fan.org> - 1.302033-1
  390. - Update to 1.302033
  391. - Fix nested TODO handling of diags (#684)
  392. * Wed Jun 22 2016 Paul Howarth <paul@city-fan.org> - 1.302031-1
  393. - Update to 1.302031
  394. - Remove Carp from dependency list (#682)
  395. * Sun Jun 19 2016 Paul Howarth <paul@city-fan.org> - 1.302030-1
  396. - Update to 1.302030
  397. - Use pre_filter instead of filter for TODO in Test::Builder (fix #683)
  398. - Fix typos in transitions doc (#681)
  399. - Add 'inherit_trace' param to run_subtest
  400. - Properly skip thread test when threads are broken
  401. * Tue Jun 14 2016 Paul Howarth <paul@city-fan.org> - 1.302026-1
  402. - Update to 1.302026
  403. - Do not fail if Test2::API::Breakage cannot load (rare 5.10.0 issue)
  404. - Potential fix for t/Legacy/Regression/637.t
  405. - Make t/Legacy/Regression/637.t AUTHOR_TESTING for now
  406. - Add Generic event type
  407. - Make sure enabling culling/shm sets pid and tid (fix #679)
  408. * Sun May 29 2016 Paul Howarth <paul@city-fan.org> - 1.302022-1
  409. - Update to 1.302022
  410. - Many micro-optimizations
  411. - Spelling fixes and tests
  412. - Fix leaky File.t file so that tmp doesn't fill up
  413. - Move some modules out of the known broken list in xt tests
  414. - Add Test2-based tools to downstream testing
  415. - Change when PID/TID are stashed (for forkprove)
  416. - VMS fixes for Files.t and IPC system
  417. - Improve thread checks to better detect broken 5.10 builds
  418. - Use thread checks to skip/run t/Legacy/Regression/637.t
  419. * Mon May 23 2016 Petr Pisar <ppisar@redhat.com> - 1.302019-2
  420. - Obsolete perl-Test2-0.000044-2 too
  421. * Thu May 19 2016 Paul Howarth <paul@city-fan.org> - 1.302019-1
  422. - Update to 1.302019
  423. - Block signals in critical IPC section (fix #661 and #668)
  424. - Merge Examples and examples into one dir (#660)
  425. - Documentation and typo fixes
  426. - Make Test2::Util::get_tid have a consistent prototype (#665)
  427. - Make TB->no_plan a no-op if a plan is set
  428. - Fix util.t win32 bug
  429. - Handle Test::Builder::Exception properly
  430. - Silence noisy STDERR in test suite
  431. - POD spelling fixes
  432. - BR: perl-generators
  433. * Wed May 18 2016 Paul Howarth <paul@city-fan.org> - 1.302015-1
  434. - Update to 1.302015
  435. - Major refactoring of existing API on top of (included) Test2
  436. - Obsolete/Provide perl-Test2
  437. * Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-365
  438. - Increase release to favour standalone package
  439. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.001014-347
  440. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  441. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.001014-346
  442. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  443. * Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-345
  444. - Increase release to favour standalone package
  445. * Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.001014-3
  446. - Perl 5.22 rebuild
  447. * Wed Mar 04 2015 Petr Šabata <contyk@redhat.com> - 1.001014-2
  448. - Correct the license tag
  449. * Wed Jan 7 2015 Paul Howarth <paul@city-fan.org> - 1.001014-1
  450. - Update to 1.001014
  451. - Fix a unit test that broke on some platforms with spaces in the $^X path
  452. - Add a test to ensure that the Changes file is updated
  453. * Wed Dec 24 2014 Paul Howarth <paul@city-fan.org> - 1.001012-1
  454. - Update to 1.001012
  455. - Move test that was dropped in the wrong directory
  456. * Tue Dec 23 2014 Paul Howarth <paul@city-fan.org> - 1.001011-1
  457. - Update to 1.001011
  458. - Fix windows test bug (GH#491)
  459. - Integrate Test::Tester and Test::use::ok for easier downgrade from trial
  460. - Remove POD Coverage test
  461. - Obsolete/Provide perl-Test-Tester and perl-Test-use-ok
  462. - Classify buildreqs by usage
  463. - Use features from recent ExtUtils::MakeMaker to simplify spec
  464. - Run tests with AUTHOR_TESTING=1 so we do the threads test too
  465. * Tue Nov 4 2014 Paul Howarth <paul@city-fan.org> - 1.001009-1
  466. - Update to 1.001009
  467. - Backport cmp_ok fix from alphas (GH#478)
  468. * Thu Oct 16 2014 Paul Howarth <paul@city-fan.org> - 1.001008-1
  469. - Update to 1.001008
  470. - Fix subtest name when skip_all is used
  471. * Tue Sep 9 2014 Paul Howarth <paul@city-fan.org> - 1.001006-1
  472. - Update to 1.001006
  473. - Documentation updates
  474. - Subtests accept args
  475. - Outdent subtest diag
  476. - Changed install path for perl 5.12 or higher
  477. * Tue Aug 26 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.001003-3
  478. - Perl 5.20 rebuild
  479. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.001003-2
  480. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  481. * Sat Mar 22 2014 Paul Howarth <paul@city-fan.org> - 1.001003-1
  482. - Update to 1.001003
  483. - Documentation updates for maintainer change
  484. - This release by EXODIST -> update source URL
  485. - Drop obsoletes/provides for old tests sub-package
  486. * Tue Nov 5 2013 Paul Howarth <paul@city-fan.org> - 1.001002-1
  487. - Update to 1.001002
  488. - Restore ability to use regex with test_err and test_out (CPAN RT#89655)
  489. - Drop upstreamed regex patch
  490. * Sat Oct 12 2013 Paul Howarth <paul@city-fan.org> - 0.99-1
  491. - 0.99 bump
  492. - This release by RJBS -> update source URL
  493. * Fri Aug 09 2013 Petr Pisar <ppisar@redhat.com> - 0.98.05-3
  494. - Pass regular expression intact
  495. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98.05-2
  496. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  497. * Mon Jul 15 2013 Petr Pisar <ppisar@redhat.com> - 0.98.05-1
  498. - 0.98_05 bump
  499. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 0.98-244
  500. - Perl 5.18 rebuild
  501. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-243
  502. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  503. * Wed Nov 21 2012 Jitka Plesnikova <jplesnik@redhat.com> - 0.98-242
  504. - Update dependencies and comments
  505. * Thu Aug 23 2012 Paul Howarth <paul@city-fan.org> - 0.98-241
  506. - Merge tests sub-package back into main package
  507. - Don't need to remove empty directories from the buildroot
  508. - Drop %%defattr, redundant since rpm 4.4
  509. - Make %%files list more explicit
  510. - Don't use macros for commands
  511. - Mark Tutorial.pod as %%doc
  512. - Drop explicit dependency on perl-devel
  513. * Mon Aug 13 2012 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-240
  514. - Bump release to override sub-package from perl.spec
  515. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
  516. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  517. * Wed Jun 06 2012 Petr Pisar <ppisar@redhat.com> - 0.98-6
  518. - Perl 5.16 rebuild
  519. * Thu May 31 2012 Petr Pisar <ppisar@redhat.com> - 0.98-5
  520. - Specify all dependencies
  521. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-4
  522. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  523. * Tue Aug 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-3
  524. - Change path on vendor, so our debuginfo are not conflicting with
  525. perl core debuginfos
  526. * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.98-2
  527. - Perl mass rebuild
  528. * Thu Feb 24 2011 Iain Arnell <iarnell@gmail.com> - 0.98-1
  529. - Update to latest upstream version
  530. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-2
  531. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  532. * Sat Nov 20 2010 Iain Arnell <iarnell@gmail.com> - 0.96-1
  533. - Update to latest upstream version
  534. - Clean up spec for modern rpmbuild
  535. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.94-2
  536. - Mass rebuild with perl-5.12.0
  537. * Tue Mar 16 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.94-1
  538. - Specfile by Fedora::App::MaintainerTools 0.006