pango-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614
  1. %define glib2_version 2.55.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.8.1
  4. %define fontconfig_version 2.12.6
  5. %define cairo_version 1.14.12
  6. # biarch support
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. %define _querymodules_suffix %{nil}
  9. %if %{build_compat32}
  10. %define _querymodules_suffix -32
  11. %endif
  12. Summary: System for layout and rendering of internationalized text.
  13. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  14. Name: pango
  15. Version: 1.40.14
  16. Release: 1%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.40/pango-%{version}.tar.xz
  20. URL: http://www.pango.org
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. # We need to prereq this so we can run pango-querymodules
  23. Requires: glib2 >= %{glib2_version}
  24. Requires: freetype2 >= %{freetype2_version}
  25. BuildRequires: libtool >= 1.4.2
  26. BuildRequires: glib2-devel >= %{glib2_version}
  27. BuildRequires: pkgconfig >= %{pkgconfig_version}
  28. BuildRequires: freetype2-devel >= %{freetype2_version}
  29. BuildRequires: fontconfig-devel >= %{fontconfig_version}
  30. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  31. BuildRequires: cairo-devel >= %{cairo_version}
  32. BuildRequires: libSM-devel
  33. BuildRequires: gobject-introspection-devel
  34. BuildRequires: libthai-devel
  35. BuildRequires: harfbuzz-devel
  36. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: Takemikaduchi
  40. %description
  41. Pango is a system for layout and rendering of internationalized text.
  42. %description -l ja
  43. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  44. %package devel
  45. Summary: System for layout and rendering of internationalized text.
  46. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. Requires: glib2-devel >= %{glib2_version}
  50. Requires: freetype2-devel >= %{freetype2_version}
  51. Requires: cairo-devel >= %{cairo_version}
  52. Requires: libX11-devel, libXft-devel, libXrender-devel
  53. Requires: harfbuzz-devel
  54. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  55. %description devel
  56. The pango-devel package includes the static libraries, header files,
  57. and developer docs for the pango package.
  58. Install pango-devel if you want to develop programs which will use
  59. pango.
  60. #####################################################################
  61. # compat32
  62. %package -n compat32-%{name}
  63. Summary: System for layout and rendering of internationalized text.
  64. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  65. Group: Development/Libraries
  66. %description -n compat32-%{name}
  67. Pango is a system for layout and rendering of internationalized text.
  68. %description -n compat32-%{name} -l ja
  69. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  70. %package -n compat32-%{name}-devel
  71. Summary: Development files for pango
  72. Summary(ja): pango 用の開発ファイル
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}
  75. Requires: %{name}-devel = %{version}
  76. %description -n compat32-%{name}-devel
  77. The pango-devel package includes the static libraries, header files,
  78. and developer docs for the pango package.
  79. %prep
  80. %setup -q -n pango-%{version}
  81. %build
  82. ###%configure --with-included-modules=basic-fc
  83. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  84. %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
  85. make %{?_smp_mflags}
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. make DESTDIR=$RPM_BUILD_ROOT install
  89. # remove unpackaged files
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %if %{build_compat32}
  97. %post -p /sbin/ldconfig -n compat32-%{name}
  98. %postun -p /sbin/ldconfig -n compat32-%{name}
  99. %endif
  100. %files
  101. %defattr(-, root, root)
  102. %doc README AUTHORS COPYING NEWS
  103. %doc pango-view/HELLO.txt
  104. #doc README AUTHORS COPYING ChangeLog
  105. #doc examples/HELLO.utf8
  106. %{_bindir}/pango-view
  107. %{_libdir}/libpango*-*.so.*
  108. %{_libdir}/girepository-1.0
  109. %{_mandir}/man*/*
  110. %files devel
  111. %defattr(-, root, root)
  112. %{_libdir}/libpango*.so
  113. %{_includedir}/*
  114. %{_libdir}/pkgconfig/*
  115. %{_datadir}/gtk-doc/*
  116. %{_datadir}/gir-1.0
  117. %if %{build_compat32}
  118. %files -n compat32-%{name}
  119. %defattr(-, root, root)
  120. %{_libdir}/libpango*-*.so.*
  121. %files -n compat32-%{name}-devel
  122. %defattr(-, root, root)
  123. %{_libdir}/libpango*.so
  124. %endif
  125. %changelog
  126. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.14-1
  127. - new upstream release.
  128. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.40.1-1
  129. - new upstream release
  130. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.1-1
  131. - new upstream release
  132. - remove old patches
  133. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.8-1
  134. - new upstream release
  135. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.5-1
  136. - new upstream release
  137. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.3-1
  138. - new upstream release
  139. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.2-1
  140. - new upstream release
  141. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
  142. - new upstream release
  143. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
  144. - new upstream release
  145. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
  146. - new upstream release
  147. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  148. - new upstream release
  149. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
  150. - new upstream release
  151. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
  152. - new upstream release
  153. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
  154. - new upstream release
  155. - update Patch0 (pango-1.31.2-lib64.patch)
  156. - add BuildRequires: harfbuzz-devel
  157. * Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  158. - new upstream release
  159. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  160. - new upstream release
  161. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
  162. - add BuildRequires: libthai-devel
  163. * Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
  164. - new upstream release
  165. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
  166. - new upstream release
  167. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
  168. - new upstream release with security fixes (CVE-2011-0020, 0064)
  169. - add Vendor/Distri tags
  170. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  171. - add BuildRequires: libSM-devel, gobject-introspection-devel
  172. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  173. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  174. - build with rpm-4.8.1-1 for pkg-config file
  175. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  176. - new upstream release
  177. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  178. - new upstream release
  179. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  180. - changed %%makeinstall to make install with DESTDIR option
  181. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  182. - new upstream release
  183. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  184. - new upstream release
  185. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  186. - new upstream release
  187. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  188. - new upstream release
  189. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  190. - new upstream release
  191. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  192. - new upstream release
  193. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  194. - removed %%if !%%{build_compat32} case condition
  195. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  196. - new upstream release
  197. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  198. - new upstream release
  199. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  200. - new upstream release
  201. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  202. - new upstream release
  203. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  204. - new upstream release
  205. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  206. - new upstream release
  207. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  208. - new upstream release
  209. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  210. - spec in UTF-8 actually
  211. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  212. - new upstream release
  213. - rebuilt with xorg-x11 7.3
  214. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  215. - new upstream release
  216. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  217. - used %{?_dist_release}
  218. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  219. - new upstream release
  220. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  221. - new upstream release
  222. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  223. - new upstream release
  224. - added Patch0 instead of Patch5
  225. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  226. - replace build with new environment
  227. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  228. - rebuild with new environment
  229. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  230. - new upstream release
  231. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  232. - new upstream release
  233. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  234. - new upstream release
  235. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  236. - new upstream release
  237. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  238. - new upstream release
  239. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  240. - new upstream release
  241. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  242. - rebuild with cairo-1.2.0
  243. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  244. - add Patch10 to create fake style(italic/bold) for all fonts.
  245. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  246. - This patch is not applied in upstream, but it seems usefull
  247. for us.
  248. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  249. - new upstream release
  250. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  251. - new upstream release
  252. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  253. - new upstream release
  254. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  255. - fix broken dependancy
  256. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  257. - new upstream release
  258. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  259. - new upstream release
  260. - add compat32 package for x86_64 arch support
  261. - add Patch5 for biarch support
  262. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  263. - new upstream release
  264. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  265. - new upstream release
  266. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  267. - new upstream release
  268. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  269. - rebuild with cairo-0.9
  270. - add patch10 to disable building example programs
  271. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  272. - new upstream release
  273. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  274. - new upstream release
  275. - drop obsolete patches
  276. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  277. - new upstream release
  278. - import upstream patches from fedora package.
  279. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  280. - new upstream release
  281. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  282. - new upstream release
  283. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  284. - remove unneeded dependancy to freetype2-devel
  285. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  286. - add patch10 to build against freetype-2.1.7
  287. - rebuild with freetype-2.1.7
  288. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  289. - new upstream release
  290. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  291. - new upstream release
  292. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  293. - new upstream release
  294. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  295. - merge patch1,2 from rawhide package.
  296. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  297. - new upstream release
  298. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  299. - new upstream release
  300. - Build for Vine Linux, specfile are based on rawhide release
  301. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  302. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  303. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  304. - explicitly require pangoxft to be built, so we catch situations such
  305. as xft.pc moving to /usr/X11R6
  306. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  307. hack
  308. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  309. - 1.1.3
  310. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  311. - Require the necessary freetype version, don't just
  312. BuildRequires it (#74744)
  313. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  314. - Own /etc/pango (#73962, Enrico Scholz)
  315. - Remove .la files from the build root
  316. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  317. - require glib 2.0.6-3, try rebuild on more arches
  318. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  319. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  320. as in gdmgreeter)
  321. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  322. - Fix linked list manipulation problem that was causing hang for anaconda
  323. - Fix warning from loading mini-fonts with context == NULL
  324. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  325. - Fix major memory leak in the last patch
  326. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  327. - Actually use language tags at the rendering layer (should fix #68211)
  328. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  329. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  330. - Fix bug causing hex boxes to be misrendered
  331. leaving RPATH (#66005)
  332. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  333. fonts with embedded bitmaps (#67851)
  334. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  335. - Make basic-x shaper work with our big-5 fonts
  336. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  337. - New upstream tarball with hooks for change-on-the fly font rendering
  338. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  339. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  340. ABI changes for pango's OpenType code.
  341. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  342. - Add some Korean aliases that the installer wants
  343. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  344. - automated rebuild
  345. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  346. - devel package requires fontconfig/Xft devel packages
  347. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  348. - rebuild in different environment
  349. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  350. - Snapshot with Xft2/fontconfig support
  351. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  352. - Version 1.0.2
  353. - Patch for charmaps problem
  354. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  355. - automated rebuild
  356. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  357. - rebuild in different environment
  358. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  359. - add patch to adjust to newer version of freetype
  360. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  361. - Update to version 1.0.1, remove patch
  362. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  363. - Patch from CVS for big speedup with FreeType-2.0.9
  364. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  365. - Rebuild
  366. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  367. - Version 1.0.0
  368. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  369. - Update to 0.26
  370. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  371. - Bump for rebuild
  372. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  373. - Update to 0.25
  374. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  375. - add horrible buildrequires hack
  376. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  377. - 0.24.90 cvs snap
  378. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  379. - Version 0.24
  380. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  381. - automated rebuild
  382. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  383. - new snap 0.23.90
  384. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  385. - rebuild with 64-bit-fixed glib
  386. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  387. - Version 0.22
  388. - add explicit check for required glib2 version before we do the build,
  389. so we don't end up with bad RPMs on --nodeps builds
  390. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  391. no one had updated recently
  392. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  393. - Version 0.21
  394. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  395. - cvs snap
  396. - new cvs snap with a bugfix
  397. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  398. - sync with Owen's changes, fix up dependency versions
  399. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  400. - 0.19
  401. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  402. - build CVS snap
  403. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  404. - no relinking junk
  405. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  406. - Version 0.18
  407. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  408. - Configure --disable-gtk-doc
  409. - BuildRequires freetype-devel, XFree86-devel
  410. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  411. - 0.17
  412. - libtool hackarounds
  413. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  414. - 0.16, rename back to pango from pango-gtkbeta
  415. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  416. - Obsolete fribidi-gtkbeta
  417. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  418. - Remove that patch I just put in
  419. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  420. - Patch pangox.pc.in to include -Iincludedir
  421. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  422. - final 0.13
  423. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  424. - New 0.13 tarball
  425. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  426. - 0.13pre1
  427. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  428. - Rename to 0.12b to avoid versioning problems
  429. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  430. - Move to a CVS snapshot
  431. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  432. - Move back to /usr
  433. - Version 0.12
  434. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  435. - Add missing %%defattr
  436. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  437. - Rebuild with a prefix of /opt/gtk-beta
  438. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  439. - version 0.11
  440. - add --without-qt
  441. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  442. - Make the devel package require *-gtkbeta-* not the normal packages.
  443. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  444. - GTK+ snapshot version installing in /opt/gtk-beta
  445. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  446. - Created spec file